Community discussions

 
ExploiterMB
just joined
Topic Author
Posts: 1
Joined: Wed Oct 17, 2018 9:13 pm

Downgrading

Wed Oct 17, 2018 11:28 pm

I recently purchased a Mikrotik RouterBoard to test out the Tenable ByTheWay vulnerability.

https://github.com/tenable/routeros/tre ... c/bytheway

It came with routerOS 6.42.1
I was able to downgrade. This was only successful with the command line method described here:

viewtopic.php?t=133611

I successfully went down from 6.42.1 to 6.40.1. I was able to go from this to 6.40.6 (bugfix) Yes, the only way to downgrade versions is to do them version by version!
I cannot go any lower than 6.40.6 (bugfix)

I found this forum entry: viewtopic.php?t=128505 from pe1chl, more specifically this response: You cannot downgrade below the version that comes with a device. When your new device came with a newer version than 6.38,
you cannot downgrade it to 6.38. The minimal version is listed in system->resources.

Can MikroTik staff confirm this?

I'm not looking forward to breaking out the JTAGULATOR and the BUSBLASTER and crowbarring that sweet sweet vulnerable 6.30.1!
 
cdemers
Member Candidate
Member Candidate
Posts: 184
Joined: Sun Feb 26, 2006 3:32 pm
Location: Canada
Contact:

Re: Downgrading

Thu Oct 18, 2018 4:01 pm

Normally the listed factory version, at least when the device is first introduced, is the first version with full support for that hardware. And may not even boot on an older version.


Sent from my SM-A520W using Tapatalk

Who is online

Users browsing this forum: No registered users and 15 guests