Community discussions

 
User avatar
DanielJB
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Mon May 27, 2013 3:05 pm

Re: RB4011: wlan1 disabling itself

Wed May 15, 2019 6:19 pm

I received my RB4011 last friday. Very happy with the design of the device. I use it as a replacement for my RB2011 which has been running perfectly for about 5 years.

I backupped the running config of the RB2011, and selectively imported this script to the RB4011. Everything seemed to be running fine, but after 24 hours, the 5GHz network disappeared. I rebooted the device, and it was available again. Last night, again after 24 hours, the network disappeared again.

The wlan1 device is enabled, but when I open it, it says 'not running'. Also, under status it shows the date the link went down last, but it seems it never came back up.
I have the RB4011 WiFi version and don't see this issue. Did you/are you able to capture a supout <10s after the radio goes down?
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Wed May 15, 2019 6:57 pm

I received my RB4011 last friday. Very happy with the design of the device. I use it as a replacement for my RB2011 which has been running perfectly for about 5 years.

I backupped the running config of the RB2011, and selectively imported this script to the RB4011. Everything seemed to be running fine, but after 24 hours, the 5GHz network disappeared. I rebooted the device, and it was available again. Last night, again after 24 hours, the network disappeared again.

The wlan1 device is enabled, but when I open it, it says 'not running'. Also, under status it shows the date the link went down last, but it seems it never came back up.
I have the RB4011 WiFi version and don't see this issue. Did you/are you able to capture a supout <10s after the radio goes down?
I sent it to the support many times already. And they are silent, or talk nonsense. Shitty wifi on the router.


64 bytes from 172.26.0.1: icmp_seq=224 ttl=64 time=7.874 ms
64 bytes from 172.26.0.1: icmp_seq=225 ttl=64 time=3.571 ms
Request timeout for icmp_seq 226
Request timeout for icmp_seq 227
Request timeout for icmp_seq 228
Request timeout for icmp_seq 229
Request timeout for icmp_seq 230
Request timeout for icmp_seq 231
Request timeout for icmp_seq 232
Request timeout for icmp_seq 233
Request timeout for icmp_seq 234
Request timeout for icmp_seq 235
Image
 
Rudolfs
MikroTik Support
MikroTik Support
Posts: 3
Joined: Fri Jun 01, 2018 8:57 am

Re: RB4011: wlan1 disabling itself

Fri May 17, 2019 1:11 pm

This issue is still being investigated by our development team. Unfortunately, this is taking longer than expected because it is not easily repeated. Any additional information regarding to "disappearance" of the 5Ghz wireless interface and how to replicate it would be appreciated and could fasten the process of resolving this matter.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri May 17, 2019 1:27 pm

This issue is still being investigated by our development team. Unfortunately, this is taking longer than expected because it is not easily repeated. Any additional information regarding to "disappearance" of the 5Ghz wireless interface and how to replicate it would be appreciated and could fasten the process of resolving this matter.
Good afternoon Rudolfs, at least some news. 👍🏻
I sent you a new suppot file - May 15th.
Image
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Thu May 23, 2019 10:38 am

Rudolfs: can you share some sneak peek on the progress? Is the reason for such behavior known and if not can we maybe help somehow?
 
JmJ17
just joined
Posts: 7
Joined: Tue Jan 02, 2007 12:45 pm

Re: RB4011: wlan1 disabling itself

Thu May 23, 2019 10:43 am

This issue is still being investigated by our development team. Unfortunately, this is taking longer than expected because it is not easily repeated. Any additional information regarding to "disappearance" of the 5Ghz wireless interface and how to replicate it would be appreciated and could fasten the process of resolving this matter.
In my case the 5Ghz doesn't disappears (it is named like the 2Ghz band), but the device doesn't connect after a few hours running.

Entering in WinBox, the 5Ghz appears as "Not running" until rebooted.
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 774
Joined: Mon May 14, 2012 9:30 pm

Re: RB4011: wlan1 disabling itself

Mon May 27, 2019 7:41 am

I ran a RB4011 at home as a wireless access point only, for about a month.

While it suffered from the same... "Can't go faster than about 300M on speed tests..." (This has been the case with every Mikrotik Wireless I have tried.)

I can't think of a time when the 5G was not accepting clients.

I set the 5 GHZ Channel to 20/40/80Mhz Ceee and frequency 5180. This worked consistently and carried an average of 20 clients at a time. I had as many as 50 on the unit when we had guests over.

I have the same settings on a cAP AC right now and it performs exactly the same.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Mon May 27, 2019 8:13 am

I have the same problem.
Some time the 5Ghz wifi stop working.
I tried disable and enable again but is stack in initializing and not running.
Tools like "scan" and "freq. usage" dose not return any result (with 2.4GHz work perfect).
The signal of 5GHz is disappeared from any devices and none of them can connect (only in 2.4GHz).
I believe with reboot, that work for some time and next i will have problem again.
But... in a router the reboot isn't so easy.

RB4011iGS+5HacQ2HnD (6.44.2)
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
Docop
just joined
Posts: 19
Joined: Thu May 23, 2019 3:56 pm

Re: RB4011: wlan1 disabling itself

Tue May 28, 2019 4:07 pm

I had many strange problem lately with the unit, but the wifi was the perfect result and working fine all the time. 2.4g and 5g have 2 different ssid name. txpower manual. no country set.
20/40/80Mhz Ceee, detect fine 5g 433mbps. Putting 160mhz is for very new device, there's not much that work with the 160 freq and especially no phone and neither the iphone and other istuff.
Also, with the higher band.. wasn't it supposed to cut the signal and modulate the power when no packet are needed instead of having all time full power.. ? Using eth cable or the sfp will fix all the problem if it's a fix unit or so and you need full all the time.

For the other issues, i did another netinstall, and then it pop up fine. it show rb 6.43.3 firm and upgraded 6.44.3 , ipv4 fasttrack by default at on. 24v around 39degC
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Tue May 28, 2019 7:36 pm

I had many strange problem lately with the unit, but the wifi was the perfect result and working fine all the time. 2.4g and 5g have 2 different ssid name. txpower manual. no country set.
20/40/80Mhz Ceee, detect fine 5g 433mbps. Putting 160mhz is for very new device, there's not much that work with the 160 freq and especially no phone and neither the iphone and other istuff.
Also, with the higher band.. wasn't it supposed to cut the signal and modulate the power when no packet are needed instead of having all time full power.. ? Using eth cable or the sfp will fix all the problem if it's a fix unit or so and you need full all the time.

For the other issues, i did another netinstall, and then it pop up fine. it show rb 6.43.3 firm and upgraded 6.44.3 , ipv4 fasttrack by default at on. 24v around 39degC
I tried all of this (different ssd, txpower manual, no_country, Ceee) but the result is the same like above.

I have 6.44.3 not 6.44.2 as i wrote above
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Tue May 28, 2019 7:54 pm

No wireless settings combination works for me either - no matter what the card freezes after some hours where the only way to fix it is to reboot.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Wed May 29, 2019 7:54 am

No wireless settings combination works for me either - no matter what the card freezes after some hours where the only way to fix it is to reboot.
The month of May ends. 🤣👍🏻
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sun Jun 02, 2019 8:20 am

I can confirm that when adaptive noise immunity is disabled at 5ghz, everything has become stable on 6.45beta54.
Image
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 774
Joined: Mon May 14, 2012 9:30 pm

Re: RB4011: wlan1 disabling itself

Mon Jun 03, 2019 12:27 am

Mikrotik can route... Much Like a Sony TV looks incredible.

But a Sony speaker is a piece of $h!+.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
User avatar
DanielJB
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Mon May 27, 2013 3:05 pm

Re: RB4011: wlan1 disabling itself

Tue Jun 11, 2019 10:37 am

I have seen this for the first time in a couple of months with an RB4011-WiFi.

Taking and decoding a supout, the kernel logs show:
2019.06.11-07:16:38.42@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:38.42@3: ath_reset
2019.06.11-07:16:38.42@3: qca9984_tx_disable: timeout
2019.06.11-07:16:39.74@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:39.74@3: ath_reset
2019.06.11-07:16:39.75@3: qca9984_tx_disable: timeout
2019.06.11-07:16:41.07@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:41.07@3: ath_reset
2019.06.11-07:16:41.07@3: qca9984_tx_disable: timeout
2019.06.11-07:16:42.39@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:42.39@3: ath_reset
2019.06.11-07:16:42.40@3: qca9984_tx_disable: timeout
2019.06.11-07:16:42.60@1: bss_timeout: timeout 1336 (jiffies 6538240, lasttx 6537575)
2019.06.11-07:16:43.72@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:43.72@3: ath_reset
2019.06.11-07:16:43.72@3: qca9984_tx_disable: timeout
2019.06.11-07:16:45.04@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:45.04@3: ath_reset
2019.06.11-07:16:45.05@3: qca9984_tx_disable: timeout
2019.06.11-07:16:45.34@0: ap_update_pm: 9c:b6:d0:fa:7d:fd left PS
2019.06.11-07:16:45.44@0: ap_update_pm: 9c:b6:d0:fa:7d:fd entered PS (bytes 0)
2019.06.11-07:16:45.62@0: ap_update_pm: 9c:b6:d0:fa:7d:fd left PS
2019.06.11-07:16:45.72@0: ap_update_pm: 9c:b6:d0:fa:7d:fd entered PS (bytes 0)
2019.06.11-07:16:46.37@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:46.37@3: ath_reset
2019.06.11-07:16:46.37@3: qca9984_tx_disable: timeout
2019.06.11-07:16:47.69@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:47.69@3: ath_reset
2019.06.11-07:16:47.70@3: qca9984_tx_disable: timeout
2019.06.11-07:16:49.02@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:49.02@3: ath_reset
2019.06.11-07:16:49.02@3: qca9984_tx_disable: timeout
2019.06.11-07:16:50.35@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:50.35@3: ath_reset
/interface wireless monitor wlan1 show the interface is running, and I see the noise floor varying:
status: running-ap
channel: 5745/20-Ceee/ac
wireless-protocol: 802.11
noise-floor: -104dBm
overall-tx-ccq: 100%
registered-clients: 1
authenticated-clients: 1
wmm-enabled: yes
notify-external-fdb: no
The registration table shows 1 client connected (which isn't), however there are no SSID broadcasts occurring. The AP got into this state after a prolonged period of co-channel interference. It is highly likely this is a Qualcomm proprietary qca9984 driver bug caused by missing state update (eg an unlock) on an error path.
 
estas
just joined
Posts: 22
Joined: Sat Nov 03, 2018 8:34 pm

Re: RB4011: wlan1 disabling itself

Tue Jun 11, 2019 6:39 pm

Hello, Rudolfs

hap ac2 have same problem. 5ghz randomly disappearing.
Last edited by estas on Tue Jun 11, 2019 8:47 pm, edited 1 time in total.
 
estas
just joined
Posts: 22
Joined: Sat Nov 03, 2018 8:34 pm

Re: RB4011: wlan1 disabling itself

Tue Jun 11, 2019 7:36 pm


do you have ipv6 on rb4011?
No, only ipv4. I disabled ipv6 in packages section.
generally strange behavior RB4011, I already do not understand anything. Support MT keeps complete silence.
I wrote to MT too...Waiting for reply..
Well how are you? Anything useful answered you?

i'd read your post in the morning, did you delete it yourself?
Hello, TimurA

I sended supout to mikrotik, they answered that they did not see any problems with 5ghz.
More interesting, hap ac2 have same problem, 5ghz randomly disappearing :)

Hmmm, i dont deleted any post..

Do you have any news/solutions for this problem?
6.45 beta54 did not help for me.

Now i have two not working properly devices, hap ac2 and rb4011 :))))
 
estas
just joined
Posts: 22
Joined: Sat Nov 03, 2018 8:34 pm

Re: RB4011: wlan1 disabling itself

Tue Jun 11, 2019 7:41 pm

I can confirm that when adaptive noise immunity is disabled at 5ghz, everything has become stable on 6.45beta54.
This solutions not working for me:( 5GHz still randomly disappearing...
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sun Jun 16, 2019 12:08 pm

I can confirm that when adaptive noise immunity is disabled at 5ghz, everything has become stable on 6.45beta54.
This solutions not working for me:( 5GHz still randomly disappearing...
Hello!, try test on 6.45beta62.
Image
 
estas
just joined
Posts: 22
Joined: Sat Nov 03, 2018 8:34 pm

Re: RB4011: wlan1 disabling itself

Mon Jun 17, 2019 10:21 pm

Hello!, try test on 6.45beta62.
I can confirm that when adaptive noise immunity is disabled at 5ghz, everything has become stable on 6.45beta54.
This solutions not working for me:( 5GHz still randomly disappearing...
Hello!, try test on 6.45beta62.
More interesting :)
I have tv box xiaomi mi box mini, when i watch iptv (5GHz) on it, 5GHz on rb4011 and hap ac2 randomly disappears...
If i turn off mi box, 5Ghz works fine!
WiFi router asus 88u and linksys e4200 dont have any problem with mi box :))
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sat Jun 22, 2019 5:07 pm


No, only ipv4. I disabled ipv6 in packages section.
generally strange behavior RB4011, I already do not understand anything. Support MT keeps complete silence.
I wrote to MT too...Waiting for reply..
Well how are you? Anything useful answered you?

i'd read your post in the morning, did you delete it yourself?
Hello, TimurA

I sended supout to mikrotik, they answered that they did not see any problems with 5ghz.
More interesting, hap ac2 have same problem, 5ghz randomly disappearing :)

Hmmm, i dont deleted any post..

Do you have any news/solutions for this problem?
6.45 beta54 did not help for me.

Now i have two not working properly devices, hap ac2 and rb4011 :))))
Yes, not fully working RB4011 devices at 5ghz and hap ac2 on qca9984 chips.

Why did they let them out ?, it's not at all clear! only trust undermined.
Image
 
estas
just joined
Posts: 22
Joined: Sat Nov 03, 2018 8:34 pm

Re: RB4011: wlan1 disabling itself

Wed Jun 26, 2019 7:16 pm

This issue is still being investigated by our development team. Unfortunately, this is taking longer than expected because it is not easily repeated. Any additional information regarding to "disappearance" of the 5Ghz wireless interface and how to replicate it would be appreciated and could fasten the process of resolving this matter.
Just connect xiaomi mi box mini to the rb 4011 or hap ac2, 5ghz will disappear soon :)
 
Kampfwurst
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Mon Mar 24, 2014 2:53 pm

Re: RB4011: wlan1 disabling itself

Fri Jun 28, 2019 7:17 pm

with the 6.45beta62 on my hap ac2 i have no problem with the 5ghz. After 1 week the Wifi is still running, Maybe some can confirm this with the RB4011
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Jun 28, 2019 7:32 pm

Maybe some can confirm this with the RB4011
No, it's still bad!
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sat Jun 29, 2019 10:25 pm

Maybe some can confirm this with the RB4011
A fundamental solution (on photo) to the 5ghz problem on the RB4011. + wAP ac. 😩🤣🤣



PS
I no longer believe that they will solve this problem at all in the next 1 year.
You do not have the required permissions to view the files attached to this post.
Image
 
Kampfwurst
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Mon Mar 24, 2014 2:53 pm

Re: RB4011: wlan1 disabling itself

Sat Jun 29, 2019 11:27 pm

What i forget to write is that i use a CAPs Manager on the hap ac2. I have two hap ac2 running. one of them is the CAPs Manager- Both oft them running without problems.
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Sat Jun 29, 2019 11:28 pm

We halt purchasing RB4011 with wireless. My personal one now has hAP AC next to it for 5Ghz.

MT: really, seriously, this is a joke. The device is mostly punched as a replacement for RB2011/3011 which packs more ports than hAP AC. Having non-functional 5Ghz makes is literally useless.
 
Kampfwurst
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Mon Mar 24, 2014 2:53 pm

Re: RB4011: wlan1 disabling itself

Sun Jun 30, 2019 12:30 am

is the 5Ghz Wifi on the R11E Card? or is it on the main board?
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Sun Jun 30, 2019 6:32 am

RB4011 Jaś R11e, but it’s responsible for handling 2.4Ghz. The 5Ghz is handled by a built-in QCA9984.

p.s. just coming back from emergency replacement of post-thunderstorm of 2x RB4011 - switched to hAP ac + switch at one location ;p
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Mon Jul 01, 2019 7:46 pm

6.45.1 didn't solve the problem.
Image
 
joaquinmb
just joined
Posts: 3
Joined: Mon Jul 01, 2019 2:23 pm

Re: RB4011: wlan1 disabling itself

Tue Jul 02, 2019 2:28 pm

6.45.1 didn't solve the problem.
TimurA,
did you reset wlan interface configuration? solved it?
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Wed Jul 03, 2019 4:32 am

That’s expected - there’s no mention of this in the release notes. I think they’re still debugging the issue.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Thu Jul 04, 2019 10:47 am

6.45.1 didn't solve the problem.
TimurA,
did you reset wlan interface configuration? solved it?
yes, in 6.45.1 solve mac address, 5ghz down again and again.

ps
I take off RB4011, and put up for sale. The problem with 5ghz will not be solved as I understand it.
Image
 
joaquinmb
just joined
Posts: 3
Joined: Mon Jul 01, 2019 2:23 pm

Re: RB4011: wlan1 disabling itself

Thu Jul 04, 2019 11:16 am

6.45.1 didn't solve the problem.
TimurA,
did you reset wlan interface configuration? solved it?
yes, in 6.45.1 solve mac address, 5ghz down again and again.

ps
I take off RB4011, and put up for sale. The problem with 5ghz will not be solved as I understand it.
I upgraded my RB4011 to 6.45.1 and 5ghz down again, with different MAC but down again. Not solved
 
CechTech
just joined
Posts: 4
Joined: Thu Jul 04, 2019 1:23 pm

Re: RB4011: wlan1 disabling itself

Thu Jul 04, 2019 1:46 pm

First Mikrotik device I bought and definitely the last one. My 5ghz wlan works max for one day. Then It disappears. Latest stable firmware. I should've bought Ubiquiti instead. Wireless device with unstable wifi like the RB4011 one is unacceptable.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Jul 05, 2019 3:44 pm

First Mikrotik device I bought and definitely the last one. My 5ghz wlan works max for one day. Then It disappears. Latest stable firmware. I should've bought Ubiquiti instead. Wireless device with unstable wifi like the RB4011 one is unacceptable.
you're right. I bought it in February and at the same time I opened the ticket. There is no solution to this day.
Image
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Sat Jul 06, 2019 1:28 pm

Yesterday I bought a cAP ac and had the same problem as the 4011 on 5GHz. After set-up he began to emit normally at 5GHz and after ~ 5 'ceased to operate the particular band. At this time, both cAP ac and 4011 have the 5GHz band stuck in enable / disable running / slave / initializing. The scan / freq options. usage does not work.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
estas
just joined
Posts: 22
Joined: Sat Nov 03, 2018 8:34 pm

Re: RB4011: wlan1 disabling itself

Sat Jul 06, 2019 3:22 pm

First Mikrotik device I bought and definitely the last one. My 5ghz wlan works max for one day. Then It disappears. Latest stable firmware. I should've bought Ubiquiti instead. Wireless device with unstable wifi like the RB4011 one is unacceptable.
Yes, you right! I also wanted to buy ubiquiti, but mikrotiks fanboys convinced me :(
These are my first two devices from mikrotik, rb4011 and hap ac2, and both do not work properly...
Mikrotik can not solve the problem for almost a half of the year and I do not think that they will solve it.
And I am lucky that I use these devices for home. I wanted to build a enterprie project on mikrotiks devices.
But no more mikrotik in my life...I'm also trying to sell them out and buy ubiquiti.
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 774
Joined: Mon May 14, 2012 9:30 pm

Re: RB4011: wlan1 disabling itself

Sun Jul 07, 2019 4:43 am

I miss the good old days when Mikrotik Routed...
And Ubnt did wireless...

It's when one tried to do the other that things start to fall apart.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
Docop
just joined
Posts: 19
Joined: Thu May 23, 2019 3:56 pm

Re: RB4011: wlan1 disabling itself

Sun Jul 07, 2019 2:59 pm

Have you try to first install fresh with netinstall 6.44.3, and then only used the: quick set and just put a password and a name ? No vpn, no port blocking.. no nothing. I'm on 20-40-80ceee , freq/chan : auto, no country set. ap-bridge and i get full speed and no disconnect at all. ssid always present.
And do you get disconnect when you are under 15feet ?
It could be extra setting you put/change.
If you want a constant link, perhaps go with eth cable, as the AC protocol is not made, intended to be transmitting 100% power all the time and keep the link open all time.
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Mon Jul 08, 2019 6:45 am

The ac is perfectly stable on other devices. We have plenty of hAP ac's and wAPs and there are no complains. Seems like only QCA9984-based devices are problematic.
The issue is not with disconnections but with the SSID being gone. From what I've seen in the lab as well as from the feedback of other people the issue is only present when nothing is connected to the 5Ghz AP for too long.
 
estas
just joined
Posts: 22
Joined: Sat Nov 03, 2018 8:34 pm

Re: RB4011: wlan1 disabling itself

Mon Jul 08, 2019 2:00 pm

the issue is only present when nothing is connected to the 5Ghz AP for too long.
No,its not true. 5GHz randomly disappears when i watch iptv.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: RB4011: wlan1 disabling itself

Mon Jul 08, 2019 2:07 pm

Is your IPTV multicast or unicast?
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Mon Jul 08, 2019 3:52 pm

Is your IPTV multicast or unicast?
did you read it, from DanielJB?
Do you understand that the device does not work?
For you already and debug made.
I have 5ghz falling from any sneeze!
I have seen this for the first time in a couple of months with an RB4011-WiFi.

Taking and decoding a supout, the kernel logs show:
2019.06.11-07:16:38.42@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:38.42@3: ath_reset
2019.06.11-07:16:38.42@3: qca9984_tx_disable: timeout
2019.06.11-07:16:39.74@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:39.74@3: ath_reset
2019.06.11-07:16:39.75@3: qca9984_tx_disable: timeout
2019.06.11-07:16:41.07@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:41.07@3: ath_reset
2019.06.11-07:16:41.07@3: qca9984_tx_disable: timeout
2019.06.11-07:16:42.39@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:42.39@3: ath_reset
2019.06.11-07:16:42.40@3: qca9984_tx_disable: timeout
2019.06.11-07:16:42.60@1: bss_timeout: timeout 1336 (jiffies 6538240, lasttx 6537575)
2019.06.11-07:16:43.72@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:43.72@3: ath_reset
2019.06.11-07:16:43.72@3: qca9984_tx_disable: timeout
2019.06.11-07:16:45.04@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:45.04@3: ath_reset
2019.06.11-07:16:45.05@3: qca9984_tx_disable: timeout
2019.06.11-07:16:45.34@0: ap_update_pm: 9c:b6:d0:fa:7d:fd left PS
2019.06.11-07:16:45.44@0: ap_update_pm: 9c:b6:d0:fa:7d:fd entered PS (bytes 0)
2019.06.11-07:16:45.62@0: ap_update_pm: 9c:b6:d0:fa:7d:fd left PS
2019.06.11-07:16:45.72@0: ap_update_pm: 9c:b6:d0:fa:7d:fd entered PS (bytes 0)
2019.06.11-07:16:46.37@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:46.37@3: ath_reset
2019.06.11-07:16:46.37@3: qca9984_tx_disable: timeout
2019.06.11-07:16:47.69@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:47.69@3: ath_reset
2019.06.11-07:16:47.70@3: qca9984_tx_disable: timeout
2019.06.11-07:16:49.02@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:49.02@3: ath_reset
2019.06.11-07:16:49.02@3: qca9984_tx_disable: timeout
2019.06.11-07:16:50.35@3: ath_beacon_tasklet: busy, reset
2019.06.11-07:16:50.35@3: ath_reset
/interface wireless monitor wlan1 show the interface is running, and I see the noise floor varying:
status: running-ap
channel: 5745/20-Ceee/ac
wireless-protocol: 802.11
noise-floor: -104dBm
overall-tx-ccq: 100%
registered-clients: 1
authenticated-clients: 1
wmm-enabled: yes
notify-external-fdb: no
The registration table shows 1 client connected (which isn't), however there are no SSID broadcasts occurring. The AP got into this state after a prolonged period of co-channel interference. It is highly likely this is a Qualcomm proprietary qca9984 driver bug caused by missing state update (eg an unlock) on an error path.
Image
 
estas
just joined
Posts: 22
Joined: Sat Nov 03, 2018 8:34 pm

Re: RB4011: wlan1 disabling itself

Mon Jul 08, 2019 5:23 pm

Is your IPTV multicast or unicast?
Multicast
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Mon Jul 08, 2019 5:38 pm

Is your IPTV multicast or unicast?
Multicast
the game with the multicast settings on the wlan interface does not give any result either. The problem is deeper .... it is enough to read how solved problems on the QCA9984 chip on OpenWRT in 2017-2018 year
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Tue Jul 09, 2019 9:05 am

I found a way to make at least this piece of shit work.
We do the following: in the ACL for 5ghz, we write the rule limiting connection -120 ..-65 (or -67).
5GHz is falling due to the fact that the client starts to reconnect frequently.

Mikrotik! solve this problem already, how much can you analyze?
Image
 
ddslc
just joined
Posts: 10
Joined: Sat Jun 22, 2019 4:32 pm

Re: RB4011: wlan1 disabling itself

Tue Jul 09, 2019 12:07 pm


5GHz is falling due to the fact that the client starts to reconnect frequently.
So why it fails when there's no clients at all? After a long period of idle?

My observations show that rts/cts disabling may help. Still investigating.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Tue Jul 09, 2019 1:21 pm


5GHz is falling due to the fact that the client starts to reconnect frequently.
So why it fails when there's no clients at all? After a long period of idle?

My observations show that rts/cts disabling may help. Still investigating.
rts/cts disabling - not help.
look at answer from DanielJB.
Image
 
CechTech
just joined
Posts: 4
Joined: Thu Jul 04, 2019 1:23 pm

Re: RB4011: wlan1 disabling itself

Tue Jul 16, 2019 1:46 pm

I upgraded to 6.45.1 and 5ghz is running and visible for 3 days. It lasts only for 1 day before. Is the issue fixed? Can someone confirm?
 
ddslc
just joined
Posts: 10
Joined: Sat Jun 22, 2019 4:32 pm

Re: RB4011: wlan1 disabling itself

Tue Jul 16, 2019 1:52 pm

I upgraded to 6.45.1 and 5ghz is running and visible for 3 days. It lasts only for 1 day before. Is the issue fixed? Can someone confirm?
Yep, running for 5 days or so. But maybe "adaptive noise immunity" disabling helped also.
 
CechTech
just joined
Posts: 4
Joined: Thu Jul 04, 2019 1:23 pm

Re: RB4011: wlan1 disabling itself

Tue Jul 16, 2019 1:56 pm

I upgraded to 6.45.1 and 5ghz is running and visible for 3 days. It lasts only for 1 day before. Is the issue fixed? Can someone confirm?
Yep, running for 5 days or so. But maybe "adaptive noise immunity" disabling helped also.
I didn't change anything in config. Just upgraded routeros.
 
ddslc
just joined
Posts: 10
Joined: Sat Jun 22, 2019 4:32 pm

Re: RB4011: wlan1 disabling itself

Tue Jul 16, 2019 2:09 pm

I didn't change anything in config. Just upgraded routeros.
is adaptive noise immunity enabled in your config?
 
CechTech
just joined
Posts: 4
Joined: Thu Jul 04, 2019 1:23 pm

Re: RB4011: wlan1 disabling itself

Wed Jul 17, 2019 7:29 pm

is adaptive noise immunity enabled in your config?
No. I'll enable it and check if my wlan is unstable. So far so good.
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Fri Jul 19, 2019 7:55 am

I had a boring day today and tested - as with beta no change, the wlan disappeared after couple of hours.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2287
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RB4011: wlan1 disabling itself

Fri Jul 19, 2019 5:57 pm

6.45.2 *) wireless - improved 802.11ac stability for all ARM devices with wireless;
LAN, FTTx, Wireless. ISP operator
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Jul 19, 2019 7:00 pm

6.45.2 *) wireless - improved 802.11ac stability for all ARM devices with wireless;
The sfp port does not work at 6.45.2, it is not possible to verify.
Image
 
ddslc
just joined
Posts: 10
Joined: Sat Jun 22, 2019 4:32 pm

Re: RB4011: wlan1 disabling itself

Sat Jul 20, 2019 8:57 am

Just updated to 6.45.2 . Wifi drops immediately, less than in 1 day
 
zekoslavmrkva
just joined
Posts: 5
Joined: Tue May 21, 2019 4:41 pm

Re: RB4011: wlan1 disabling itself

Sun Jul 21, 2019 11:57 pm

SFP Not work at 6.45.2!!!, Is it any way to back on 6.45.1?
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Mon Jul 22, 2019 4:27 am

SFP Not work at 6.45.2!!!, Is it any way to back on 6.45.1?
LMGTFY - 1st result: viewtopic.php?t=133611
 
zekoslavmrkva
just joined
Posts: 5
Joined: Tue May 21, 2019 4:41 pm

Re: RB4011: wlan1 disabling itself

Mon Jul 22, 2019 7:52 am

SFP Not work at 6.45.2!!!, Is it any way to back on 6.45.1?
LMGTFY - 1st result: viewtopic.php?t=133611
Thanx dear,
I am realy NEW here!
Where I can find 6.45.1? How I can find there https://mikrotik.com/download/archive image for RB4011 device?
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Mon Jul 22, 2019 8:08 am

SFP Not work at 6.45.2!!!, Is it any way to back on 6.45.1?
LMGTFY - 1st result: viewtopic.php?t=133611
Thanx dear,
I am realy NEW here!
Where I can find 6.45.1? How I can find there https://mikrotik.com/download/archive image for RB4011 device?
https://download.mikrotik.com/routeros/ ... 6.45.1.npk
Image
 
zekoslavmrkva
just joined
Posts: 5
Joined: Tue May 21, 2019 4:41 pm

Re: RB4011: wlan1 disabling itself

Mon Jul 22, 2019 1:27 pm

SFP Not work at 6.45.2!!!, Is it any way to back on 6.45.1?
LMGTFY - 1st result: viewtopic.php?t=133611
Thanx dear,
I am realy NEW here!
Where I can find 6.45.1? How I can find there https://mikrotik.com/download/archive image for RB4011 device?
https://download.mikrotik.com/routeros/ ... 6.45.1.npk
SFP Not work at 6.45.2!!!, Is it any way to back on 6.45.1?
LMGTFY - 1st result: viewtopic.php?t=133611
Thanx dear,
I am realy NEW here!
Where I can find 6.45.1? How I can find there https://mikrotik.com/download/archive image for RB4011 device?
https://download.mikrotik.com/routeros/ ... 6.45.1.npk
Thx Timur, you are the best
 
Frostbyte
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Dec 25, 2017 1:42 am

Re: RB4011: wlan1 disabling itself

Mon Jul 22, 2019 2:30 pm

This is honestly unacceptable! If you can't fix your product, issue a recall! More than half a year has passed already..
These units are not cheap at all (230+ EUR) to purchase, and they can't even perform their basic as-advertised functionality in a reliable fashion, for Pete's sake!

Also..

Literally no one:

MikroTik:
*Offers supposed WiFi stability upgrade; SFP+ port no longer works*
 
codruts
newbie
Posts: 34
Joined: Thu Nov 01, 2018 10:38 am

Re: RB4011: wlan1 disabling itself

Tue Jul 23, 2019 7:40 am

i suppose that nobody tried another OS on rb4011...
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Wed Jul 24, 2019 4:50 pm

6.45.2 *) wireless - improved 802.11ac stability for all ARM devices with wireless;
test on 6.46beta16, wlan1 disabling itself. not fix
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Thu Jul 25, 2019 12:04 am

This is honestly unacceptable! If you can't fix your product, issue a recall! More than half a year has passed already..
These units are not cheap at all (230+ EUR) to purchase, and they can't even perform their basic as-advertised functionality in a reliable fashion, for Pete's sake!

Also..

Literally no one:

MikroTik:
*Offers supposed WiFi stability upgrade; SFP+ port no longer works*
Hello, Frostbyte, I have the exact same situation, 7 months. No response and no response that the device is defective. The only thing that I received from the support is that they have been working on the problem for 7 months already. This is sad!

They write that they fixed 802.11ac for ARM, but in the end it was frustrating.

In my regions, all distributors - seeing my problem do not order the RB4011, for fear of return and complaints. And this is all that I could achieve.
Image
 
codruts
newbie
Posts: 34
Joined: Thu Nov 01, 2018 10:38 am

Re: RB4011: wlan1 disabling itself

Thu Jul 25, 2019 8:42 am

i still believe that it's a hardware version problem; i haven't this problem with wlan1 disabling itself (router bought from romania, in december 2018).
for sure, 160mhz option isn't working, even if the settings say so; and only once wlan1 started to search another free 5ghz channel, due of meteo radars relatively nearby [an anti-hail rockets system at ~10km], kicking me out for those regulated 10 minutes.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Thu Jul 25, 2019 11:10 am

i still believe that it's a hardware version problem; i haven't this problem with wlan1 disabling itself (router bought from romania, in december 2018).
for sure, 160mhz option isn't working, even if the settings say so; and only once wlan1 started to search another free 5ghz channel, due of meteo radars relatively nearby [an anti-hail rockets system at ~10km], kicking me out for those regulated 10 minutes.
I also bought the RB4011 in 2018, in December. After the MUM, fell for advertising.
Came to me in early January. And there is a problem.
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Thu Jul 25, 2019 2:01 pm

PCI info of RB4011 - Atheros Communications Inc. unknown device (rev: 0)

Most likely the problem is in the wifi chip, it is previously a revision. According to the openwrt people Atheros QCA9984 rev 1.0, and the problem was solved by the firmware of the chip back in 2018. I am very disappointed in RB4011. I do not want to be more impressed. :evil:
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Thu Jul 25, 2019 8:44 pm

@mikrotik seems to me not looking there at all. Constantly write increased stability in 802.11ac. wlan1 often crashes when a device reconnects to RB4011 from another device.
And there will be ipv6 - multicast.

and here are the links to fixes on openwrt on the QCA9984 chip:
https://patchwork.kernel.org/patch/10723033/
https://patchwork.kernel.org/patch/10385043/
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Jul 26, 2019 7:59 pm

after a wlan1 failure, a red diode is lit on the inside of the device.
You do not have the required permissions to view the files attached to this post.
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sat Jul 27, 2019 8:28 am

I found a solution!
i hade wlan1 was always in the bridge. If wlan1 is removed from the bridge, then it stops falling, and the red diode goes out.
In the case of CAPSMAN, I installed a datapach for wlan1 without Local Forwarding, and it also stopped falling, and the red diode is off.

@mikrotik, why should an expensive router users themselves look for your problem? We have been talking about the problem for 7 months already, and you are silent - like a fish on the ice! You have a problem with ROS in the bridge for QCA9984!
Image
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Sat Jul 27, 2019 9:32 am

The problem is with ipv6 multicast or with bridge on 5ghz?
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sat Jul 27, 2019 9:42 am

The problem is with ipv6 multicast or with bridge on 5ghz?
something makes wlan1 fall, obviously not the correct processing of data from wlan1. If refer to patches from openwrt then multicast.
Image
 
Kampfwurst
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Mon Mar 24, 2014 2:53 pm

Re: RB4011: wlan1 disabling itself

Sat Jul 27, 2019 2:11 pm

What i forget to write is that i use a CAPs Manager on the hap ac2. I have two hap ac2 running. one of them is the CAPs Manager- Both oft them running without problems.
As i wrote before. On my hap ac2 with the caps manager and without local forward on the wifi its running fine. Maybe this helps someone
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sat Jul 27, 2019 2:32 pm

What i forget to write is that i use a CAPs Manager on the hap ac2. I have two hap ac2 running. one of them is the CAPs Manager- Both oft them running without problems.
As i wrote before. On my hap ac2 with the caps manager and without local forward on the wifi its running fine. Maybe this helps someone
Yes, only link performance drops
Image
 
Docop
just joined
Posts: 19
Joined: Thu May 23, 2019 3:56 pm

Re: RB4011: wlan1 disabling itself

Sat Jul 27, 2019 5:31 pm

160mg is for future, if people try or complain about an iphone not connecting at that speed.. the istuff don't support it. The ac norm is not made to be all time on, it's an hashing power. Better to used the 10g fiber port or simple eth cable to have a full conectivity. Why wifi is so needed ? Only a battery operated stuff need it, the rest, as soon you need to be plug to the ac, you can have an eth cable.
Do a netinstall, do the simple ac setup /corner left and all is up and wifi work without disconnect. So no vlan, no ipv6, no extra firewall stuff... This is the basic first step to do before saying it's not working. and not after a-b-c-z mod and addition of vlan and multiple subnet and so on..
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Sat Jul 27, 2019 5:38 pm

Cutting off multicast completely is probably a terrible idea since many applications rely on that (AirPlay, Dropbox just to name two).

Also, phones are pretty capable of ac but they rarely use it due to the battery consumption.
8946D612-1D8F-4202-979E-AC82028F24F8.png
Tablets and laptops in the other hand... well, ac is needed.
I want to see how you drag Ethernet cable to a TV, thermostat, smart speaker and all different things which are wired to the power but connected to the WiFi for convenience. You cannot tell your customers that you will rip their walls and connect everything using an Ethernet cable... cmon, it’s 2019.

p.s. also the point about ipv6 is completely missed. A lot of systems use IPv6 in the local network. Disabling IPv6 nowadays is like refusing to use LTE.
You do not have the required permissions to view the files attached to this post.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sat Jul 27, 2019 5:57 pm

Do a netinstall, do the simple ac setup /corner left and all is up and wifi work without disconnect. So no vlan, no ipv6, no extra firewall stuff... This is the basic first step to do before saying it's not working. and not after a-b-c-z mod and addition of vlan and multiple subnet and so on..
how much can we do netinstall! Do you think idiots here?
if we do not use multicast, vlan, ipv6 and so on - then why is this neutered device needed?
Can take ASUS or Tp-Link for morons and everything works without tuning.
Synology RT2600ac - QCA9984, there were similar problems, even in 2018, and they solved them.
In the framework of this forum, I gave a link to the forum of theirs.
PS
Do you think I did not with an empty config and did not check?!. @Mikrotik has a ticket with suppot files and not one. And not only from me open tickets.

PS
Synology - they screwed WPA3 back in 2018, CARLL!
Synology RT2600ac Release Notes - v1.2-7742 (2018-10-16)
Added support for WPA3 Personal/Enterprise

PS
on the other hand, they release 6.45.2 and send an SPF port to hells. A week has passed and no warning in the description of a stable branch, and if it were not for the forum, many would suffer.
Image
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Mon Jul 29, 2019 3:41 pm

I found a solution!
i hade wlan1 was always in the bridge. If wlan1 is removed from the bridge, then it stops falling, and the red diode goes out.
In the case of CAPSMAN, I installed a datapach for wlan1 without Local Forwarding, and it also stopped falling, and the red diode is off.

@mikrotik, why should an expensive router users themselves look for your problem? We have been talking about the problem for 7 months already, and you are silent - like a fish on the ice! You have a problem with ROS in the bridge for QCA9984!
Sorry but i cant verify.
I removed wlan1 (5ghz) from bridge but still dose not work.
I tried disable/enable but... same problem.
I tried add to bridge again but... nothing.
I tried all combinations with above (without restart) but nothing worked.

5ghz work only after reboot and for limited time.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
skb73
just joined
Posts: 10
Joined: Fri Jan 18, 2019 3:29 pm

Re: RB4011: wlan1 disabling itself

Thu Aug 01, 2019 12:30 pm

What i forget to write is that i use a CAPs Manager on the hap ac2. I have two hap ac2 running. one of them is the CAPs Manager- Both oft them running without problems.
As i wrote before. On my hap ac2 with the caps manager and without local forward on the wifi its running fine. Maybe this helps someone
TimurA, my friend, thanks a lot. Seems like turning the local forwarding off fixed my problems with more than 20 CAP ACs.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sat Aug 03, 2019 2:14 pm

What i forget to write is that i use a CAPs Manager on the hap ac2. I have two hap ac2 running. one of them is the CAPs Manager- Both oft them running without problems.
As i wrote before. On my hap ac2 with the caps manager and without local forward on the wifi its running fine. Maybe this helps someone
TimurA, my friend, thanks a lot. Seems like turning the local forwarding off fixed my problems with more than 20 CAP ACs.
always please skb73.
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sat Aug 03, 2019 2:15 pm

I found a solution!
i hade wlan1 was always in the bridge. If wlan1 is removed from the bridge, then it stops falling, and the red diode goes out.
In the case of CAPSMAN, I installed a datapach for wlan1 without Local Forwarding, and it also stopped falling, and the red diode is off.

@mikrotik, why should an expensive router users themselves look for your problem? We have been talking about the problem for 7 months already, and you are silent - like a fish on the ice! You have a problem with ROS in the bridge for QCA9984!
Sorry but i cant verify.
I removed wlan1 (5ghz) from bridge but still dose not work.
I tried disable/enable but... same problem.
I tried add to bridge again but... nothing.
I tried all combinations with above (without restart) but nothing worked.

5ghz work only after reboot and for limited time.
rechecked. Unfortunately wlan1 only works through CAPSMAN without Local forward.
Image
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Wed Aug 07, 2019 8:34 am

I found a solution!
i hade wlan1 was always in the bridge. If wlan1 is removed from the bridge, then it stops falling, and the red diode goes out.
In the case of CAPSMAN, I installed a datapach for wlan1 without Local Forwarding, and it also stopped falling, and the red diode is off.

@mikrotik, why should an expensive router users themselves look for your problem? We have been talking about the problem for 7 months already, and you are silent - like a fish on the ice! You have a problem with ROS in the bridge for QCA9984!
Sorry but i cant verify.
I removed wlan1 (5ghz) from bridge but still dose not work.
I tried disable/enable but... same problem.
I tried add to bridge again but... nothing.
I tried all combinations with above (without restart) but nothing worked.

5ghz work only after reboot and for limited time.
rechecked. Unfortunately wlan1 only works through CAPSMAN without Local forward.
I confirm.
With CAPsMAN work perfect.
3 days work perfect without problem.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
anuser
Member
Member
Posts: 397
Joined: Sat Nov 29, 2014 7:27 pm

Re: RB4011: wlan1 disabling itself

Wed Aug 07, 2019 5:50 pm

Can you please post you config on a working RB4011 running with CAPSMAN?
 
ddslc
just joined
Posts: 10
Joined: Sat Jun 22, 2019 4:32 pm

Re: RB4011: wlan1 disabling itself

Wed Aug 07, 2019 6:07 pm

I cannot explain it, but now it works for 3 days without capsman... Still waiting for a glitch
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Wed Aug 07, 2019 6:34 pm

Can you please post you config on a working RB4011 running with CAPSMAN?
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether6
add bridge=bridge1 interface=ether7
add bridge=bridge1 interface=ether8
add bridge=bridge1 interface=ether9
add bridge=bridge1 interface=ether10
add bridge=bridge1 interface=wlan2

/interface wireless cap
# 
set bridge=bridge1 discovery-interfaces=bridge1 enabled=yes interfaces=wlan1

/caps-man configuration
add country=greece datapath.bridge=bridge1 hide-ssid=yes installation=indoor \
    keepalive-frames=enabled mode=ap multicast-helper=default name=cfg1 \
    rates.vht-supported-mcs="" security.authentication-types=wpa2-psk \
    security.group-encryption=aes-ccm security.group-key-update=5m \
    security.passphrase=123456 ssid=MySSID

/caps-man interface
add configuration=cfg1 disabled=no l2mtu=1600 mac-address=12:34:56:78:90:12 \
    master-interface=none name=cap1 radio-mac=12:34:56:78:90:12 radio-name=\
    012345678912

/caps-man manager
set enabled=yes

/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=bridge1

/caps-man provisioning
add action=create-dynamic-enabled disabled=yes master-configuration=cfg1
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
codruts
newbie
Posts: 34
Joined: Thu Nov 01, 2018 10:38 am

Re: RB4011: wlan1 disabling itself

Wed Aug 07, 2019 8:56 pm

so, technically, me, who didn't use all mk gimmicks, just plain setup... i had a perfectly useful router! :))
 
wrkq
newbie
Posts: 42
Joined: Mon Jul 29, 2019 10:59 pm

Re: RB4011: wlan1 disabling itself

Sun Aug 11, 2019 5:02 pm

Well, knock on wood, but after last round of config changes my 5G wifi is still working with 10 days of uptime...
[admin@MikroTik] > /system resource print
             uptime: 1w3d12h10m4s
            version: 6.44.5 (long-term)
         build-time: Jul/04/2019 10:32:21
   factory-software: 6.43.10
        free-memory: 955.2MiB
       total-memory: 1024.0MiB
                cpu: ARMv7
          cpu-count: 4
      cpu-frequency: 1400MHz
           cpu-load: 0%
     free-hdd-space: 128.8MiB
    total-hdd-space: 170.9MiB
  architecture-name: arm
         board-name: RB4011iGS+5HacQ2HnD
           platform: MikroTik
[admin@MikroTik] > /interface wireless monitor [find] once
                   status: running-ap           running-ap
                  channel: 2447/20-Ce/gn(17dBm) 5200/20-eCee/ac/P(20dBm)+5530/80/DP(24dBm)
        wireless-protocol: 802.11               802.11
              noise-floor: -102dBm              -105dBm
           overall-tx-ccq: 77%                  100%
       registered-clients: 2                    1
    authenticated-clients: 2                    1
              wmm-enabled: yes                  yes
I can't suggest too much aside of 6.44.5 but I currently have it set up in 80+80 mode with statically configured frequencies. Specifically
set wlan1 band=5ghz-n/ac channel-width=20/40/80mhz-XXXX frequency=5200 secondary-channel=5530
I do have
adaptive-noise-immunity=none
(and I remember ANI being a massive pain on OpenWRT in the past) but it was off the whole time before anyway.

I actually had a massive amount of trouble setting up 80+80.
For first bunch of attempts "set secondary-channel=" command was accepted, returned me to prompt... but crashed the wireless subsystem.
Both 2.4 and 5.0 wifi go down, and many commands such like /interface print (not to mention /interface wireless print) just frozen the console.
A minute or two later I've been also losing the ability to open new ssh connections - key was accepted but then terminal hanged in blank.

Only fix for that was a power cycle.
Actually, no, that was a long night and I forgot the whole story.
Because the faulty config was already saved, after a reset I could log in but wifi was still crashed and trying to do e.g. /interface print would freeze the management plane again.
So after that power cycle it was actually required to restore backup, which would then say it will restart but fail to do so (because crashed system components).
Manual power cycle at that point brought me back to the config from backup, so with the ability to edit wireless config again.
So, try another setting, freeze the device again, rinse, repeat.

I'm still not 100% sure but I think what resolved this was setting
channel-width=20/40/80mhz-XXXX
.
Earlier it was specifically
channel-width=20/40/80mhz-Ceee
on the assumption of "if I'm setting frequencies manually, I should set up the control channel position manually too, right?".

But... yeah. Works for me for now, at least.

PS. Can anyone point out to me what's the logic for the code-tag to sometimes render inline and sometimes as a box?
 
ddslc
just joined
Posts: 10
Joined: Sat Jun 22, 2019 4:32 pm

Re: RB4011: wlan1 disabling itself

Tue Aug 13, 2019 5:12 pm

Nope. Playing with channel settings still have no effect.
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Wed Aug 14, 2019 9:17 am

I'll stay with CAPsMAN until MT release a patch in stable ROS.
In this time, is the only solution that work 100%.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Aug 16, 2019 8:05 am

It was discovered empirically that macbook pro 15 "2017 and macbook pro 15" 2019 are to blame for the fall of wlan1. There is no such effect on windows 10.

this is in my case.

ps
maybe it's itunes wifi synchronization with iphone, ipad behaves like this or Airdrop or something specific - which I don’t know.

ps2

disabled AirDrop everywhere until the interface crashes. I will watch.
Image
 
aya
just joined
Posts: 8
Joined: Fri Jun 21, 2013 12:19 pm

Re: RB4011: wlan1 disabling itself

Sat Aug 17, 2019 5:47 pm

After a year of work, my HAP AC2 failed. Bought to replace RB4011. And in this device, for 3 days of operation, WiFi turned off 2 times. Does everyone have a problem or replace the device in the store?
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Sat Aug 17, 2019 6:03 pm

@aya: Please, respect each other. You posted in a topic where multiple people are describing the problem for 4 pages - you should take a look first I think.

The MT is working on the solution. Replacing the device will not help.
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Sun Aug 18, 2019 10:59 am

After a year of work, my HAP AC2 failed. Bought to replace RB4011. And in this device, for 3 days of operation, WiFi turned off 2 times. Does everyone have a problem or replace the device in the store?
...
@aya: Please, respect each other. You posted in a topic where multiple people are describing the problem for 4 pages - you should take a look first I think.

The MT is working on the solution. Replacing the device will not help.
In addition... in this time we have a solution that work perfect without any problem...
The solution is CAPsMAN and i have a mini tutorial / sample code above.
Last edited by denisun on Mon Aug 19, 2019 10:12 am, edited 1 time in total.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
Reinis
MikroTik Support
MikroTik Support
Posts: 56
Joined: Wed Jan 02, 2019 12:14 pm
Location: Latvia
Contact:

Re: RB4011: wlan1 disabling itself

Mon Aug 19, 2019 7:22 am

After a year of work, my HAP AC2 failed. Bought to replace RB4011. And in this device, for 3 days of operation, WiFi turned off 2 times. Does everyone have a problem or replace the device in the store?
Please write to support@mikrotik.com, providing supout.rif from your device generated after the crash (when the interface is "down"). Additionally, If you know how to repeat the issue with your setup, please provide detailed steps.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24206
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB4011: wlan1 disabling itself

Fri Aug 23, 2019 9:08 am

Several days passed, still no replies and not a single email about this issue.

Is the RB4011 5GHz issue resolved?
No answer to your question? How to write posts
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Aug 23, 2019 9:30 am

Several days passed, still no replies and not a single email about this issue.

Is the RB4011 5GHz issue resolved?
Hello Normis,

No, the problem is not resolved.
we sit and watch you :) when something is decided :)

PS
I sent new data to Reiniss, and my conclusions about the SSID drop.
Image
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24206
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB4011: wlan1 disabling itself

Fri Aug 23, 2019 9:43 am

Timur, I understand from Reinis, that your problem is not related to wireless at all, it's most likely a Layer 2 misconfiguration problem. My question was to the other participants of this thread.
No answer to your question? How to write posts
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Aug 23, 2019 9:55 am

Timur, I understand from Reinis, that your problem is not related to wireless at all, it's most likely a Layer 2 misconfiguration problem. My question was to the other participants of this thread.
Normis!

here it is not a level 2 configuration. You have some problems with RoS on L2. Since it affects wlan1 but not wlan2 - how can you explain this? When all the interfaces are in one bridge! And checked without a bridge! Let's not throw off the problem for a special case!

You DanielJB and others described the same symptoms. ping increases and SSID translation stops

/caps-man remote-cap print
# ADDRESS NAME STATE RADIOS
2 172.27.0.1/58405 [11:E9:4B:BF:AB:CE] Run 2

Explain to me what is going on on L2 in RB4011. When the device in capsman constantly generates a left mac address. Non-native!
I already mentioned this to Arthus and Rudolfs and Reinis.

PS
Remember how we resolved the issue of identical mac addresses on SFP and wlan1 for a long time.
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Aug 23, 2019 10:21 am

Good, Normis. I was already tired of saying that there is a problem. Let it be your way. No problem.
Image
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24206
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB4011: wlan1 disabling itself

Fri Aug 23, 2019 10:33 am

Timur, nothing is wrong with your 2GHz, because nothing is connecting there. Please be reasonable and follow our support department recommendations, your configuration needs restructuring.
No answer to your question? How to write posts
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Aug 23, 2019 11:07 am

Timur, nothing is wrong with your 2GHz, because nothing is connecting there. Please be reasonable and follow our support department recommendations, your configuration needs restructuring.
Normis, look carefully suppout the files, after the fall of wlan1 everyone runs away to wlan2.

I all answered your support, read carefully.
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Aug 23, 2019 3:21 pm

After a year of work, my HAP AC2 failed. Bought to replace RB4011. And in this device, for 3 days of operation, WiFi turned off 2 times. Does everyone have a problem or replace the device in the store?
...
@aya: Please, respect each other. You posted in a topic where multiple people are describing the problem for 4 pages - you should take a look first I think.

The MT is working on the solution. Replacing the device will not help.
In addition... in this time we have a solution that work perfect without any problem...
The solution is CAPsMAN and i have a mini tutorial / sample code above.
Hello Denisun,

Another working method I have. for wlan1 set the parameter Frame LifeTime> 0. etc 2.00 or 3.00.
You can already enable Local Forwarding in CAPSMAN.
Image
 
mikelaurense
just joined
Topic Author
Posts: 7
Joined: Mon Dec 03, 2018 9:14 am

Re: RB4011: wlan1 disabling itself

Fri Aug 23, 2019 9:07 pm

As the original poster of this thread, I can also confirm this isn’t fixed yet. I might not have posted a lot, but I’ve certainly kept up with all the comments made in this thread.
I currently do not have a problem with 5GHz WiFi in the RB4011, but a cAP Gi-5acD2nD provisioned via capsman currently has it’s 5GHz Interface down. See screenshot
You do not have the required permissions to view the files attached to this post.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Fri Aug 23, 2019 10:33 pm

I currently do not have a problem with 5GHz WiFi in the RB4011
Could you tell us how you solved the problem?
Image
 
mikelaurense
just joined
Topic Author
Posts: 7
Joined: Mon Dec 03, 2018 9:14 am

Re: RB4011: wlan1 disabling itself

Sat Aug 24, 2019 1:55 am

No I meant I don’t have a problem at this moment. But it can occur at any time and then I have to reboot the device again
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Sun Aug 25, 2019 10:59 am

After a year of work, my HAP AC2 failed. Bought to replace RB4011. And in this device, for 3 days of operation, WiFi turned off 2 times. Does everyone have a problem or replace the device in the store?
...
@aya: Please, respect each other. You posted in a topic where multiple people are describing the problem for 4 pages - you should take a look first I think.

The MT is working on the solution. Replacing the device will not help.
Hello @TimurA.

In addition... in this time we have a solution that work perfect without any problem...
The solution is CAPsMAN and i have a mini tutorial / sample code above.
Hello Denisun,

Another working method I have. for wlan1 set the parameter Frame LifeTime> 0. etc 2.00 or 3.00.
You can already enable Local Forwarding in CAPSMAN.
Thanks for support.
I'll try this.
For your opinion... what is the best value (default is 0).
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sun Aug 25, 2019 11:47 am

After a year of work, my HAP AC2 failed. Bought to replace RB4011. And in this device, for 3 days of operation, WiFi turned off 2 times. Does everyone have a problem or replace the device in the store?
...
@aya: Please, respect each other. You posted in a topic where multiple people are describing the problem for 4 pages - you should take a look first I think.

The MT is working on the solution. Replacing the device will not help.
Hello @TimurA.

In addition... in this time we have a solution that work perfect without any problem...
The solution is CAPsMAN and i have a mini tutorial / sample code above.
Hello Denisun,

Another working method I have. for wlan1 set the parameter Frame LifeTime> 0. etc 2.00 or 3.00.
You can already enable Local Forwarding in CAPSMAN.
Thanks for support.
I'll try this.
For your opinion... what is the best value (default is 0).
Hello, 1.00 (10ms) and 2.00 (20ms)
Image
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Sun Aug 25, 2019 6:06 pm

After a year of work, my HAP AC2 failed. Bought to replace RB4011. And in this device, for 3 days of operation, WiFi turned off 2 times. Does everyone have a problem or replace the device in the store?
...
@aya: Please, respect each other. You posted in a topic where multiple people are describing the problem for 4 pages - you should take a look first I think.

The MT is working on the solution. Replacing the device will not help.
Hello @TimurA.

In addition... in this time we have a solution that work perfect without any problem...
The solution is CAPsMAN and i have a mini tutorial / sample code above.
Hello Denisun,

Another working method I have. for wlan1 set the parameter Frame LifeTime> 0. etc 2.00 or 3.00.
You can already enable Local Forwarding in CAPSMAN.
Thanks for support.
I'll try this.
For your opinion... what is the best value (default is 0).
Hello, 1.00 (10ms) and 2.00 (20ms)
ok but in winbox the frame-lifetime value is in (s) not (ms).
Also in export file.
The value of 1.00 translate to 1s not in 10ms.
I changed to 0.01 and in the export file i took 10ms.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Mon Aug 26, 2019 5:53 am


...

Hello @TimurA.

In addition... in this time we have a solution that work perfect without any problem...
The solution is CAPsMAN and i have a mini tutorial / sample code above.
Hello Denisun,

Another working method I have. for wlan1 set the parameter Frame LifeTime> 0. etc 2.00 or 3.00.
You can already enable Local Forwarding in CAPSMAN.
Thanks for support.
I'll try this.
For your opinion... what is the best value (default is 0).
Hello, 1.00 (10ms) and 2.00 (20ms)
ok but in winbox the frame-lifetime value is in (s) not (ms).
Also in export file.
The value of 1.00 translate to 1s not in 10ms.
I changed to 0.01 and in the export file i took 10ms.
viewtopic.php?t=59164
Image
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Mon Aug 26, 2019 9:16 am



Hello Denisun,

Another working method I have. for wlan1 set the parameter Frame LifeTime> 0. etc 2.00 or 3.00.
You can already enable Local Forwarding in CAPSMAN.
Thanks for support.
I'll try this.
For your opinion... what is the best value (default is 0).
Hello, 1.00 (10ms) and 2.00 (20ms)
ok but in winbox the frame-lifetime value is in (s) not (ms).
Also in export file.
The value of 1.00 translate to 1s not in 10ms.
I changed to 0.01 and in the export file i took 10ms.
viewtopic.php?t=59164
This is an old thread.
I believe the correct value for 10ms is 0.01. Not 1.00.
As i said... the rsc file give me for 1.00 the value of 1s,
instead of 0.01 which give me the value 10ms
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
muetzekoeln
Member Candidate
Member Candidate
Posts: 142
Joined: Fri Jun 29, 2018 2:34 pm

Re: RB4011: wlan1 disabling itself

Mon Aug 26, 2019 10:52 am

This is an old thread.

Which version of ROS did change this? Or was the information from this old thread wrong? And by the way, what is the default value? Infinitely, as FAQ states? Normis??
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Mon Aug 26, 2019 1:02 pm

This is an old thread.
I believe the correct value for 10ms is 0.01. Not 1.00.
As i said... the rsc file give me for 1.00 the value of 1s,
instead of 0.01 which give me the value 10ms
0.01 perfect for wlan1! thx
Image
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Mon Aug 26, 2019 1:51 pm

This is an old thread.

Which version of ROS did change this? Or was the information from this old thread wrong? And by the way, what is the default value? Infinitely, as FAQ states? Normis??
I dont know from which version changed the base.
The default value is 0 that mean it is disable.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 901
Joined: Tue Oct 11, 2005 4:53 pm

Re: RB4011: wlan1 disabling itself

Mon Sep 02, 2019 11:03 pm

Several days passed, still no replies and not a single email about this issue.

Is the RB4011 5GHz issue resolved?
The problem still exists.
For me it took about 29 days on a brand new RB4011, before it occurred.
Since then the wifi gets disabled (stuck in "initializing") in less than a day for 3 days in a row now...
 
ddslc
just joined
Posts: 10
Joined: Sat Jun 22, 2019 4:32 pm

Re: RB4011: wlan1 disabling itself

Tue Sep 03, 2019 3:17 am

Looks like frame lifetime = 0.02 work fine. 8 days - all systems nominal :-)
 
Nirox
just joined
Posts: 24
Joined: Sun Dec 16, 2018 11:47 pm

Re: RB4011: wlan1 disabling itself

Wed Sep 04, 2019 3:33 pm

Hello team.

Someone already updated RB4011 (wifi) on RouterOS 6.46beta38?

Support send me email with next recommendation...

In the latest RouterOS 6.46beta38 there was done major improvements to increase the stability, please upgrade the to see if it solves the issue.
Please send us the supout.rif file from your device right after the issue appears.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Thu Sep 05, 2019 6:24 am

Hello team.

Someone already updated RB4011 (wifi) on RouterOS 6.46beta38?

Support send me email with next recommendation...

In the latest RouterOS 6.46beta38 there was done major improvements to increase the stability, please upgrade the to see if it solves the issue.
Please send us the supout.rif file from your device right after the issue appears.
use with 6.46beta38 frame-lifetime=0.01
Image
 
ddslc
just joined
Posts: 10
Joined: Sat Jun 22, 2019 4:32 pm

Re: RB4011: wlan1 disabling itself

Tue Sep 10, 2019 12:28 am

Looks like frame lifetime = 0.02 work fine. 8 days - all systems nominal :-)
Well. No good. After 14 days wlan1 disappeared again
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Tue Sep 10, 2019 11:03 pm

Looks like frame lifetime = 0.02 work fine. 8 days - all systems nominal :-)
Well. No good. After 14 days wlan1 disappeared again
It still work in my setup.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Wed Sep 11, 2019 2:39 pm

After upgrade today to 6.45.6 (stable), i cannot connect to 5GHz. :(
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
Nirox
just joined
Posts: 24
Joined: Sun Dec 16, 2018 11:47 pm

Re: RB4011: wlan1 disabling itself

Wed Sep 11, 2019 3:21 pm

After upgrade today to 6.45.6 (stable), i cannot connect to 5GHz. :(

welcome to club :(


You not see network or get message "Password is wrong"?
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Wed Sep 11, 2019 3:50 pm

After upgrade today to 6.45.6 (stable), i cannot connect to 5GHz. :(
no problem, i was connected to 5ghz

7 ;;; Macbook Pro
interface=cap6 ssid="XXX5ghz" mac-address=XX:XX:XX:XX:XX:XX
tx-rate-set="OFDM:6-54 BW:1x-4x SGI:1x-4x HT:0-23 VHTMCS:SS1=0-9,SS2=0-9,SS3=0-9" eap-identity=""
Image
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Wed Sep 11, 2019 4:08 pm

After upgrade today to 6.45.6 (stable), i cannot connect to 5GHz. :(

welcome to club :(


You not see network or get message "Password is wrong"?
I didn't see the 5GHz wireless.
Now work perfect, without any changes.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
andriys
Forum Guru
Forum Guru
Posts: 1179
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: RB4011: wlan1 disabling itself

Wed Sep 11, 2019 6:41 pm

I didn't see the 5GHz wireless.
Now work perfect, without any changes.
What channel do you use? Perhaps, "now" means "once radar detection is complete"? Just guessing.
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Wed Sep 11, 2019 9:12 pm

I didn't see the 5GHz wireless.
Now work perfect, without any changes.
What channel do you use? Perhaps, "now" means "once radar detection is complete"? Just guessing.
I have it in auto.
I believe it tried to find a free channel and it was delayed.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
andriys
Forum Guru
Forum Guru
Posts: 1179
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: RB4011: wlan1 disabling itself

Wed Sep 11, 2019 10:08 pm

I have it in auto.
I believe it tried to find a free channel and it was delayed.
In this case the delay is most certainly caused by DFS (radar detection). When a DFS-enforced channel is selected, a delay (before you see your SSID on air) of at least 10 minutes is always to be expected.
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Wed Sep 11, 2019 11:01 pm

I have it in auto.
I believe it tried to find a free channel and it was delayed.
In this case the delay is most certainly caused by DFS (radar detection). When a DFS-enforced channel is selected, a delay (before you see your SSID on air) of at least 10 minutes is always to be expected.
Yes. That was...
I tried without create dynamic provisioning (without any provisioning) and still work.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
UpRunTech
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Fri Jul 27, 2012 12:11 pm

Re: RB4011: wlan1 disabling itself

Thu Sep 26, 2019 2:41 pm

As the original poster of this thread, I can also confirm this isn’t fixed yet. I might not have posted a lot, but I’ve certainly kept up with all the comments made in this thread.
I currently do not have a problem with 5GHz WiFi in the RB4011, but a cAP Gi-5acD2nD provisioned via capsman currently has it’s 5GHz Interface down. See screenshot
I recall I had problems with devices connecting reliably on CAPSMan systems until I started forcing Ce or Ceee. Don't let the radio chose the mode.
 
Nirox
just joined
Posts: 24
Joined: Sun Dec 16, 2018 11:47 pm

Re: RB4011: wlan1 disabling itself

Thu Sep 26, 2019 10:50 pm

As the original poster of this thread, I can also confirm this isn’t fixed yet. I might not have posted a lot, but I’ve certainly kept up with all the comments made in this thread.
I currently do not have a problem with 5GHz WiFi in the RB4011, but a cAP Gi-5acD2nD provisioned via capsman currently has it’s 5GHz Interface down. See screenshot
I recall I had problems with devices connecting reliably on CAPSMan systems until I started forcing Ce or Ceee. Don't let the radio chose the mode.
Hello team. Sorry, but I think will be better if we all bury this “perfect and best solution “. I’m reschedule all my critical projects on “old” hAP AC and now I’m happy. 35 days without any problem.

Mikrotik betrayed my hope like minimum in seriously project. And I wrote this with big regret.
 
Retral
just joined
Posts: 13
Joined: Wed Jul 25, 2018 9:10 pm

Re: RB4011: wlan1 disabling itself

Thu Sep 26, 2019 11:55 pm

As the original poster of this thread, I can also confirm this isn’t fixed yet. I might not have posted a lot, but I’ve certainly kept up with all the comments made in this thread.
I currently do not have a problem with 5GHz WiFi in the RB4011, but a cAP Gi-5acD2nD provisioned via capsman currently has it’s 5GHz Interface down. See screenshot
I recall I had problems with devices connecting reliably on CAPSMan systems until I started forcing Ce or Ceee. Don't let the radio chose the mode.
I second Nitrox's statement. You cannot leave anything on Mikrotiks in capsman or the wireless interface auto for anything related to channel width. I personally have repeatedly experienced out in the field and while testing in our data center this wrong extension channel selection. One channel I have seen this on for sure is ch165 being used in extensions, which from everything I know is only a 20mhz channel that is not part of Ceee eeeC or anything other than a lone 20mhz channel. Also why can you not exclude DFS channels outside of capsman? With custom channel list you can of course but why not otherwise like capsman has?
 
UpRunTech
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Fri Jul 27, 2012 12:11 pm

Re: RB4011: wlan1 disabling itself

Fri Sep 27, 2019 2:51 am

I'd say perhaps there are clients out there that don't work well using anything other than Ce or Ceee. Options like eCee or eC or eeeeCeee are there so the radio can find a clear 20MHz space for C and optionally use the e's depending on the radio interference environment. For 5GHz indoors this shouldn't be a huge problem, even in apartment blocks as 5GHz doesn't propagate through walls very well. Maybe outdoors this could be a bigger problem for 5GHz if there are a lot of PtP and PtMP links. For 2GHz just stick with a 20MHz channel on 1, 6 or 11 with b and g disabled. That said clients may not negotiate anything other than Ceee/Ce very well anyway - at least with Mikrotik. I have found the less choice or variety you give both the access point and the clients the better the outcomes. And always set multicast helper to full - discovery broadcasts and DHCP works much better with it on.

Here's my example of a recipe for happy CAPSMan and is typical of what I use. It works well with HAPAC2 and CAPAC. I have an RB4011 with Wifi but I found a bug the other day where it will always do Ceeeeeee when I only ask for Ceee - and Mikrotik have acknowledged this bug and will fix it. CAPSMan doesn't even give your a choice for Ceeeeeeee - at least in Winbox.

Put this mangle rule on all the APs if you use local forwarding, otherwise it only has to be on the CAPSMan controller.
/ip firewall mangle
add action=set-priority chain=postrouting comment="Set DSCP to interface priority for WMM" new-priority=from-dscp-high-3-bits \
    out-bridge-port=all-wireless passthrough=yes
This config gives each radio freedom to choose from the defined frequencies. Note I used hide-sensitive.
/caps-man security
add authentication-types=wpa2-psk disable-pmkid=yes encryption=aes-ccm group-encryption=aes-ccm name=YOURSECURITY
/caps-man configuration
add channel.band=2ghz-onlyn channel.extension-channel=disabled channel.frequency=2412,2437,2462 channel.tx-power=20 country=YOURCOUNTRY \
    datapath.bridge=BridgeMain datapath.client-to-client-forwarding=yes datapath.local-forwarding=no distance=indoors multicast-helper=\
    full name=YOURSSID rates.basic=12Mbps rates.supported=12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps security=YOURSECURITY ssid=YOURSSID
add channel.band=5ghz-n/ac channel.extension-channel=Ceee channel.frequency=5180,5260,5500,5660,5745 channel.tx-power=20 country=\
    YOURCOUNTRY datapath.bridge=BridgeMain datapath.client-to-client-forwarding=yes datapath.local-forwarding=no distance=indoors \
    multicast-helper=full name=YOURSSID5G rates.basic=12Mbps rates.supported=12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps security=YOURSECURITY \
    ssid=YOURSSID
/caps-man manager
set enabled=yes upgrade-policy=require-same-version
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=BridgeMain
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=YOURSSID name-format=identity
add action=create-dynamic-enabled hw-supported-modes=ac,an master-configuration=YOURSSID5G name-format=identity
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: RB4011: wlan1 disabling itself

Sun Sep 29, 2019 7:51 pm

I check the above setup and work perfect.
"What one programmer can do in one month, two programmers can do in two months."
Fred Brooks...
 
Frostbyte
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Dec 25, 2017 1:42 am

Re: RB4011: wlan1 disabling itself

Thu Oct 03, 2019 12:59 am

Issue is still at large, support hasn't responded to my emails since July 22.
Unfortunately on the secondary device, downstairs, one of the client devices is a xiaomi mi box..
I also noticed that on the primary device, upstairs, a nintendo switch will also make the 5GHz band fail after a while..

At this point I think we need to create a fundraiser to buy and ship some of these "problematic" client devices to MT so that they can finally troubleshoot/reproduce in a reliable fashion. :lol:
Honestly, this joke has dragged on too long.. Especially to those of us who bought the device on release and we're closing in to a whole year without a basic functionality working proper.. I shake my head..

But I'm not going to give up, nor on the 5GHz stability, neither on channel 50.. We flipping paid every pretty penny for all those features..
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Thu Oct 03, 2019 5:30 am

Issue is still at large, support hasn't responded to my emails since July 22.
Unfortunately on the secondary device, downstairs, one of the client devices is a xiaomi mi box..
I also noticed that on the primary device, upstairs, a nintendo switch will also make the 5GHz band fail after a while..

At this point I think we need to create a fundraiser to buy and ship some of these "problematic" client devices to MT so that they can finally troubleshoot/reproduce in a reliable fashion. :lol:
Honestly, this joke has dragged on too long.. Especially to those of us who bought the device on release and we're closing in to a whole year without a basic functionality working proper.. I shake my head..

But I'm not going to give up, nor on the 5GHz stability, neither on channel 50.. We flipping paid every pretty penny for all those features..
And what do you offer? Just send them devices? Or something specific?

I know that there is an error on L2 during data processing from wlan1 to the CPU.

I'll try today to agree to take a test from a new batch of the device. If there are no problems there, we need with you and the community to decide what to do with Mikrotik. How to act.
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Thu Oct 03, 2019 9:18 am

I received from a new batch of RB4011, after 2 hours, it will be clear. I'm starting the tests.

My assembled in Latvia is old, and the new is assembled in Lithuania
Image
 
anuser
Member
Member
Posts: 397
Joined: Sat Nov 29, 2014 7:27 pm

Re: RB4011: wlan1 disabling itself

Thu Oct 03, 2019 9:33 am

Does the problem also exist with current RouterOS v7.0 beta2 ?
 
Frostbyte
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Dec 25, 2017 1:42 am

Re: RB4011: wlan1 disabling itself

Thu Oct 03, 2019 9:35 am

@TimurA

If it's a hardware revision issue, then the obvious would be to demand an RMA/replacement.

The only thing that I disagree with is us sending our devices over first. For good or for bad, the two RB4011 units are the core of my network.. and I will not be accepting ending up without a network on my home (on top of suffering from that WiFi issue for almost a year), because MikroTik is unable to send a device replacement in advance (upon receiving proof of purchase of course).

TL;DR: They send the replacement first, then I send them the faulty one back. Not the other way around. And I will not be accepting to be charged even one penny for their f-up.
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Thu Oct 03, 2019 11:00 am

You can calm down, there is no difference in the revision of RB4011. Everything is just as bad on the new device.

the one that was tested is released in March 2019, my old one was released at the Sep of 2018.

All symptoms are the same.
You do not have the required permissions to view the files attached to this post.
Image
 
Frostbyte
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Dec 25, 2017 1:42 am

Re: RB4011: wlan1 disabling itself

Thu Oct 03, 2019 1:13 pm

I honestly doubt this is a new hardware/mainboard revision. It's more likely that the new unit you got, only got assembled at a different date and factory.

I sincerely hope that the issue lies within the software and not on the hardware. Time will tell.. Just how much more time it will take, that I do not know..
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Sun Oct 06, 2019 7:28 pm

colleagues, disconnect Discovery on RB4011 and on neighboring Discovery devices. And check out the work of 5ghz. There is a suspicion that because of this the storm is on L2, and 5ghz has problems. The feeling is that all the problems are due to Realtek RTL8367.
Image
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Mon Oct 07, 2019 8:44 am

Colleagues, I completely blocked the CDP / LLDP in the bridge with filters. 5ghz does not fall.

add action = drop chain = forward dst-mac-address = 01: 00: 0C: CC: CC: CC / FF: FF: FF: FF: FF: FF
add action = drop chain = forward dst-mac-address = 01: 80: C2: 00: 00: 0E / FF: FF: FF: FF: FF: FF
add action = drop chain = input dst-mac-address = 01: 00: 0C: CC: CC: CC / FF: FF: FF: FF: FF: FF
add action = drop chain = input dst-mac-address = 01: 80: C2: 00: 00: 0E / FF: FF: FF: FF: FF: FF

most likely there is a leak in RB4011. I continue the study.
Image
 
ddslc
just joined
Posts: 10
Joined: Sat Jun 22, 2019 4:32 pm

Re: RB4011: wlan1 disabling itself

Tue Oct 08, 2019 1:46 am

Colleagues, I completely blocked the CDP / LLDP in the bridge with filters. 5ghz does not fall.

I tried it. Nope, that's not a solution. Still hanging
 
TimurA
Member Candidate
Member Candidate
Posts: 186
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: RB4011: wlan1 disabling itself

Tue Oct 08, 2019 7:18 am

Colleagues, I completely blocked the CDP / LLDP in the bridge with filters. 5ghz does not fall.

I tried it. Nope, that's not a solution. Still hanging
yes, my tests failed too. :(

already tired of RB4011. Let Mikrotik live on his own with this problem. I'll wait for 802.11ax. I'll see who first buys, what problems will experience. And then I will only order.
Image
 
ynqjwsm
just joined
Posts: 3
Joined: Tue Sep 13, 2016 7:47 am

Re: RB4011: wlan1 disabling itself

Tue Oct 08, 2019 12:37 pm

same problem on my RB4011iGS+5HacQ2HnD,,,,wlan1 interface QCA9984 stop working,,,re-enable stuck on "initializing",,,,,only reboot can make it return to work.
hope mk can fix this....asap
 
Nirox
just joined
Posts: 24
Joined: Sun Dec 16, 2018 11:47 pm

Re: RB4011: wlan1 disabling itself

Tue Oct 08, 2019 1:18 pm

same problem on my RB4011iGS+5HacQ2HnD,,,,wlan1 interface QCA9984 stop working,,,re-enable stuck on "initializing",,,,,only reboot can make it return to work.
hope mk can fix this....asap
we discussed this more than one year.... asap... no, it's Mikrotik....
 
r00t
Member Candidate
Member Candidate
Posts: 202
Joined: Tue Nov 28, 2017 2:14 am

Re: RB4011: wlan1 disabling itself

Tue Oct 08, 2019 4:35 pm

The new Mikrotik Audience uses same QCA radio for 2nd 5GHz WIFI (for inet distribution). Will be interesting to see if it also have problems.
If it works on Audience but not on RB4011, it's clearly hardware issue of RB4011 design. Could be as small thing as missing capacitor somewhere or having too long traces on PCB that sometimes produce glitch... but we will see after a few months when Audience will be more common.
But it's really annoying this issue is STILL not fixed! Seems like Mikrotik doesn't even know why it's happening...
 
ddslc
just joined
Posts: 10
Joined: Sat Jun 22, 2019 4:32 pm

Re: RB4011: wlan1 disabling itself

Tue Oct 08, 2019 4:53 pm

The only way to speedup fixing it is to distribute this information wide, so anybody who plans to buy Mikrotik think twice.
 
joaquinmb
just joined
Posts: 3
Joined: Mon Jul 01, 2019 2:23 pm

Re: RB4011: wlan1 disabling itself

Tue Oct 08, 2019 5:35 pm

are you testing with 6.46beta44 ? In changelog:
*) wireless - improved stability when setting fixed primary and secondary channels on RB4011iGS+5HacQ2HnD-IN;
*) wireless - improved 802.11ac stability for all ARM devices with wireless;
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 774
Joined: Mon May 14, 2012 9:30 pm

Re: RB4011: wlan1 disabling itself

Tue Oct 08, 2019 7:41 pm

We believe we have fixed the issue, but that particular fix has not yet been released. Wait for the next beta please.
FORTUNATELY... I only have one in the field and it has not exhibited this particular problem. Could the fact that I am in the US have something to do with it?

The reports of the wifi disabling itself... I never had that.

I have had other issues... but never that one. Could the fact that my routers are configured to UNITED STATES 2 or 3 or what ever help explain this?
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 901
Joined: Tue Oct 11, 2005 4:53 pm

Re: RB4011: wlan1 disabling itself

Tue Oct 08, 2019 9:52 pm

For the problem to manifest you have to have no device connected to 5GHz wifi for a few hours. Then it "crashes".

The title is a bit misleading. The interface doesn't get disabled, in that you don't see it disabled (greyed out) in winbox.
It shows up/enabled fine in winbox/cli, but it doesn't transmit any SSID when the problem occurs. If you try to change any setting while that happens, then it gets stuck at "initializing" state and doesn't change until you reboot the device.
 
Reinis
MikroTik Support
MikroTik Support
Posts: 56
Joined: Wed Jan 02, 2019 12:14 pm
Location: Latvia
Contact:

Re: RB4011: wlan1 disabling itself

Thu Oct 10, 2019 6:41 am

For the problem to manifest you have to have no device connected to 5GHz wifi for a few hours. Then it "crashes".

The title is a bit misleading. The interface doesn't get disabled, in that you don't see it disabled (greyed out) in winbox.
It shows up/enabled fine in winbox/cli, but it doesn't transmit any SSID when the problem occurs. If you try to change any setting while that happens, then it gets stuck at "initializing" state and doesn't change until you reboot the device.
Sadly, it's not that easy as currently we couldn't reproduce the issue locally while following any of the guides from people who has contacted us directly. There are much more variables needed in order to repeat the issue. If you want to help to resolve this issue, please contact support@mikrotik.com
 
Nirox
just joined
Posts: 24
Joined: Sun Dec 16, 2018 11:47 pm

Re: RB4011: wlan1 disabling itself

Thu Oct 10, 2019 9:13 am

For the problem to manifest you have to have no device connected to 5GHz wifi for a few hours. Then it "crashes".

The title is a bit misleading. The interface doesn't get disabled, in that you don't see it disabled (greyed out) in winbox.
It shows up/enabled fine in winbox/cli, but it doesn't transmit any SSID when the problem occurs. If you try to change any setting while that happens, then it gets stuck at "initializing" state and doesn't change until you reboot the device.
Sadly, it's not that easy as currently we couldn't reproduce the issue locally while following any of the guides from people who has contacted us directly. There are much more variables needed in order to repeat the issue. If you want to help to resolve this issue, please contact support@mikrotik.com

Setup RB4011 in home or office 20-25 working places. Reproduce 100%
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 901
Joined: Tue Oct 11, 2005 4:53 pm

Re: RB4011: wlan1 disabling itself

Thu Oct 10, 2019 10:33 am

For the problem to manifest you have to have no device connected to 5GHz wifi for a few hours. Then it "crashes".

The title is a bit misleading. The interface doesn't get disabled, in that you don't see it disabled (greyed out) in winbox.
It shows up/enabled fine in winbox/cli, but it doesn't transmit any SSID when the problem occurs. If you try to change any setting while that happens, then it gets stuck at "initializing" state and doesn't change until you reboot the device.
Sadly, it's not that easy as currently we couldn't reproduce the issue locally while following any of the guides from people who has contacted us directly. There are much more variables needed in order to repeat the issue. If you want to help to resolve this issue, please contact support@mikrotik.com
Interesting. Then why did normis say that you believe that you have fixed the issue and that we should wait for the next beta?
And more interesting, why did he delete his post stating that?!
We believe we have fixed the issue, but that particular fix has not yet been released. Wait for the next beta please.
 
Reinis
MikroTik Support
MikroTik Support
Posts: 56
Joined: Wed Jan 02, 2019 12:14 pm
Location: Latvia
Contact:

Re: RB4011: wlan1 disabling itself

Thu Oct 10, 2019 1:58 pm

Interesting. Then why did normis say that you believe that you have fixed the issue and that we should wait for the next beta?
And more interesting, why did he delete his post stating that?!
We believe we have fixed the issue, but that particular fix has not yet been released. Wait for the next beta please.
I deleted the post as he misunderstood what was fixed in one of the unreleased beta versions.
 
SergeiF
just joined
Posts: 22
Joined: Wed Aug 02, 2017 4:01 am

Re: RB4011: wlan1 disabling itself

Fri Oct 11, 2019 3:28 am

I am not buying until this issue is resolved. Too expensive device to beta test.
 
Retral
just joined
Posts: 13
Joined: Wed Jul 25, 2018 9:10 pm

Re: RB4011: wlan1 disabling itself

Fri Oct 11, 2019 4:04 am

One thing that may help replicate this issue is using the sfp port. Both times I have witnessed this and all times our tech support has witnessed this the sfp port is in use.
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 901
Joined: Tue Oct 11, 2005 4:53 pm

Re: RB4011: wlan1 disabling itself

Mon Oct 14, 2019 11:16 pm

One thing that may help replicate this issue is using the sfp port. Both times I have witnessed this and all times our tech support has witnessed this the sfp port is in use.
Interesting detail.

In my board that the issue occurs, I indeed use the SFP port.
 
kiler129
Member Candidate
Member Candidate
Posts: 227
Joined: Tue Mar 31, 2015 4:32 pm
Contact:

Re: RB4011: wlan1 disabling itself

Tue Oct 15, 2019 6:25 am

The SFP port doesn't seem to play a role - I tested a single one with SFP and couple with standard default config setup with Ethernet-1 WAN and they were crashing equally bad ;)

Who is online

Users browsing this forum: No registered users and 15 guests