Community discussions

 
cad614
just joined
Topic Author
Posts: 1
Joined: Sun Oct 07, 2018 5:14 am

RB2011 and Intel X540-AT2

Sun Jan 06, 2019 7:10 pm

Hi all,
Over the holidays I decided to build a new PC for the lab using an Intel X540-AT2 network card. When connecting to the RB201UAS-2HnD (ROS 6.43.8) on ports 6-10 it works as expected (max at 100Mb), however on ports 1-5 it auto-negotiates to 100Mb full but refuses to acquire an address. I tried to force speeds on ports 1-5 without success, swapped cables, verified cables on other equipment. Ran both Ubuntu 18.04 and Windows 10 with the latest Intel drivers thinking it must be a driver issue with the NIC. Finally I connected a spare RB751G to the PC and it works, auto-negotiates at 1Gb full - no issues.

The RB2011 in question has no issues connecting at 1Gbs to the RB751G, hAP ac², a windows PC with an Intel 82566DM-2 NIC, or an Asus RT-N56U.

After searching online it looks like this was a fairly common issue with the RB2011 series and Cisco equipment starting back in 2013. I ran across numerous complaints but failed to find the resolution. Did I overlook something, or do I need to keep a second switch in place?
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: RB2011 and Intel X540-AT2

Thu Jan 10, 2019 9:53 pm

I had some issues with auto-negotiation. There is some trick, but for me the best thing was to just get a RB4011.

Who is online

Users browsing this forum: No registered users and 9 guests