Community discussions

 
palhaland
just joined
Topic Author
Posts: 10
Joined: Mon Aug 15, 2016 9:05 pm

Audience

Tue May 14, 2019 5:51 pm

Now that MikroTik is making a mesh router, will they have a "backbone" version that also support this mesh model (secondary 5G radio to run the mesh). Let's say add a secondary 5g wireless card to RB4011?
 
anuser
Member
Member
Posts: 406
Joined: Sat Nov 29, 2014 7:27 pm

Re: Audience

Tue May 14, 2019 10:25 pm

I actually want to see a cAP ac version 2 with 2x 5GHz + 1x 2GHz with the enhanced PoE+ capabilities, i.e. Running 3x cAP ac in a daisy chain
 
jvparis
just joined
Posts: 7
Joined: Mon Jan 14, 2019 9:53 am
Location: Germany

Re: Audience

Wed Sep 11, 2019 4:00 pm

 
muetzekoeln
Member Candidate
Member Candidate
Posts: 146
Joined: Fri Jun 29, 2018 2:34 pm

Re: Audience

Wed Sep 11, 2019 4:24 pm

I think, Audience has been released:
Interesting. Anyone with information about the implemented mesh protocol? Do Audience has band-steering? How does it deal with RADAR detection (=wireless Backbone down?)? When will come a Powerline modem for Audience? Can wired connections to Audience-APs be part of the mesh?
 
r00t
Member Candidate
Member Candidate
Posts: 221
Joined: Tue Nov 28, 2017 2:14 am

Re: Audience

Wed Sep 11, 2019 4:43 pm

Interesting device!

Image
Hope the 5GHz behaves better than on RB4011, it uses same QCA9984 radio chipset...

Also interesting construction, with these inverted dishes creating sector "corner" antennas:
Image
 
mkx
Forum Guru
Forum Guru
Posts: 3223
Joined: Thu Mar 03, 2016 10:23 pm

Re: Audience

Wed Sep 11, 2019 9:03 pm

When will come a Powerline modem for Audience?
There won't be one. Audience hasn't got USB port (at least I didn't see it mentioned), so you'll have to use generic PowerLine2ethernet devices.
BR,
Metod
 
User avatar
xvo
Long time Member
Long time Member
Posts: 603
Joined: Sat Mar 03, 2018 1:12 am
Location: Moscow, Russia

Re: Audience

Wed Sep 11, 2019 9:14 pm

There won't be one. Audience hasn't got USB port (at least I didn't see it mentioned), so you'll have to use generic PowerLine2ethernet devices.
But it has two ethernet ports, so PWR-LINE-PRO can be used.
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1743
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Audience

Wed Sep 11, 2019 10:04 pm

There won't be one. Audience hasn't got USB port (at least I didn't see it mentioned), so you'll have to use generic PowerLine2ethernet devices.
But it has two ethernet ports, so PWR-LINE-PRO can be used.
good idea but be aware PWR-LINE-PRO is not manageable
 
r00t
Member Candidate
Member Candidate
Posts: 221
Joined: Tue Nov 28, 2017 2:14 am

Re: Audience

Thu Sep 12, 2019 3:31 am

Too bad Mikrotik again saved a $1 instead of giving us USB port. The huge price difference would have probably made this device completely overpriced...
According to the datasheet, CPU have one USB 3.0 port. Just route it out to the connector.... but that's too much to ask for probably. Same CPU is in RB 450Gx4, but again, no USB port... SAD!
 
User avatar
antispam
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Mon Apr 11, 2005 5:57 pm

Re: Audience

Thu Sep 12, 2019 10:35 am

that one USB port is dedicated for mPCIe card for LTE.

They should go for more expensive SoC then.
 
TimurA
Member Candidate
Member Candidate
Posts: 190
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: Audience

Thu Sep 12, 2019 10:38 am

why usb if there is no print server support in ROS?
ImageImage
 
User avatar
antispam
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Mon Apr 11, 2005 5:57 pm

Re: Audience

Thu Sep 12, 2019 10:44 am

who still uses so old printers without eth wifi /cloud :D :D
 
r00t
Member Candidate
Member Candidate
Posts: 221
Joined: Tue Nov 28, 2017 2:14 am

Re: Audience

Thu Sep 12, 2019 8:53 pm

that one USB port is dedicated for mPCIe card for LTE.
Fair point.

However:
  • SOC still also have one USB 2.0 port they could use
  • Or just add an USB 3.0 HUB chip... would probably cost $2 instead of $1...
  • And back to the RB 450Gx4, it doesn't even have mPCIe slot, so no excuses here
 
mada3k
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Mon Jul 13, 2015 10:53 am
Location: Sweden

Re: Audience

Fri Sep 13, 2019 1:39 pm

why usb if there is no print server support in ROS?
because all recent shareable printers today have ethernet or wifi.
Manages some CCR's, RB750Gr3, RB922 and wAP's
 
TimurA
Member Candidate
Member Candidate
Posts: 190
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: Audience

Fri Sep 13, 2019 2:24 pm

why usb if there is no print server support in ROS?
because all recent shareable printers today have ethernet or wifi.
yes, I hinted at it :)
ImageImage
 
uldise
just joined
Posts: 8
Joined: Fri Jul 27, 2018 6:04 pm

Re: Audience

Fri Sep 13, 2019 8:03 pm

a quick question about LTE6 modem - is it a miniPCIe device? if yes, will it be available separately? and if yes, can it be replaced in SXT LTE Kit to achieve CA?
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1743
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Audience

Sat Sep 14, 2019 12:37 am

a quick question about LTE6 modem - is it a miniPCIe device? if yes, will it be available separately? and if yes, can it be replaced in SXT LTE Kit to achieve CA?


Audience LTE6 kit - MiniPCIe slot with factory installed R11e-LTE6 card and SIM slot.

https://i.mt.lv/cdn/rb_files/1568200061 ... -%20qg.pdf
 
User avatar
doneware
Trainer
Trainer
Posts: 539
Joined: Mon Oct 08, 2012 8:39 pm
Location: Hungary

Re: Audience

Sun Sep 15, 2019 9:20 am

  • Or just add an USB 3.0 HUB chip... would probably cost $2 instead of $1...
  • And back to the RB 450Gx4, it doesn't even have mPCIe slot, so no excuses here
in case of the 450Gx4 it was a crucial goal to keep the same form factor as the 850Gx2 and 450/450G.
alao it is rated for harsh temperatures so you don’t really have full freedom at chosing components. the pcb is already filled with components, no place for a mpcie slot or a full sized usb connector.
new externally accessible connectors would anyway require new case designs or mods, and there are tons of 3rd party case manufacturers out there.
#TR0359
 
r00t
Member Candidate
Member Candidate
Posts: 221
Joined: Tue Nov 28, 2017 2:14 am

Re: Audience

Sun Sep 15, 2019 2:08 pm

thanks for explanation doneware ... yes, form factor compatibility often sucks like this, been there, done that

But really, for new hardware, please consider routing out as many interfaces as possible.
USB is very handy, you even have the PLC box now, but there are many devices you can't connect it to because there's no USB.
Same for mini-pcie slot, with LoRA released soon and LTE cards being popular, having extra slot is always good.
New SOCs have a lot of interfaces and it's sad to see when they can't be used...
 
User avatar
JohnTRIVOLTA
Member Candidate
Member Candidate
Posts: 208
Joined: Sun Dec 25, 2016 2:05 pm
Location: BG/Sofia

Re: Audience

Sun Sep 15, 2019 9:23 pm

Can anyone post a single export file of basic configuration when Audience connecting to the other audience device with mesh setup? I have to know out exactly what is configured in ROS !
 
badbadc0ffee
just joined
Posts: 1
Joined: Mon Sep 23, 2019 10:15 am

Re: Audience

Mon Sep 23, 2019 10:17 am

Is the second 5GHz WLAN really only usable for the mesh backbone (as the announcement suggests) or is it freely configurable (e.g. as client, AP, CAP)?
 
User avatar
soonwai
Member Candidate
Member Candidate
Posts: 163
Joined: Mon Feb 06, 2012 10:50 pm
Location: Kuala Lumpur

Re: Audience

Mon Sep 23, 2019 10:30 pm

I presume this will have 802.11r/k/v ? For the "wifi mesh".
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Audience

Tue Sep 24, 2019 9:04 am

The other 5GHz interface is freely configurable. By default, it's used to link with another Audience unit, but you can remove the default config and use it just like any other MikroTik device. So in total you have three wlan interfaces for any setup you want.
No answer to your question? How to write posts
 
muetzekoeln
Member Candidate
Member Candidate
Posts: 146
Joined: Fri Jun 29, 2018 2:34 pm

Re: Audience

Tue Sep 24, 2019 9:28 am

I presume this will have 802.11r/k/v ?

You are quite alone with this. Unfortunately!
 
telcouk
just joined
Posts: 18
Joined: Mon Jan 08, 2018 3:50 pm

Re: Audience

Wed Sep 25, 2019 11:31 am

If you have multiple units, do they act as one and support handover between access points?
Also will they band steer devices?
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1743
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Audience

Wed Sep 25, 2019 4:12 pm

poor man audience :lol:
poor-man-audience.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Audience

Thu Sep 26, 2019 10:01 am

Of course you can duplicate the functionality of Audience with other devices, RouterOS is very flexible and you can reconfigure any number of MikroTik products to achieve the same functionality. The benefit of Audience is that the secondary 5GHz interface is built into the same enclosure and the whole kit looks very pretty.
No answer to your question? How to write posts
 
anuser
Member
Member
Posts: 406
Joined: Sat Nov 29, 2014 7:27 pm

Re: Audience

Fri Sep 27, 2019 12:35 pm

Of course you can duplicate the functionality of Audience with other devices, RouterOS is very flexible and you can reconfigure any number of MikroTik products to achieve the same functionality. The benefit of Audience is that the secondary 5GHz interface is built into the same enclosure and the whole kit looks very pretty.
With its 2nd 5GHz interface the Audience will be a really nice access point for rooms with higher density when MU-MIMO is available (disable meshing, running standalone or with capsman controller), i.e.:
- 2.4GHz: 2x2:2
- 5.0GHz: 2x2:2 + 4x4:4

Also it has PoE+ in. Now I need either a wall mounting kit for Audience or a wAP/cAP wall mountable version of it. Are there any plans for that?
 
neutronlaser
Member Candidate
Member Candidate
Posts: 212
Joined: Thu Jan 18, 2018 5:18 pm

Re: Audience

Sat Sep 28, 2019 8:48 pm

Also it has PoE+ in. Now I need either a wall mounting kit for Audience or a wAP/cAP wall mountable version of it. Are there any plans for that?
Glue
 
modsx
just joined
Posts: 14
Joined: Wed Feb 24, 2016 3:54 pm

Re: Audience

Wed Oct 02, 2019 7:34 pm

To me, this device looks like an offensive to a provaider, where it creates the basis for using the operator frequency indoors. Everyone will find it hard to indulge.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Audience

Thu Oct 03, 2019 3:35 pm

What operator frequency do you mean? It is certified to be used indoors and only uses frequencies allowed for that purpose.
No answer to your question? How to write posts
 
flatbat
newbie
Posts: 48
Joined: Tue Apr 06, 2010 11:18 pm

Re: Audience

Thu Oct 03, 2019 4:56 pm

Audience is just using CAPsMAN and link with other CAP-devices on the third wlan similar to repeater (bridge-ap/station-bridge).
It is not using WDS mesh or any specific mesh technology.
 
anuser
Member
Member
Posts: 406
Joined: Sat Nov 29, 2014 7:27 pm

Re: Audience

Sun Oct 06, 2019 11:26 am

Audience is just using CAPsMAN and link with other CAP-devices on the third wlan similar to repeater (bridge-ap/station-bridge).
It is not using WDS mesh or any specific mesh technology.
Source:?
 
flatbat
newbie
Posts: 48
Joined: Tue Apr 06, 2010 11:18 pm

Re: Audience

Sun Oct 06, 2019 6:24 pm

Audience is just using CAPsMAN and link with other CAP-devices on the third wlan similar to repeater (bridge-ap/station-bridge).
It is not using WDS mesh or any specific mesh technology.
Source:?

The device itself..;

[admin@Audience1] > /system default-configuration print
                script: :global ssid;
                        #| RouterMode:
                        #|  * WAN port is protected by firewall and enabled DHCP client
                        #|  * Wireless and Ethernet interfaces (except WAN port/s)
                        #|    are part of LAN bridge
                        #| WPS Sync:
                        #|     mode:          ap-bridge;
                        #|     wpa2:          yes;
                        #|     channel-width: 20/40mhz-XX;
                        #| LAN Configuration:
                        #|     IP address 192.168.88.1/24 is set on bridge (LAN port)
                        #|     DHCP Server: enabled;
                        #|     DNS: enabled;
                        #| CAPsMAN:
                        #|     bands:               b/g/n, a/n, a/n/ac;
                        #|     installation:        indoor;
                        #|     channel-width:       20MHz;
                        #|     forwarding:          local;
                        #| Wireless: CAP enabled on wireless interfaces
                        #| WAN (gateway) Configuration:
                        #|     gateway:  ether1 ;
                        #|     ip4 firewall:  enabled;
                        #|     NAT:   enabled;
                        #|     DHCP Client: enabled;
                        
                        :global defconfMode;
                        :log info Starting_defconf_script_;
                        #-------------------------------------------------------------------------------
                        # Apply configuration.
                        # these commands are executed after installation or configuration reset
                        #-------------------------------------------------------------------------------
                        :if ($action = "apply") do={
                          # wait for interfaces
                          :local count 0;
                          :while ([/interface ethernet find] = "") do={
                            :if ($count = 30) do={
                              :log warning "DefConf: Unable to find ethernet interfaces";
                              /quit;
                            }
                            :delay 1s; :set count ($count +1); 
                          };
                          :local count 0;
                          :while ([/interface wireless print count-only] < 2) do={ 
                            :set count ($count +1);
                            :if ($count = 40) do={
                              :log warning "DefConf: Unable to find wireless interface(s)"; 
                              /ip address add address=192.168.88.1/24 interface=ether1 comment="defconf";
                              /quit
                            }
                            :delay 1s;
                          };
                          /interface wireless security-profiles {
                            add name=wpsSync
                            set wpsSync mode=dynamic-keys group-ciphers=aes-ccm unicast-ciphers=aes-ccm \
                              authentication-types=wpa2-psk disable-pmkid=yes wpa2-pre-shared-key=7448-b666 comment=defconf 
                          };
                          :local count 0;
                          :while ([/interface wireless find default-name="wlan3"] = "") do={ 
                            :if ($count = 15) do={
                              :log warning "DefConf: Unable to find wlan3 interface";
                              /quit
                            }
                            :delay 1s; :set count ($count +1);
                          };
                          /interface wireless {
                            :local wl3 [find default-name="wlan3"]
                            :local wlanMac  [get $wl3 mac-address];
                            :set ssid "SYNC-$[:pick $wlanMac 9 11]$[:pick $wlanMac 12 14]$[:pick $wlanMac 15 17]"
                            set $wl3 disabled=no mode=ap-bridge band=5ghz-a/n/ac ssid=$ssid security-profile=wpsSync wps-mode=push-button
                            set $wl3 channel-width=20/40mhz-XX
                          };
                         /interface list add name=WAN comment="defconf"
                         /interface list add name=LAN comment="defconf"
                         /interface bridge
                           add name=bridge disabled=no auto-mac=yes protocol-mode=rstp comment=defconf;
                         :local bMACIsSet 0;
                         :foreach k in=[/interface find where !(slave=yes  || name="ether1" || name~"bridge")] do={
                           :local tmpPortName [/interface get $k name];
                           :log info "port: $tmpPortName"
                           :if ($bMACIsSet = 0) do={
                             :if ([/interface get $k type] = "ether") do={
                               /interface bridge set "bridge" auto-mac=no admin-mac=[/interface ethernet get $tmpPortName mac-address];
                               :set bMACIsSet 1;
                             }
                           }
                           /interface bridge port
                             add bridge=bridge interface=$tmpPortName comment=defconf;
                         }
                           /ip pool add name="default-dhcp" ranges=192.168.88.10-192.168.88.254;
                           /ip dhcp-server
                             add name=defconf address-pool="default-dhcp" interface=bridge lease-time=10m disabled=no;
                           /ip dhcp-server network
                             add address=192.168.88.0/24 gateway=192.168.88.1 comment="defconf";
                          /ip address add address=192.168.88.1/24 interface=bridge comment="defconf";
                         /ip dns {
                             set allow-remote-requests=yes
                             static add name=router.lan address=192.168.88.1 comment=defconf
                         }
                        
                          /caps-man configuration {
                            add name=cfg-2ghz ssid=MikroTikD31D7F-2 channel.band=2ghz-b/g/n channel.control-channel-width=20mhz \
                              channel.extension-channel=XX distance=indoors installation=indoor \
                              datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes comment=defconf
                            add name=cfg-5ghz-ac ssid=MikroTikD31D7F-5 channel.band=5ghz-a/n/ac channel.control-channel-width=20mhz \
                              channel.extension-channel=XXXX distance=indoors installation=indoor \
                              datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes comment=defconf
                            add name=cfg-5ghz-an ssid=MikroTikD31D7F-5 channel.band=5ghz-a/n channel.control-channel-width=20mhz \
                              channel.extension-channel=XX distance=indoors installation=indoor \
                              datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes comment=defconf
                          };
                          /caps-man provisioning {
                            add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=cfg-2ghz \
                              name-format=prefix-identity name-prefix=2ghz comment=defconf
                            add action=create-dynamic-enabled hw-supported-modes=ac master-configuration=cfg-5ghz-ac \
                              name-format=prefix-identity name-prefix=5ghz-ac comment=defconf
                            add action=create-dynamic-enabled hw-supported-modes=an master-configuration=cfg-5ghz-an \
                              name-format=prefix-identity name-prefix=5ghz-an comment=defconf 
                          };
                          /caps-man manager interface {
                            set [ find default=yes ] forbid=yes
                            add disabled=no interface=bridge comment=defconf
                          };
                          /caps-man manager set enabled=yes
                          /interface wireless cap set enabled=yes interfaces=wlan1,wlan2 caps-man-addresses=127.0.0.1
                           /ip dhcp-client add interface=ether1 disabled=no comment="defconf";
                         /interface list member add list=LAN interface=bridge comment="defconf"
                         /interface list member add list=WAN interface=ether1 comment="defconf"
                         /ip firewall nat add chain=srcnat out-interface-list=WAN ipsec-policy=out,none action=masquerade comment="defconf: mas>
                         /ip firewall {
                           filter add chain=input action=accept connection-state=established,related,untracked comment="defconf: accept establi>
                           filter add chain=input action=drop connection-state=invalid comment="defconf: drop invalid"
                           filter add chain=input action=accept protocol=icmp comment="defconf: accept ICMP"
                           filter add chain=input action=accept dst-address=127.0.0.1 comment="defconf: accept to local loopback (for CAPsMAN)"
                           filter add chain=input action=drop in-interface-list=!LAN comment="defconf: drop all not coming from LAN"
                           filter add chain=forward action=accept ipsec-policy=in,ipsec comment="defconf: accept in ipsec policy"
                           filter add chain=forward action=accept ipsec-policy=out,ipsec comment="defconf: accept out ipsec policy"
                           filter add chain=forward action=fasttrack-connection connection-state=established,related comment="defconf: fasttrac>
                           filter add chain=forward action=accept connection-state=established,related,untracked comment="defconf: accept estab>
                           filter add chain=forward action=drop connection-state=invalid comment="defconf: drop invalid"
                           filter add chain=forward action=drop connection-state=new connection-nat-state=!dstnat in-interface-list=WAN comment>
                         }
                           /ip neighbor discovery-settings set discover-interface-list=LAN
                           /tool mac-server set allowed-interface-list=LAN
                           /tool mac-server mac-winbox set allowed-interface-list=LAN
                        }
                        #-------------------------------------------------------------------------------
                        # Revert configuration.
                        # these commands are executed if user requests to remove default configuration
                        #-------------------------------------------------------------------------------
                        :if ($action = "revert") do={
                        /user set admin password=""
                         /system routerboard mode-button set enabled=no
                         /system routerboard mode-button set on-event=""
                         /system script remove [find comment~"defconf"]
                         /ip firewall filter remove [find comment~"defconf"]
                         /ip firewall nat remove [find comment~"defconf"]
                         /interface list member remove [find comment~"defconf"]
                         /interface detect-internet set detect-interface-list=none
                         /interface detect-internet set lan-interface-list=none
                         /interface detect-internet set wan-interface-list=none
                         /interface detect-internet set internet-interface-list=none
                         /interface list remove [find comment~"defconf"]
                         /tool mac-server set allowed-interface-list=all
                         /tool mac-server mac-winbox set allowed-interface-list=all
                         /ip neighbor discovery-settings set discover-interface-list=!dynamic
                           :local o [/ip dhcp-server network find comment="defconf"]
                           :if ([:len $o] != 0) do={ /ip dhcp-server network remove $o }
                           :local o [/ip dhcp-server find name="defconf" !disabled]
                           :if ([:len $o] != 0) do={ /ip dhcp-server remove $o }
                           /ip pool {
                             :local o [find name="default-dhcp" ranges=192.168.88.10-192.168.88.254]
                             :if ([:len $o] != 0) do={ remove $o }
                           }
                           :local o [/ip dhcp-client find comment="defconf"]
                           :if ([:len $o] != 0) do={ /ip dhcp-client remove $o }
                         /ip dns {
                           set allow-remote-requests=no
                           :local o [static find comment="defconf"]
                           :if ([:len $o] != 0) do={ static remove $o }
                         }
                         /ip address {
                           :local o [find comment="defconf"]
                           :if ([:len $o] != 0) do={ remove $o }
                         }
                         :foreach iface in=[/interface ethernet find] do={
                           /interface ethernet set $iface name=[get $iface default-name]
                         }
                         /interface bridge port remove [find comment="defconf"]
                         /interface bridge remove [find comment="defconf"]
                         /interface wireless cap set enabled=no interfaces="" caps-man-addresses=""
                         /interface wireless reset-configuration wlan1
                         /interface wireless reset-configuration wlan2
                         /interface wireless reset-configuration wlan3
                          /interface wireless security-profiles remove [find name="wpsSync"]
                          /caps-man manager set enabled=no
                          /caps-man manager interface remove [find comment="defconf"]
                          /caps-man manager interface set [ find default=yes ] forbid=no
                          /caps-man provisioning remove [find comment="defconf"]
                          /caps-man configuration remove [find comment="defconf"]
                        }
                        :log info Defconf_script_finished;
                        :set defconfMode;
                        :set ssid;
                        
      caps-mode-script: #-------------------------------------------------------------------------------
                        # Note: script will not execute at all (will throw a syntax error) if
                        #       dhcp or wireless-fp packages are not installed
                        #-------------------------------------------------------------------------------
                        
                        #| CAP configuration
                        #|
                        #|   Wireless interfaces are set to be managed by CAPsMAN.
                        #|   All ethernet interfaces and CAPsMAN managed interfaces are bridged.
                        #|   DHCP client is set on bridge interface.
                        
                        # bridge port name
                        :global brName  "bridgeLocal";
                        :global logPref "defconf:";
                        
                        
                        :global action;
                        
                        :log info $action
                        
                        :if ($action = "apply") do={
                        
                          # wait for ethernet interfaces
                          :local count 0;
                          :while ([/interface ethernet find] = "") do={
                            :if ($count = 30) do={
                              :log warning "DefConf: Unable to find ethernet interfaces";
                              /quit;
                            }
                            :delay 1s; :set count ($count + 1);
                          }
                        
                          :local macSet 0;
                          :local tmpMac "";
                        
                          :foreach k in=[/interface ethernet find] do={
                            # first ethernet is found; add bridge and set mac address of the ethernet port
                            :if ($macSet = 0) do={
                              :set tmpMac [/interface ethernet get $k mac-address];
                              /interface bridge add name=$brName auto-mac=no admin-mac=$tmpMac comment="defconf";
                              :set macSet 1;
                            }
                            # add bridge ports
                            /interface bridge port add bridge=$brName interface=$k comment="defconf"
                          }
                        
                          # try to add dhcp client on bridge interface (may fail if already exist)
                          :do {
                            /ip dhcp-client add interface=$brName disabled=no comment="defconf"
                          } on-error={ :log warning "$logPref unable to add dhcp client";}
                        
                        
                          # try to configure caps (may fail if for example specified interfaces are missing)
                          :local interfacesList "";
                          :local bFirst 1;
                        
                          # wait for wireless interfaces
                          :while ([/interface wireless find] = "") do={
                            :if ($count = 30) do={
                              :log warning "DefConf: Unable to find wireless interfaces";
                              /quit;
                            }
                            :delay 1s; :set count ($count + 1);
                          }
                        
                          # delay just to make sure that all wireless interfaces are loaded
                          :delay 5s;
                          :foreach i in=[/interface wireless find] do={
                            if ($bFirst = 1) do={
                              :set interfacesList [/interface wireless get $i name];
                              :set bFirst 0;
                            } else={
                              :set interfacesList "$interfacesList,$[/interface wireless get $i name]";
                            }
                          }
                          :do {
                            /interface wireless cap
                              set enabled=yes interfaces=$interfacesList discovery-interfaces=$brName bridge=$brName
                          } on-error={ :log warning "$logPref unable to configure caps";}
                        
                        }
                        
                        :if ($action = "revert") do={
                          :do {
                            /interface wireless cap
                              set enabled=no interfaces="" discovery-interfaces="" bridge=none
                          } on-error={ :log warning "$logPref unable to unset caps";}
                        
                          :local o [/ip dhcp-client find comment="defconf"]
                          :if ([:len $o] != 0) do={ /ip dhcp-client remove $o }
                        
                          /interface bridge port remove [find comment="defconf"]
                          /interface bridge remove [find comment="defconf"]
                        
                        }
  wps-sync-mode-script: #-------------------------------------------------------------------------------
                        # Note: script will not execute at all (will throw a syntax error) if
                        #       dhcp or wireless-fp packages are not installed
                        #-------------------------------------------------------------------------------
                        
                        #| WPS Sync Configuration:
                        #|  * Wireless and ethernet interfaces bridged with enabled DHCP client
                        #|  * wlan1/2 access points and wlan3 wps sync releater
                        #| Wireless: CAP enabled on wlan1/2
                        #| WPS Sync:
                        #|     mode:          repeater;
                        #| LAN Configuration:
                        #|     DHCP client: enabled;
                        
                        
                        # bridge port name
                        :global brName  "bridgeLocal";
                        :global logPref "defconf:";
                        :global ssid;
                        
                        :global action;
                        
                        :log info $action
                        
                        :if ($action = "apply") do={
                        
                          # wait for ethernet interfaces
                          :local count 0;
                          :while ([/interface ethernet find] = "") do={
                            :if ($count = 30) do={
                              :log warning "DefConf: Unable to find ethernet interfaces";
                              /quit;
                            }
                            :delay 1s; :set count ($count + 1);
                          }
                        
                          :local macSet 0;
                          :local tmpMac "";
                        
                          :foreach k in=[/interface ethernet find] do={
                            # first ethernet is found; add bridge and set mac address of the ethernet port
                            :if ($macSet = 0) do={
                              :set tmpMac [/interface ethernet get $k mac-address];
                              /interface bridge add name=$brName auto-mac=no admin-mac=$tmpMac comment="defconf";
                              :set macSet 1;
                            }
                            # add bridge ports
                            /interface bridge port add bridge=$brName interface=$k comment="defconf"
                          }
                        
                          # try to add dhcp client on bridge interface (may fail if already exist)
                          :do {
                            /ip dhcp-client add interface=$brName disabled=no comment="defconf"
                          } on-error={ :log warning "$logPref unable to add dhcp client";}
                        
                        
                          :local count 0;
                          :while ([/interface wireless print count-only] < 3) do={
                            :set count ($count +1);
                            :if ($count = 40) do={
                              :log warning "DefConf: Unable to find wireless interfaces";
                              /ip address add address=192.168.88.1/24 interface=ether1 comment="defconf";
                              /quit
                            }
                            :delay 1s;
                          };
                        
                          :foreach k in=[/interface wireless find] do={
                            # add bridge ports
                            /interface bridge port add bridge=$brName interface=$k comment="defconf"
                          }
                        
                          :local hwInfo [/interface wireless info hw-info [.. find where default-name="wlan3"] as-value];
                          #:if (($hwInfo->"locked-countries")~"russia") do={
                            /interface wireless set [find where default-name="wlan3"] channel-width=20/40mhz-XX band=5ghz-a/n/ac
                          #} else={
                          #  /interface wireless set [find where default-name="wlan3"] channel-width=20/40/80mhz-XXXX band=5ghz-a/n/ac
                          #}
                        
                          /interface wireless cap
                            set discovery-interfaces=bridgeLocal enabled=yes interfaces=wlan1,wlan2
                          /interface wireless
                            setup-repeater wlan3 duration=2m
                        }
                        
                        :if ($action = "revert") do={
                          :local o [/ip dhcp-client find comment="defconf"]
                          :if ([:len $o] != 0) do={ /ip dhcp-client remove $o }
                        
                          /interface bridge port remove [find comment="defconf"]
                          /interface bridge remove [find comment="defconf"]
                        
                          /interface wireless cap set enabled=no interfaces="" discovery-interfaces=""
                          /interface wireless reset-configuration wlan1
                          /interface wireless reset-configuration wlan2
                          /interface wireless reset-configuration wlan3
                        
                        
                        }
                        
                        :set brName;
                        :set logPref;
                        :set ssid;
 
SvSx10
just joined
Posts: 1
Joined: Thu Oct 17, 2019 8:54 pm

Re: Audience

Thu Oct 17, 2019 9:11 pm

What operator frequency do you mean? It is certified to be used indoors and only uses frequencies allowed for that purpose.
Hello! I do not speak English well and I only have a MTCNA certificate.
It looks like you understand a new product and can answer many questions!
Correctly, I understand that in the configuration from the box, combining all the devices into a common network will they connect to each other and rebuild the configuration?

I will explain my question:
What happens if I connect to access point number 1, access point number 2, and then to access point number 2, access point number 3 and suddenly access point number 2 is disconnected (it doesn’t matter for what reason)? Will access point number 3 try to connect to access point number 1 or will it wait for access point number 2 to appear on the network (all access points in the Wi-Fi coverage area)?
Additional question:
If I connect an access point number 2 and 3 to an access point number 1. Will access point number 1 act as a controller and access points number 2 and 3 will not try to transfer data between themselves directly?

Sorry again for my English, I use Google translator to my shame.
I hope you can help me. Thank.

Who is online

Users browsing this forum: No registered users and 26 guests