Community discussions

 
User avatar
axrst
just joined
Topic Author
Posts: 11
Joined: Sat Jul 21, 2012 4:10 pm

PowerBox pro cannot upgrade from 44.2 to 45.1

Thu Jul 04, 2019 12:36 pm

Hi,

I'm trying to upgrade my PowerBox Pro from 44.2 to 45.1. Seems to download ok and performs a reboot, but after that I'm still in 44.2. The flash storage seems full (15,9mb of 16mb are used) so I cannot do that manually.

Any ideas?

Thanks
 
mkx
Forum Guru
Forum Guru
Posts: 2468
Joined: Thu Mar 03, 2016 10:23 pm

Re: PowerBox pro cannot upgrade from 44.2 to 45.1

Thu Jul 04, 2019 1:57 pm

Is there anything about it in log?
BR,
Metod
 
User avatar
axrst
just joined
Topic Author
Posts: 11
Joined: Sat Jul 21, 2012 4:10 pm

Re: PowerBox pro cannot upgrade from 44.2 to 45.1

Fri Jul 05, 2019 10:20 am

hi,

no, no info in the log file for this issue.
 
User avatar
krafg
Member Candidate
Member Candidate
Posts: 193
Joined: Sun Jun 28, 2015 7:36 pm

Re: PowerBox pro cannot upgrade from 44.2 to 45.1

Tue Jul 09, 2019 10:07 pm

You need to load the file to RAM memory, not to flash.

In files, put the file outside of flash folder. Make sure while the file is transferring, the flash memory used do not increase.

The last resource is always install it through NetInstall.

Regards.
Image
 
User avatar
doneware
Trainer
Trainer
Posts: 477
Joined: Mon Oct 08, 2012 8:39 pm
Location: Hungary

Re: PowerBox pro cannot upgrade from 44.2 to 45.1

Wed Jul 10, 2019 1:24 pm

strange, mine did work well, albeit it was an upgrade from 44.3 to 45.1
also included flash usage to see how much free space you usually ought to have with a clean setup. this one has almost literally no config in it:
/interface bridge
add name=bridge1 protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] speed=100Mbps
set [ find default-name=ether2 ] speed=100Mbps
set [ find default-name=ether3 ] speed=100Mbps
set [ find default-name=ether4 ] speed=100Mbps
set [ find default-name=ether5 ] speed=100Mbps
set [ find default-name=sfp1 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether1
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge1
/ip ssh
set allow-none-crypto=yes forwarding-enabled=remote strong-crypto=yes
/system clock
set time-zone-name=Europe/Budapest
/system identity
set name=1.icp
/system logging
add prefix=XXX topics=script,debug
/system routerboard settings
set auto-upgrade=yes
You do not have the required permissions to view the files attached to this post.
#TR0359
 
User avatar
axrst
just joined
Topic Author
Posts: 11
Joined: Sat Jul 21, 2012 4:10 pm

Re: PowerBox pro cannot upgrade from 44.2 to 45.1

Fri Jul 12, 2019 6:54 pm

You need to load the file to RAM memory, not to flash.

In files, put the file outside of flash folder. Make sure while the file is transferring, the flash memory used do not increase.

The last resource is always install it through NetInstall.

Regards.
I did that thing with ram, but no luck. After reboot I'm still on 6.44.2. I should try net install, but that has some extra work and I don't want to pause working my setup.
 
User avatar
axrst
just joined
Topic Author
Posts: 11
Joined: Sat Jul 21, 2012 4:10 pm

Re: PowerBox pro cannot upgrade from 44.2 to 45.1

Fri Jul 12, 2019 6:58 pm

strange, mine did work well, albeit it was an upgrade from 44.3 to 45.1
also included flash usage to see how much free space you usually ought to have with a clean setup. this one has almost literally no config in it:
Well, here is mine:
[axrst@FKids0-PowerBoxPro] /system resource> print
                   uptime: 5m15s
                  version: 6.44.2 (stable)
               build-time: Apr/01/2019 12:47:57
         factory-software: 6.36
              free-memory: 107.4MiB
             total-memory: 128.0MiB
                      cpu: MIPS 74Kc V5.0
                cpu-count: 1
            cpu-frequency: 800MHz
                 cpu-load: 10%
           free-hdd-space: 80.0KiB
          total-hdd-space: 16.0MiB
  write-sect-since-reboot: 132
         write-sect-total: 193226
               bad-blocks: 0%
        architecture-name: mipsbe
               board-name: PowerBox Pro
                 platform: MikroTik
And the files:
[axrst@FKids0-PowerBoxPro] /file> print
 # NAME                                        TYPE                                              SIZE CREATION-TIME       
 0 flash                                       disk                                                   jan/01/1970 03:00:07
 1 flash/skins                                 directory                                              jan/01/1970 03:00:08
 2 flash/user-manager                          directory                                              oct/03/2018 01:15:11
 3 flash/user-manager/sqldb                    file                                           80.0KiB oct/03/2018 01:22:26
 4 flash/user-manager/logsqldb                 file                                            6.0KiB oct/03/2018 01:15:14
Where did the flash space gone? Only 80KBs free. Is this (maybe) a reason for the upgrade miss-function??
 
mkx
Forum Guru
Forum Guru
Posts: 2468
Joined: Thu Mar 03, 2016 10:23 pm

Re: PowerBox pro cannot upgrade from 44.2 to 45.1

Sat Jul 13, 2019 12:12 am

My guess is that you'll have to perform netinstall.

Make sure you create and save configuration export (the text version of it) before doing it. I also suggest that you start configuring it starting from default setup ... specially firewall settings ... and only add needed functionality (not just blindingly copy over the old config).
BR,
Metod

Who is online

Users browsing this forum: No registered users and 15 guests