Community discussions

MikroTik App
 
Wintel2019
just joined
Topic Author
Posts: 4
Joined: Thu Jul 18, 2019 10:44 am

Internet network exchange on lost connection

Thu Jul 18, 2019 11:24 am

On the Routerboard device model RB201 1iL-RM we have two WAN connections and a LAN connection. When it goes down the WAN1 internet connection must automatically switch over to WAN2. When the WAN1 connection is re-established the Router must return to the main internet connection, WAN1. How can I configure it? Is it possible to have a script already working?
Thank you.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 976
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: Internet network exchange on lost connection

Thu Jul 18, 2019 4:28 pm

Look here.
-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
Wintel2019
just joined
Topic Author
Posts: 4
Joined: Thu Jul 18, 2019 10:44 am

Re: Internet network exchange on lost connection

Fri Jul 19, 2019 8:29 pm

I followed the guide but I can't get it to work.
You have a backup file for this configuration that you can import.
Thank you so much
Fernando
 
User avatar
krafg
Long time Member
Long time Member
Posts: 594
Joined: Sun Jun 28, 2015 7:36 pm

Re: Internet network exchange on lost connection

Sun Jul 21, 2019 4:12 am

With export command, copy and paste here your configuration (using hide sensitive option).

Regards.
If you want to know my network, you can find it here.

Image
 
Wintel2019
just joined
Topic Author
Posts: 4
Joined: Thu Jul 18, 2019 10:44 am

Re: Internet network exchange on lost connection

Mon Jul 22, 2019 9:49 am

# model = 2011iL
# serial number = 762507C3378A
/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether1 ] name=ether1WAN1
set [ find default-name=ether2 ] name=ether2WAN2
set [ find default-name=ether9 ] name=ether9LANlocal
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=pool1 ranges=192.168.1.2-192.168.1.254
/ip dhcp-server
add address-pool=pool1 disabled=no interface=bridge1 name=server1
/interface bridge port
add bridge=bridge1 interface=ether9LANlocal
/ip address
add address=192.168.2.99/24 interface=ether1WAN1 network=192.168.2.0
add address=192.168.3.99/24 interface=ether2WAN2 network=192.168.3.0
add address=192.168.1.1/24 interface=ether9LANlocal network=192.168.1.0
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.1.1 \
netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall nat
add action=masquerade chain=srcnat
/ip route
add check-gateway=ping distance=1 gateway=8.8.8.8 routing-mark=ISP1
add check-gateway=ping distance=2 gateway=208.67.222.222 routing-mark=ISP1
add check-gateway=ping distance=1 gateway=208.67.222.222 routing-mark=ISP2
add check-gateway=ping distance=2 gateway=8.8.8.8 routing-mark=ISP2
add distance=1 dst-address=8.8.8.8/32 gateway=192.168.2.1 scope=10
add distance=1 dst-address=208.67.222.222/32 gateway=192.168.3.1 scope=10
/ip ssh
set allow-none-crypto=yes forwarding-enabled=remote
/system clock
set time-zone-name=Europe/Rome
 
Wintel2019
just joined
Topic Author
Posts: 4
Joined: Thu Jul 18, 2019 10:44 am

Re: Internet network exchange on lost connection

Wed Jul 24, 2019 6:57 pm

There are changes to be made to the script sent

Who is online

Users browsing this forum: No registered users and 18 guests