Community discussions

 
iulianv
just joined
Topic Author
Posts: 4
Joined: Thu Aug 01, 2019 11:36 am

1100x4 unexpected downgrade

Thu Aug 01, 2019 11:46 am

Hello MikroTik forumists,

Did it ever happen to anyone that, following power issues, an 1100x4 gets downgraded to an older RouterOS version (and sometimes even to an older config)? I've seen it on several devices in several locations, and I've only seen it on 1100x4s (we're also using x2s and CCRs) - what's different with the x4 about the OS and config storage that could be related to this behaviour?

Thank you.
 
mkx
Forum Guru
Forum Guru
Posts: 2981
Joined: Thu Mar 03, 2016 10:23 pm

Re: 1100x4 unexpected downgrade

Thu Aug 01, 2019 12:30 pm

This could happen if NAND was partitioned (for fall-back) and the backup partition never got updated (neither ROS nor config). The mechanism is such that routerboot starts device from the other partition if there's an error making RB to reboot. Power outage counts as such (personally I don't think power outage should be the reason to switch over to backup partition).

Check output of command /partitions print to see if this might be the case (if it only displays single partition, then my theory is a miss).
BR,
Metod
 
iulianv
just joined
Topic Author
Posts: 4
Joined: Thu Aug 01, 2019 11:36 am

Re: 1100x4 unexpected downgrade

Thu Aug 01, 2019 12:50 pm

Spot on!
> /partitions print
Flags: A - active, R - running
 #    NAME                      FALLBACK-TO                      VERSION                                         SIZE
 0 AR part0                     next                             RouterOS v6.44.3 Apr/23/2019 12:37:03          64MiB
 1    part1                     next                             RouterOS v6.45.2 Jul/17/2019 10:04:19          64MiB
The Wiki manual page should be enough to enlighten me further - thank you very much for the hint.
 
wrkq
newbie
Posts: 42
Joined: Mon Jul 29, 2019 10:59 pm

Re: 1100x4 unexpected downgrade

Thu Aug 01, 2019 6:25 pm

Power outage counts as such (personally I don't think power outage should be the reason to switch over to backup partition).
From what I've seen power outage should not cause partition switch unless the data on active partition is corrupted and boot from it failed.
I mean, just yesterday I've been hard unplugging power from my partitioned RB4011 multiple times because I found a way to make the management plane hang when setting up 80+80MHz mode, and it never failed to other partition because after power on the part0 boot was successful every time.

I think the "boot from it failed" mechanism can also kick in if you have power come back for a very short time and fail again.
(power fail - ... - power back - routerboot starts, begins loading part0 - power fail - ... - power back - routerboot starts, notices "loading from part0 did not complete last time" and switches to part1).
 
sid5632
Member
Member
Posts: 352
Joined: Fri Feb 17, 2017 6:05 pm

Re: 1100x4 unexpected downgrade

Fri Aug 02, 2019 3:50 am

Did it ever happen to anyone that, following power issues, an 1100x4 gets downgraded to an older RouterOS version (and sometimes even to an older config)? I've seen it on several devices in several locations, and I've only seen it on 1100x4s
I had that on a 951G when I pulled the power out half way through booting. When I re-powered it, it came up on a really old ROS version and config.
I don't think it was partitioned. It may have been in the past though. Very weird.

Who is online

Users browsing this forum: No registered users and 15 guests