Community discussions

MikroTik App
 
Mett
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Sat Mar 12, 2016 10:15 pm

RB4011: SFP power cycle?

Tue Nov 17, 2020 3:59 pm

Hey,

I'm using a CarlitoxxPro SFP-ONT with a RB4011. When the RB4011 reboots, the SFP ONT is not available. What I have to do is removing the module and plug it back in.

Obviously I need to power cycle the SFP. Is there a hidden option which makes that happen?
forum.mikrotik@honig.do0.de
 
Elans
MikroTik Support
MikroTik Support
Posts: 88
Joined: Wed Apr 18, 2018 12:41 pm

Re: RB4011: SFP power cycle?

Thu Nov 19, 2020 8:46 am

Hello Mett,
No, unfortunately, there is no such option.
 
msatter
Forum Guru
Forum Guru
Posts: 1983
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: RB4011: SFP power cycle?

Thu Nov 19, 2020 11:00 am

You could try this as scipt running (Terminal) after the router has booted and see if that helps:
{
disable sfp-sfpplus1
:delay 50ms
enable  sfp-sfpplus1
}
My scipt-code in PPP Profile for not obtaining a MTU of 1500:
{
:delay 4s
/interface
:if (([pppoe-client monitor pppoe-out as-value once]->"mtu") < 1500) do={
disable sfp-sfpplus1
:delay 50ms
enable  sfp-sfpplus1
:log warning "PPPoE MTU lower than 1500 so the SFP port is restarted"} 
}
One RB4011 (cooled) and a RB760iGS (hEX S) in series. The 4011 Does PPPoE/IKEv2.
The cooler: viewtopic.php?f=3&t=138613&start=300#p799879
Running:
RouterOS 6.48beta58 / Winbox 3.27 64bits / MikroTik APP 1.3.15
 
Mett
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Sat Mar 12, 2016 10:15 pm

Re: RB4011: SFP power cycle?

Thu Nov 19, 2020 11:12 am

No, unfortunately disabling the SFP port and reenabling it doesn't helps in this case. At the moment, I have to remove the module after boot and plug it back to the cage so it works.
forum.mikrotik@honig.do0.de

Who is online

Users browsing this forum: No registered users and 37 guests