Community discussions

MikroTik App
just joined
Topic Author
Posts: 2
Joined: Wed Dec 25, 2019 7:16 pm

Loop caused by faulty port?

Wed Nov 25, 2020 5:47 pm

RB 941 -2nd keeps on giving me a loop error on port 3.
Saw there a loop yhe moment I tried logging into it. Showing me two mac addresses, which I later confirmed was the wlan and the bridge ports.
Moved the cable from the device that was plugged in on port 3 to port 4 to see if the problem still exists (before I moved I disabled both ports to stop the broadcast) No more loop was found after I enabled them. So I tried identifying the problem by doing the same plugging it back into port 3 - this time it did the same, but also gave me a message that the cable is showing 10mb - Which I know isn't true as I tested it to be 1Gbs.

Weird enough ended up markimg the port as faulty and disabling it.
Moved to port 4 and everything still working.
Has anyone else had this problem and can maybe try to explain to me why this could happen?
User avatar
Forum Guru
Forum Guru
Posts: 1252
Joined: Mon Apr 08, 2019 1:16 am

Re: Loop caused by faulty port?

Thu Nov 26, 2020 1:07 am

Whatever is at the other end of that cable can cause this. (a loop)
If there is NO DIFFERENCE between the ether3 and ether4 port settings or filters, then the only difference is the MAC address of the ports. The bridge may take the MAC address from the first active port. So it can change when you move the cable. The used MAC address must always be unique in that network.
How can you test that the cable is 1Gbps? Maybe it can carry 1Gbps like a Cat5E or Cat6 cable, but by default the actual speed is "negotiated" between the 2 devices at both ends of the cable.
The 10 Mbps negotiation result indicates either a faulty cable or a disturbed negotiation process. A faulty cable may work or not, or have crosstalk between the wires or not, depending on how it is bend or stretched.

Who is online

Users browsing this forum: No registered users and 47 guests