Community discussions

 
MimiFleX
newbie
Topic Author
Posts: 49
Joined: Tue Jun 13, 2006 2:36 pm
Location: France

UPS on miniRouter ?

Tue Jul 24, 2007 9:10 pm

Hi,

We're using a lot of RB532 monitoring SmartAPC UPS via serial port and black cable provided with the UPS.

But today we are starting using the wonderful miniRouter board when we don't need embedded WLAN cards. I disabled (as usual for RB532) serial terminal in RouterOS, to enable UPS monitoring... without success. My UPS entry stays « Invalid ».

I've also posted a message about this problem on routerboard forum available here : http://forum.routerboard.com/viewtopic.php?f=3&t=3614

Do someone succeeded to make SmartUPS working on miniRouter ? Can I make something on RouterOS or my serial cable to make UPS monitoring working ?

Best regards,
MFX.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: UPS on miniRouter ?

Thu Jul 26, 2007 10:21 am

RouterOS v2.9 doesn't allow you to change the port settings for the RB100 series boards.
You can upgrade to V3.0 where you can do that.
 
MimiFleX
newbie
Topic Author
Posts: 49
Joined: Tue Jun 13, 2006 2:36 pm
Location: France

Re: UPS on miniRouter ?

Thu Aug 02, 2007 12:00 pm

Thanks for your answer.

Ok, I've just upgraded to 3.0rc1 and UPS is working correctly.
But miniRouter is unable to boot with UPS serial cable connected. If the cable is connected after boot, all is ok !

On RB532 I have to set "enter-setup-on" to "delete-key" to avoid RB532 to enter bios settings from a random character sent by UPS at boot. I also set "enter-setup-on" to "delete-key" on miniRouter, but the result is the same, the board stays with both LEDs steady ON, and nothing more.

How can I avoid miniRouter to stay in an unknown boot state when UPS cable connected ?

Regards,

MFX.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: UPS on miniRouter ?

Thu Aug 02, 2007 12:33 pm

I have tried with the latest version of BIOS version (system routerboard print, system routerboard upgrade, system reboot).
Login to the BIOS and check the boot key, when I configured it to <Delete>, any other keyboard key is not working.
 
MimiFleX
newbie
Topic Author
Posts: 49
Joined: Tue Jun 13, 2006 2:36 pm
Location: France

Re: UPS on miniRouter ?

Fri Aug 03, 2007 5:53 pm

ok, with the 2.9 routerboard firmware, boot is ok.

I didn't try this 2.9 version at first because the last version available on http://www.routerboard.com is 2.8. I was not able to see the Changelog for 2.9, and didn't want to brick the board ;)
The 2.9 Changelog is here : http://www.routerboard.com/files/rb-2.9/CHANGELOG but, is not visible on http://www.routerboard.com/rb100.html.

This problem is not mentioned on this Changelog but now it works.

Thanks a lot,

MFX.
 
ELSE
newbie
Posts: 26
Joined: Thu Nov 01, 2007 7:19 am

Re: UPS on miniRouter ?

Wed Nov 28, 2007 2:19 pm

Hello!

I have the same "boot problem" with connected APC UPS (SUA2200RMXLI3U) and the "invalid"-message too. Please, tell me: How can you solve the boot problem with UPS connected?
I have already installed RouterOS 2.9.48 but both problems are not fixed.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: UPS on miniRouter ?

Wed Nov 28, 2007 11:09 pm

Else, please check the both settings mentioned previoisly.
1) Make sure you have the latest RouterBOARD BIOS version.
2) Check that you have configured <delete> key for 'enter-setup-on'.

Report back with the results.
 
6ara6ashka
just joined
Posts: 3
Joined: Wed Dec 05, 2007 9:24 am
Location: Russia, Volgograd

Re: UPS on miniRouter ?

Wed Dec 05, 2007 11:22 am

Else, please check the both settings mentioned previoisly.
1) Make sure you have the latest RouterBOARD BIOS version.
2) Check that you have configured <delete> key for 'enter-setup-on'.

Report back with the results.
Hello! I have too this problem from APC UPS.
Where i can see this: Make sure you have the latest RouterBOARD BIOS version?
I make, like write in refman2.9.pdf (pages 585-590), but in ver. 2.9.48 and 3.0rc11 has not /system routerboard bios menu:(
In ver. 3.0rc11 i see:
/system routerboard> print
routerboard: yes
current-firmware: "2.8"
upgrade-firmware: "2.12"
then i use comamnd upgrade, put "Y", then i see
/system routerboard> print
routerboard: yes
current-firmware: "2.12"
upgrade-firmware: "2.12", but when i open "new terminal" window again, setup shows me:
/system routerboard> print
routerboard: yes
current-firmware: "2.8"
upgrade-firmware: "2.12"

Also, where i can see this: Check that you have configured <delete> key for 'enter-setup-on'?
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: UPS on miniRouter ?

Wed Dec 05, 2007 3:02 pm

6ara6ashka,
attach null modem cable,
run Terminal emulation program (HyperTerminal, SecureCRT).

Login to router BIOS,
- hit any key, when routerboard is swiched on.
There you should find such command.
 
6ara6ashka
just joined
Posts: 3
Joined: Wed Dec 05, 2007 9:24 am
Location: Russia, Volgograd

Re: UPS on miniRouter ?

Fri Dec 07, 2007 8:04 am

6ara6ashka,
attach null modem cable,
run Terminal emulation program (HyperTerminal, SecureCRT).

Login to router BIOS,
- hit any key, when routerboard is swiched on.
There you should find such command.
I configured <delete> key for 'enter-setup-on' in BIOS, i upgrade BIOS to ver 2.12, and that's what get:
If I attach UPS cable and disable food (simulation fall on nutrition), including the food and then again, it is not loaded mikrotik (green light is lit), and it should not go. If AGAIN disable and enable pitnaie, the mikrotik starts normally loaded.
Here's another: when booting from the cable modem, why then loaded it 2.8, the 2.12 version, in turn, that is, if the restart mikrotik loaded 2.12 if reboot again loaded 2.8.

p.s. May be could try 2.9.50 version, not 3.0rc11?

Who is online

Users browsing this forum: No registered users and 12 guests