Community discussions

 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Per interface traffic shaping

Thu Nov 26, 2009 2:02 pm

Hi,

I have an RB450G and I would like to shape on LAN interfaces without MAC or IP address.
For example shape the whole traffic of ether3 interface to 2Mbps/4Mbps up/down.
It is possible? It could work?

Thx,
oreggin
 
guille4
Frequent Visitor
Frequent Visitor
Posts: 93
Joined: Tue Sep 29, 2009 9:23 pm

Re: Per interface traffic shaping

Sat Dec 05, 2009 5:45 am

Sure. Put a queue tree rule as follows:
/queue tree add name="ether2" parent=ether2 limit-at=2000000 priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
limit-at format is in bits/seg,

ether2 is an example: put your own interface here.

This limits are ever applied in outgoing traffic of the interface.
 
RK
Long time Member
Long time Member
Posts: 560
Joined: Tue Nov 21, 2006 11:22 am
Location: Winnipeg, Canada and Central America

Re: Per interface traffic shaping

Mon Dec 07, 2009 11:29 pm

Sure. Put a queue tree rule as follows:
/queue tree add name="ether2" parent=ether2 limit-at=2000000 priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
Shouldn't it actually be "max-limit"?
limit-at should be empty in this case
 
guille4
Frequent Visitor
Frequent Visitor
Posts: 93
Joined: Tue Sep 29, 2009 9:23 pm

Re: Per interface traffic shaping

Wed Dec 09, 2009 2:27 am

yes, you're right. My mistake.
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: Per interface traffic shaping

Fri Dec 18, 2009 4:34 pm

THX, I will try.
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: Per interface traffic shaping

Sat Sep 11, 2010 3:13 pm

This isn't working on wlan1 interface for example, but works on bridge1.
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: Per interface traffic shaping

Mon Sep 13, 2010 6:44 pm

Sorry, I forgot: It was tested on ROS v5beta6
 
RK
Long time Member
Long time Member
Posts: 560
Joined: Tue Nov 21, 2006 11:22 am
Location: Winnipeg, Canada and Central America

Re: Per interface traffic shaping

Tue Sep 14, 2010 8:28 am

This isn't working on wlan1 interface for example, but works on bridge1.
If you are using bridges, be sure to enable IP firewall in the bridge settings.
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: Per interface traffic shaping

Wed Sep 22, 2010 3:27 pm

I have a RB433AH with an 11n wireless miniPCI card and use 5.0rc1 ROS.

If I enable any queue on wlan1 (which isn't member port of bridge1), on the ether2 and ether3 port (which are member ports of bridge1) DNS resolving is slow (~5000msec). If I disable the queue DNS resolving is fast again ~50-100ms.

If I enable any queue on bridge1 (which have member ports of wlan1, ether2, ether3), on the ether2 and ether3 port (which are member ports of bridge1) DNS resolving is slow (~5000msec). If I disable the queue DNS resolving is fast again ~50-100ms.

Interesting but on clients on wlan1 interface DNS resolving isn't slow any of the scenarios above.

The use-ip-firewall bridge settings doesn't affect the result.

Any idea?
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: Per interface traffic shaping

Wed Sep 22, 2010 3:42 pm

Sure. Put a queue tree rule as follows:
/queue tree add name="ether2" parent=ether2 limit-at=2000000 priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
Shouldn't it actually be "max-limit"?
limit-at should be empty in this case
This queue is doesn't any effect with this setting:
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=8700k max-limit=10M name=wifi parent=wlan1 priority=8 queue=default
Edit: wlan1 is not a member oprt of bridge1 and no any opther queue on the system.
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: Per interface traffic shaping

Sun Sep 26, 2010 8:31 pm

Any idea?
 
dan24
just joined
Posts: 1
Joined: Mon Oct 04, 2010 5:00 pm

Re: Per interface traffic shaping

Thu Nov 11, 2010 12:58 pm

disable ipv6 in browser -> faster dns resolving with queueing with bridge
 
GSM
just joined
Posts: 1
Joined: Wed Sep 06, 2017 12:33 am

Re: Per interface traffic shaping

Wed Sep 06, 2017 12:35 am

Dears,

Can this be done through GUI or it's just via CLI?
 
Quindor
Member
Member
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: Per interface traffic shaping

Thu Sep 07, 2017 8:13 pm

Dears,

Can this be done through GUI or it's just via CLI?
Why are you reviving a topic from 2010?! Come on.

Also the question, you can easily look this up with just a bit of googling or trying. The answer is, this can be done through winbox, web interface and cli.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!

Who is online

Users browsing this forum: No registered users and 27 guests