Page 1 of 1

Per interface traffic shaping

Posted: Thu Nov 26, 2009 2:02 pm
by oreggin
Hi,

I have an RB450G and I would like to shape on LAN interfaces without MAC or IP address.
For example shape the whole traffic of ether3 interface to 2Mbps/4Mbps up/down.
It is possible? It could work?

Thx,
oreggin

Re: Per interface traffic shaping

Posted: Sat Dec 05, 2009 5:45 am
by guille4
Sure. Put a queue tree rule as follows:
/queue tree add name="ether2" parent=ether2 limit-at=2000000 priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
limit-at format is in bits/seg,

ether2 is an example: put your own interface here.

This limits are ever applied in outgoing traffic of the interface.

Re: Per interface traffic shaping

Posted: Mon Dec 07, 2009 11:29 pm
by RK
Sure. Put a queue tree rule as follows:
/queue tree add name="ether2" parent=ether2 limit-at=2000000 priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
Shouldn't it actually be "max-limit"?
limit-at should be empty in this case

Re: Per interface traffic shaping

Posted: Wed Dec 09, 2009 2:27 am
by guille4
yes, you're right. My mistake.

Re: Per interface traffic shaping

Posted: Fri Dec 18, 2009 4:34 pm
by oreggin
THX, I will try.

Re: Per interface traffic shaping

Posted: Sat Sep 11, 2010 3:13 pm
by oreggin
This isn't working on wlan1 interface for example, but works on bridge1.

Re: Per interface traffic shaping

Posted: Mon Sep 13, 2010 6:44 pm
by oreggin
Sorry, I forgot: It was tested on ROS v5beta6

Re: Per interface traffic shaping

Posted: Tue Sep 14, 2010 8:28 am
by RK
This isn't working on wlan1 interface for example, but works on bridge1.
If you are using bridges, be sure to enable IP firewall in the bridge settings.

Re: Per interface traffic shaping

Posted: Wed Sep 22, 2010 3:27 pm
by oreggin
I have a RB433AH with an 11n wireless miniPCI card and use 5.0rc1 ROS.

If I enable any queue on wlan1 (which isn't member port of bridge1), on the ether2 and ether3 port (which are member ports of bridge1) DNS resolving is slow (~5000msec). If I disable the queue DNS resolving is fast again ~50-100ms.

If I enable any queue on bridge1 (which have member ports of wlan1, ether2, ether3), on the ether2 and ether3 port (which are member ports of bridge1) DNS resolving is slow (~5000msec). If I disable the queue DNS resolving is fast again ~50-100ms.

Interesting but on clients on wlan1 interface DNS resolving isn't slow any of the scenarios above.

The use-ip-firewall bridge settings doesn't affect the result.

Any idea?

Re: Per interface traffic shaping

Posted: Wed Sep 22, 2010 3:42 pm
by oreggin
Sure. Put a queue tree rule as follows:
/queue tree add name="ether2" parent=ether2 limit-at=2000000 priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
Shouldn't it actually be "max-limit"?
limit-at should be empty in this case
This queue is doesn't any effect with this setting:
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=8700k max-limit=10M name=wifi parent=wlan1 priority=8 queue=default
Edit: wlan1 is not a member oprt of bridge1 and no any opther queue on the system.

Re: Per interface traffic shaping

Posted: Sun Sep 26, 2010 8:31 pm
by oreggin
Any idea?

Re: Per interface traffic shaping

Posted: Thu Nov 11, 2010 12:58 pm
by dan24
disable ipv6 in browser -> faster dns resolving with queueing with bridge

Re: Per interface traffic shaping

Posted: Wed Sep 06, 2017 12:35 am
by GSM
Dears,

Can this be done through GUI or it's just via CLI?

Re: Per interface traffic shaping

Posted: Thu Sep 07, 2017 8:13 pm
by Quindor
Dears,

Can this be done through GUI or it's just via CLI?
Why are you reviving a topic from 2010?! Come on.

Also the question, you can easily look this up with just a bit of googling or trying. The answer is, this can be done through winbox, web interface and cli.