Community discussions

 
NetWorker
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Sun Jan 31, 2010 6:55 pm

Usb port invalid

Sun Jan 31, 2010 7:09 pm

Hi all.

I'll start off by saying that I'm new to Mikrotik and am already in love with you guys! I've setup my RB 411U with a Huawei E226 (like E220) 3G modem in no time and it works great. Except for one minor detail.


Almost every time (I'd say 9 out of 10) I shutdown the router, disconnect the power, and boot up again, the usb port (under system) comes back invalid. A reboot rectifies the problem.

This basically means that every time I power up and boot, I have to reboot. It's not really really a problem. Just a little anoying.

Any one else experiencing this? Has anyone come up with a solution?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3423
Joined: Mon May 31, 2004 2:55 pm

Re: Usb port invalid

Mon Feb 01, 2010 1:48 pm

Are you using the latest RouterOS version?
Can you reproduce it almost every reboot?
Maybe you could provide remote access to that router?
Please contact support@mikrotik.com
 
NetWorker
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Sun Jan 31, 2010 6:55 pm

Re: Usb port invalid

Mon Feb 01, 2010 9:23 pm

Are you using the latest RouterOS version?
Thanks for the reply uldis. RouterOS version 4.4
Can you reproduce it almost every reboot?
It's basically like this. Every time I shut it down and boot it up again, I have to reboot because the usb port shows invalid in red. After the reboot, everything is fine. It happened once or twice that I didn't have to reboot. Why that was, I have no idea.

I have a theory however. I think it's the modems fault. I believe it needs a couple of seconds to start after receiving power. I don't know exactly how much time after starting to receive power, the RB provides power through the usb.
My theory then is that if the modem starts talking to the RouterOS only after it already boot up, it won't recognize it. And since a reboot doesn't cut the power to the modem, it will recognize it without problems.
Maybe you could provide remote access to that router?
Gladly. I'm a little low on bandwidth (EDGE) on site, but I think it will do to run winbox remotely, telnet in or whatever.
Please contact support@mikrotik.com
Will do. I'm not on site now (and I think I won't be until next week). But I'll send an e-mail when I know for sure.
 
diaan1
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Tue Jun 12, 2007 7:31 pm

Re: Usb port invalid

Wed Feb 03, 2010 1:26 am

I have the same problem with a 411U an Huawei E220. Starts up correctly 50% of the time, other times exactly what you describe and this requires a trip to the site- Very frustrating.

Any suggestions?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3423
Joined: Mon May 31, 2004 2:55 pm

Re: Usb port invalid

Wed Feb 03, 2010 1:19 pm

please provide us access to the board where you see this problem. We need access from the ethernet or wireless side.
 
NetWorker
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Sun Jan 31, 2010 6:55 pm

Re: Usb port invalid

Wed Feb 03, 2010 9:36 pm

Oh... That's going to be a problem. The board is in a remote location and the only internet access is per GSM. Hence without the modem on the board, I have no way of providing access. I'd had to remove the whole thing from the tower and bring it in to the city...

If you guys really need it, then I'll do it. But if there is any way around it, let's try that first. I can provide access via the modem and I can send the support file in if that helps.
 
jcem
Member Candidate
Member Candidate
Posts: 137
Joined: Sun May 24, 2009 4:41 pm
Location: Grebbestad, Sweden

Re: Usb port invalid

Fri Mar 12, 2010 11:51 pm

I can confirm this problem with E220 and ROS 4.6. A cold restart allwas has to be followed by a Reboot

RGDS
 
Steve0
newbie
Posts: 37
Joined: Mon Feb 08, 2010 8:34 pm
Location: Somewhere between the Bit and the Byte

Re: Usb port invalid

Sat Mar 13, 2010 3:00 am

I have a theory however. I think it's the modems fault. I believe it needs a couple of seconds to start after receiving power. I don't know exactly how much time after starting to receive power, the RB provides power through the usb.
/system routerboard settings set boot-delay=9s
I have no experience with this setup, but maybe a boot delay would give the usb enough time to boot. I think the default is 2 or 3 seconds. Hope it helps.
 
NetWorker
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Sun Jan 31, 2010 6:55 pm

Re: Usb port invalid

Sat Mar 13, 2010 10:06 pm

Steve0, that's a great idea! I haven't been on site for about a month now, for which reason I haven't followed up on this. I'll give it a shot when I'm there again.
 
jcem
Member Candidate
Member Candidate
Posts: 137
Joined: Sun May 24, 2009 4:41 pm
Location: Grebbestad, Sweden

Re: Usb port invalid

Sun Mar 14, 2010 8:11 pm

I tried this too with the delay, but the same result

Is the port supposed to be invalid if you boot RB with no USB attached?
 
NetWorker
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Sun Jan 31, 2010 6:55 pm

Re: Usb port invalid

Sun Mar 14, 2010 10:31 pm

Damn... Was hoping it'd work. I'll give it a try though jcem, to see if we get the same results. But like I said, I don't know when that's going to be. I'm burried with work and college and don't have time to make the trip (200 km).

And no, it's not supposed to come back invalid with nothing attached to it. At least not in my experience. With nothing connected to the usb it should boot fine every time.
 
csickles
Forum Guru
Forum Guru
Posts: 1257
Joined: Fri May 28, 2004 8:46 pm
Location: Phoenix, AZ
Contact:

Re: Usb port invalid

Sun Mar 14, 2010 11:02 pm

I can provide a box. Let me know when you want to get to it.

Email in my account at mikrotik.com. (OEM)
Things that make you go "Hmmmmmmmm"...

Craig
 
jcem
Member Candidate
Member Candidate
Posts: 137
Joined: Sun May 24, 2009 4:41 pm
Location: Grebbestad, Sweden

Re: Usb port invalid

Mon Mar 15, 2010 12:03 am

Trying the same settings with a second RB 411U works without any problems!

:?
 
NetWorker
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Sun Jan 31, 2010 6:55 pm

Re: Usb port invalid

Wed Mar 17, 2010 7:10 pm

Trying the same settings with a second RB 411U works without any problems!
The same settings being the delay? How much did you use? I'd give as much delay as it takes the modem to blink once (you know, when it sees the network it blinks once, else it blinks twice in quick succession) plus 5 or 10 seconds. If that doesn't fix it, it'd kill my above described theory.

But like I said, it's now going to be a while before I'm there again.
 
User avatar
DogHead
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Jan 03, 2008 9:36 pm
Location: Anywhere you want me to be

Re: Usb port invalid

Tue Apr 06, 2010 9:29 pm

We have been having this same problem with a RB433UAH and a Sierra Wireless U598. This is with ROS 4.6. The problem we are seeing is that the USB port is either being reported as invalid or is completely undetected after EITHER a warm reboot or a power reset.

If we hot plug the modem into the USB after the RB433UAH is already running, all is well, but after a reboot, it is the same thing. I would confirm about 90% failures to detect. It seems like a problem with the USB hot plug driver. It does not behave the same across multiple boards. Some detect and boot fine and others have this issue.

Going to check BIOS.

Any suggestions?
WOOF BANG!
 
NetWorker
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Sun Jan 31, 2010 6:55 pm

Re: Usb port invalid

Wed Apr 07, 2010 3:31 am

Sorry DogHead, I'm all out of suggestions.

I tried this weekend the 9 second delay (9s being the highest value) with no results.

Also forgot to generate the support file. :(
Will do it next time.
 
User avatar
DogHead
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Jan 03, 2008 9:36 pm
Location: Anywhere you want me to be

Re: Usb port invalid

Wed Apr 07, 2010 9:51 am

We upgraded bios to 2.25.

So what we are seeing is that the Sierra Wireless 598U USB modem will sometimes be detected and sometimes not. There appear to be two different conditions: the USB port completely not discovered and the USB port being partially discovered but being shown as invalid.

Sometimes the system will recover and load the driver from a power reset, other times it will not. We tried the boot-delay setting, but it appears to make no difference.

The only action that seems to always fix it is to hot plug the 598U while the board is powered up. Again, this is why I think it must be related to the USB hot plug driver. The modem is just not being enumerated properly.

It is not a power issue as we have seen this with 12, 18 and 24 V supplies with and without miniPCI cards.

The modems will work 100% of the time with a windows PC and the Sierra Wireless Watcher application and windows driver.

We really want to make this work on the 433 as we have a need for multiple wireless interfaces. Any suggestions?
WOOF BANG!
 
User avatar
DogHead
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Jan 03, 2008 9:36 pm
Location: Anywhere you want me to be

Re: Usb port invalid

Thu Apr 08, 2010 4:01 am

So, it appears to be that the 598U has a timing issue with the USB driver. About 30% of the time the USB port is missing, 20% of the time the USB port is invalid, and 10% of the time the driver appears to load, but then we see that the modem is constantly resetting the link.

We have tried setting the boot-delay up to 9s. No difference.

We have tried every possible init string.

We have 4 modems and they all behave similar. With Windows drivers we do not see this issue. With Linux on x86 we do not see this issue. It appears to be unique to MT.

It would be very helpful if there were a manual way to restart the USB hot plug driver, or otherwise scan the USB bus for the modem. The only way we can restart the modems is with power reset.

We have a large opportunity for a public safety application and need to get this fixed asap. We have tried the U760 with same results.

When we do get the modem to load, it stays up reliably and will reconnect, but the boot up process is where the issue is.

MT guys, any ideas?
WOOF BANG!
 
User avatar
DogHead
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Jan 03, 2008 9:36 pm
Location: Anywhere you want me to be

Re: Usb port invalid

Fri Apr 09, 2010 2:40 am

We continue to test the Sierra Wireless 598U and 760U with the RB433. We have concluded that the modems take just slightly longer to power on and register themselves as an active USB devices than the RB433 takes to boot. So the OS does not recognize the USB port on the modems properly.

Solutions that we think would be required:

1. Allow for longer boot-delay interval
2. Allow for rescan of the USB ports for devices
3. Allow for power off/power on of USB ports in order to simulate USB device insertion

Other suggestions?
WOOF BANG!
 
User avatar
DogHead
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Jan 03, 2008 9:36 pm
Location: Anywhere you want me to be

Re: Usb port invalid

Sat Apr 10, 2010 12:24 am

USB invalid/undiscovered problem persists under ROS5.0beta1 too which is supposed to have new 3G drivers.

I think it is related to USB hot plug driver and not necessarily tied to the modem driver.
WOOF BANG!
 
coyotenq
just joined
Posts: 10
Joined: Tue Jan 26, 2010 6:11 pm

Re: Usb port invalid

Sat Apr 10, 2010 1:50 pm

I can't solve the problem but maybe some info i grab in my tests helps...

I have a RB433uah + Sierra C885 USB 3g Modem.

In my case (we have 10 RB and 10 modems) i can absolutely discard a hard failure.

Modem is in 90% cases detected, but no answer is given in any of the 7 data channels it shows. It simply stays in "resetting link state" in PPPoE, with the same config used by AT&T to set up the connection under windows (all modems works fine under win).

So, i try running OpenWRT natively on the board, and, flawless, the modem works and the PPPoE client works perfect.

Conclusion, USB hotplug driver MUST be the problem. I can't modify the RouterOS drivers, but maybe, support people can fix this easy.

I hope this helps.
Alejandro
 
User avatar
DogHead
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Jan 03, 2008 9:36 pm
Location: Anywhere you want me to be

Re: Usb port invalid

Sun Apr 11, 2010 4:12 am

The Pantech UMW190 works flawlessly. Cold booted 20 times with no issues. Warm rebooted 20 times with no issue. No lcp errors, no disconnects. Tested with both ROS4.6 and 5.9b1.

This is not a cheap modem. It is multiband supporting both GSM, UMTS, and CDMA. Primary carrier is Verizon CDMA and then roams out to other networks. Works fine on Verizon standard EvDO plan or you can buy a Global Roaming plan which fails over to other networks if CDMA is not available.

Too many issues with the Sierra Wireless and Novatel modems.

Now I just have to figure out which modem to use for Sprint.

I would still like to see someone address cold boot issues with USB hotplug driver. I think this is still an important issue to fix.
WOOF BANG!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23998
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Usb port invalid

Wed May 05, 2010 11:42 am

please make several supout.rif files - when you have plugged in the card and then booted the board, when you have booted the board and only then plugged in the card.

we will try to find the issue then.
No answer to your question? How to write posts
 
hedele
Member
Member
Posts: 338
Joined: Tue Feb 24, 2009 11:23 pm

Re: Usb port invalid

Wed May 05, 2010 7:05 pm

Until then, you could try to write some scripts which check if the port is in invalid state and reboots the routerboard if necessary :)
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23998
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Usb port invalid

Fri May 07, 2010 3:10 pm

for you that have Huaway cards, we have fixed this issue in RouterOS v5beta2, so you can try that.

Doghead - you have a Sierra card, this is another problem. Can you send us supout.rif files like I asked above?
No answer to your question? How to write posts
 
csickles
Forum Guru
Forum Guru
Posts: 1257
Joined: Fri May 28, 2004 8:46 pm
Location: Phoenix, AZ
Contact:

Re: Usb port invalid

Fri May 07, 2010 4:58 pm

Normis..

I usualy dont have issues with the 598s..

But I will watch mine and send supouts if I see this issue..

I will mention this thread ID in the message...
Things that make you go "Hmmmmmmmm"...

Craig
 
csickles
Forum Guru
Forum Guru
Posts: 1257
Joined: Fri May 28, 2004 8:46 pm
Location: Phoenix, AZ
Contact:

Re: Usb port invalid

Fri May 07, 2010 5:03 pm

Needed to read closer...

Will send a batch of files today.. (Sierra card out , instaled and rebooted, installed after reboot)

I use the Sierra 598U from sprint....

I sould have a 3G from verizon any day... (Special request) also a sierra wireless device..

I see the AT&T "lightning" is also the same Mfg..

(The 4Gs are 301u so prob wont do any good...)
Things that make you go "Hmmmmmmmm"...

Craig
 
yffud
just joined
Posts: 11
Joined: Tue Mar 16, 2010 7:53 pm
Location: Ireland

Re: Usb port invalid

Thu May 27, 2010 5:30 pm

for you that have Huaway cards, we have fixed this issue in RouterOS v5beta2, so you can try that.

Doghead - you have a Sierra card, this is another problem. Can you send us supout.rif files like I asked above?

Still having issues with v5beta2 hauwei not coming up right.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3423
Joined: Mon May 31, 2004 2:55 pm

Re: Usb port invalid

Fri May 28, 2010 2:19 pm

for you that have Huaway cards, we have fixed this issue in RouterOS v5beta2, so you can try that.

Doghead - you have a Sierra card, this is another problem. Can you send us supout.rif files like I asked above?

Still having issues with v5beta2 hauwei not coming up right.
please send the support output file to support@mikrotik.com and it would be great if you coul also provide in email the remote-access to that modem.
 
hedele
Member
Member
Posts: 338
Joined: Tue Feb 24, 2009 11:23 pm

Re: Usb port invalid

Wed Jun 09, 2010 6:19 pm

I had strange issues with 5.0 beta 2 on a RB433UAH - namely that connecting the ppp-client worked only once, after that the modem would no longer respond - ROS would send ATH, +++, ATH, +++, ATH, +++ ... and so on (Huawei E122)

With RouterOS 4.10 the usb port is invalid about every second reboot :)
I helped myself with that short script:

system script
add name=usb-checker policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\
:delay 15000ms; \r\
\n:if ([/port get [find where inactive] name] ~ \"usb\") do {:log info Por\
t-removal; :beep length=2s frequency=1000; /sys reboot;};"

I run it at every reboot with the scheduler

/system scheduler
add comment="" disabled=no interval=0s name=schedule1 on-event=\
"/system script run usb-checker" policy=\
reboot,read,write,policy,test,password,sniff,sensitive start-time=startup


Sometimes it has to auto-reboot 2 or 3 times to get the port valid again, but it does the job :)

Careful, it might lead to unwanted infinite reboot cycles if something else goes wrong! maybe change the delay to something larger if you are anxious :) Also, please only use it for Routerboard 433 UAH, i did not test it with anything else.
 
clmanning
just joined
Posts: 8
Joined: Tue Feb 23, 2010 12:06 am
Location: Kentucky, USA

Re: Usb port invalid

Thu Oct 14, 2010 6:13 pm

For what it's worth

After pulling what little hair I had remaining then reading all I could find on this subject, I figured that if the 598U was to remain powered up somehow (externally powered USB hub or something similar) then this would prove or disprove the boot timing theory.

So... plugged in a powered USB hub to a 411U running v5.0rc1, then the 598 into the hub. Cycled power on the RB several times while maintaining power on the hub. No luck either on a reset or a power cycle. Does this mean that it must be in the HotBoot portion of the BIOS?

I was also thinking of trying to set a delay in the init string but I don't think it will fix the problem since constant power to the modem didn't do the trick.

Anyone find a fix yet?
 
mcustance
just joined
Posts: 8
Joined: Fri Apr 01, 2011 4:33 pm

Re: Usb port invalid

Fri Apr 01, 2011 4:40 pm

Hi,

Has there been any progres with this? I have a RB/433UAH running V5 installed today. I am trying to connect a ZTE MF112 USB modem. As with other users it seems to pick it up every so often on a power reset. We are also seeing that the routerboard randomly restarting as soon as we turn on PPP with the modem connected.

CHeers

Michael
 
Eye3Motion
just joined
Posts: 7
Joined: Thu Jan 17, 2013 3:20 am

Re: Usb port invalid

Thu Jan 17, 2013 7:21 am

Is any one found a fix. I am having a same result. See below
1. RouterOS --> v5.22
2. 411U board
3. I can't make Sprint 598 3G usb data card to work when 411U boots up. It will only
work when I disconnect and reconnect and than it recognize my usb device but I can't
make this card to work in when it boot. I have increase my boot-delay time to 9s but no
difference. Appreciate any support. Thanks
 
User avatar
DogHead
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Jan 03, 2008 9:36 pm
Location: Anywhere you want me to be

Re: Usb port invalid

Fri Jan 18, 2013 7:07 pm

Eye3Motion...The USB drivers in ROS5.22 seem to work reliably to support most 3G (UMTS, HSPA, EvDO) modems. They do not support any LTE other than the Bandrich C501 that is derived from GOBI 3000. Just saw that ATT has authorized this modem. In US that is the only carrier that can use this modem right now. Not available for Verizon or Sprint. Someone said that the Sierra Wireless MC7710 worked...of course that will only work with RB411U that has miniPCIe slot.

Would be cool if there was a RB433 like board with miniPCIe slot and sim.
WOOF BANG!
 
sergio8
just joined
Posts: 1
Joined: Tue May 14, 2013 2:35 pm

Re: Usb port invalid

Tue May 14, 2013 2:56 pm

Hi everyone! I am using RB751-2HnD + huawei EC306-2 USB modem and have same problem. In my park about 15 pcs of RB751 and now a bought five 411UAHL RB and get same sad situation with USB port!
Sometimes I get another port like a USB2 or UNKNOWN.
using all 5 ver OS , now on v5.24
before read this topic thought about the voltages, and try all of 12-24v.
this does not solve the problem
help!


I also want to add.. find some ZTE AT-commands wich disable/enable flash cd-drive:
AT+ZCDRUN=8 disable
AT+ZCDRUN=9 enable


maybe there is something same for HUAWEI ?
 
zohaib
just joined
Posts: 11
Joined: Sun Nov 06, 2011 8:19 pm

Re: Usb port invalid

Wed Jun 12, 2013 1:21 am

i am also facing similar issue
i am using 750up with zte ac2791 evdo rev b modem network PTCL
after reboot "could not acquire serial port" error
i hope it will fix by mikrotik soon

i am waiting for the respond by mikrotik support to fix my issue
 
acatheking
just joined
Posts: 4
Joined: Thu Sep 22, 2011 5:02 pm

Re: Usb port invalid

Thu Aug 01, 2013 12:13 am

Almost every time (I'd say 9 out of 10) I shutdown the router, disconnect the power, and boot up again, the usb port (under system) comes back invalid. A reboot rectifies the problem.

This basically means that every time I power up and boot, I have to reboot. It's not really really a problem. Just a little anoying.

Any one else experiencing this? Has anyone come up with a solution?

The same problem here. I have RB411UAHR (6.1 OS) + Sierra Wireless MC8775 pci exprees mini card.

This problem about usb+Mikrotik is not solved through a few last versions 4.x, 5.x, 6.x.

I hope that someone from the Mikotik company will finnaly try to solve this permanently.

In the meantime, I will use Open WRT for this job, which is very stable with usb 3g devices.
 
ikazategi
just joined
Posts: 2
Joined: Tue Jul 30, 2013 7:05 pm

Re: Usb port invalid

Thu Aug 01, 2013 12:37 pm

I had strange issues with 5.0 beta 2 on a RB433UAH - namely that connecting the ppp-client worked only once, after that the modem would no longer respond - ROS would send ATH, +++, ATH, +++, ATH, +++ ... and so on (Huawei E122)

With RouterOS 4.10 the usb port is invalid about every second reboot :)
I helped myself with that short script:

system script
add name=usb-checker policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\
:delay 15000ms; \r\
\n:if ([/port get [find where inactive] name] ~ \"usb\") do {:log info Por\
t-removal; :beep length=2s frequency=1000; /sys reboot;};"

I run it at every reboot with the scheduler

/system scheduler
add comment="" disabled=no interval=0s name=schedule1 on-event=\
"/system script run usb-checker" policy=\
reboot,read,write,policy,test,password,sniff,sensitive start-time=startup


Sometimes it has to auto-reboot 2 or 3 times to get the port valid again, but it does the job :)

Careful, it might lead to unwanted infinite reboot cycles if something else goes wrong! maybe change the delay to something larger if you are anxious :) Also, please only use it for Routerboard 433 UAH, i did not test it with anything else.
Good morning I changed a bit your script. I commented the problem I had is:
hardware:
RU411U
RouterOS version: 4.5 and 6
3g Modem: MC8780, MC8775, EU870D

problem:
Sometimes when you soft reset the USB port appears inactive and the only way to return to activate was doing a power cycle.

solution:
After talking with Mikrotik support Sierra Wireless and did not get the solution, but I was able to fix it (not the best way) with a script that does the following:
- Remove the USB inactive
- Soft reset the router
- In the interface ppp-out I called 3g I set port to usb2 (default removed RouterOS USB port in my case) and remove the interfaces created by default (ppp-out who are inactive).

#######USB-CHECKER
:delay 15000ms;

#Establecemos a la interfaz 3g el puerto usb2
:local Port3g [/interface ppp-client get "3g" port];
if ($Port3g != "usb2") do {
:interface ppp-client set "3g" port="usb2";
};

#Borramos las interfaces creadas automaticamente que estas desactivadas y contienen por ppp-out
:foreach pppDel in= [/interface ppp-client find where disabled] do={
/interface ppp-client remove $pppDel;
:log info ppp-out-Inactive-removed;
};

#Chequeo usb
:foreach usbPortInactive in=[/port find where inactive] do {
/port remove $usbPortInactive;
:log info Port-Inactive-removed;
:beep length=2s frequency=1000;
/sys reboot;
};
#################
 
acatheking
just joined
Posts: 4
Joined: Thu Sep 22, 2011 5:02 pm

Re: Usb port invalid

Thu Aug 01, 2013 5:36 pm

It is not need to change previous script. I tried it on RB411UAHR + Sierra Wireless MC8775 and it works. USB became active after 2-3 auto-reboot :)
 
ikazategi
just joined
Posts: 2
Joined: Tue Jul 30, 2013 7:05 pm

Re: Usb port invalid

Fri Aug 02, 2013 2:24 pm

It is not need to change previous script. I tried it on RB411UAHR + Sierra Wireless MC8775 and it works. USB became active after 2-3 auto-reboot :)
in my case doing soft reset is sometimes not enough, the usb is still listed as inactive, and the only solution is to do a power cycle or delete the port.
 
wauzestyle
just joined
Posts: 3
Joined: Tue Aug 11, 2015 6:38 pm

Re: Usb port invalid

Tue Aug 11, 2015 6:43 pm

Hello all,

I just have bought a mikrotik CRS125-24G-1S cloud router switch for my firt mikrotik hardware experiences. i also starting to sell those on my work because i like this kind of configureble routers.

But unfornetly the CRS125-24G-1S + Huawai USB modem comes up with same kind of proplem mentioned above. usb is invalid after reboot from the OS.

OS version 6.30.2
 
wauzestyle
just joined
Posts: 3
Joined: Tue Aug 11, 2015 6:38 pm

Re: Usb port invalid

Tue Aug 11, 2015 7:08 pm

hello,

i have this same issue in my cloud router switches CRS125-24G-1S with mikrotik aproved Huawai USB modem..

Already some solution here? I where starting to roll this out in the field for remote support solution. I order yesterday more of these switches..

hope there wil be on solution on this problem. i just started to love mikrotik os.

BR
 
RLithgo
newbie
Posts: 30
Joined: Mon Dec 12, 2016 12:21 am

Re: Usb port invalid

Sun Mar 05, 2017 4:26 am

7 years from the original post and i have this exact issue.
It was all working fine for 2 months until yesterday.
I've had to disable the USB 3g modem until a fix is found.
Reboot temporarily fixes the USB port but then it goes to invalid state shortly after.
 
jblackburn
just joined
Posts: 1
Joined: Sun May 25, 2014 6:21 pm

Re: Usb port invalid

Tue Jul 11, 2017 1:54 am

Does anyone have any ideas on this? I have the Sierra Wireless 308. We have tried 2 separate modems with no luck to rule out HW. It work about 20% of the time but seems to require us to remove and re-insert the USB. Have tried on 6.39 and now 6.40rc36. Comes up with 0 ports, but vendor and name is correct in the USB tab.

Thanks!
 
NetWorker
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Sun Jan 31, 2010 6:55 pm

Re: Usb port invalid

Sat Jul 22, 2017 12:08 am

Well, we've moved past using 3g modems a couple of years ago. But are considering setting one up again as a backup connection since the site now also runs a server and some more critical traffic.

On topic, I wanted to point out that we later moved from the USB dongles to a Sierra Wireless MC 8775 3g miniPCI-express card. This card did not present the issue at all.

As to the root cause of the issue, I'm all out of ideas. Sorry.
 
anatod
just joined
Posts: 1
Joined: Mon Jan 08, 2018 6:49 pm

Re: Usb port invalid

Fri Aug 17, 2018 1:00 am

v 6.42.3 RB2011UAS-2HnD same problem with Huawei usb. The port is inactive, but in Resources/USB show me Huawei.

Who is online

Users browsing this forum: No registered users and 11 guests