Community discussions

MUM Europe 2020
 
User avatar
mag
Member
Member
Topic Author
Posts: 378
Joined: Thu Jul 01, 2004 12:32 pm
Location: Cologne, NRW, Germany
Contact:

RB/750G switch chip features

Sun Apr 25, 2010 6:59 pm

According to http://wiki.mikrotik.com/wiki/Manual:Sw ... _Switching
I am trying some functions. First one is this:
Ether1 port on RB450G has a feature that allows it to be removed/added to the default switch group. By default ether1 port will be included in the switch group. This configuration can be changed with /interface ethernet switch set switch1 switch-all-ports=no

"yes" means ether1 is part of switch and supports switch grouping, and all other advanced Atheros8316 features including extended statistics (/interface ethernet print stats).

"no" means ether1 is not part of switch, effectivly making it as stand alone ethernet port, this way increasing its troughtput to other ports in bridged, and routed mode, but removing the switching possibility on this port.
but when trying this result looks like:
[admin@rb750g] > int ether switch print        
Flags: I - invalid 
 #   NAME     TYPE         MIRROR-SOURCE     MIRROR-TARGET     SWITCH-ALL-PORTS
 0   switch1  Atheros-8316 none              none             

[admin@rb750g] > interface ethernet switch set switch1 switch-all-ports=no

[admin@rb750g] > int ether switch print                     
Flags: I - invalid 
 #   NAME     TYPE         MIRROR-SOURCE     MIRROR-TARGET     SWITCH-ALL-PORTS
 0   switch1  Atheros-8316 none              none     


does not seem to work at all... Has anyone been able to use this feature?


Second try considers VLANs, according to http://wiki.mikrotik.com/wiki/Manual:Sw ... Vlan_Table

As far as I understand it is possible to give VLAN-tag handling to the sowitch chip by creating a VLAN table. Sounds good, but how do i connect access ports (i.e. untagged ones) to that particular VLAN?

TIA
 
kirshteins
MikroTik Support
MikroTik Support
Posts: 592
Joined: Tue Dec 02, 2008 10:55 am

Re: RB/750G switch chip features

Mon Apr 26, 2010 8:52 am

1) Only 450G supports this feature.
2) Do you mean adding VLAN tags for specific ports?
 
User avatar
mag
Member
Member
Topic Author
Posts: 378
Joined: Thu Jul 01, 2004 12:32 pm
Location: Cologne, NRW, Germany
Contact:

Re: RB/750G switch chip features

Mon Apr 26, 2010 12:15 pm

Thank you for the answers.
1) Only 450G supports this feature.
Ok, i just tried because it seems to have the same chipset.

2) Do you mean adding VLAN tags for specific ports?
yes probably. A short example of a 2-port VLAN (id/tag 101), where ether1 is tagged (trunk port) and ether2 is untagged (access port):
/interface vlan add name=vlan1 vlan-id=101 interface=ether1

/interface bridge add name=vlan1
/interface bridge port add bridge=vlan1 interface=vlan1-e1
/interface bridge port add bridge=vlan1 interface=ether2
possibly could then replaced by something like this:
/interface ethernet switch vlan
add vlan-id=101 ports=1
add vlan-id=101 ports=2

/interface ethernet switch ports
print
set 0 vlan-mode=secure           \\ 0 = ether1

Who is online

Users browsing this forum: alber and 19 guests