Community discussions

MikroTik App
 
rmichael
Forum Veteran
Forum Veteran
Topic Author
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Miserable 3des ipsec performance on RB750

Fri Jun 25, 2010 2:24 am

PC1---RB750-[ipsec 3des]-RB750--PC2

PC1 to PC2, 1500bytes, udp, 3des ipsec traffic, one way:

65% CPU @ 100kbps
94% CPU @ 150kbps

(ROS4.9)

EDIT: same (lack of) performance on v4.10
 
meno
Member Candidate
Member Candidate
Posts: 233
Joined: Sat Jul 19, 2008 4:45 am

Re: Miserable 3des ipsec performance on RB750

Fri Jun 25, 2010 5:16 am

try to connect PC1 to ether1 and the rest to ether2-5

do not use pc1 to pc2 using ether2-5...
I tested normal internet routing upto 40Mbps with rb750

Image
 
rmichael
Forum Veteran
Forum Veteran
Topic Author
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: Miserable 3des ipsec performance on RB750

Fri Jun 25, 2010 6:30 am

Hi meno. I think you might have misunderstood as I took a few shortcuts in my diagram. I'm testing throughput over ipsec tunnel between two RB750. Both with factory setup (eth 1 wan, eth2-5 switchport1), firewall disabled. Here's detailed setup:

PC_1 running btest----[eth5]RB750_A[eth1]---{ipsec tunner established}---[eth1]RB750_B[eth5]----PC_2 running btest

I'm getting abysmal 150kbps (that's bits per second!) throughput at >90% CPU utilization.
 
meno
Member Candidate
Member Candidate
Posts: 233
Joined: Sat Jul 19, 2008 4:45 am

Re: Miserable 3des ipsec performance on RB750

Fri Jun 25, 2010 7:01 am

I got u.. it will be poor.. these chip are made for SOHO router but its amplified by RouterOS.. if u want good performance buy at lease RB450G or RB1000 it has ipsec hardware acelerator
 
roadracer96
Forum Veteran
Forum Veteran
Posts: 714
Joined: Tue Aug 25, 2009 12:01 am

Re: Miserable 3des ipsec performance on RB750

Fri Jun 25, 2010 8:03 am

FWIW, I have 1 customer w/ RB450Gs at each site with 3des IPSEC over a T1 at each end. Itll saturate the T1 and not max the CPU. IIRC, it was at ~30-40% cpu?
 
rmichael
Forum Veteran
Forum Veteran
Topic Author
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: Miserable 3des ipsec performance on RB750

Fri Jun 25, 2010 8:09 am

FWIW, I have 1 customer w/ RB450Gs at each site with 3des IPSEC over a T1 at each end. Itll saturate the T1 and not max the CPU. IIRC, it was at ~30-40% cpu?
Thanks. I've seen other posts quoting 4Mbps of VPN throughput for RB450G so that sounds about right.
 
rmichael
Forum Veteran
Forum Veteran
Topic Author
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: Miserable 3des ipsec performance on RB750

Sun Jun 27, 2010 1:01 am

Turns out RB750 has issues with port 1. IPSec throughput on other ports is quite good.
 
Swordforthelord
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Thu Jul 08, 2010 10:18 pm

Re: Miserable 3des ipsec performance on RB750

Sun Jul 17, 2011 9:31 am

Where did you get this information about Port 1 on the RB750? I have an older one with IPSEC latency issues.

Who is online

Users browsing this forum: No registered users and 24 guests