Page 1 of 1

RB112 - Kernel panic - not syncing

Posted: Mon Oct 03, 2011 2:32 pm
by Intrepid
I try to install ROS with Netinstall.
My first RB112 upgraded OK, but when I try with the second RB112, I get the following errormessage:
I've tried to format nand... anything else I should do?

Bricked?



RouterBOOT booter 2.6

RouterBoard 112

CPU frequency: 175 MHz
Memory size: 16 MB

Press any key within 2 seconds to enter setup..
kernel not found
trying bootp protocol....................................... OK
Got IP address: 192.168.100.98
resolved mac address 00:21:70:DC:46:0D
transfer started .......................... transfer ok, time=3.77s
setting up elf image... OK
jumping to kernel code
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Re: RB112 - Kernel panic - not syncing

Posted: Mon Oct 03, 2011 4:39 pm
by Intrepid
Okei, after some searching, i found out that i need the RB112 or RB500 firmware, that is supposed to be located at routerboard.com, but i cant find it.

Anyone?

Re: RB112 - Kernel panic - not syncing

Posted: Mon Oct 03, 2011 9:52 pm
by jhheider

Re: RB112 - Kernel panic - not syncing

Posted: Mon Oct 03, 2011 10:59 pm
by Intrepid
Yeah, I know that, but I dont think id make my self clear on this one.

I need the firmware, the .fwf file for RouterBOOT, for RB112...

Edit: I've found it at http://www.routerboard.sk/#rb111_112, hope that works...

Re: RB112 - Kernel panic - not syncing

Posted: Tue Oct 04, 2011 1:07 pm
by Intrepid
In Console, I used "upgrade firmware over serial port", and in hypertrm i used transfer and protocol Xmodem. Firmware update was 32kb, and went fine, rebooted and the upgraded to ROS 5.2 via ethernet and Netinstall.

Problem solved :)

Image