Page 1 of 1

RB751U-2HnD - poor wireless performance & problems

Posted: Wed Mar 28, 2012 6:05 pm
by paoloaga
I am experiencing a lot of problems with wireless devices connected to the RB751-2HnD.

I bought 3 units, in 2 different periods of time (2 when they became available several months ago, and one which arrived today). Local distributor said the last one is a new revision.

They are all configured as an access-point (802.11 b/g/n), and I get a lot of disconnections and very poor performances (high latency, variable between 40 and 3000ms, 100kbit/s throughput). If I manually set noise-floor to -90dB it becomes usable, but still I have reliability problems.

There are no interferences on the channel and devices work very well when connected to other access-points.

I already tried different ROS versions (5.6, 5.7, 5.9 and 5.14). All show the same behaviour on all units.

Does it happen only to me?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Mar 29, 2012 9:47 am
by uldis
have you contacted the support@mikrotik.com about the configuration of your wireless interface?
Do you use indoor built-in antennas or you connect external antenna connected to the external connector?
What wireless devices you use to test that performance? How many clients you have on that AP? What signal levels they have?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Mar 29, 2012 10:31 am
by WirelessRudy
You have to clearify better what your network setup is.
You talk about these 3 devices setup as access points and that there is no interference. Which is possible..
But then you talk about the fact that they connect well to other access points. How is that?
That is a. either not possible, or b. you work in a mesh (WDS) system.

More than 3 AP's in 2,4Ghz band means interference since there are only 3 separated 20Mhz channels available in 802.11b/g
If the radio's are even working in 802.11n than you already have interference with 2 units at the same time.

These unist are all High Power units, and if they are all in one room and working in 'n' mode it is inevatible you have interferences.

So work out a better radio/spectrum plan.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Mar 30, 2012 1:32 am
by paoloaga
I didn't contact support, yet, but I can do it tomorrow sending all details. I have some knowledge on wireless devices, and these aren't my first mikrotik AP I am using. The configuration is simple: bridge between ethernet and wireless, no routing, no nat... it's just an access point, configured as 802.11b/g/n with WPA2 PSK (AES CCM). I am using built-in antennas. I made tests using a Nokia N900, an ASUS Centrino laptop, an LG android phone. I tried also (today afternoon) with two other laptops (a Dell and an Acer). All the clients show the same behaviour.
Having only one client connected or multiple ones don't change the behaviour.
Signal levels ranging from -61 to -75 depending on position and distance, the result is the same.

WirelessRudy: These 3 devices were used one at a time, never together, but all three show the same behaviour. If I replace the RB751 with another access-point, (I tried with DLINK and NETGEAR, 802.11n), all clients work as expected.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Mar 30, 2012 4:29 am
by lunchboxrts
I didn't contact support, yet, but I can do it tomorrow sending all details. I have some knowledge on wireless devices, and these aren't my first mikrotik AP I am using. The configuration is simple: bridge between ethernet and wireless, no routing, no nat... it's just an access point, configured as 802.11b/g/n with WPA2 PSK (AES CCM). I am using built-in antennas. I made tests using a Nokia N900, an ASUS Centrino laptop, an LG android phone. I tried also (today afternoon) with two other laptops (a Dell and an Acer). All the clients show the same behaviour.
Having only one client connected or multiple ones don't change the behaviour.
Signal levels ranging from -61 to -75 depending on position and distance, the result is the same.

WirelessRudy: These 3 devices were used one at a time, never together, but all three show the same behaviour. If I replace the RB751 with another access-point, (I tried with DLINK and NETGEAR, 802.11n), all clients work as expected.
I have about the same results with the 751's. Sometimes you can make them work by disabling chain 1. The 751's would be great if they worked, but we have about a 75-80% deaf rate out of the box. RMAing the device and we still have the same % of them being deaf. Stopped using them until Mikrotik can address the issue.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Mar 30, 2012 11:27 pm
by mtmx80
+1 for wireless reliability issues. Even if you make it works it become unreliable few minutest later...

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Apr 12, 2012 5:05 pm
by vihai
I confirm there are several issues with RB751 wireless.

My setup is the following:

RB751 with ROS 5.14 configured with B+G+N, italian regulatory domain (20 dBm), very clean 2.4 GHz spectrum

2 clients within 1 m range:

A Dell D830 with an Intel 4965AGN running Linux
A Nokia N900

The Dell client, thought using high-speed modulations has unstable throughput rarely going over 30 Mbit/s to an ethernet-connected host (either single TCP or concurrent TCP sessions).
Playing with several radio parameters didn't show any noticeable improvement however it is somewhat usable.

The N900 has bigger issues that seems to be related with its WiFi power saving (http://wiki.maemo.org/Wifi_Power_Saving_Mode_%28PSM%29 )

Pinging it from the host has high packet loss and latency:
64 bytes from 10.0.6.26: icmp_req=40 ttl=64 time=928 ms
64 bytes from 10.0.6.26: icmp_req=41 ttl=64 time=3.22 ms
64 bytes from 10.0.6.26: icmp_req=42 ttl=64 time=255 ms
64 bytes from 10.0.6.26: icmp_req=43 ttl=64 time=488 ms
64 bytes from 10.0.6.26: icmp_req=44 ttl=64 time=699 ms
64 bytes from 10.0.6.26: icmp_req=45 ttl=64 time=978 ms
64 bytes from 10.0.6.26: icmp_req=46 ttl=64 time=2.86 ms
64 bytes from 10.0.6.26: icmp_req=47 ttl=64 time=11332 ms
64 bytes from 10.0.6.26: icmp_req=48 ttl=64 time=10333 ms
64 bytes from 10.0.6.26: icmp_req=49 ttl=64 time=9333 ms
64 bytes from 10.0.6.26: icmp_req=50 ttl=64 time=8334 ms
64 bytes from 10.0.6.26: icmp_req=51 ttl=64 time=7335 ms
64 bytes from 10.0.6.26: icmp_req=52 ttl=64 time=6335 ms
64 bytes from 10.0.6.26: icmp_req=53 ttl=64 time=5336 ms
64 bytes from 10.0.6.26: icmp_req=54 ttl=64 time=4346 ms
64 bytes from 10.0.6.26: icmp_req=55 ttl=64 time=3346 ms
64 bytes from 10.0.6.26: icmp_req=56 ttl=64 time=2346 ms
64 bytes from 10.0.6.26: icmp_req=57 ttl=64 time=1347 ms
64 bytes from 10.0.6.26: icmp_req=58 ttl=64 time=347 ms
Sometimes it is completely mute and starts responding again as soon as it sends a packet by itself. If for example I start a ping FROM the N900 to an outside host, it somewhat works as long as the ping is running.

Disabiling N900 power saving seem to fix the issue, however it is not acceptable as the power consumption goes sky high. Power saving features do work with all other WiFi access point I used elsewhere:
64 bytes from 10.0.6.26: icmp_req=108 ttl=64 time=3.06 ms
64 bytes from 10.0.6.26: icmp_req=109 ttl=64 time=2.91 ms
64 bytes from 10.0.6.26: icmp_req=110 ttl=64 time=2.91 ms
64 bytes from 10.0.6.26: icmp_req=111 ttl=64 time=2.84 ms
64 bytes from 10.0.6.26: icmp_req=112 ttl=64 time=2.72 ms
64 bytes from 10.0.6.26: icmp_req=113 ttl=64 time=3.16 ms
64 bytes from 10.0.6.26: icmp_req=114 ttl=64 time=2.29 ms
64 bytes from 10.0.6.26: icmp_req=115 ttl=64 time=3.56 ms

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Apr 14, 2012 10:10 am
by rjickity
im also experiencing poor performance. i have been testing all different configurations on this, this unit was meant to be a simple access point in a home environment indoors. It was put in purely to stream media from the lan to wireless clients and it has failed.

I have a bridge with ether1 and wlan1 on it. Simple way to reproduce is to begin pushing data through the wlan :)

e.g. ping from host sitting 1meter from router without anything running, response 1ms almost consistent. start a btest to the routerboard, begins to transfer - throughput is ~21mbps and CPU resources on the RB is 100%. after approx 1 minute the throughput drops to ~6mbps and the latency begins to fluctuate dramatically seemingly inconsistent.
 /interface wireless print

 0  R name="wlan1" mtu=1500 mac-address=00:0C:42:XX:XX:XX arp=enabled
      interface-type=Atheros 11N mode=ap-bridge ssid="wlan"
      frequency=2457 band=2ghz-b/g/n channel-width=20/40mhz-ht-above
      scan-list=default wireless-protocol=802.11 antenna-mode=rxa-txb
      wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no
      bridge-mode=enabled default-authentication=yes default-forwarding=yes
      default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no
      security-profile=default compression=no

The CPU does appear to be a bottleneck however it seems like there is a buffer or something filling up which when hit makes it unusable.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Apr 14, 2012 11:21 am
by rjickity
I have just tested on the same frequency with the same hosts on a tplink 1043nd and the throughput was a pretty consistent ~100mbps with 1-3ms latency for 10+ minutes.

This unit was half the price of the 751u and has gig interfaces :-( I may have to just use that instead and shelf the 751u

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Apr 14, 2012 7:58 pm
by ranpha
RB751U-2HnD has a very poor reception performance without an antenna. High ping, low CCQ and packet loss is going to be common.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Apr 25, 2012 8:57 am
by Mrhot2000
well the device i would never recomend for its wifi. I have bought and used several all ending the same way. Use them with external antenna 15dbi alfa with surge protector run fines for a few days then the receiving slowly becomes unstable and eventually unusable. clients still get stong singals as tx power is fine but rx is almost non existant. I even have 2 units which are stuck in a strange situation they power on and all ethernet ports lights are on with no wires attached no ports are working but wifi is working you connected to wifi and access winbox try to reset or upgrade the os. try the jumper or what ever it boots up to the same situation.

total 13 Units bought none worked as expected. I am running serveral rb433uah with r52hn cards they are running for a very very long time now without issues

RB751U-2HnD - poor wireless performance & problems

Posted: Wed Apr 25, 2012 9:19 am
by TheWiFiGuy
I have to disagree.

Were running them as internal repeaters for our hotspotmservices with no problems whatsoever. Using both 751 and 751 g without external antenna ( and would never,ever use a 15 db omni on an internal device ).

So far at least 100+ devices without a single dead unit.

My advice: buy a unit, test it and make up your own mind.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed May 02, 2012 1:45 am
by godovic
I don't have poor wireless performance, but have problems with connections between computers.
The setup is simple access point without any firewall or mangle rule. Just bridge (wireless and the ethernet port)

My biggest problem is to find some computer share in network.. Especially, the Mac OS clients cannot find Windows Share or Windows shared printers. Before I had Linksys WRT160NL, also configured as AP, and there wasn't a problems in the same network - same configuration.

Maybe I should setup something else on my mikrotik but cannot find simple access point tutorial - most of them are for configuring NAT router.

tnx

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed May 02, 2012 9:46 am
by normis
anyone with problems, post output of this command:
/interface wireless export compact 

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Jun 07, 2012 3:26 am
by vihai
anyone with problems, post output of this command:
Sorry, I didn't have a RB751 at hand to do the tests.

I just had a fresh RB751G-2HnD delivered to me, I installed 5.17 and 6.0beta2, in both cases the problem with N900 power saving consistently showed up.

The N900 completely stopped responding to pings until it had to transmit bu itself, then the queue was flushed. As soon as it stops generating traffic it stopped responding.
64 bytes from n900.orlandi.com (62.212.12.15): icmp_req=236 ttl=64 time=3.58 ms
64 bytes from n900.orlandi.com (62.212.12.15): icmp_req=237 ttl=64 time=28869 ms
64 bytes from n900.orlandi.com (62.212.12.15): icmp_req=238 ttl=64 time=27870 ms
64 bytes from n900.orlandi.com (62.212.12.15): icmp_req=239 ttl=64 time=26870 ms
64 bytes from n900.orlandi.com (62.212.12.15): icmp_req=240 ttl=64 time=25871 ms
64 bytes from n900.orlandi.com (62.212.12.15): icmp_req=241 ttl=64 time=24883 ms
64 bytes from n900.orlandi.com (62.212.12.15): icmp_req=242 ttl=64 time=23884 ms
64 bytes from n900.orlandi.com (62.212.12.15): icmp_req=243 ttl=64 time=22890 ms
64 bytes from n900.orlandi.com (62.212.12.15): icmp_req=244 ttl=64 time=21890 ms
64 bytes from n900.orlandi.com (62.212.12.15): icmp_req=245 ttl=64 time=20891 ms
This is the output of
/interface wireless export compact 
:
# jan/02/1970 06:18:53 by RouterOS 6.0beta2
# software id = xxxx-xxxx
#
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk eap-methods=passthrough management-protection=allowed mode=dynamic-keys \
    name=WPA2 supplicant-identity="" wpa-pre-shared-key=xxxxxxxx wpa2-pre-shared-key=xxxxxxxx
/interface wireless
set 0 antenna-gain=3 band=2ghz-b/g/n country=italy disabled=no frequency=2442 l2mtu=2290 mode=ap-bridge \
    security-profile=WPA2 wireless-protocol=802.11
Note that I tried changing wireless protocol to 802.11-only-G with no difference.

A Groove 2AHn with a very similar configuration worked flawlessy.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Jun 12, 2012 6:42 am
by Ham
Having the same problems as vihai, but with a Acer A500 tablet & RB751G

Once connected to the rb751 there are no problems, but once the device goes into power saving mode/std-by and is awoken it will hardly pass any traffic. I have to disable the wifi on the tablet and reconnect to get any kind of data through.

Prior to the using the RB751G I was using a RB711-UA-2Hnd as a AP with no problems.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Jun 12, 2012 7:33 am
by scampbell
I did some quick tests with an iPhone and RB751U-2HnD RoS 5.17

First I ran the test with the phone very close to the AP. The TX CCQ was pretty low but pings responded ok.

I moved the iPhone 2 metre away from the AP and TX CCQ improved to better than 80%

FYI My RB751U-2HnD is set to 17dBm rtaher than full power. (Regulatory Mode and Country=NZ).

When the iPhone screen went black the pings stopped responding. The iPhone also "deregistered" from the RB751U-2HnD.

When I touched the control button on the iPhone to "wake" it, it registered on the RB751U-2HnD and the pings started responding again ok within a couple of seconds.

In all cases the pings varied from 2ms-100ms which was not ideal but certainly still usable.

The main thing I think to take from this is being to close to the AP or having too much power could be an issue and will cause lost packets etc. We see the same thing when testing a pair of SXT's on the bench. If you do not drop the power they do not work well.

Hard to believe but too much power can sometimes be bad :lol:

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Jun 12, 2012 9:38 am
by uldis
Having the same problems as vihai, but with a Acer A500 tablet & RB751G

Once connected to the rb751 there are no problems, but once the device goes into power saving mode/std-by and is awoken it will hardly pass any traffic. I have to disable the wifi on the tablet and reconnect to get any kind of data through.

Prior to the using the RB751G I was using a RB711-UA-2Hnd as a AP with no problems.
make sure that you use the latest RouterOS version on the board.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Jun 12, 2012 11:13 am
by Beone
We've started deploying this device when it was launched, we have about 50 of them in the field.
We must say, we had lots of trouble with this device (concerning wireless). We've made tons of supout's and Mikrotik did lots of efforts to fix it. It went better when ROS version nrs increased, but it still ain't stable as we expected. We 've ended up reconfiguring most of them without any wireless activated and added an extra ubnt access point to obtain wifi. These configurations are as good as 100% stable. Still sad it's a no go with RB751-2HnD and wireless enabled as price is good, but we can't afford to loose stability. Loosing stability is loosing customers and we can't risk that. For this reason we discontinued using this device in new deployments.

kind regards

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Jun 16, 2012 3:59 pm
by LizardKings
Same wireless performance problems here. Have two RB751U-2HnD with the same performance issues.

/interface wireless security-profiles
set [ find default=yes ] group-ciphers="" supplicant-identity=MikroTik unicast-ciphers=\
""
add authentication-types=wpa2-psk eap-methods=passthrough group-ciphers=tkip,aes-ccm \
management-protection=allowed mode=dynamic-keys name=mywireless1 \
supplicant-identity="" unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=xxxxx \
wpa2-pre-shared-key=XXXXX
/interface wireless
set 0 band=2ghz-b/g/n country=netherlands disabled=no frequency=2437 ht-rxchains=0,1 \
ht-txchains=0,1 l2mtu=2290 mode=ap-bridge security-profile=mywireless1 ssid=\
mywireless1 wireless-protocol=any
add area="" arp=enabled bridge-mode=enabled default-ap-tx-limit=0 \
default-authentication=yes default-client-tx-limit=0 default-forwarding=yes \
disable-running-check=no disabled=yes hide-ssid=no mac-address=02:0C:42:FB:CA:09 \
master-interface=wlan1 max-station-count=2007 mtu=1500 multicast-helper=default \
name=mywireless12 proprietary-extensions=post-2.9.25 security-profile=\
mywireless1 ssid=mywireless12 update-stats-interval=disabled \
wds-cost-range=0 wds-default-bridge=none wds-default-cost=0 wds-ignore-ssid=no \
wds-mode=disabled wmm-support=disabled
/interface wireless nstreme
set wlan1 framer-policy=best-fit

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Jun 19, 2012 5:57 pm
by uldis
LizardKings, disable the TKIP wireless encryption and try again.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jun 20, 2012 2:07 pm
by buckett
Just to chime in and say I also had similar issue with the 751G-2HnD wireless. Clients of Macbook, iPad, Android, Windows 7 would all seem to work fine for a while but then start to see poor throughput and packet loss. Gave up and bought a TP-Link WR841N which worked fine out of the box.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jun 20, 2012 11:22 pm
by taduikis
Yeah, I did the same thing.. When I ran out of patience, I took out some old 11g linksys router from waste and replaced 751 with it.. Wireless of 751 is a complete joke and are not worth my time anymore. Sorry, Mikrotik

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Jun 21, 2012 8:33 am
by ddd
If you run them in single chain mode (disable chain 1 for both ht tx and ht rx) they work fine.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Jun 22, 2012 4:15 pm
by vihai
If you run them in single chain mode (disable chain 1 for both ht tx and ht rx) they work fine.
Negative, the power saving related issue is present even with 802.11n disabled.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Jun 22, 2012 5:07 pm
by uldis
If you run them in single chain mode (disable chain 1 for both ht tx and ht rx) they work fine.
Negative, the power saving related issue is present even with 802.11n disabled.
make sure that you use the latest RouterOs version when you are testing that problem.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Jun 23, 2012 8:08 am
by aymale03
Hi , Mikrotik

Any fix on version 5.18 to fix RB751-2Hnd wireless performance?

Thanks

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Jun 23, 2012 3:13 pm
by vihai
Negative, the power saving related issue is present even with 802.11n disabled.
make sure that you use the latest RouterOs version when you are testing that problem.
I tested either with 6.0beta2 and 5.17, I'm going to test with 5.18 but if the problem persist will you try to troubleshoot these issues with a bit more commitment?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Jun 26, 2012 3:00 am
by jandafields
Hi , Mikrotik

Any fix on version 5.18 to fix RB751-2Hnd wireless performance?

Thanks
No, it looks like 5.18 is no better :(

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jun 27, 2012 5:52 am
by Ham
Yup 5.18 and upgraded to the new boot loader, the same issues with certain devices still exist re: power saving.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jun 27, 2012 6:05 pm
by vadyalex
Yeah, I did the same thing.. When I ran out of patience, I took out some old 11g linksys router from waste and replaced 751 with it.. Wireless of 751 is a complete joke and are not worth my time anymore. Sorry, Mikrotik
Sounds like my next step, can't get wireless speed performance from this device.

Do other wireless Mikrotik devices work same badly? Any feedback? Anyone tried to use two 751 in a pair as wireless bridge using Mikrotik proprietary protocol? Any feedback?

I have TP-Link, Netgear, Linksys devices and first two had issues in the long run but Linksys with Tomato firmware works as a charm. Can't complain.

When I first found out about Mikrotik it was article about its wired devices but seems SOHO wireless is not their best competence.

Did anyone tried Ubiquiti devices? Any feedback?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jun 27, 2012 6:22 pm
by aymale03
Hi folks

Mikrotik? Any answer about the problem? Or can we getting back the router to you? So, we will get our money in return.
Your clients have been waiting for a solution since March, 4 months!!

Thanks

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jun 27, 2012 10:59 pm
by taduikis
Good point about Mikrotik ain't doing well in SOHO device segment. The same applies to Ubiquiti. I have read in forums that their products also aren't very great for simple home users with laptops.
You can of course play with all the wifi settings and adjustments routeros let you, but it's simply not the way with SOHO devices..

To my opinion, Mikrotiks best bet to be competitive would be to make some cheaper wifi router with completely different OS that requires less resources but offers slightly more features as an advantage to other routers in the market. Let's be honest, routeros is great, but 80% of it is only a burden when serving ordinary home user. And integrated lower gain antennas with superpower radio is seriously a wrong move..

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jun 27, 2012 11:55 pm
by honzam
Good idea, it is possible now in WEBFIG disabled unused and unnecessary items for the Home User.

It would be good if rb751 have external connector - RSMA.
MMCX is good on towers instalations but not for HOME production

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Jun 28, 2012 4:41 pm
by vadyalex
I partly agree with you about complexity but my opinion is that it is nice to have so complicated and wide amount of parameters to tune. The device is not for regular user.
Since there is DD-WRT, Tomato and "stock" firmware for SOHO routers from different brands. So for the user there is a choice.


But let's face it - there is a problem in 751 Mikrotik wireless router. Wireless works poorly.
And I am not sure about the reason. Is it hardware "bug" or RouterOS?
I don't have another wireless Mikrotik devices to judge. I do have 750GL and haven't noticed problems so far.

That's why I ask: does anyone have experience with another Mikrotik wireless devices for in-door use?
Maybe I would give a try for one more device.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Jun 29, 2012 6:17 pm
by krakenant
Try disabling the TX on chain 0, that is what we found did the most good for us. It halves your TX power, but really, what consumer device really needs 1W of power from an AP.

We have about 1500 RB751U devices out in the field.

Let me know if this helps you too. Fairly certain the issues have something to do with splitting chain-0 RX and TX into two different antennas.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Jul 02, 2012 2:49 am
by vadyalex
Try disabling the TX on chain 0, that is what we found did the most good for us. It halves your TX power, but really, what consumer device really needs 1W of power from an AP.

We have about 1500 RB751U devices out in the field.

Let me know if this helps you too. Fairly certain the issues have something to do with splitting chain-0 RX and TX into two different antennas.
Thank you for the tip. Seems like it helped a little.

Here are my tests using Speedtest.com to the nearest server in the city:
Tx chain chain0 chain1
Rx chain chain0 chain1

ping 29 ms
download 1 Mbps
upload 3 Mbps
Tx chain chain1
Rx chain chain0 chain1

ping 33 ms
download 7 Mbps
upload 2 Mbps
Tx chain chain1
Rx chain chain0

ping 28 ms
download 4.5 Mbps
upload 5 Mbps
Tx chain chain0
Rx chain chain0

ping 36 ms
download 2.6 Mbps
upload 3.5 Mbps

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Jul 03, 2012 7:24 pm
by krakenant
Thanks for validating what we found, though we were able to go much higher, at least with decent signal strengths.

Anyone else try it?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jul 04, 2012 12:09 pm
by vadyalex
What results do you get? Could you share your experience?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jul 04, 2012 7:42 pm
by mtmx80
Actually I think RB751 series are Mikrotik's Windows Vista. You couldn't tell exactly what's wrong with it, but its a piece of ....
I hope Mikrotik learned the lesson and new RB951 series and RB2011 series will perform flawlessly. First would be suitable for smaller flats and users without special needs, while RB2011 could be a high end SOHO router.

I partly agree with you about complexity but my opinion is that it is nice to have so complicated and wide amount of parameters to tune. The device is not for regular user.
Since there is DD-WRT, Tomato and "stock" firmware for SOHO routers from different brands. So for the user there is a choice.


But let's face it - there is a problem in 751 Mikrotik wireless router. Wireless works poorly.
And I am not sure about the reason. Is it hardware "bug" or RouterOS?
I don't have another wireless Mikrotik devices to judge. I do have 750GL and haven't noticed problems so far.

That's why I ask: does anyone have experience with another Mikrotik wireless devices for in-door use?
Maybe I would give a try for one more device.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Jul 05, 2012 7:37 am
by navidbaradaran
I setup a big wireless HotSpot coverage for a Hotel by installing 70 units of RB751U-2HnD and from very early moments the headaches started.
I understand that RB751 has a very limited wireless capacity but cuz my usage is only for internet distribution in low rates that was not a big deal.

The most major issue was RB751 wireless card is Halting time by time, working for hours and halting, and clients did not discover SSID anymore, when disable and enable WiFi card it returns back. I am using bridge between ether1 and wifi card.

I am using 24db EIRP and an external antenna, tried to reduce power to 17db, nothing changed.
When changed the config and disabled the bridge (putting a NAT on each RB751!!) halt condition resolved.

I have this problem in all 70 units till today, forced to not use bridge over wifi, left me alone with many issues with IP address management for routing.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Jul 05, 2012 2:20 pm
by vadyalex
Bad experience is experience.

But do you have a success story with Mikrotik for indoor use?

My concern is: should I buy another Mikrotik device after all this story or just try to sell my boxes and go to something else to experiment with.
How does it RB751 perform as wireless bridge using Mikrotik Nv2 protocol?
Actually I think RB751 series are Mikrotik's Windows Vista. You couldn't tell exactly what's wrong with it, but its a piece of ....
I hope Mikrotik learned the lesson and new RB951 series and RB2011 series will perform flawlessly. First would be suitable for smaller flats and users without special needs, while RB2011 could be a high end SOHO router.

I partly agree with you about complexity but my opinion is that it is nice to have so complicated and wide amount of parameters to tune. The device is not for regular user.
Since there is DD-WRT, Tomato and "stock" firmware for SOHO routers from different brands. So for the user there is a choice.


But let's face it - there is a problem in 751 Mikrotik wireless router. Wireless works poorly.
And I am not sure about the reason. Is it hardware "bug" or RouterOS?
I don't have another wireless Mikrotik devices to judge. I do have 750GL and haven't noticed problems so far.

That's why I ask: does anyone have experience with another Mikrotik wireless devices for in-door use?
Maybe I would give a try for one more device.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Jul 08, 2012 11:14 am
by ddd
In all cases the pings varied from 2ms-100ms which was not ideal but certainly still usable.

I think you will find that's just the iPhone causing the ping spikes, it does that on most routers. Nothing to do with the 751.
Google it and you will see it happens to everyone.


I have tried to reproduce the connection and speed issues reported here and I'm unable to find anything wrong, are people still having issues?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Jul 08, 2012 6:43 pm
by jandafields
Actually I think RB751 series are Mikrotik's Windows Vista. You couldn't tell exactly what's wrong with it, but its a piece of ....
I hope Mikrotik learned the lesson and new RB951 series and RB2011 series will perform flawlessly. First would be suitable for smaller flats and users without special needs, while RB2011 could be a high end SOHO router.
Unfortunately, I have found that the RB951 is much worse than the RB751. The RB951 wireless stops working ALL the time, and requires a restart of the wireless interface.

I'm using RB951 wireless AP in bridge.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Jul 08, 2012 8:41 pm
by navidbaradaran
Actually I think RB751 series are Mikrotik's Windows Vista. You couldn't tell exactly what's wrong with it, but its a piece of ....
I hope Mikrotik learned the lesson and new RB951 series and RB2011 series will perform flawlessly. First would be suitable for smaller flats and users without special needs, while RB2011 could be a high end SOHO router.
Unfortunately, I have found that the RB951 is much worse than the RB751. The RB951 wireless stops working ALL the time, and requires a restart of the wireless interface.

I'm using RB951 wireless AP in bridge.
That's my exact issue in 751 too, finally I had to turn to routed mode instead of bridging.
So WiFi + Bridging is a same issue in 751 & 951, any resolution MikroTik?
i I have 70 units of 751 with this issue!!!

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Jul 08, 2012 8:52 pm
by jandafields
Actually I think RB751 series are Mikrotik's Windows Vista. You couldn't tell exactly what's wrong with it, but its a piece of ....
I hope Mikrotik learned the lesson and new RB951 series and RB2011 series will perform flawlessly. First would be suitable for smaller flats and users without special needs, while RB2011 could be a high end SOHO router.
Unfortunately, I have found that the RB951 is much worse than the RB751. The RB951 wireless stops working ALL the time, and requires a restart of the wireless interface.

I'm using RB951 wireless AP in bridge.
That's my exact issue in 751 too, finally I had to turn to routed mode instead of bridging.
So WiFi + Bridging is a same issue in 751 & 951, any resolution MikroTik?
i I have 70 units of 751 with this issue!!!

Keep sending this to support@mikrotik.com so they know it is a high priority problem. At this point, we have no idea if they are even working on it.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jul 11, 2012 1:59 pm
by rado3105
Dont recommend anybody to buy it. A lot of problems, very bad latency, throughoutput, signal. I tryed also external antennna didnt helped. Before that I had on place ubnt routerostation with cm9 but it was destroyed by lighting. I was looking for somethins simplier. Now I am very sorry.....to buy this crap...

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jul 11, 2012 2:39 pm
by DiabolixZA
Dont recommend anybody to buy it. A lot of problems, very bad latency, throughoutput, signal. I tryed also external antennna didnt helped. Before that I had on place ubnt routerostation with cm9 but it was destroyed by lighting. I was looking for somethins simplier. Now I am very sorry.....to buy this crap...
Maybe the RB2011US will fix the indoor wireless issue and maybe that is why they are 4 months behind schedule on releasing the RB2011US?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Jul 12, 2012 11:55 am
by vadyalex
C'mone they are from different categories.. Why would one compare them.

Another question is: did Mikrotik make improvements and RB951-2n performs better?
Dont recommend anybody to buy it. A lot of problems, very bad latency, throughoutput, signal. I tryed also external antennna didnt helped. Before that I had on place ubnt routerostation with cm9 but it was destroyed by lighting. I was looking for somethins simplier. Now I am very sorry.....to buy this crap...
Maybe the RB2011US will fix the indoor wireless issue and maybe that is why they are 4 months behind schedule on releasing the RB2011US?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Jul 27, 2012 1:32 pm
by ice94
Fix:

Change this parameter in wireless:
Advanced Distance=Dynamic
Tx Power--> TX power Mod: Card Rates

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Jul 28, 2012 6:54 am
by taloot
i bought 20 units, 3 hours project, takes from me 5 days, and alot of expansise,

very bad soho device, a drawon flagship of mikrotik soho,

only workable on 2412 to 2427

other than that its waste of time,

hardware design bug, EVM and couple of readings should be tested before release a broken arm device

i quit mikrotik 3 years ago, for similar issues,

installers and contactor have no time to waste submiting bug report

mikrotik good for p2p only,
ubnt for the reset of wireless deplyment, even in p2p if the signal is low go for ubnt

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Aug 09, 2012 11:54 am
by vadyalex
Fix:

Change this parameter in wireless:
Advanced Distance=Dynamic
Tx Power--> TX power Mod: Card Rates
Which card rate to specify?
I tried different options and still have 2 mbps throughput over Wi-Fi...

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Oct 26, 2012 9:57 am
by saintofinternet
does the poor wireless problem still persists?? with the latest update firmware??

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Oct 26, 2012 12:47 pm
by Intrepid
I tested it some days ago with ROS 5.21, and got a little over 30mbit upload and download speed, with standard wireless settings.
Works ok for me :)

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Oct 27, 2012 6:28 pm
by DBob
I tested it some days ago with ROS 5.21, and got a little over 30mbit upload and download speed, with standard wireless settings.
Works ok for me :)
30mbit is a little bit few from a device, which should generate lot more.
Or you meant 30mbyte 8)

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Oct 27, 2012 7:31 pm
by jandafields
30mbit is a little bit few from a device, which should generate lot more.
Or you meant 30mbyte 8)
No, I don't think these devices are capable of doing 30mbytes. 30mbits, on the other hand, sounds normal for an Internet connection.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Nov 19, 2012 10:00 pm
by conky
What a huge disappointment. Just bought an RB751G-2HnD and the wifi performance is indeed crap.
Upgraded to latest router os 5.21 and no change.

Tested with 2 laptops, one connected with ethernet cable, the other via wifi, mas download speed that I can get when SCPing a file is 6-7MB/s.
Wifi signal: Link Quality=70/70 Signal level=-27 dBm

Even the cheaper Tplink (tl-wr1043nd) outperforms the routerboard. :(
Wit the tplink I get a stable 14MB/s (112mbit/s). Two times faster than the routerboard.

Is this because of the lack of proper antennas on the RB751?
Has anyone tested it with attaching external antenna?

Dear MikroTik, can you please respond?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Nov 20, 2012 11:07 am
by turalo
Same here, have few of them, Somehow the one in the office works for the most of times, but at home, and few at customers site have the same wifi problems, good fast connection but very poor quality, most of times no response, you request a website and wait, and wait, and wait then you understand that nothing happens :) , it's like there is a black hole where all the data is lost on the way :)
it shows 100% of connection signal. But in reality is just rubbish.

try any cheap wifi router gives better result.

I have to admit that when it works for a short time its very good, in office for example the times that it works I can get up to 30mb up and down, while my total speed is 35mb up and down.
so if it works it works very good, but to get it to work si almost impossible, and if you will, then it wouldn't last for long.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Nov 21, 2012 1:08 pm
by conky
Is expecting an answer from MikroTik really too much to ask?
You have loads of unsatisfied customers here, what are you doing in order to address the issues?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Nov 21, 2012 1:16 pm
by uldis
what wireless data-rates it is using when you are doing the test? Make support output file and send that to support@mikrotik.com

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Nov 21, 2012 10:33 pm
by turalo
what wireless data-rates it is using when you are doing the test? Make support output file and send that to support@mikrotik.com
I just made the supout file, I opened it with notepad++ it's coded, I need to know what info is there ? if my passwords are there too, then I would not want it to be seen by anybody...

anybody knows if the passwords are there too ?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Nov 22, 2012 4:04 pm
by normis
what wireless data-rates it is using when you are doing the test? Make support output file and send that to support@mikrotik.com
I just made the supout file, I opened it with notepad++ it's coded, I need to know what info is there ? if my passwords are there too, then I would not want it to be seen by anybody...

anybody knows if the passwords are there too ?
you want your problem fixed or not? send the file and don't worry

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Nov 22, 2012 5:00 pm
by turalo
Easy for you to say... I'll change the passeord first, and will make a new file.
I had bad experiance with kolmisoft, our password were misused by one
Of their workers, then i lost almost 1000 eu.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Nov 23, 2012 9:30 am
by normis
Password is not saved in that file. You can use online supout.rif viewer to check yourself (supout.rif viewer is in your mikrotik.com account)

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Dec 04, 2012 12:02 am
by hondavf100f
Have same problems as everybody else in here...
My RB751G-2HnD have poor download speeds...
I normaly gets about 15Mbps down and 30-40Mbps up. (have fibre connection 60/60)


Anybody have any sugestions to improve this config?
export compact 
# dec/03/2012 22:53:00 by RouterOS 5.22
# software id = xxxx-xxxx
#
/interface bridge
add l2mtu=1598 name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods=passthrough \
    management-protection=allowed mode=dynamic-keys name=yamaha \
    supplicant-identity="" wpa-pre-shared-key=xxxxxxxxxxxxxx \
    wpa2-pre-shared-key=xxxxxxxxxxxxxx
/interface wireless
set 0 band=2ghz-b/g/n disabled=no frequency=2437 l2mtu=2290 mode=ap-bridge \
    security-profile=yamaha ssid=yamaha
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
/ip dhcp-client
add default-route-distance=0 disabled=no host-name=wifi interface=ether1 \
    use-peer-dns=no
/ip firewall service-port
set ftp disabled=yes
set irc disabled=yes
/ip service
set "" disabled=no port=22
/system clock
set time-zone-name=Europe/Oslo
/system identity
set name=WiFi
/system leds
set 0 interface=wlan1
/system ntp client
set enabled=yes mode=unicast
/tool bandwidth-server
set enabled=no
[root@WiFi] > 

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Dec 19, 2012 6:04 pm
by xmanuw
I am really stunned that Mikrotik isn't doing anything about this topic. The problem is present in all versions and it seems Mikrotik is not even trying to fix this.

Unfortunately this leaves most people no choice than to switch vendors...
I'm really interested in the development here, but it seems Mikrotik is not interested in keeping it's customers.

As the issues persist I'm thinking maybe this whole thing is a architectural error and cannot be fixed by software. At least it would be nice to admit that... So the customers are not fooled any more...

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Dec 19, 2012 10:01 pm
by turalo
The problem with mikrotik is simple, they have opened the box of pandora and dont understand that not everyone is able to set everything right even with 10 years of experiance in this sector.
With many diplomas and certificates of like ccna mcsa etc... So there are so many options open, which are just not needed to be open, they have to be set well by default and closed off, and if and only if somebody needs to see / change them, then they should give a separate acces to it. For the normal IT guy, who just wants to diploy this in an office / company situation it's not needed to have all those options and get lost in them.
I personally love some of tools of Mikrotik, tools like torch etc... but further ? nothing special, many many many options which just waste my time when setting them to the right settings, this is all done in all other vendors. Specially I was disappointed to see that there is no board with built in support for vdsl / adsl or voip fxo ports.

So that's why I heard about mikrotik for the first time just few months ago. working in this field for so many years :) and hear about them just few months ago, I dont consider myself as outof dated IT guy :) I work with many different brands and types, also buying, selling, supporting etc...

So I gues, yes they have some problems with understanding the market, I dont thinkn they are not worth it, but they indeed need to get awake, and think better about different types of users / markets.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Dec 20, 2012 9:46 am
by normis
hondavf100f please make this command: /interface wireless print advanced

basically the speed depends also on the laptop. many laptops only have one chain (antenna) and don't support wide channels (40MHz), which limits the maximum air rate to 65Mbit, for example testing at this rate with single TCP connection will give you some 15Mbits. So please tell us how you test this.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Dec 20, 2012 7:46 pm
by PastuhMedvedey
I use the following configuration radio interface.
In this good speed. The clients netbook "Aspire d257".

My config :

[admin@MikroTik] /interface wireless> export compact
# dec/20/2012 19:32:17 by RouterOS 5.22
# software id = 5Y9M-CTS4
#
/interface wireless security-profiles
set [ find default=yes ] group-ciphers="" unicast-ciphers=""
add authentication-types=wpa2-psk eap-methods=passthrough mode=dynamic-keys \
name=profile1 supplicant-identity="" wpa2-pre-shared-key=xxxxxxxxxxxx
/interface wireless
set 0 adaptive-noise-immunity=ap-and-client-mode band=2ghz-onlyn \
default-authentication=no default-forwarding=no disabled=no distance=\
indoors frequency=2447 ht-guard-interval=long ht-rxchains=0,1 \
ht-txchains=0,1 hw-protection-mode=rts-cts l2mtu=2290 max-station-count=\
10 mode=ap-bridge periodic-calibration=enabled \
periodic-calibration-interval=10 scan-list=default security-profile=\
profile1 ssid=MTwireless tx-power=5 tx-power-mode=card-rates \
wireless-protocol=802.11
/interface wireless nstreme
set wlan1 disable-csma=yes enable-nstreme=yes
/interface wireless access-list
add interface=wlan1 mac-address=74:F0:6D:07:FF:0D
add interface=wlan1 mac-address=78:92:9C:61:30:42
/interface wireless sniffer
set multiple-channels=yes
/interface wireless snooper
set receive-errors=yes

In the image below you can see the speed of downloading torrent files
ISP-PROVIDER -> pptp -> nat -> wifi -> aspired257

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Dec 20, 2012 10:41 pm
by turalo
I would like to make one important note, the problem of wireless is not just everywhere and every time.
In my case in office it works perfect, with all pc's, mobiles, ipads etc... all perfect.
But at home, and on many other location it does not, I use same config as in office in other locations, also same firmware version etc...
Problem is that it's not possible to use a backup file, from one mikrotik on another, it brakes the settings corrupts some of them, so
every time you have to set it again, so far I know I have set all routers the same way but only 1 at office works fine, all others a shit with wifi.
That's why I'm saying that they have made it unnecessary difficult enabling all options by default.
in our office even thru 3-4 wals it works perfect. while a decrypt router which we payed 200 Europe for did not even reach 1 wall with good quality.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Dec 21, 2012 12:58 pm
by Neilson
@PastuhMedvedey

I think if you look at the details from the registration table you see that normis put you on the right track, you seem to be connected single antenna and 20mhz channels so you are only connected at "radio rate" 65Mbps.

This will limit your theoretical performance and also your real world performance. I would advise using wired connections for your torrenting and indeed whenever possible. Wireless is a wonderful technology but it has its place and time like everything else and the benefits of portability etc do come with drawbacks.

Infrastructure links use every possibly tech and fixed positioning, clear line of sight, multiple chains, wide channels etc to provide the rock steady performance we strive to give which cant be guaranteed in other situations.

Regards
Alexander

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Dec 21, 2012 3:43 pm
by miro10hr
I have the following problem (or it is a feature maybe?) with RB751U-2HnD.

I have 802.11b/g/n enabled since I have some legacy devices and some new devices. I was testing with one laptop with 802.11g wireless card, no other devices connected.

If I enable only chain 0 (antenna mode - antenna A), I get full 802.11g speeds. I was testing with a little program LAN speed test towards local server. The throughput I get is some 20 Mbps which is fine.

If I turn on chain 1 the signal is little bit stronger, but it seems like the connection is 802.11b. I can't get more then 5-6 Mbps throughput. With only that device connected. It doesn't matter if I change antenna mode, the results are poor.

If I connect some 802.11n devices the results are the same. No more then 5-6 Mbps of throughput. If chain1 and chain 0 are enabled I cannot get more then 5-6 Mbps of throughput.

I tried to upgrade to 6.0rc6, but behavior is the same.

Is this normal?

Here is print of wireless advanced
Flags: X - disabled, R - running 
 0  R name="wlan1" mtu=1500 mac-address=D4:CA:6D:55:C6:DD arp=enabled 
      disable-running-check=no interface-type=Atheros AR92xx 
      radio-name="RB751U_radio" mode=ap-bridge ssid="XXXXXXX" area="" 
      frequency-mode=manual-txpower country=no_country_set antenna-gain=0 
      frequency=2442 band=2ghz-b/g/n channel-width=20/40mhz-ht-below 
      scan-list=default wireless-protocol=802.11 rate-set=default 
      supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps 
      supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,
                    54Mbps 
      basic-rates-b=1Mbps basic-rates-a/g=6Mbps max-station-count=2007 
      distance=dynamic tx-power-mode=default noise-floor-threshold=default 
      nv2-noise-floor-offset=default periodic-calibration=default 
      periodic-calibration-interval=60 dfs-mode=none antenna-mode=ant-a 
      wds-mode=disabled wds-default-bridge=none wds-default-cost=100 
      wds-cost-range=50-150 wds-ignore-ssid=no update-stats-interval=disabled 
      bridge-mode=enabled default-authentication=yes default-forwarding=yes 
      default-ap-tx-limit=0 default-client-tx-limit=0 
      proprietary-extensions=post-2.9.25 wmm-support=disabled hide-ssid=no 
      security-profile=Xxxxxx disconnect-timeout=3s on-fail-retry-time=100ms 
      preamble-mode=both compression=no allow-sharedkey=no 
      station-bridge-clone-mac=00:00:00:00:00:00 ht-ampdu-priorities=0 
      ht-guard-interval=any 
      ht-supported-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,
                 mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,
                 mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23 
      ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 
      ht-txchains=0 ht-rxchains=0 ht-amsdu-limit=8192 ht-amsdu-threshold=8192 
      tdma-period-size=2 nv2-queue-count=2 nv2-qos=default nv2-cell-radius=30 
      nv2-security=disabled nv2-preshared-key="" hw-retries=7 
      frame-lifetime=0 adaptive-noise-immunity=none 
      hw-fragmentation-threshold=disabled hw-protection-mode=none 
      hw-protection-threshold=0 frequency-offset=0 rate-selection=advanced 
      multicast-helper=default

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Dec 22, 2012 11:37 am
by Dobby
Hello miro10hr,

please at first don´t get me wrong, my English skills are not the best, I don´t want to kidding you and/or bothering with you. but did ever thought about that you was buying a to low sorted device? Is it perhaps not better better for you to get a RB435G or a RB493G to be right sorted? Perhaps I am false with my thinking, but if this one device is not fitting your needs and wishes or plain is serving you the right throughput, should it be done by a more powerful RouterBoard?

I wish you all a merry Christmas and be healthy.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Dec 23, 2012 7:24 pm
by jlct021
Same problem.

Signal strength shows up as great; but pings to the RB (from multiple devices / varying distances both near and far) and diabolical.

I don't want to disable a chain as if I understand this will reduce signal strength and I need all I can get for this install. (lots of walls etc)

Any body had any success in resolving this?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Dec 23, 2012 8:25 pm
by normis
please tell me what signal you get. make sure botch chains are turned on, and distance is set to "indoors". also that your channels are set to 40mhz above.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Dec 23, 2012 8:46 pm
by jlct021
Unit is on site at the moment. (Am going back tomorrow)

Signal strength was anywhere between -35 (if next to the rb) to -65 (if upstairs)

Didn't turn any chains off, didn't change the distance, changed the Chanel to 20mhz (all else is factory default with no other interfering devices)

No matter if I'm standing next to the rb, 5 or 10M away with clear LOS; the pings to the rb and thus internet etc are terrible.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Dec 23, 2012 9:59 pm
by normis
bring it upstairs, set the channel width back to 40-up, make sure you actually have the 802.11n mode enabled (not b or g only). specifically make sure distance is set to "indoors" (might need to click "Advanced Mode").

The defaults are not perfect, so just make sure all this is set. Then make supout.rif file at the moment when device is downloading something, and signal is -65. Send supout.rif to support and/or attach here.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Dec 26, 2012 5:45 pm
by jlct021
Reset to factory default, checked all was as you sugested and the crazy ping times to the rb seem to have stabalized. Will keep an eye on it and email supout.rif if happens again. Thanks

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Fri Dec 28, 2012 8:03 pm
by Boter
0  R name="wlan1" mtu=1500 mac-address=D4:CA:6D:20:D1:9D arp=enabled 
      disable-running-check=no interface-type=Atheros AR92xx 
      radio-name="D4CA6D20D19D" mode=ap-bridge ssid="wifree.si" area="" 
      frequency-mode=manual-txpower country=no_country_set antenna-gain=0 
      frequency=2412 band=2ghz-b/g/n channel-width=20/40mhz-ht-above 
      scan-list=default wireless-protocol=any rate-set=default 
      supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps 
      supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,
                    54Mbps 
      basic-rates-b=1Mbps basic-rates-a/g=6Mbps max-station-count=2007 
      distance=indoors tx-power-mode=default noise-floor-threshold=default 
      nv2-noise-floor-offset=default periodic-calibration=default 
      periodic-calibration-interval=60 dfs-mode=none antenna-mode=ant-a 
      wds-mode=disabled wds-default-bridge=none wds-default-cost=100 
      wds-cost-range=50-150 wds-ignore-ssid=no update-stats-interval=disabled 
      bridge-mode=enabled default-authentication=yes default-forwarding=yes 
      default-ap-tx-limit=0 default-client-tx-limit=0 
      proprietary-extensions=post-2.9.25 wmm-support=disabled hide-ssid=no 
      security-profile=default disconnect-timeout=3s on-fail-retry-time=100ms 
      preamble-mode=both compression=no allow-sharedkey=no 
      station-bridge-clone-mac=00:00:00:00:00:00 
      ht-ampdu-priorities=0,1,2,3,4,5,6,7 ht-guard-interval=any 
      ht-supported-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,
                 mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,
                 mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23 
      ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 
      ht-txchains=1 ht-rxchains=0,1 ht-amsdu-limit=8192 
      ht-amsdu-threshold=8192 tdma-period-size=2 nv2-queue-count=2 
      nv2-qos=default nv2-cell-radius=30 nv2-security=disabled 
      nv2-preshared-key="" hw-retries=7 frame-lifetime=0 
      adaptive-noise-immunity=none hw-fragmentation-threshold=disabled 
      hw-protection-mode=none hw-protection-threshold=0 frequency-offset=0 
      rate-selection=advanced multicast-helper=default 
This is my current config. I have 100/100 internet. When I disable Tx chain 0 I only get about 30/30 of it through wireless, and about 50 over ethernet cable. Laptop have gbit NIC and SSD drive. I wonder if I can get more?

If I have Tx chain enabled I get about 10-30mbit's, so for now best choice is to disable Tx chain.

I have several 751 and 951 units, all seems to have same problem. I tried with different settings, but still can't get maximum or at least stable line.

Btw over wifi youtube is working very poor. Uni/Multicast works flawlesly through LAN, through WLAN works only multicast. Any ideas about that too?

I have multicast problem over SXT too.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Jan 03, 2013 7:58 pm
by Boter
Anything new about the topic?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Jan 06, 2013 7:52 pm
by Moc
Hi,

I've sent 2 supout.rif to support, here my ticket number : [Ticket#2013010666000081]

I've loaded them in the supout viewer and I noticed that both show high CPU load when this occur (over 50%).

I got another wireless access point in the mean time, and I've also noticed that the ping are lower on the other AP. 1.4ms average compare to about 3.8ms . The mikrotik will sometime answer at 1.4ms too, but it really rare. I've notice also the mikrotik will spike more often to higher than 3ms than the other router.

I've also installed the other router in a more complicated scenario : Wireless AP->Windows Server acting as a router -> Mikrotik, and it is farther away + including more obstacle(2 floor vs 1 simple wall).

I've tried to be close or farther from the mikrotik router and I got the same result.

I really hope this can tracked down and fixed once and for all !!!

Moc

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Jan 28, 2013 9:27 pm
by myso
Hi guys,

I'm going to return my brand new RB751G-2HnD, because this is totally unacceptable:

Image

All the clients are in the same room as the router! After lowering the TX power to 17dbm it got a little bit better, but still a lot worse than the SOHO d-link AP/router :(

Just out of curiosity, is it worth trying the new RB951G-2HnD, or is it the same crap as 751G with a faster CPU and bigger memory only?

I like mikrotik devices a lot, but this one's a big disappointment.

Thanks

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Jan 28, 2013 11:42 pm
by Boter
RB951G-2n has really bad performance too... About 10/2 mbits. So i guess it's not much better.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Jan 28, 2013 11:54 pm
by ohara
RB951G-2n has really bad performance too... About 10/2 mbits. So i guess it's not much better.
Just to be clear, such device does not exist. Myso was asking aboud RB951G-2HnD. You are probably using RB951-2n.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Jan 29, 2013 12:04 am
by myso
Well, I have ordered 2pcs 951G-2HnD, I'll do the testing and let you know :? This is a very frustrating issue...

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Jan 29, 2013 8:38 am
by Boter

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Jan 29, 2013 9:29 am
by normis
This is not RB951G-2n, it is RB951-2n

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Jan 30, 2013 6:02 am
by phsjason
Just an odd note.
After a lot of testing and configuring, I decided to 'reset' the wireless interface to defaults and see how it worked. Surprisingly, it was quite a bit faster @30Mbps each direction of throughput. When I looked at the defaults settings in 5.22, they were different than the defaults from previous versions. For instance, Only chain 0 TX/RX was enabled and it was set to antenna A versus having all chains enabled. Might be worth a shot to load 5.22, update routerboard FW, and then reset wireless interface to default, then test/tweak.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Feb 04, 2013 12:16 pm
by myso
Hi guys, I've done some testing on my own. I got the RB751G working at it's best by either enabling regulatory domain for my country or manually decreasing the TX power to 17dbm. After that, clients were able to associate at some interesting speeds (depending on client capabilities, mostly Apple devices and 3 laptops with intel and broadcom cards). The real throughput measured against a RB-SXTG--5HnD hooked up to the 751G gave a maximum throughput of 30mbps. Unfortunately that's the only test I managed to perform before returning the 751G to the dealer.

Now I'm running the 951G, again with regulatory domain set to my country. the association speeds are a little bit higher than before, no real throughput tests done yet.

I'll keep you up-to-date with this.

Michael

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Feb 04, 2013 12:33 pm
by Dobby
mostly Apple devices and
try out to disable them sending TOS nad test it again please :wink:
I'll keep you up-to-date with this.
Would be fine.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Apr 07, 2013 11:52 am
by kwagga
Hi Guys,

Does anyone have an update regarding the poor 802.11n throughput of the RB751/RB951 devices?

I'm looking at buying a couple, but I've read so many threads with people battling with these units, I wonder if I shouldn't maybe avoid them completely?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Apr 07, 2013 9:54 pm
by myso
Hi I managed to do some tests using RB951G-2HnD today:
c:\soft>iperf -c 10.69.4.53 -P 20 -w 512k -t 60
------------------------------------------------------------
Client connecting to 10.69.4.53, TCP port 5001
TCP window size:  512 KByte
------------------------------------------------------------
[280] local 10.69.4.54 port 50095 connected with 10.69.4.53 port 5001
[264] local 10.69.4.54 port 50093 connected with 10.69.4.53 port 5001
[248] local 10.69.4.54 port 50091 connected with 10.69.4.53 port 5001
[232] local 10.69.4.54 port 50089 connected with 10.69.4.53 port 5001
[216] local 10.69.4.54 port 50087 connected with 10.69.4.53 port 5001
[200] local 10.69.4.54 port 50085 connected with 10.69.4.53 port 5001
[184] local 10.69.4.54 port 50083 connected with 10.69.4.53 port 5001
[168] local 10.69.4.54 port 50081 connected with 10.69.4.53 port 5001
[152] local 10.69.4.54 port 50079 connected with 10.69.4.53 port 5001
[136] local 10.69.4.54 port 50077 connected with 10.69.4.53 port 5001
[272] local 10.69.4.54 port 50094 connected with 10.69.4.53 port 5001
[256] local 10.69.4.54 port 50092 connected with 10.69.4.53 port 5001
[224] local 10.69.4.54 port 50088 connected with 10.69.4.53 port 5001
[208] local 10.69.4.54 port 50086 connected with 10.69.4.53 port 5001
[192] local 10.69.4.54 port 50084 connected with 10.69.4.53 port 5001
[176] local 10.69.4.54 port 50082 connected with 10.69.4.53 port 5001
[160] local 10.69.4.54 port 50080 connected with 10.69.4.53 port 5001
[144] local 10.69.4.54 port 50078 connected with 10.69.4.53 port 5001
[128] local 10.69.4.54 port 50076 connected with 10.69.4.53 port 5001
[240] local 10.69.4.54 port 50090 connected with 10.69.4.53 port 5001
[ ID] Interval       Transfer     Bandwidth
[184]  0.0-60.4 sec  57.0 MBytes  7.92 Mbits/sec
[216]  0.0-60.5 sec  54.3 MBytes  7.53 Mbits/sec
[168]  0.0-60.5 sec  52.3 MBytes  7.25 Mbits/sec
[272]  0.0-60.6 sec  50.9 MBytes  7.05 Mbits/sec
[256]  0.0-60.7 sec  38.3 MBytes  5.29 Mbits/sec
[240]  0.0-60.7 sec  40.3 MBytes  5.58 Mbits/sec
[144]  0.0-60.7 sec  30.2 MBytes  4.17 Mbits/sec
[224]  0.0-60.8 sec  39.7 MBytes  5.47 Mbits/sec
[128]  0.0-60.8 sec  50.3 MBytes  6.94 Mbits/sec
[160]  0.0-60.8 sec  39.9 MBytes  5.51 Mbits/sec
[200]  0.0-60.8 sec  36.6 MBytes  5.04 Mbits/sec
[192]  0.0-61.0 sec  11.8 MBytes  1.62 Mbits/sec
[248]  0.0-61.0 sec  11.9 MBytes  1.64 Mbits/sec
[232]  0.0-61.0 sec  11.9 MBytes  1.64 Mbits/sec
[136]  0.0-61.0 sec  11.8 MBytes  1.62 Mbits/sec
[280]  0.0-61.0 sec  12.0 MBytes  1.65 Mbits/sec
[264]  0.0-61.0 sec  12.0 MBytes  1.65 Mbits/sec
[152]  0.0-61.0 sec  11.8 MBytes  1.62 Mbits/sec
[176]  0.0-61.0 sec  11.8 MBytes  1.62 Mbits/sec
[208]  0.0-61.0 sec  11.8 MBytes  1.62 Mbits/sec
[ ID] Interval       Transfer     Bandwidth
[SUM]  0.0-61.0 sec   597 MBytes  82.0 Mbits/sec
6 WiFi 00:16:EA:xx:xx:xx no  -62dBm@1Mbps    135.... 5m37s
 int wirele print 
Flags: X - disabled, R - running 
 0  R name="WiFi" mtu=1500 mac-address=00:0C:42:xx:xx:xx arp=enabled interface-type=Atheros AR9300 mode=ap-bridge ssid="xxxx" frequency=2437 band=2ghz-b/g/n 
      channel-width=20/40mhz-ht-above scan-list=default wireless-protocol=unspecified wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no 
      bridge-mode=enabled default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no 
      security-profile=xxxx compression=no
/interface wireless
set 0 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=10 area="" arp=enabled band=2ghz-b/g/n basic-rates-a/g=6Mbps basic-rates-b=1Mbps bridge-mode=enabled channel-width=\
    20/40mhz-ht-above compression=no country="czech republic" default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 default-forwarding=yes dfs-mode=none \
    disable-running-check=no disabled=no disconnect-timeout=3s distance=indoors frame-lifetime=0 frequency=2437 frequency-mode=regulatory-domain frequency-offset=0 hide-ssid=no \
    ht-ampdu-priorities=0 ht-amsdu-limit=8192 ht-amsdu-threshold=8192 ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-guard-interval=any ht-rxchains=0,1 \
    ht-supported-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23 \
    ht-txchains=0,1 hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-threshold=0 hw-retries=7 l2mtu=2290 mac-address=00:0C:42:B7:9B:23 max-station-count=2007 \
    mode=ap-bridge mtu=1500 multicast-helper=default name=WiFi noise-floor-threshold=default nv2-cell-radius=30 nv2-noise-floor-offset=default nv2-preshared-key="" nv2-qos=default \
    nv2-queue-count=2 nv2-security=disabled on-fail-retry-time=100ms periodic-calibration=default periodic-calibration-interval=60 preamble-mode=both proprietary-extensions=\
    post-2.9.25 radio-name=000C42xxxxxx rate-selection=advanced rate-set=default scan-list=default security-profile=xxxx ssid=xxxx station-bridge-clone-mac=\
    00:00:00:00:00:00 supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps tdma-period-size=2 tx-power-mode=default \
    update-stats-interval=disabled wds-cost-range=50-150 wds-default-bridge=none wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wireless-protocol=unspecified wmm-support=\
    disabled
/interface wireless manual-tx-power-table
set WiFi manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17\
    ,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,HT40-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17"

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Apr 08, 2013 4:27 am
by ddd
From my experience if you are in a quiet environment with no other 2.4ghz interference they work perfectly.
However they don't seem to be able to deal with noisy environments compared to normal retail routers.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Apr 08, 2013 10:05 am
by myso
In my short experience (1x RG751G-2HnD and 1x RG951G-2HnD installation) - you have to very carefully select the TX power, either by regulatory domain or manually, because the radio is very powerful!!! Especially 1000mW on the 951G-2HnD!

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue May 21, 2013 5:53 pm
by Moc
I just upgraded to 6.0, and it appear that my wireless connectivity is finally usable/stable... This is just a 10min test I did... Will report back if I get issues under a longer usage period. But as 5.25 I still had issues with it.

I didn't factory reset when I upgraded from 5.25 to 6.0, so still running the default config of 5.25

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu May 30, 2013 5:56 pm
by Boter
It's the same with 6 here at my place. I still cant get more than 30/30.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Aug 20, 2013 2:52 pm
by jberen
Hi, any news on this topic more?, Boys Mikrotik?.


8) JB

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Aug 20, 2013 6:56 pm
by Boter
I have send support.rif on mikrotik support mail, it's over a month... and still no answer

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Aug 21, 2013 2:15 am
by opalit
I am experiencing a lot of problems with wireless devices connected to the RB751-2HnD.

I bought 3 units, in 2 different periods of time (2 when they became available several months ago, and one which arrived today). Local distributor said the last one is a new revision.

They are all configured as an access-point (802.11 b/g/n), and I get a lot of disconnections and very poor performances (high latency, variable between 40 and 3000ms, 100kbit/s throughput). If I manually set noise-floor to -90dB it becomes usable, but still I have reliability problems.

There are no interferences on the channel and devices work very well when connected to other access-points.

I already tried different ROS versions (5.6, 5.7, 5.9 and 5.14). All show the same behaviour on all units.

Does it happen only to me?
I had a RB751G 2HnD with poor Wireless, I downgraded to 5.16 and it is great

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Oct 08, 2013 11:42 pm
by MiniMe
Have you tried to change in AP bridged mode from wlan<->ether1[WAN]-mode to wlan<->ether2[LAN]-mode?

I got much better wireless performance results with that combination.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Dec 02, 2013 12:25 pm
by shadowskippie
Good Afternoon

So, I've done quite a bit of testing with this problem and from what i can see it happens when you add the Wlan to the bridge int. not sure as to why it does this but when i remove the Wlan from the bridge and run it in a routed setup it functions better.

So, this is kind of where a little help is required, the more ppl testing this solution the better.
I took the Wlan out of the bridge, remove the SSID and hid it for good measure.
Then i added a virtualAP to the wireless and setup my wireless SSID there and added that instead to the bridge.

As of typing this it seems to be functioning okay but I've only had this solution running for about a day now.

So, try this solution and see if it helps fix the problem

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Dec 03, 2013 6:32 pm
by Xcelsium
I tried removing the wlan from the bridge and using it as a router, it help but not too much still getting delay of 2000ms after 5 mins or with 1Mbps Trafic

Doing a more detailed troubleshooting ,changing preamble mode to long and change the HT-TX-chain=0 and HT-RX-chain=1 made to be more stable the communications,

Doing a 5min ping test to my RB951Ui-2HnD with 1 Mbps Download Traffic for 5min result on an average ping of 11ms, a max of 174ms and a min of 0 and a packet loss of 0%


Doint the same test with both TX and RX chain activated with 1Mbps download Traffic got average ping of 108ms max of 947ms and a min of 0ms and a packet loss of 10%

Image

BR
Xcelsium

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Dec 04, 2013 6:45 pm
by Boter
support mail still didnt answer. Maybe any unoficial answer when will poor wifi performance being solved?

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Dec 05, 2013 12:57 pm
by uldis
we do not suggest to disable the RX for chain0 as you always need to have chain0 RX enabled in order to make stable wireless connection.
We suggest to reset the wireless interface configuration to default values, here is an example command how to do that:
/interface wireless reset-configuration wlan1

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Feb 03, 2014 10:27 pm
by DeBergz
Do you find any solution to poor wifi perfomance?

I have a RB951G-2HnD and the wifi perfomance is so poor.
On speedtest.net with cable I have 9-11Mbps and on wifi 0.6-2 Mbps.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Feb 08, 2014 8:18 am
by mivan
too bad I read this after buying a 751u 2hnd .... my very first Mikrotik =P
just found this because of the same problems described in previous pages

WiFi connection is worse I ever had

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Feb 09, 2014 2:01 pm
by Fredrik75
I have several RB7* RB9* routers with this problem.
Get at most about 10Mbit download (about 20MBit with cable).

Tried to reset the settings but still the same issue. Tried different channels, 20MHz, 20MHz/40MHz etc but no change...

I have no problem with a product has some flaws in software that can be corrected, but the lack of interest from MikroTik to solve this issue is very strange...

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Wed Feb 12, 2014 1:10 am
by hedele
Well I found that for the wireless in 751U and 751G to work reliably, I have to disable RX/TX Chain 1, leaving only chain 0 active.
While that limits me to 65 Mbps @ 20 MHz (Real-Life throughput of around 35-40 Mbps), at least the connection is stable.

Enabling TX chain 1 is usually(!) not a problem as well, but enabling RX chain 1 causes all kinds of mayhem. RX signal strength on the 751 flaps around between -80 and -35 dbm with the laptop being less than 3 meters away, RX speed flaps around between 1 Mbps and > 100 Mbps, latency goes through the roof, real-life speeds of around 4 Mbps maximum.

I have had the exact same behavior on three different units, using several RouterOS versions, so I guess there really is something wrong with the MIMO setup in those devices. If free spectrum is available, go for 40 MHz and RX/TX chain 1 disabled. If not, stay on 20 MHz and disable RX chain 1 only. In case that still produces strange problems, the failsafe setting I found that should always work is 20 MHz, RX/TX chain 1 disabled, hardware-retries set to 15. Even more failsafe - but kind of backwards - use 802.11g only. In fact I actually have to use 802.11g only because my Nintendo devices refuse to associate with 751/951 equipment set to 802.11bgn.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun May 18, 2014 3:46 am
by gammy69er
Well, I am extremely fresh to this whole subject, but as I work for a small ISP that supplies Hotspot Tech to Managed Apartments and Hotels - I have had a major trial by fire over the last 3 months. In saying that - there are a few things I have found - they may help others with their problems.

1. Mikrotik Routerboard wireless appears to be 95% reliable when running - any reliability issues are due to a failing Routerboard - cases of High Ping may be included in this if your ping is greater than 2s (so a std timeout)

2. Mikrotik Routerboards are NOT setup out of the box - you need to configure EVERYTHING you want to use before it will work. Prime example of this is that under "/interface wireless" if you "set ht-amsdu-limit=" to anything below the default max of 8192 (initial thread I read was 256 - I like results with 2048), you will see a marked improvement of throughput. I was getting 22mbps max initially, that increased to 50 - 60 mbps (Clear LOS). The problem is that I get the same results on a 951 with one chain, and here I am using 2 chains on a 751.

3. the reason that I believe I am getting such poor performance on the Wireless - Signal loss under load - I have my RB 1 room away, in a Dark Spot for testing - I get 5 bars signal (sorry for being sooo technical - haven't figured out wireshark yet :/) - 300mbps report rate. As soon as I put load into the unit - drops to 4 bars and jumps between 54, 81, 108 and 121.5 mbps. Now I know that 54 and 108 and single and dual chain "g", 81, could still be "g", but 121.5 is definitely and "n" rate, and is single chain. I also have a Ubiqity Pico M2 HP to test with, and when I have it in the same position as the RB - I get Full Signal, 1 chain 150mbps report - under load - Full signal, 121.5, 150 mbps report - I get 60/70 throughput.

All testing carried out with Btest to router from an i5 750 @ 4ghz PC with N600 TP-Link Usb Stick

so the Morals of my story...
1. Check your settings - make sure that your datarates haven't been disabled for higher rates if you are getting below 15 mbps to router. if you are getting lower, then Hardreset config and start again. Scripting is a good thing to do here. If this doesn't help - try a replacement unit.
2. if you are getting average wireless throughputs - then try changing the Mac layer stuff - I noticed a significant increase in the speeds of the units - for a smaller SoHo or Home/apartment environment, this will become acceptable to most.
3. in saying all this - the wireless is still ****ed. granted, I am not yet MT certified - but when you put a Radio with supposed "27DBm" output - I would expect much better wireless results than a home grade Belkin, for which I do not see... TP-Links are the way to go for regular home users - but I am looking into Ubiquty/RB combos for our business now as the Ubiquty has, as far as I have seen over the last 6 years or retail and corporate sales, the best wireless out there, hands down. The combo you ask, bescause MT still has the best overall system - Powerful, configurable and inexpensive. DD-wrt - just not for me.

Anywho - My question in this whole bit is does anyone know of a way to improve the WiFi, does the external antenna help that much - and if so, does it only help one chain. I know the RB's with add on WiFi work a treat, but cost a little to much for most of our applications.

either way, Cheers - hope this info helps someone.

*EDIT* So I noticed something after further testing - I had the unit set to Regulatory_domain - New Zealand - and although NZ allows for 30dBm, the unit had been restricted to 17dBm - hence my Low Signals - strangely, after restoring to 27DBm - my signal was much higher, but my throughput dropout was far more severe - Dropping to 5.5mbps sync rate and <3mbps data rate. returning my power to ~19dBm returned my throughput to previously mentioned levels - so if signal is not an issue, dropping your Power may help.

In saying that - I had a look at the antenna array and found it to be a little lack lustre - has anyone ever tried reconnecting their own antennas and seeing if that helps the situation - if so, I would recommend reporting it to Mikrotik - they may consider a future model with no internal array and just external connectors.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Mon Jul 14, 2014 10:43 am
by ik3umt
In my 2.4 Ghz radioamateur experience, I found many times the receiver saturation leads to a messy quality reception
Some few hundreds meters links made with yagi antennas with huge latency and retransmissions, gone OK only changing antennas with simple low gain dipole (the homemade radios has no TX power regulation capability) to oppose the too strong signal causing distortions on the receiver frontend.

Working with 18-20dbm and over inside a single room, desn't seem a good idea
Think you have to watch a solar eclipse without filtering sunglasses.......

Just my two cents....

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Thu Jul 24, 2014 3:56 pm
by hflack
Anyone able to help me with wireless dropouts? Connection will suddenly drop for a moment then reconnect either automatically or require manual connection again.

[admin@MikroTik @ Hayden's] > /interface wireless export compact
# jan/02/1970 10:37:49 by RouterOS 5.26
# software id = ZPD8-PEXA
#
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods=passthrough management-protection=\
allowed mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key='' wpa2-pre-shared-key=\
''
add authentication-types=wpa-psk,wpa2-psk eap-methods=passthrough management-protection=allowed mode=dynamic-keys \
name=profile1 supplicant-identity="" wpa-pre-shared-key='' wpa2-pre-shared-key=''
/interface wireless
set 0 band=2ghz-b/g/n channel-width=20/40mhz-ht-above disabled=no distance=indoors frequency=2432 ht-rxchains=0,1 \
ht-txchains=0,1 l2mtu=2290 mode=ap-bridge security-profile=profile1 ssid=MikroTik wireless-protocol=any

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sat Oct 18, 2014 1:58 am
by scampbell
These are the settings we use where tablets and Apples are being used.....

1. Use a current RoS
2. Set tx power to 17dBm
3. Use Channel width=20MHz - 20/40MHz is not universally accepted by all devices and uses a lot of spectrum
4. Set distance=indoors
5. Disable TKIP in your security profiles - it limits speed to 54Mbps
6. Set ht-tx-chain=0,1 and ht-rx-chain=0,1 where supported
7. Set Guard Interval=long - allows for slower devices

This has given us stability and happy users.

Handheld devices will look at the signal from an AP and if it is really strong reduce their own power to conserve battery. The result is they may then not have sufficient signal to reach the AP, especially if it's running at 30dBm :lol:

It is best to match your AP capability to that of the devices it serves. So a really strong AP signal may not be serving you well if your client device cannot communicate back to it. It is better to have more low power AP's than 1 big one.

Tablets and iPhones disconnect when they go into standby mode - their wireless shuts down when not in use. Expect frequent re-connections from them.

Lastly, if you are running multiple 2.4 GHz AP's at a site stagger them on channel's 1,6 and 11.

And once you are running reliably you can then "tweak" the settings to see what works best for you.

I hope this helps.

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Tue Mar 21, 2017 5:57 pm
by sb56637
1. Use a current RoS
2. Set tx power to 17dBm
3. Use Channel width=20MHz - 20/40MHz is not universally accepted by all devices and uses a lot of spectrum
4. Set distance=indoors
5. Disable TKIP in your security profiles - it limits speed to 54Mbps
6. Set ht-tx-chain=0,1 and ht-rx-chain=0,1 where supported
7. Set Guard Interval=long - allows for slower devices
...
I hope this helps.
It sure did help! Sorry for necrobumping this thread, but I just wanted to say that #2 and #4 in scampbell's list were the key to *finally* solving major issues with "disconnected, extensive data loss" errors on my network. (In my case, the devices were laptops with Intel WiFI chipsets, not mobile devices.) I've been fighting with this for weeks, and I've tried everything. Especially when doing large file transfers over the LAN with several connections to the same device, it would consistently disconnect after a few seconds to a few minutes, with "extensive data loss" in the logs. According to NetworkManager on the clients, the disconnects were for "reason -4". So I finally ran across this thread, made changes #2 and #4, and after extensive network stress testing I can say I haven't had a single disconnection. Then I reset the WiFI distance to "dynamic" and power levels to "default", and *boom*, a disconnect with "extensive data loss" within less than a minute. Re-applied #2 and #4, and it runs fast and stable. Another added benefit of this change is that my network throughput is almost twice as fast. So thanks again to scampbell!

There are similar suggestions here too: https://gryzli.info/2015/06/20/mikrotik ... rformance/

Re: RB751U-2HnD - poor wireless performance & problems

Posted: Sun Sep 10, 2017 10:58 pm
by scampbell
1. Use a current RoS
2. Set tx power to 17dBm
3. Use Channel width=20MHz - 20/40MHz is not universally accepted by all devices and uses a lot of spectrum
4. Set distance=indoors
5. Disable TKIP in your security profiles - it limits speed to 54Mbps
6. Set ht-tx-chain=0,1 and ht-rx-chain=0,1 where supported
7. Set Guard Interval=long - allows for slower devices
...
I hope this helps.
It sure did help! Sorry for necrobumping this thread, but I just wanted to say that #2 and #4 in scampbell's list were the key to *finally* solving major issues with "disconnected, extensive data loss" errors on my network. (In my case, the devices were laptops with Intel WiFI chipsets, not mobile devices.) I've been fighting with this for weeks, and I've tried everything. Especially when doing large file transfers over the LAN with several connections to the same device, it would consistently disconnect after a few seconds to a few minutes, with "extensive data loss" in the logs. According to NetworkManager on the clients, the disconnects were for "reason -4". So I finally ran across this thread, made changes #2 and #4, and after extensive network stress testing I can say I haven't had a single disconnection. Then I reset the WiFI distance to "dynamic" and power levels to "default", and *boom*, a disconnect with "extensive data loss" within less than a minute. Re-applied #2 and #4, and it runs fast and stable. Another added benefit of this change is that my network throughput is almost twice as fast. So thanks again to scampbell!

There are similar suggestions here too: https://gryzli.info/2015/06/20/mikrotik ... rformance/
Welcome :-)