Community discussions

MUM Europe 2020
 
jurck
just joined
Topic Author
Posts: 6
Joined: Fri May 25, 2012 3:25 pm

RB751G-2HnD wirelless performance

Fri May 25, 2012 3:46 pm

I have some problem with wirelless on RB751G-2HnD. I'm using it as ap-bridge. It was ok for few weeks but now I have ping delays on wirelless some times over 1000 ms and packet loss. There is no traffic on wirelless. I turned on debug for wirelles bot no log. On wired it is ok.
Security is WPA2+EAP.
Any idea?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24333
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB751G-2HnD wirelless performance

Mon May 28, 2012 8:29 am

make sure you have latest RouterOS version, then post configuration output from command
/export compact
No answer to your question? How to write posts
 
jurck
just joined
Topic Author
Posts: 6
Joined: Fri May 25, 2012 3:25 pm

Re: RB751G-2HnD wirelless performance

Mon May 28, 2012 9:20 am

I solved the problem, for now. I reset config to default, restore the config from backup and upgraded to lastest version of RouterOS.
 
jurck
just joined
Topic Author
Posts: 6
Joined: Fri May 25, 2012 3:25 pm

Re: RB751G-2HnD wirelless performance

Sat Jun 02, 2012 12:36 pm

Now I upgraded to 5.17 and the problem is here again. I downgraded to 5.16 and reset, then restore the config, but still problem with wifi.

Ping on wifi with 5.17:
Pinging 192.168.1.1 with 32 bytes of data:

Ping statistics for 192.168.1.1:
    Packets: Sent = 121, Received = 112, Lost = 9 (7% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 3708ms, Average = 816ms
Ping on wifi with default config in 5.16
Ping statistics for 192.168.88.1:
    Packets: Sent = 55, Received = 54, Lost = 1 (1% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 2382ms, Average = 498ms
configuration
# jun/02/2012 11:27:44 by RouterOS 5.16
# software id = 9E9T-2X63
#
/interface bridge
add admin-mac=D4:CA:6D:25:FD:C9 arp=proxy-arp auto-mac=no l2mtu=1598 name=bridge-local protocol-mode=rstp
/interface ethernet
set 0 name=ether1-gateway
set 1 arp=proxy-arp name=ether2-master-local speed=1Gbps
set 2 master-port=ether2-master-local name=ether3-slave-local speed=1Gbps
set 3 master-port=ether2-master-local name=ether4-slave-local
set 4 master-port=ether2-master-local name=ether5-slave-local
/interface wireless
set 0 band=2ghz-b/g/n channel-width=20/40mhz-ht-above country=slovenia disabled=no ht-rxchains=0,1 ht-supported-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15 ht-txchains=0,1 \
    l2mtu=2290 mode=ap-bridge ssid=tsunami wireless-protocol=802.11
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods=passthrough mode=dynamic-keys wpa-pre-shared-key=\
    *** wpa2-pre-shared-key=***
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip pool
add name=default-dhcp ranges=192.168.1.100-192.168.1.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge-local name=default
/ipv6 dhcp-server
add address-pool=pool6 authoritative=yes disabled=no interface=bridge-local name=dhcp6
/ipv6 pool
add name=pool6 prefix=2001:x:x:x::/64 prefix-length=65
/interface wireless connect-list
add interface=wlan1 mac-address=98:0C:82:2B:B7:8A
/interface wireless snooper
set receive-errors=yes
/ip address
add address=192.168.88.1/24 comment="default configuration" interface=bridge-local
add address=x.x.x.x/x interface=ether1-gateway
add address=192.168.1.1/24 interface=bridge-local
/ip dhcp-client
add comment="default configuration" interface=ether1-gateway
/ip dhcp-server network
add address=192.168.1.0/24 comment="default configuration"  \
    gateway=192.168.1.1
/ip dns static
add address=192.168.88.1 name=router
/ip neighbor discovery
set ether1-gateway disabled=yes
set wlan1 disabled=yes
/ip proxy access
add src-address=192.168.0.0/24
add action=deny dst-port=23-25
add action=deny
/ip route
add distance=1 gateway=ether1-gateway
/ip traffic-flow
set interfaces=ether1-gateway
/ip upnp
set allow-disable-external-interface=no enabled=yes
/ip upnp interfaces
add interface=ether2-master-local type=internal
add interface=ether1-gateway type=external
/ipv6 address
add address=2001:x:x:x::2/64 advertise=no interface=sit1
add address=2001:x:x:x::1/64 interface=bridge-local
/system leds
set 0 interface=wlan1
/tool mac-server
add disabled=no interface=ether2-master-local
add disabled=no interface=ether3-slave-local
add disabled=no interface=ether4-slave-local
add disabled=no interface=ether5-slave-local
add disabled=no interface=wlan1
add disabled=no interface=bridge-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=wlan1
add interface=bridge-local
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: RB751G-2HnD wirelless performance

Mon Jun 04, 2012 5:39 pm

what else has changed since it was working ok for few weeks? maybe you installed a new router on 2.4ghz near this one?
 
jurck
just joined
Topic Author
Posts: 6
Joined: Fri May 25, 2012 3:25 pm

Re: RB751G-2HnD wirelless performance

Mon Jun 04, 2012 7:07 pm

Nothing changed. I have only this router.
 
webscientist
just joined
Posts: 13
Joined: Wed May 30, 2012 8:29 pm

Re: RB751G-2HnD wirelless performance

Mon Jun 04, 2012 7:41 pm

Nothing changed. I have only this router.
maybe someone else did? have you checked wireless spectrum noise?

sometime simply changing band greatly help.
 
jurck
just joined
Topic Author
Posts: 6
Joined: Fri May 25, 2012 3:25 pm

Re: RB751G-2HnD wirelless performance

Mon Jun 04, 2012 7:49 pm

yes I checked. As you can see on this forum, I'm not only one who have this problem.
 
mikko
newbie
Posts: 37
Joined: Tue Jan 11, 2011 5:18 pm
Location: Finland

Re: RB751G-2HnD wirelless performance

Mon Jun 04, 2012 8:56 pm

What kind client do you have? I dont have that board, but others with 52n cards. I have seen bad wireless performance with old broadcom G chipsets if preamble if set both or short. With long preamble my laptops with old broadcom radios work ok.

And run spectrum scan in dude. I have had problems with some customers that have analog wireless security cameras in 2.4 GHz band. Even one of those cameras can fill half of 2.4 GHz spectrum.
Mikko, MTCNA, CCNA
 
User avatar
ohara
Member
Member
Posts: 371
Joined: Mon Jun 13, 2011 11:30 pm
Location: Warsaw

Re: RB751G-2HnD wirelless performance

Mon Jun 04, 2012 9:41 pm

jurck, test the attached settings and say if it makes a difference. I get good results in my small flat. ROS 5.17, FW 2.38, devices with static IP from DHCP. I just have a different software ID than you. Only thing that I am wondering about is why devices don't connect at more than 65/65Mbps.
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 15 guests