Community discussions

 
mtmx80
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 87
Joined: Wed Mar 16, 2011 11:12 pm

RB2011 switch port groups

Wed Jul 04, 2012 8:04 pm

Hi.

does anybody knows if ports can be grouped on RB2011 to act like a simple switch ? The goal is to achieve wire speed switching on some ports. If it's possible which ports can be joined to a switch?
 
User avatar
uebi
Member Candidate
Member Candidate
Posts: 117
Joined: Tue Sep 13, 2005 5:27 pm
Location: Austria
Contact:

Re: RB2011 switch port groups

Thu Jul 05, 2012 12:22 am

Iirc there are 2 switch chips. One for the gig ports and the SFP slot (RB2011LS) and one for the fast ethernet ports.

Hth,
uebi
"They have the Internet on computers now?" - Homer Simpson
 
mtmx80
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 87
Joined: Wed Mar 16, 2011 11:12 pm

Re: RB2011 switch port groups

Fri Jul 06, 2012 12:05 pm

Hm... I'm unsure. I don't see the second switch chip.
 
User avatar
uebi
Member Candidate
Member Candidate
Posts: 117
Joined: Tue Sep 13, 2005 5:27 pm
Location: Austria
Contact:

Re: RB2011 switch port groups

Fri Jul 06, 2012 12:24 pm

In winbox menu Switch you should see

Atheros8327 for ether1-ether5+sfp1 and
Atheros8227 for ether6-ether10


KR,
uebi
"They have the Internet on computers now?" - Homer Simpson
 
mtmx80
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 87
Joined: Wed Mar 16, 2011 11:12 pm

Re: RB2011 switch port groups

Thu Jul 12, 2012 12:51 pm

You have right!

Atheros8327 is present on RB2011 series(ether1-ether5+sfp1) RB750GL, RB751G-2HnD and RB1100AH, RB1100AHx2(ether1-ether5, ether6-ether10).
Atheros8227 is present on RB2011 series(ether6-ether10).
More info http://wiki.mikrotik.com/wiki/Manual:Sw ... p_Features

There is still one question What's the difference in features between 8327 and 8227?
 
sdrenner
Member Candidate
Member Candidate
Posts: 138
Joined: Wed Mar 02, 2005 10:03 pm
Contact:

Re: RB2011 switch port groups

Wed Nov 28, 2012 10:05 pm

Hi.

does anybody knows if ports can be grouped on RB2011 to act like a simple switch ? The goal is to achieve wire speed switching on some ports. If it's possible which ports can be joined to a switch?

Did you ever find a way to put all ports into 1 switch?
I am wanting to do this on RB493g and RB2011
 
w0lt
Member
Member
Posts: 484
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: RB2011 switch port groups

Wed Nov 28, 2012 10:51 pm

Did you ever find a way to put all ports into 1 switch?
I am wanting to do this on RB493g and RB2011
Set ether1 as the master for ether 2-5, then set ether6 as the master for ether 7-10, then bridge ether6 to ether1.

See if that works for you.
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "

Image
 
fullerms
newbie
Posts: 26
Joined: Tue Nov 13, 2012 7:17 am

Re: RB2011 switch port groups

Thu Nov 29, 2012 3:49 am

Set ether1 as the master for ether 2-5, then set ether6 as the master for ether 7-10, then bridge ether6 to ether1.

New to routeros, so please excuse the noob question. How to configure this? In cli or the web interface?
 
w0lt
Member
Member
Posts: 484
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: RB2011 switch port groups

Thu Nov 29, 2012 4:20 am

Set ether1 as the master for ether 2-5, then set ether6 as the master for ether 7-10, then bridge ether6 to ether1.

New to routeros, so please excuse the noob question. How to configure this? In cli or the web interface?

Either one... Or you can use Winbox which is a free GUI configuration and management tool.
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "

Image
 
fullerms
newbie
Posts: 26
Joined: Tue Nov 13, 2012 7:17 am

Re: RB2011 switch port groups

Thu Nov 29, 2012 5:09 am

Set ether1 as the master for ether 2-5, then set ether6 as the master for ether 7-10, then bridge ether6 to ether1.

New to routeros, so please excuse the noob question. How to configure this? In cli or the web interface?

Either one... Or you can use Winbox which is a free GUI configuration and management tool.

Ok thanks. Checked my config in Winbox,

Ether6 is master for 7-10. And Ether 2-5, ether6 and wlan 1 are part of bridge-local. Is this correct? And I assume ether 1 is left out because it is the "WAN" port and must be routed?
 
w0lt
Member
Member
Posts: 484
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: RB2011 switch port groups

Thu Nov 29, 2012 4:13 pm

Ok thanks. Checked my config in Winbox,

Ether6 is master for 7-10. And Ether 2-5, ether6 and wlan 1 are part of bridge-local. Is this correct? And I assume ether 1 is left out because it is the "WAN" port and must be routed?[/quote]


The configuration I listed was only to use the RB2011 as a complete switch. Do you have a RB2011UAS-2HnD? If so, add a Cisco compatible GLC module to the SFP port. That will give you GigE ethernet which you can use for you NAT interface to the internet.
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "

Image
 
fullerms
newbie
Posts: 26
Joined: Tue Nov 13, 2012 7:17 am

Re: RB2011 switch port groups

Thu Nov 29, 2012 4:46 pm

Ok thanks. Checked my config in Winbox,

Ether6 is master for 7-10. And Ether 2-5, ether6 and wlan 1 are part of bridge-local. Is this correct? And I assume ether 1 is left out because it is the "WAN" port and must be routed?

The configuration I listed was only to use the RB2011 as a complete switch. Do you have a RB2011UAS-2HnD? If so, add a Cisco compatible GLC module to the SFP port. That will give you GigE ethernet which you can use for you NAT interface to the internet.[/quote]


Yes, I have a RB2011UAS-2HnD. So is my config correct?

I have been searching high and low for a Copper SFP, but they are all in excess of 70 USD. Anyplace where I can source them for cheap?
 
andriys
Forum Guru
Forum Guru
Posts: 1179
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: RB2011 switch port groups

Thu Nov 29, 2012 5:25 pm

I have been searching high and low for a Copper SFP, but they are all in excess of 70 USD. Anyplace where I can source them for cheap?
Do you really need it? 10 copper ports is not enough for you?

Back to the original question. If you need WAN port to be 1G port then do the following:

1. Set master port for ports 1, 2 and 6 to none.
2. Set master port for ports 3-5 to ether2.
3. Set master port for ports 7-10 to ether6.
4. Make ether2 and ether6 a part of the bridge (bridge-local).

This way you will have ether1 as your WAN port and bridge-local as your LAN port. 1G ports 2-5 are hardware-switched together, 100M ports 6-10 are hardware switched together as well, and these to groups of hardware switched ports are software bridged.

And if 100M is enough for your WAN port you can consider the following scenario as an alternative:
1. Set master port for ports 1, 6 and 10 to none.
2. Set master port for ports 2-5 to ether1.
3. Set master port for ports 7-9 to ether6.
4. Make ether1 and ether6 a part of the bridge (bridge-local).

This way you will have ether10 as your WAN port and bridge-local as your LAN port. 1G ports 1-5 are hardware-switched together, 100M ports 6-9 are hardware switched together as well, and these to groups of hardware switched ports are software bridged.

Regards,
Andrey.
 
fullerms
newbie
Posts: 26
Joined: Tue Nov 13, 2012 7:17 am

Re: RB2011 switch port groups

Thu Nov 29, 2012 5:36 pm

I have been searching high and low for a Copper SFP, but they are all in excess of 70 USD. Anyplace where I can source them for cheap?
Do you really need it? 10 copper ports is not enough for you?

Back to the original question. If you need WAN port to be 1G port then do the following:

1. Set master port for ports 1, 2 and 6 to none.
2. Set master port for ports 3-5 to ether2.
3. Set master port for ports 7-10 to ether6.
4. Make ether2 and ether6 a part of the bridge (bridge-local).

This way you will have ether1 as your WAN port and bridge-local as your LAN port. 1G ports 2-5 are hardware-switched together, 100M ports 6-10 are hardware switched together as well, and these to groups of hardware switched ports are software bridged.

And if 100M is enough for your WAN port you can consider the following scenario as an alternative:
1. Set master port for ports 1, 6 and 10 to none.
2. Set master port for ports 2-5 to ether1.
3. Set master port for ports 7-9 to ether6.
4. Make ether1 and ether6 a part of the bridge (bridge-local).

This way you will have ether10 as your WAN port and bridge-local as your LAN port. 1G ports 1-5 are hardware-switched together, 100M ports 6-9 are hardware switched together as well, and these to groups of hardware switched ports are software bridged.

Regards,
Andrey.
My broadband link is at 100 Meg now, see below :D

Image

For a few dollars more, I can upgrade it to 150 Meg. So yes, I need my WAN port to be able to route more than 100 Meg.

And yes, if I can add one more Gig port to the RB2011UAS-2HnD, I can remove a four port switch from my network. Less complexity, power and heat :)
 
fullerms
newbie
Posts: 26
Joined: Tue Nov 13, 2012 7:17 am

Re: RB2011 switch port groups

Sun Dec 02, 2012 5:40 am

Back to the original question. If you need WAN port to be 1G port then do the following:

1. Set master port for ports 1, 2 and 6 to none.
2. Set master port for ports 3-5 to ether2.
3. Set master port for ports 7-10 to ether6.
4. Make ether2 and ether6 a part of the bridge (bridge-local).

This way you will have ether1 as your WAN port and bridge-local as your LAN port. 1G ports 2-5 are hardware-switched together, 100M ports 6-10 are hardware switched together as well, and these to groups of hardware switched ports are software bridged.
Is this config correct? Why is there no entry under "Switch all ports" Does it mean the CPU is handling the traffic now? How do I configure ether1 as the WAN port?

[admin@MikroTik] > interface ethernet switch print
Flags: I - invalid
# NAME TYPE MIRROR-SOURCE MIRROR-TARGET SWITCH-ALL-PORTS
0 switch1 Atheros-8327 none none
1 switch2 Atheros-8227 none none



[admin@MikroTik] > interface ethernet print
Flags: X - disabled, R - running, S - slave
# NAME MTU MAC-ADDRESS ARP MASTER-PORT SWITCH
0 X sfp1 1500 xx:xx:xx:xx:xx:A9 enabled none switch1
1 R ether1-gateway 1500 xx:xx:xx:xx:xx:AA enabled none switch1
2 R ether2 1500 xx:xx:xx:xx:xx:AB enabled none switch1
3 RS ether3 1500 xx:xx:xx:xx:xx:AC enabled ether2 switch1
4 S ether4 1500 xx:xx:xx:xx:xx:AD enabled ether2 switch1
5 S ether5 1500 xx:xx:xx:xx:xx:AE enabled ether2 switch1
6 R ether6 1500 xx:xx:xx:xx:xx:AF enabled none switch2
7 RS ether7 1500 xx:xx:xx:xx:xx:B0 enabled ether6 switch2
8 S ether8 1500 xx:xx:xx:xx:xx:B1 enabled ether6 switch2
9 S ether9 1500 xx:xx:xx:xx:xx:B2 enabled ether6 switch2
10 S ether10 1500 xx:xx:xx:xx:xx:B3 enabled ether6 switch2
[admin@MikroTik] >
 
andriys
Forum Guru
Forum Guru
Posts: 1179
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: RB2011 switch port groups

Sun Dec 02, 2012 11:55 am

Why is there no entry under "Switch all ports".
According to http://wiki.mikrotik.com/wiki/Manual:Sw ... p_Features this option is only meaningful on RB450G and RB435G boards. On your device (RB2011, I assume) this option does nothing.
Does it mean the CPU is handling the traffic now?
That depends on what traffic you're referring to. Lets assume you've configured your device like this:
1. Set master port for ports 1, 2 and 6 to none.
2. Set master port for ports 3-5 to ether2.
3. Set master port for ports 7-10 to ether6.
4. Make ether2 and ether6 a part of the bridge (bridge-local).
In this case you have two groups of ports. The first group includes 1G ports from 2 to 5, while the second group includes 100M ports from 6 to 10. any traffic passing between any couple of ports inside any given group is handled by the switch chip. But any traffic passing from port in one group to a port in another group will be handled by CPU.

For example:
Traffic between ports 2 and 5 - switch chip
Traffic between ports 3 and 4 - switch chip
Traffic between ports 6 and 7 - switch chip
Traffic between ports 8 and 10 - switch chip
Traffic between ports 3 and 6 - CPU
Traffic between ports 5 and 9 - CPU

There is no way to pass traffic between 1G and 100M ports off-CPU.
[admin@MikroTik] > interface ethernet print
You'd better show us

ros code

/interface ethernet export
 
fullerms
newbie
Posts: 26
Joined: Tue Nov 13, 2012 7:17 am

Re: RB2011 switch port groups

Sun Dec 02, 2012 1:06 pm

You'd better show us

ros code

/interface ethernet export
[admin@MikroTik] > interface ethernet export

#
/interface ethernet
set 0 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=yes full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:A9 master-port=none mtu=1500 name=sfp1 speed=100Mbps
set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:AA master-port=none mtu=1500 name=ether1-gateway speed=100Mbps
set 2 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:AB master-port=none mtu=1500 name=ether2 speed=100Mbps
set 3 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:AC master-port=ether2 mtu=1500 name=ether3 speed=100Mbps
set 4 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:AD master-port=ether2 mtu=1500 name=ether4 speed=100Mbps
set 5 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:AE master-port=ether2 mtu=1500 name=ether5 speed=100Mbps
set 6 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:AF master-port=none mtu=1500 name=ether6 speed=100Mbps
set 7 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:B0 master-port=ether6 mtu=1500 name=ether7 speed=100Mbps
set 8 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:B1 master-port=ether6 mtu=1500 name=ether8 speed=100Mbps
set 9 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:B2 master-port=ether6 mtu=1500 name=ether9 speed=100Mbps
set 10 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=xx:xx:xx:xx:xx:B3 master-port=ether6 mtu=1500 name=ether10 speed=100Mbps
/interface ethernet switch
set 0 mirror-source=none mirror-target=none name=switch1
set 1 mirror-source=none mirror-target=none name=switch2
/interface ethernet switch port
set 0 vlan-header=leave-as-is vlan-mode=disabled
set 1 vlan-header=leave-as-is vlan-mode=disabled
set 2 vlan-header=leave-as-is vlan-mode=disabled
set 3 vlan-header=leave-as-is vlan-mode=disabled
set 4 vlan-header=leave-as-is vlan-mode=disabled
set 5 vlan-header=leave-as-is vlan-mode=disabled
set 6 vlan-header=leave-as-is vlan-mode=disabled
set 7 vlan-header=leave-as-is vlan-mode=disabled
set 8 vlan-header=leave-as-is vlan-mode=disabled
set 9 vlan-header=leave-as-is vlan-mode=disabled
set 10 vlan-header=leave-as-is vlan-mode=disabled
set 11 vlan-header=leave-as-is vlan-mode=disabled
set 12 vlan-header=leave-as-is vlan-mode=disabled

I did some testing with jperf, getting only around 225 Mbps between two gig ports.
 
Quindor
Member
Member
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: RB2011 switch port groups

Mon Dec 03, 2012 8:15 pm

Euhm, why are all your speeds set to 100Mbit? If I do an export the speed are not explicitly listed unless I forced them?

Can you try forcing a gigabit or setting auto-negotiation?

Otherwise try to clear your config, configure the bare minimum (put them in a switch group) and try then?
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
fullerms
newbie
Posts: 26
Joined: Tue Nov 13, 2012 7:17 am

Re: RB2011 switch port groups

Tue Dec 04, 2012 4:11 am

Euhm, why are all your speeds set to 100Mbit? If I do an export the speed are not explicitly listed unless I forced them?

Can you try forcing a gigabit or setting auto-negotiation?

Otherwise try to clear your config, configure the bare minimum (put them in a switch group) and try then?

I checked the status, the ports negotiated the right speeds. And there is no option to remove the explicitly set speeds.

This is what I see in the command line

Interface --> ethernet --> set --> ether1-gateway ---> speed=100Mbps / 10Mbps / 1Gbps
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: RB2011 switch port groups

Tue Dec 04, 2012 9:52 am

Block diagram from the link explains about switch chip and ports,
http://routerboard.com/pdf/446/Block-RB2011UAS-2HnD.pdf
 
User avatar
Maggiore81
Member Candidate
Member Candidate
Posts: 217
Joined: Sun Apr 15, 2012 12:10 pm
Location: Italy
Contact:

Re: RB2011 switch port groups

Mon Mar 18, 2013 8:49 pm

Why is there no entry under "Switch all ports".
According to http://wiki.mikrotik.com/wiki/Manual:Sw ... p_Features this option is only meaningful on RB450G and RB435G boards. On your device (RB2011, I assume) this option does nothing.
Does it mean the CPU is handling the traffic now?
That depends on what traffic you're referring to. Lets assume you've configured your device like this:
1. Set master port for ports 1, 2 and 6 to none.
2. Set master port for ports 3-5 to ether2.
3. Set master port for ports 7-10 to ether6.
4. Make ether2 and ether6 a part of the bridge (bridge-local).
In this case you have two groups of ports. The first group includes 1G ports from 2 to 5, while the second group includes 100M ports from 6 to 10. any traffic passing between any couple of ports inside any given group is handled by the switch chip. But any traffic passing from port in one group to a port in another group will be handled by CPU.

For example:
Traffic between ports 2 and 5 - switch chip
Traffic between ports 3 and 4 - switch chip
Traffic between ports 6 and 7 - switch chip
Traffic between ports 8 and 10 - switch chip
Traffic between ports 3 and 6 - CPU
Traffic between ports 5 and 9 - CPU

There is no way to pass traffic between 1G and 100M ports off-CPU.
[admin@MikroTik] > interface ethernet print
You'd better show us

ros code

/interface ethernet export

A simple question:

If I set switch group port 1-3
port 4 routed
port 5 routed

traffic from any port 1-3 to port 4 or 5 will pass by cpu?
Dott. Elia Spadoni
---
Network Administrator,
MTCNA, MTCRE, MTCTCE, MTCINE, MTCWE
Spadhausen Internet Provider
Ravenna, ITALY
http://www.spadhausen.com
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RB2011 switch port groups

Tue Mar 19, 2013 3:51 pm

yes, traffic from ports 1-3 will pass through CPU to get to 4 or 5
 
tribute2soad
just joined
Posts: 8
Joined: Thu Jul 12, 2012 12:03 pm

Re: RB2011 switch port groups

Mon Jan 13, 2014 1:18 pm

Hi there! I got a little problem and hope somebody can help me:

I've 2x RB2011LS, firmware is 6.4. The both sfp-ports are set to trunk ports. I've got some vlans through both 2011LS. On each end i've some access ports. To this point, no problems are present.

Now I need at one end a new port (eth6 --> switch2) which I also want put in a new vlan (access port). I set the config of the mikrotiks as follow:

on router #1:
[medcon1] interface ethernet print
Flags: X - disabled, R - running, S - slave
 #    NAME                                          MTU MAC-ADDRESS          ARP          MASTER-PORT                                 SWITCH
 0 RS ether1                                       1500 XX:XX:XX:XX:XX:XX enabled    ether2                                             switch1
 1 R  ether2                                        1500 XX:XX:XX:XX:XX:XX enabled    none                                               switch1
 2 RS ether3                                       1500 XX:XX:XX:XX:XX:XX enabled    ether2                                             switch1
 3 RS ether4                                       1500 XX:XX:XX:XX:XX:XX enabled    ether2                                             switch1
10 RS sfp1-medcon2                            1500 XX:XX:XX:XX:XX:XX enabled    ether2                                             switch1
[medcon1] interface ethernet switch port print
Flags: I - invalid
 #   NAME                                          SWITCH                                                                        VLAN-MODE VLAN-HEADER    DEFAULT-VLAN-ID
 0   sfp1-medcon2                                switch1                                                                       secure    add-if-missing            auto
 1   ether1                                          switch1                                                                       secure    always-strip               800
 2   ether2                                          switch1                                                                       secure    add-if-missing            auto
 3   ether3                                          switch1                                                                       secure    always-strip               500
 4   ether4                                          switch1                                                                       secure    always-strip               900
11   switch1_cpu                                 switch1                                                                       secure    leave-as-is               auto
[medcon1] interface ethernet switch vlan print
Flags: X - disabled, I - invalid
 #   SWITCH                                            VLAN-ID      PORTS
 0   switch1                                             800            ether1
                                                                              sfp1-medcon2                                                                                           
 5   switch1                                             500            ether3
                                                                              sfp1-medcon2
 6   switch1                                             900            ether4
                                                                              sfp1-medcon2
[medcon1]
on router #2:
[medcon2] interface ethernet print
Flags: X - disabled, R - running, S - slave
 #    NAME                                          MTU MAC-ADDRESS          ARP        MASTER-PORT                       SWITCH
 0 RS ether1                                       1500 XX:XX:XX:XX:XX:XX enabled    sfp1-medcon1                       switch1
 4 RS ether5                                       1500 XX:XX:XX:XX:XX:XX enabled    sfp1-medcon1                       switch1
 5 RS  ether6                                        1500 XX:XX:XX:XX:XX:XX enabled     none                                  switch2
 6  S ether7                                        1500 XX:XX:XX:XX:XX:XX enabled    ether6                                 switch2
10 RS  sfp1-medcon1                             1500 XX:XX:XX:XX:XX:XX enabled    none                                    switch1
[medcon2] interface ethernet switch port print
Flags: I - invalid
 #   NAME                                         SWITCH                          VLAN-MODE VLAN-HEADER    DEFAULT-VLAN-ID
 0   sfp1-medcon1                               switch1                          secure        add-if-missing            auto
 1   ether1                                         switch1                          secure        always-strip               800
 5   ether5                                         switch1                          secure        always-strip               500
 6   ether6                                         switch2                          secure        always-strip               900
11   switch1_cpu                                 switch1                          secure        leave-as-is               auto
[medcon2] interface ethernet switch vlan print
Flags: X - disabled, I - invalid
 #   SWITCH                       VLAN-ID    PORTS
 0   switch1                              800    ether1-AirFiber
                                                      sfp1-medcon1
 5   switch1                              500    ether5-Lobacker-5GHz
                                                      sfp1-medcon1
 6   switch1                              900    sfp1-medcon1
 7   switch2                             900    ether6-interlink-schaalby
[medcon2] interface bridge port print
Flags: X - disabled, I - inactive, D - dynamic
 #    INTERFACE                                                        BRIDGE                                       PRIORITY  PATH-COST    HORIZON
 0    ether6                                                              bridge-local-masterports                   0x80         10              none
 1    sfp1-medcon1                                                    bridge-local-masterports                   0x80         10              none
My problem is, that i can't ping through vlan900 :(

Some ideas?
 
tribute2soad
just joined
Posts: 8
Joined: Thu Jul 12, 2012 12:03 pm

Re: RB2011 switch port groups

Fri Jan 17, 2014 11:24 am

nobody?
 
alsur
just joined
Posts: 5
Joined: Tue Mar 25, 2014 4:56 pm

Re: RB2011 switch port groups

Tue Mar 25, 2014 5:04 pm

I know this is a bit outdated now but being new to Mikrotik I have a doubt referring to the two chips and performance.
I am preparing a setup on the 2011UiAS with 2 WANS with faiolver and the rest of the ports available for the local network (bridged).
I am not sure how many of the 1G ports I would be requiring but up till I read this entry I had clear that I would move the WANs to eth6-7 as this are all VDSLs of up to 30Mb at the moment. By doing this I was hoping to liberate as many 1G ports as possible (5) for local network traffic.
Now I am in doubt that since the main use is routing internet traffic this could have a penalize in performance as I understand it would all mean "software" CPU traffic.
Considering 3x 1Gb ports might be enough in my case, would I be better off leaving WANs on eth1-2 so most traffic remains on the same "side" and through the best router chip?
Many thanks.
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: RB2011 switch port groups

Wed Mar 26, 2014 11:24 pm

routing is routing period. you will use cpu any time that happens.

the only time the switch chip gets involved is when there is no routing, say where traffic is coming in from port 1 to port 3, with no routing involvement. otherwise the cpu is affected
 
alsur
just joined
Posts: 5
Joined: Tue Mar 25, 2014 4:56 pm

Re: RB2011 switch port groups

Thu Mar 27, 2014 10:36 am

thanks. That was my guess so in my scenario I understand that having 2 x WANs on either 100Mbps or 1Gb ports would have the same CPU use.
I now have to work out why traffic is not routing that way but that is going to be part of my learning curve with Mikrotik ;)
 
bkuhn
Frequent Visitor
Frequent Visitor
Posts: 73
Joined: Fri Oct 15, 2010 12:17 am

Re: RB2011 switch port groups

Tue Sep 30, 2014 9:44 pm

Quick question for the guru's...

I know this is an old post, but it is relevant to my issue.

Would this be possible?
ether1-gateway

bridge-local > ether2-master, ether3-5slave
interfaces > ether6-master, ether7-10slave
Then take a physical cable between ether5 and ether6 bypassing the CPU for switching
 
Quindor
Member
Member
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: RB2011 switch port groups

Wed Oct 01, 2014 7:34 pm

Quick question for the guru's...

I know this is an old post, but it is relevant to my issue.

Would this be possible?
ether1-gateway

bridge-local > ether2-master, ether3-5slave
interfaces > ether6-master, ether7-10slave
Then take a physical cable between ether5 and ether6 bypassing the CPU for switching
Yes, but why would you want to? The 100Mbit bridge between the switches through the CPU doesn't cost much performance.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
bkuhn
Frequent Visitor
Frequent Visitor
Posts: 73
Joined: Fri Oct 15, 2010 12:17 am

Re: RB2011 switch port groups

Wed Oct 01, 2014 7:46 pm

I was testing throughput with the btest utility between a Windows host on ether2 and the RB2011 with all gigabit ether ports in a bridge group and I was only hitting 80-90Mbit/s at 95% CPU. I was thinking doing my half ass workaround would bypass the CPU for all switching.

I also tested between 2 computers last night with ether2 set as master and all ether3-5 as slave. It was bypassing the CPU as it was only hitting 4% but I was still only getting about 200-300Mbit/s.
 
Quindor
Member
Member
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: RB2011 switch port groups

Wed Oct 01, 2014 9:11 pm

I was testing throughput with the btest utility between a Windows host on ether2 and the RB2011 with all gigabit ether ports in a bridge group and I was only hitting 80-90Mbit/s at 95% CPU. I was thinking doing my half ass workaround would bypass the CPU for all switching.

I also tested between 2 computers last night with ether2 set as master and all ether3-5 as slave. It was bypassing the CPU as it was only hitting 4% but I was still only getting about 200-300Mbit/s.
Yeah, euhm. That should work a lot better. Either bridged or switched you should be able to get 1Gbit, so something else might be wrong.

Check flow control on the ports too.

Also, I don't know this btest utility, but I advise to use iperf. You can find a guide here: http://blog.quindorian.org/2014/05/a-gu ... ering.html
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
bkuhn
Frequent Visitor
Frequent Visitor
Posts: 73
Joined: Fri Oct 15, 2010 12:17 am

Re: RB2011 switch port groups

Wed Oct 01, 2014 9:25 pm

btest is the bandwidth test utility MikroTik has available for download.

Checked flow control, it is off for tx and rx.

I have another RB2011, maybe I'll connect it via gigabit and run a bandwidth test between the 2 ruling out the Windows boxes.
 
Quindor
Member
Member
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: RB2011 switch port groups

Wed Oct 01, 2014 9:50 pm

btest is the bandwidth test utility MikroTik has available for download.

Checked flow control, it is off for tx and rx.

I have another RB2011, maybe I'll connect it via gigabit and run a bandwidth test between the 2 ruling out the Windows boxes.
I advise to put it on auto
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
toshes22
just joined
Posts: 2
Joined: Thu Sep 03, 2015 9:48 am

Re: RB2011 switch port groups

Thu Sep 03, 2015 12:35 pm

Hi sir,


I have a problem with my network and I can see you have many experiences with mikrotik router. Here is my problem that I want to consult to you sir.

ISP 35Mbps
Main Router- Mikrotik RB951G-2hnd (4 companies connected)
HotSpot Wifi Router - Mikrotik RB1100Ah with 35 units Dlink access points connected.

Company 1,3 & 4 are connected directly to RB951G
Port 2 - Company 1 has 5mb allocated
Port 3 - Mikrotik RB1100Ah (HotSpot and Company 2 shares the 10mb)
Port 4 - Company 3 has 10mb allocated
Port 5 - Company 4 has 10mb allocated

My problem is that I'm experiencing slow connection. Could it be possibly because the Mikrotik RB951G-2hnd is not that capable of handling roughly 230 users actively at the same time.

Right now I bought the 10 ports mikrotik RB2011UiAS and planning to use this to replace my RB951G.
Can you give me advise me sir how should I configure this Mikrotik RB2011UiAs for better performance. What I want to do is directly connect all 4 companies to this router and also my HotSpot router. Kindly advise sir how should I configure this.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: RB2011 switch port groups

Sat Sep 05, 2015 7:32 pm

Bridging the 2 switches severely affects routing performance.

It does not matter if your WAN is only up to about 200/20.
 
Quindor
Member
Member
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: RB2011 switch port groups

Sun Sep 06, 2015 3:22 am

@vortex your reply is quite confusing. He is not talking about bridging and in his setup he wouldn't need to bridge either? I do agree that with a bridge or without the RB2011 shouldn't be too bothered by it since the bridge will max out because of the 100Mbps internal switch uplink.

@toshes22 Euhm, I'm not sure how you picked the RB2011 but it has exactly the same CPU as the RB951G you are using right now? There will be virtually no difference between them CPU or throughput wise...

So if you are only using some queues on the ports to distribute the bandwith on the RB951G/RB2011 there is no reason why you would not get full speed. It should be able to handle it easily even with some queues set for bandwith restrictions per port. Have you checked if the router is indeed hitting 100% CPU usage during usage?

Where are you doing the queues for the wireless clients? Looking at your design these should be running on the RB1100Ah which has your wireless clients connected. The RB1100Ah is a much faster device and much better suited for that role and it would offload the RB951G/RB2011!

Please provide us with a bit more details, since your setup should be having no problems at all.

p.s. It would have been better to open a new topic for this, since your question has nothing to do with the actual topic you posted in?
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
toshes22
just joined
Posts: 2
Joined: Thu Sep 03, 2015 9:48 am

RB2011UiAS-RM in Switch Mode

Mon Sep 07, 2015 11:06 am

@vortex your reply is quite confusing. He is not talking about bridging and in his setup he wouldn't need to bridge either? I do agree that with a bridge or without the RB2011 shouldn't be too bothered by it since the bridge will max out because of the 100Mbps internal switch uplink.

@toshes22 Euhm, I'm not sure how you picked the RB2011 but it has exactly the same CPU as the RB951G you are using right now? There will be virtually no difference between them CPU or throughput wise...

So if you are only using some queues on the ports to distribute the bandwith on the RB951G/RB2011 there is no reason why you would not get full speed. It should be able to handle it easily even with some queues set for bandwith restrictions per port. Have you checked if the router is indeed hitting 100% CPU usage during usage?

Where are you doing the queues for the wireless clients? Looking at your design these should be running on the RB1100Ah which has your wireless clients connected. The RB1100Ah is a much faster device and much better suited for that role and it would offload the RB951G/RB2011!

Please provide us with a bit more details, since your setup should be having no problems at all.

p.s. It would have been better to open a new topic for this, since your question has nothing to do with the actual topic you posted in?


Yes sir I just need to use more ports since the rb951g only has 5 ports. They bought this rb1100ah to serve mainly for wifi hotspot users only. We upgraded our bandwidth and distribute it centrally because before each of these companies have their own ISP. Right now we only have one ISP and the distribution of bandwidths are done using the rb951g. What I want to do now is to use this RB2011UiAS as the main switch to allocate bandwidths per ports in each company. How should I do it? I created bridge1 and joined port1 (wan), but when trying to join the port6 it does not allow (port6 is already added to Bridge Local) then I can't access to the interface and have to reset it to factory default.

Thank you for the replies guys.
 
thenoob
just joined
Posts: 22
Joined: Wed Mar 27, 2013 2:23 am

Re: RB2011UiAS-RM in Switch Mode

Mon Feb 29, 2016 10:30 pm

@vortex your reply is quite confusing. He is not talking about bridging and in his setup he wouldn't need to bridge either? I do agree that with a bridge or without the RB2011 shouldn't be too bothered by it since the bridge will max out because of the 100Mbps internal switch uplink.

@toshes22 Euhm, I'm not sure how you picked the RB2011 but it has exactly the same CPU as the RB951G you are using right now? There will be virtually no difference between them CPU or throughput wise...

So if you are only using some queues on the ports to distribute the bandwith on the RB951G/RB2011 there is no reason why you would not get full speed. It should be able to handle it easily even with some queues set for bandwith restrictions per port. Have you checked if the router is indeed hitting 100% CPU usage during usage?

Where are you doing the queues for the wireless clients? Looking at your design these should be running on the RB1100Ah which has your wireless clients connected. The RB1100Ah is a much faster device and much better suited for that role and it would offload the RB951G/RB2011!

Please provide us with a bit more details, since your setup should be having no problems at all.

p.s. It would have been better to open a new topic for this, since your question has nothing to do with the actual topic you posted in?


Yes sir I just need to use more ports since the rb951g only has 5 ports. They bought this rb1100ah to serve mainly for wifi hotspot users only. We upgraded our bandwidth and distribute it centrally because before each of these companies have their own ISP. Right now we only have one ISP and the distribution of bandwidths are done using the rb951g. What I want to do now is to use this RB2011UiAS as the main switch to allocate bandwidths per ports in each company. How should I do it? I created bridge1 and joined port1 (wan), but when trying to join the port6 it does not allow (port6 is already added to Bridge Local) then I can't access to the interface and have to reset it to factory default.

Thank you for the replies guys.
not sure i understand you correctly each link is for each company or all the wan side of the links are independent but all the lan part are mixed to be redistributed to all companies??

RB2011 only has 200Mbps max of internal bandwidth ( on switch chip + gig ports) otherwise the max is only about 80Mbps on bridged interfaces and anything routed aswell (going tru cpu)

if bandwidth its not mixed then i would just use a switch and put each companies in their own vlan with their providers.
 
Fraction
Frequent Visitor
Frequent Visitor
Posts: 82
Joined: Wed Jan 16, 2013 9:42 pm
Location: Helsinki, Finland

Re: RB2011 switch port groups

Wed Oct 19, 2016 4:32 pm

Hi,

Is it possible to use switch based vlan's between switch groups?
If I understand the theory right, it should work if I add "switch-cpu" in both groups as port to every vlan but I had no luck with that (sorry, can't give real config exports because I already went back to software-vlans and bridges). Did I understand that right?

What I basically did:
-set one port of both switch to master port for every other ports in same switch
-add ports to vlan [switch1: ether1(trunk) & cpu to every vlan + necessary access ports, switch2: cpu to every vlan + necessary access ports]
-set vlan-mode to secure in every port in both groups
-set vlan-header to "add-if-missing" in ether1 and "always-strip" in every other ports (hmm.. I should actually use add-if-missing with both cpu-ports?)
-set default-vlan-id for access ports

Did I just typo somewhere, or did I understand the whole idea somehow incorrectly?
I will try later again, but if someone can give some guidance/hints it would be greatly appreciated, thank you!

Who is online

Users browsing this forum: No registered users and 8 guests