Community discussions

 
sylaan
just joined
Topic Author
Posts: 13
Joined: Fri Jun 15, 2012 10:17 pm

411U-3G - SIM card PIN is not used

Mon Aug 27, 2012 9:18 am

Hi All,

I am evaluating a RB411U-3G and I have some problems with the PIN on the SIM card. If I disable the PIN everything works fine, the PPP Client connects, gets an IP, I have internet access.

The problem appears when I try to enable the PIN on the card. If I do that and I enter the correct PIN in the PPP Client config, then the PPP connection does not come up anymore. Under "PPP Info" I see "Waiting for PIN" or some such and that's that, there is no connection to the 3G Network. The devices will be in the future preconfigured with everything and then will be sent to remote locations, where someone must only plug in the SIM (which comes with the PIN active from the 3G provider, which we know beforehand) and the connection has to work.

Why is the PIN not used ? The entered PIN is definitely correct, I checked that several times. Do I need to type it in a certain way or what could be the problem ?

Thanks,
Sylaan
 
vk7zms
Member Candidate
Member Candidate
Posts: 227
Joined: Thu Jun 29, 2006 3:01 am
Location: Hobart, Tasmania
Contact:

411U-3G - SIM card PIN is not used

Mon Aug 27, 2012 10:11 am

PIN function normally works well, we use it often. Have had problem setting it on occasion and have had to do it manually from the modem serial console
 
sylaan
just joined
Topic Author
Posts: 13
Joined: Fri Jun 15, 2012 10:17 pm

Re: 411U-3G - SIM card PIN is not used

Mon Aug 27, 2012 10:25 am

Well, setting it up from the console is obviously not an option in my case, since the device will be in some remote location. But setting it is not the problem, I can set it up fine over Winbox when I pre-configure the router. The problem in my case seems to be that the Mikrotik is simply not using it and the 3G connection does not come up.
 
vk7zms
Member Candidate
Member Candidate
Posts: 227
Joined: Thu Jun 29, 2006 3:01 am
Location: Hobart, Tasmania
Contact:

411U-3G - SIM card PIN is not used

Mon Aug 27, 2012 12:14 pm

I don't know why it happens, but sometimes the PIN doesn't get sent to the modem from ROS correctly.

ROS appears to store it correctly, just doesn't always send it through to the modem.

If you are going to configure prior to dispatch via winbox, could you not do it manually prior to dispatch?

I will look up the exact syntax I use to set it on Sierra cards and post shortly
 
vk7zms
Member Candidate
Member Candidate
Posts: 227
Joined: Thu Jun 29, 2006 3:01 am
Location: Hobart, Tasmania
Contact:

411U-3G - SIM card PIN is not used

Mon Aug 27, 2012 12:23 pm

From the MT command line (select "new terminal" from winbox) you access the modem serial console

/system serial-terminal usb2 channel=3

You should now be able to issue modem commands

Type at, and you should get "OK" as the response.

Now set the pin by entering modem command

at+cpin=xxxx
 
sylaan
just joined
Topic Author
Posts: 13
Joined: Fri Jun 15, 2012 10:17 pm

Re: 411U-3G - SIM card PIN is not used

Mon Aug 27, 2012 2:34 pm

Hey there,

Thanks for the answer, I will give that a try today or tomorrow morning and let you know.

But this seems to be an obvious bug, is this not known ?
 
vk7zms
Member Candidate
Member Candidate
Posts: 227
Joined: Thu Jun 29, 2006 3:01 am
Location: Hobart, Tasmania
Contact:

411U-3G - SIM card PIN is not used

Mon Aug 27, 2012 5:00 pm

The guy from my local Sierra supplier was aware of it, so I guess so
 
sylaan
just joined
Topic Author
Posts: 13
Joined: Fri Jun 15, 2012 10:17 pm

Re: 411U-3G - SIM card PIN is not used

Thu Aug 30, 2012 4:24 pm

I tested this today and the command works, as soon as I manually enter it the SIM gets unlocked and I can dial out.

Unfortunately it does not survive a hard reboot. I tried to put AT+CPIN="1234" in the modem init string but all I get in the logs is an error to initialize the modem. Any idea how I can issue this after boot ? Do I really need to write a script , assuming it's possible to do this via a script, just for a simple thing like entering the SIM card PIN ?
 
vk7zms
Member Candidate
Member Candidate
Posts: 227
Joined: Thu Jun 29, 2006 3:01 am
Location: Hobart, Tasmania
Contact:

411U-3G - SIM card PIN is not used

Fri Aug 31, 2012 2:08 pm

That is odd - did you leave the pin set at the mikrotik OS level as well?
 
sylaan
just joined
Topic Author
Posts: 13
Joined: Fri Jun 15, 2012 10:17 pm

Re: 411U-3G - SIM card PIN is not used

Fri Aug 31, 2012 2:27 pm

Yes, I did, but as I mentioned before that PIN seems to be completely ignored by the router. I sent a message about this to support@mikrotik.com but so far no reply.
 
januszzz
Member Candidate
Member Candidate
Posts: 102
Joined: Wed Oct 07, 2009 9:17 pm

Re: 411U-3G - SIM card PIN is not used

Wed Sep 19, 2012 10:26 am

Hello,

blind shot - once upon a time I've somehow discovered that PIN is incorrectly delivered to OS. Solution was to put in double double quotes :-) , i.e.: ""1234"". For me it helped with Dell 5530 and some early 5.x version.

http://forum.mikrotik.com/viewtopic.php?f=2&t=49009

Good luck!
 
jeremyh
Frequent Visitor
Frequent Visitor
Posts: 66
Joined: Tue Jul 10, 2012 1:21 pm

Re: 411U-3G - SIM card PIN is not used

Wed Sep 19, 2012 2:05 pm

Hello,

blind shot - once upon a time I've somehow discovered that PIN is incorrectly delivered to OS. Solution was to put in double double quotes :-) , i.e.: ""1234"". For me it helped with Dell 5530 and some early 5.x version.

http://forum.mikrotik.com/viewtopic.php?f=2&t=49009

Good luck!
That's interesting.

I am experiencing exactly this issue, though only on RoS 5.20. If I configure a PIN in the PPP interface it doesn't work, and I have to manually set it via the serial-terminal of the modem.

However, I do not have this issue on 5.18. I saw this on 5.20 and then downgraded to 5.18 and confirmed that the problem doesn't occur. I upgraded to 5.20 again and was able to reproduce the issue. Mikrotik support have asked for a supout file which I have provided.
 
el berto
Member Candidate
Member Candidate
Posts: 197
Joined: Wed Sep 26, 2007 10:53 am

Re: 411U-3G - SIM card PIN is not used

Mon Sep 08, 2014 11:15 am

RB411U, 3G card SIERRA WIRELESS MC8775
Ros 6.19, firmware 3.18

I set sim card pin field to "1234" and also to ""1234""
04:02:20 async,ppp,info 3G: initializing... 
04:02:20 async,ppp,info 3G: reseting link... 
04:02:20 system,info device changed by admin 
04:02:21 async,debug usb2:0: sent ATH 
04:02:21 async,debug usb2:0: rcvd OK 
04:02:21 async,ppp,info 3G: initializing modem... 
04:02:22 async,ppp,info 3G: dialing out... 
04:02:22 async,debug usb2:0: sent AT+CPIN? 
04:02:22 async,debug usb2:0: rcvd OK 
04:02:22 async,debug usb2:0: sent AT+CGDCONT=1,"IP","ibox.tim.it" 
04:02:22 async,debug usb2:0: rcvd OK 
04:02:22 async,debug usb2:0: sent ATDT*99***1# 
04:02:22 async,debug usb2:0: rcvd ERROR 
04:02:22 async,debug usb2:0: resetting modem 
04:02:23 async,debug usb2:0: sent ATH 
04:02:23 async,debug usb2:0: rcvd OK 
But ppp info still showing:
PIN Status: waiting for primary PIN

Also tryed to set init AT command: at+cpin="1234"
04:13:46 async,debug usb2:0: resetting modem
04:13:47 async,debug usb2:0: sent ATH
04:13:47 async,debug usb2:0: rcvd OK
04:13:47 async,debug usb2:0: sent at+cpin="1234"
04:13:47 async,debug usb2:0: rcvd ERROR
04:13:47 async,info init string failed: at+cpin="1234"

So I must enter pin manually.
What's wrong?

Who is online

Users browsing this forum: No registered users and 13 guests