Community discussions

MUM Europe 2020
 
jonimant
just joined
Topic Author
Posts: 3
Joined: Thu Nov 21, 2013 10:29 am

failover with 3 WAN without balancing

Thu Nov 21, 2013 10:55 am

Mikrotik RB2011UiAS-RM

RouterOS ver. 6.6

We have 3 different internet connections, the port configuration looks like this:

ethernet1 WAN1 – PPPOE connection, static IP
ethernet2 WAN2 – static IP
ethernet3 WAN3 – 3g internet connection switched to 3G router, IP: 192.168.4.4

ethernet4 – not in use
ethernet5 – not in use

ethernet6 – 192.168.1.0 subnet
ethernet7 – 192.168.2.0 subnet
ethernet8 – 192.168.3.0 subnet
ethernet9 – ethernet6
ethernet10 – ethernet6

bridge-local 192.168.88.1

My question is, can we do failover with this 3 WAN connections, without using balancing? If WAN1 is unaccessable, it should switch to WAN2, and if both WAN1 and WAN2 are down, it should switch to WAN3 3g. When Wan1 or Wan2 is up, it should switch back from 3g.

Is it possible to do this without writing a script, or somebody already did some configuration similar like this? Can somebody send me a link with a similar configuration?
 
User avatar
nick3dos
Member Candidate
Member Candidate
Posts: 189
Joined: Fri Apr 29, 2011 11:03 pm
Location: Greece

Re: failover with 3 WAN without balancing

Thu Nov 21, 2013 3:51 pm

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=WAN1 – PPPOE connection, static IP
add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=WAN2 – static IP
add disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.4.4
Change WAN1 and WAN2 to your static ips...
 
ronniee
Member Candidate
Member Candidate
Posts: 124
Joined: Sun Jan 15, 2006 9:32 pm

Re: failover with 3 WAN without balancing

Thu Nov 21, 2013 8:30 pm

hi,
here you need to enable "check gateway=ping" option?
And in this case, how are the NAT routes made?
3 rules to every out-interface? ether1-wan1, ether2-wan2, ether3-wan3?

thanks

Who is online

Users browsing this forum: No registered users and 23 guests