Community discussions

MUM Europe 2020
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

CCR1009-8G-1S-1S+ General info & Questions

Mon Apr 28, 2014 7:18 pm

So, as FedEX and Interprojekt promised I received my CCR1009-8G-1S-1S+ today. I unpacked it and took a bunch of pictures of the outside and inside.

I was able to find it using the "MAC method" just fine and it was running RouterOS 6.10 out of the box. It updated to 6.12 just fine too. I have not run any tests on it yet but I have made several screenshots.

There is a complete album with lots of pictures here, but I will take some highlights and post them below!

As with the RB2011 before, any questions regarding the CCR1009 or things you would like tested with it (possible within a home environment). I will not be putting this CCR1009 into (home) production use for at least a month I think, so let me know what you would like to see!

Image
Included accessories, no free copper SFP as with some other CCR's

Image
A shallow depth white box

Image
I bought the 1S+ version mainly because of the LCD screen and 10G abilities

Image
Future expand-ability should be no problem! I'm betting on have FTTH within the next 2 or 3 years

Image
Back side, showing the dual-PSU and MicroSD card slot

Image
Dual-PSU rated for use all around the world using standard power plug connectors

Image
Two fans which can be seperatly controlled it seems. Also the MicroSD slot

Image
When this thing is built into a rack it will be nearly impossible to reach the MicroSD slot

Image
Opening up the box!

Image
The Dual-PSU supplies 24v. From what I have read you can actually apply a third power source using POE. Highest voltage will be used first. I did not dare open the PSU box any further. :shock:

Image
Hooked up and running. The LED's seem to be good LED's with fairly quick blinking, unlike the RB2011 for instance

Image
Selecting the "Informative SlideShow" it shows current throughput and system health. Idle usage seems to be around ~15watt according to the software. I will take a separate measurement myself later

Image
~100MB of storage and 2GB of memory
Last edited by Quindor on Tue Apr 29, 2014 12:55 am, edited 2 times in total.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Apr 28, 2014 7:19 pm

I took some interfaces screenshots with general information and of some differences I noticed versus the RB2011 for instance.

Image
I am able to find and connect to the CCR1009 just fine using the "MAC" option

Image
Voltage, Temperature and power metering, 128MB of storage (on mine), 9 cores Tile CPU

Image
100MB of actual storage, 85MB usable. Not very much now a days, but you can use the MicroSD slot to expand it if needed.

Image
Select-able CPU speeds to make it use less power or produce less heat (allows the CCR to be used in more extreme situations)

Image
Included license

Image
Interface shot, notice no "switch" selection in the menu bar

Image
These selections differ from my RB2011, more options are possible and more information is given. Also the "cable test" option is new for me. The option to include a port in a switch is missing though. It will probably be added in a future firmware!
Last edited by Quindor on Mon Apr 28, 2014 7:32 pm, edited 2 times in total.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Apr 28, 2014 7:21 pm

- Do the ports connected to the switch chip behave differently then the native CPU ports?
My personal initial testing seems to indicate that they cause more CPU usage during bridging or routing then the NON-switch ports do. Also it seems that the ports condense some traffic streams (such as NAT) to a single thread. This could potentially limit certain usage scenario's. During my tests it never limited traffic below 1Gbit/sec though, it just caused (a lot) more CPU.

You can find all the screenshots over here.

Iperf was used using: "iperf -c xxx.xxx.xxx.xxx -w 128KB -t 30 -P 60" so only upload was tested.

NAT - Routing
Image
1Gbit/s NAT using all CPU ports

Image
1Gbit/sec NAT using 1 Switch and 1 CPU port

Image
1Gbit/sec NAT using all Switch ports

Bridging
Image
Bridging all CPU ports

Image
Bridging all Switch ports

Image
Bridging between 1 Switch and 1 CPU port

As you can see, it behaves quite differently depending on which combination you use. This was all tested using 6.12 with routerboard firmware 3.13. If this is the final behavior of the product, careful port planning is needed. But I have a feeling they might not yet be done integrating the switch into the "tile" platform as we have seen with the CRS, etc.

- How powerful is the CPU?
That's a hard question to answer. In testing bridging or even using NAT over 1 core gave me at least 1Gbit of throughput without problem. The core did reach 100% though with NAT. So assume I think it's safe to assume that 1 core can do about 1Gbit/sec.
note: There seems to be a difference between using direct CPU ports or Switch ports, please see above

- How much noise does it make?
When first turning it on it's completely silent. After a little while you some whining noise to start which keeps stepping up in frequency. I believe this to be the voltage to the fans that is being raised digitally. After a little bit you can hear a fan starting but it spins at quite a low RPM.

- Can the fans be controlled?
No, (presently) there is no way of controlling the fans.

Because it's voltage regulated there is "a lot" of mechanical buzzing noise combined with very faint wind/fan noise. During tests and generating load I can hear a (second?) fan spin up quickly but also spin-down quickly again. I believe the mechanical whirring/rattling noise is a by product of on the one side the fans themselves but on the other side of the voltage regulation method. The whirring/rattling noise does become less loud after having the unit on for a while. Sadly Mikrotik does not use PWM fans yet which have caused less noise, then again, this is a datacenter product and for in a datacenter the CCR is in no way loud or obtrusive.

I would not advise you putting it in your living room or something, but a few meters away or inside of a closet (provide ventilation) it should not be intrusive during normal usage. An option might be to replace the fans with models from Noctua (which will almost certainly be more quiet) but this will void warranty. (This has NOT been verified)

- Can the dual PSU be monitored?
No, the PSU module is only connected using power connectors to the mainboard. The routerboard monitors the voltage that it is receiving, but it cannot determine or monitor if 1, 2 or 3 power sources are connected. In theory the power source with the highest voltage will be used first and fail-over will happen automatically if that source fails.

- How fast are the LED's?
They are of the normal variety. Not the newer super fast blinking one's, neither the very slow uninformative RB2011 kind. I have no other way to describe them then normal, as you see on many types of network equipment.

- How much power does it use?
I have measured power using the internal wattage display and with an external wall plug meter.

Idle the internal meter shows 16w, the external meter shows around 17.1w. I believe this to be because of the conversion efficiency in the PSU which is pretty good. During my tests I have seen a maximum of 17.3w of internal usage which would round up to about 18.5w of external usage. Quite power efficient for the amount of routing power it holds, an equivalent performing x86 platform would use a lot more I believe.
Last edited by Quindor on Wed Apr 30, 2014 1:59 am, edited 4 times in total.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
Shiro
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Sep 25, 2013 6:44 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Apr 28, 2014 9:37 pm

Thanks for the review and pictures, still waiting for my ccr1009 to arrive :]
 
meetriks
just joined
Posts: 18
Joined: Sun Apr 27, 2014 9:41 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 12:39 am

Deleted
Last edited by meetriks on Tue Apr 29, 2014 10:25 pm, edited 1 time in total.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1825
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 12:41 am

Wow, Mikrotik actually listened to my feature suggestion for the IEC power cord clamps!

Hopefully this and the dual PSU feature finds its way on to the 1036 models too :)
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24334
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 8:09 am

Quick note to Quindor, you are connecting to Ether8, but the IP address is on Ether1. Unlike the RB2011, the CCR series doesn't have all ports switched, so you need to connect to Eth1 and configure the device according to your needs.
No answer to your question? How to write posts
 
User avatar
Belgarion186
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Thu Jan 23, 2014 3:33 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 8:20 am

@Quindor, thank you for the very informative review and pictures.

A question regarding the fans as I'm kind of concerned by the noise from them especially the 'buzzing noise' since I plan to place it in my very silent home computer room.

Is it possible to set the fans so that they spin at a constant rate (eg. 30% or 50%) regardless of CPU load ?
 
coylh
Member Candidate
Member Candidate
Posts: 160
Joined: Tue Jul 12, 2011 12:11 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 8:30 am

How is the switch chip configured without a switch menu option?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24334
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 8:42 am

How is the switch chip configured without a switch menu option?
Feature missing from Winbox in v6.12, you can use console for now, Switch menu will be in Winbox from v6.13
No answer to your question? How to write posts
 
joegoldman
Long time Member
Long time Member
Posts: 509
Joined: Mon May 27, 2013 2:05 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 9:01 am

Hijacking a little - normis can you confirm/deny if dual PSU will make its way to 1036 models?
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 12:57 pm

Quick note to Quindor, you are connecting to Ether8, but the IP address is on Ether1. Unlike the RB2011, the CCR series doesn't have all ports switched, so you need to connect to Eth1 and configure the device according to your needs.
Hi Normis, thank you for your comment! I understand this of course and it was only connected to Ether8 for the photo. After that I made lots of different combinations (routed, NAT, bridged, etc.) as you can see in my screenshots and test results.

I'm much more interested in the reason why the ports on the switch chip behave so much differently then the direct connected CPU ports. They seem to generate a LOT more CPU load, and are less multithreaded with NAT. I don't understand the technical reason behind this, but maybe you can clarify this? It would make a lot of difference in how and where the CCR1009 is usable.
Last edited by Quindor on Tue Apr 29, 2014 2:19 pm, edited 1 time in total.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24334
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 1:08 pm

All switched ports share 1gbps full duplex link to CPU, other than that there should be no difference
No answer to your question? How to write posts
 
SwissWISP
Member Candidate
Member Candidate
Posts: 181
Joined: Fri Sep 23, 2011 12:16 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 2:11 pm

Hijacking a little - normis can you confirm/deny if dual PSU will make its way to 1036 models?
I would like to know this too. :D
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24334
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 2:13 pm

Hijacking a little - normis can you confirm/deny if dual PSU will make its way to 1036 models?
I would like to know this too. :D
It would be a different device then. As you can see, all new CCR units have dual PSU, so if we release a new 36 core model, it will have them. We are working on it.
No answer to your question? How to write posts
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 3:26 pm

All switched ports share 1gbps full duplex link to CPU, other than that there should be no difference
Ok, cool. I hoped a bigger interconnect then 1Gbps would have been used, but I can understand that restraint from a cost perspective.

About the performance difference, in the current version of RouterOS it does seem to generate a LOT (5x to 8x) more load then the CPU ports. Could you check my tests? Please let me know if you need more information! Especially NAT on the switch ports consolidates all the load to one core it would seem, while CPU ports do not show the save behavior.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
KoDAk
newbie
Posts: 32
Joined: Mon May 27, 2013 11:34 pm
Location: Ukraine, Kharkov

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Apr 29, 2014 6:56 pm

- How much noise does it make?
Sadly Mikrotik does not use PWM fans yet which have caused less noise, then again, this is a datacenter product and for in a datacenter the CCR is in no way loud or obtrusive.

I would not advise you putting it in your living room or something, but a few meters away or inside of a closet (provide ventilation) it should not be intrusive during normal usage.
wery sad
it is not datacenter product ( at max it is small office and Home-office (where noise is big problem...)

can you do some advice
how minimize noise & and what cooler can make 1009 silent ?
Certified MTCNA
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Wed Apr 30, 2014 1:47 am

@Quindor Is it possible to set the fans so that they spin at a constant rate (eg. 30% or 50%) regardless of CPU load ?
I have checked and while I am able to set the fan to manual mode or auto mode, it seems to only specify which kind of fan is connected (2 wire or 3 wire) and not give me any control over it.

Also, the read-out of the fans does circulate during the "informative slideshow" and I am able to find it using the CLI. No WinBox options yet though. And even the CLI only reports on 1 of the fans, not both as the slideshow does.
[admin@MikroTik] /system health> print
fan-mode: auto
use-fan: main
active-fan: none
cpu-overtemp-check: yes
cpu-overtemp-threshold: 100C
cpu-overtemp-startup-delay: 1m
voltage: 23.8V
current: 627mA
fan-speed: 0RPM
temperature: 23C
cpu-temperature: 45C
power-consumption: 14.9W
To answer another question from @KoDAk there does not seem to be a manual speed control option and replacing the cooling will be quite hard since the case is 1U so any kind of cooling will be a heatsink with forced airflow which results in 40mm fans.

I think your best bet would be replacing both fans with Noctua's. I use Noctua in all my equipment that needs to be (virtually) silent. Not cheap, but the best fans on the market. The Noctua NF-A4x10 FLX seems to have the right dimensions and uses the same 3pin connector. I have no idea about air rate and flow though and if they will actually keep the CCR cool enough, etc. And while I think these are your best bet in silencing your CCR, your warranty will absolutely be voided. ;)

Another thing I just realized. There is no active monitoring on the PSU's. The routerboard does not know how many PSU's are actually connected (photo's only show power cables going from the PSU module to the mainboard) so there is no way to check if 1 or 2 power cables are connected and/or working.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
User avatar
Vanta
just joined
Posts: 7
Joined: Mon Nov 29, 2010 5:24 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Wed Apr 30, 2014 8:14 am

Another thing I just realized. There is no active monitoring on the PSU's. The routerboard does not know how many PSU's are actually connected (photo's only show power cables going from the PSU module to the mainboard) so there is no way to check if 1 or 2 power cables are connected and/or working.
What a shame...
There is a LED indication of PSU status?
How do I know if one of the PSUs broken?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24334
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CCR1009-8G-1S-1S+ General info & Questions

Wed Apr 30, 2014 8:18 am

at max it is small office and Home-office (where noise is big problem
the CCR1009 has the power to run a medium sized ISP, so, I don't agree to the above.
No answer to your question? How to write posts
 
SwissWISP
Member Candidate
Member Candidate
Posts: 181
Joined: Fri Sep 23, 2011 12:16 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Wed Apr 30, 2014 9:26 am

Another thing I just realized. There is no active monitoring on the PSU's. The routerboard does not know how many PSU's are actually connected (photo's only show power cables going from the PSU module to the mainboard) so there is no way to check if 1 or 2 power cables are connected and/or working.
What a shame...
There is a LED indication of PSU status?
How do I know if one of the PSUs broken?
Good question.
In my opinion such a device should have LEDs which are indicating the status of each PSU. Additionally this information should also be available via SNMP. The latter is especially important for ISPs. I don't visit all of our sites on a daily basis to check LEDs. :D
Last edited by SwissWISP on Wed Apr 30, 2014 9:41 am, edited 1 time in total.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: CCR1009-8G-1S-1S+ General info & Questions

Wed Apr 30, 2014 9:34 am

I think your best bet would be replacing both fans with Noctua's. I use Noctua in all my equipment that needs to be (virtually) silent. Not cheap, but the best fans on the market. The Noctua NF-A4x10 FLX seems to have the right dimensions and uses the same 3pin connector. I have no idea about air rate and flow though and if they will actually keep the CCR cool enough, etc. And while I think these are your best bet in silencing your CCR, your warranty will absolutely be voided. ;)
if swapped FANs are of good quality and does not damage fan controller you are fine. So, when choosing FANs check if power usage of new ones is in the same ballpark as ones supplied from us. Also note that different fans can report RPM and starting voltage can be different so reading in RouterOS can be different from reality after the swap.
 
KoDAk
newbie
Posts: 32
Joined: Mon May 27, 2013 11:34 pm
Location: Ukraine, Kharkov

Re: CCR1009-8G-1S-1S+ General info & Questions

Wed Apr 30, 2014 8:57 pm

at max it is small office and Home-office (where noise is big problem
the CCR1009 has the power to run a medium sized ISP, so, I don't agree to the above.
OK i mean:
I dream to see model like:
*RB2011UiAS-2HnD-IN* but on CPU: TLR4-00980CG-10CE
(sfp \ 1g Ethernet ports 10-12 (PoE on 2 ports of them) \ usb \802.11b/g/n \ LCD )
and price 250-350$

and CRS mast have only CPU: TLR4-00980CG-10CE and more
Certified MTCNA
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Wed Apr 30, 2014 11:13 pm

at max it is small office and Home-office (where noise is big problem
the CCR1009 has the power to run a medium sized ISP, so, I don't agree to the above.
OK i mean:
I dream to see model like:
*RB2011UiAS-2HnD-IN* but on CPU: TLR4-00980CG-10CE
(sfp \ 1g Ethernet ports 10-12 (PoE on 2 ports of them) \ usb \802.11b/g/n \ LCD )
and price 250-350$

and CRS mast have only CPU: TLR4-00980CG-10CE and more
Ok, I understand, but I don't think this is the right topic to discuss such a thing. The CCR1009 is a perfect device suited for a lot of tasks as it is right now. But it certainly isn't a "one size fits all" device, which is impossible anyway in my opinion.

The nice thing about routerboard's is that you can either go the x86 route and build it yourself, or, what I would advise, buy several routerboards which each excels in their specific task (routing, VPN, switching, wireless, etc.) and use a combination of boards of which often one can be used for multiple roles!

The CCR1009 cannot do wireless for instance, but it does make an excellent firewall, router and switch! Please state your desired device and it's features in a "desired hardware" topic or something like that. I'm willing to bet that if you can make a compelling business case, mikrotik/routerboard will listen and produce the device.

So now back to the (so far) excellent CCR1009! Any questions regarding it or things you might want to see or have me test?
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
User avatar
Belgarion186
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Thu Jan 23, 2014 3:33 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu May 01, 2014 3:56 am

@Quindor, thank you again for the detailed reply regarding the fan settings.

Any chance you have the specs of the fans ? Mainly Voltage and Amp (eg. 12VDC, 0.11A). I'm thinking of replacing them with quality fans either from Delta, Sanyo-Denki or NMB.

Also, from the pictures, the fans look like they are 40x40x20mm. I believe Noctua only has 40x40x10mm so the 10mm gap could be an issue.

Best regards.
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu May 01, 2014 4:14 am

@Quindor, thank you again for the detailed reply regarding the fan settings.

Any chance you have the specs of the fans ? Mainly Voltage and Amp (eg. 12VDC, 0.11A). I'm thinking of replacing them with quality fans either from Delta, Sanyo-Denki or NMB.

Also, from the pictures, the fans look like they are 40x40x20mm. I believe Noctua only has 40x40x10mm so the 10mm gap could be an issue.

Best regards.
Thnx's! I always value other people sharing information about new products so when I get a first, I'm happy to oblige! Karma is always appreciated. ;)

If I can find the time tommorow I will give removing the fan shroud a go. If it's indeed just a plastic shroud with the heatsink underneath it, there should be no harm in removing it and looking around. I would rather not remove it if the heatsink is attached because of thermal paste and such.

I actually should have the Noctua fan model lying around here somewhere so I can compare the size and see if they are 10mm or 20mm thick. I actually don't know and it's a good point! I will also see if there is a sticker on the fans listing their specs.

Funny you mention Detra, although they make great datacenter server fans, they are insanely loud, or at least that is how I know them. I go with Noctua when I can, otherwise papst for specialist applications. Sanyo-Denki is used by some PSU manufactorers (seasonic for instance I believe) and they also make great smooth fans!
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu May 01, 2014 9:09 pm

Ok, I've taken the beast apart and made lots of photo's again. I have added them to the existing album so you should be able to find them.

Image
Shroud and fans removed

You where correct that the Noctua fans where 10mm versions and you need a 20mm version! For that reason I have included photo's of the measurements of the fans using a caliper so that it can hopefully help in selecting new ones.

Image
The fans upclose

Image
Difference in height of the fans

Image
Fans and shrouds removed

Image
Thickness of the fans used. Because of the forced airflow shroud system a tight fit will be required!

I have also made a video (And audio) recording to try and capture what kind of noise the fans actually make. I think it succeeded pretty well actually. Mind you, this video will feature the sounds exaggerated because the camera was literally 10cm away of the exhaust. In reality you would not put your ear that close, but it did enable me to capture the sounds pretty well.
At first you hear me flicking the switch of the extension cord, then some faint beeping and a louder beep which is the routerboard booting. After that you hear a digital beep sound/coil whine of voltage being applied to the fan but it does not start up yet. At that point the routerboard is booted and I do a 1Gbit/sec NAT test using the switched ports to simulate CPU load and the fans spring to life, when the test is done the fans spindown and the 'idle' noise is clearly noticeable. I do another test so you can hear the fans spin up and after that the spindown again. Hopefully this illustrates the "noise" I tried to describe before.

I am also now convinced that this is in part because of the way the fans are regulated (voltage controller with no lower level for instance). But it's mostly the fans which just make this noise, even when spinning faster. So replacing them for a better/lower mechanical noise fan should certainly help.

Looking up the fans I have made a PDF which lists their specifications: http://www.chiefly-choice.com/fans/uplo ... lyg44f.pdf . If you wish to replace the fans they most important factors are airflow, static pressure and size of course.

12v (Voltage
8.60 CFM (Airflow)
Current 0.08A (Amps)
0.96 Watt
7000 RPM (max)
28.50dBa (noise)

The problem with these fans, although their dBa seems to be ok, the rattling noise makes for an irritating pattern. If you can find a fan with a smoother noise profile, I believe the CCR1009 can be placed in a fairly quiet environment.

ps. Maybe I should not have put the camera in front of the exhaust. There is a lot of wind noise. ;) The squealing and rattling is still audible though, so this should do. Remember, the microphone was very close to capture the noise so the recording is very much exaggerated.

Also, I would like to re-state that although these fans make more noise then they maybe need to, in a datacenter they are perfectly fine. People would also complain if they added $20 to the price to buy silent fans. And as stated before, people can do that themselves if they wish. Replacing them with a same-size model is trivial.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
User avatar
Belgarion186
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Thu Jan 23, 2014 3:33 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri May 02, 2014 4:08 am

Thank you very much.

The stock fan does sound really noisy (for a home environment at least).

I searched around on eBay and found this SanyoDenki 40x40x20mm :

Image

Link : http://www.ebay.com/itm/251084457182

I believe it should be a good replacement for the stock fans.
 
User avatar
omega-00
Forum Guru
Forum Guru
Posts: 1167
Joined: Sat Jun 06, 2009 4:54 am
Location: Australia
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri May 02, 2014 8:28 am

Another thing I just realized. There is no active monitoring on the PSU's. The routerboard does not know how many PSU's are actually connected (photo's only show power cables going from the PSU module to the mainboard) so there is no way to check if 1 or 2 power cables are connected and/or working.
What a shame...
There is a LED indication of PSU status?
How do I know if one of the PSUs broken?
Good question.
In my opinion such a device should have LEDs which are indicating the status of each PSU. Additionally this information should also be available via SNMP. The latter is especially important for ISPs. I don't visit all of our sites on a daily basis to check LEDs. :D
An LED indication at the very least would be useful. I mean you don't imagine you're going to have 2 PSU's fail straight away and it's useful to be able to connect the router up to independant power rails (and PoE which is cool), but some sort of monitoring integration would be excellent in any future revisions of the 1036 and 1072's *hint hint*

Thanks for the awesome post Qunidor!
brightwifi.com | mikrotik-routeros.com | MTCNA,MTCWE.MTCTCE | Give karma where due
 
Jeroen1000
Member Candidate
Member Candidate
Posts: 195
Joined: Fri Feb 18, 2011 2:05 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Wed May 07, 2014 10:42 pm

+1 thank you for this excellent overview. Much appreciated. So then, it does not route over 1 gigabit over a single upstream port? What is the 10 gigabit SFP+ port for then?

(sorry I have not updated myself since the Routerboard 450g series)
 
onnoossendrijver
Member
Member
Posts: 418
Joined: Mon Jul 14, 2008 11:10 am
Location: The Netherlands

Re: CCR1009-8G-1S-1S+ General info & Questions

Wed May 07, 2014 11:36 pm

+1 thank you for this excellent overview. Much appreciated. So then, it does not route over 1 gigabit over a single upstream port? What is the 10 gigabit SFP+ port for then?
What about inter-vlan routing on the 10g port? :)
Linux/network engineer: ITIL, LPI1, CCNA R+S, CCNP R+S, JNCIA, JNCIS-SEC
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu May 08, 2014 10:15 am

- Can the dual PSU be monitored?
No, the PSU module is only connected using power connectors to the mainboard. The routerboard monitors the voltage that it is receiving, but it cannot determine or monitor if 1, 2 or 3 power sources are connected. In theory the power source with the highest voltage will be used first and fail-over will happen automatically if that source fails.
starting from RouterOS 6.13 PSU monitoring will be possible. Due to some technical difficulties this feature was delayed. Same will be true for CCR1016-12S-1S+
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu May 08, 2014 9:34 pm

+1 thank you for this excellent overview. Much appreciated. So then, it does not route over 1 gigabit over a single upstream port? What is the 10 gigabit SFP+ port for then?

(sorry I have not updated myself since the Routerboard 450g series)
I think I might have explained it wrongly then. I believe it certainly can achieve much more speed then 1Gbit.

For a single SESSION it won't be able to achieve more then 1Gbps (with the current software) but if you are using multiple sessions they get neatly balanced over the available CPU's thus should deliver maximum performance all the cores are capable of, not just 1. I did notice some odd behavior using the switched ports instead of the CPU connected ports, but hopefully that will be fixed in the future. I don't have a block diagram to go on, but from what I understand from the TileGX CPU the 10Gbit port is directly CPU connected, not through the switch, so no problems there.

The CCR1009 is definitely able to transfer more then 1Gbps!
What about inter-vlan routing on the 10g port? :)
Sadly I have no 10Gbit equipment so I am unable to test that at this time. I do believe they have fixed some inter-vlan routing issues over a single port since one of the latest versions of RouterOS so it should be okay?
starting from RouterOS 6.13 PSU monitoring will be possible. Due to some technical difficulties this feature was delayed. Same will be true for CCR1016-12S-1S+
That would be awesome! I guess it's able to monitor all the voltages separately and thus determine how many PSU's are connected. Would be awesome! When the feature arrives I will test it and then change my information post!
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri May 09, 2014 1:32 pm

for these routers you will only be able to see that PSU is OK of FAILed.
 
KoDAk
newbie
Posts: 32
Joined: Mon May 27, 2013 11:34 pm
Location: Ukraine, Kharkov

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri May 09, 2014 11:10 pm

can come one post
architecture diagram of 1009?
Certified MTCNA
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon May 12, 2014 6:27 pm

can come one post
architecture diagram of 1009?
None is available yet but it isn't too hard to puzzle together.

SFP port : Direct CPU
SFP+ port : Direct CPU
Port 1-4: Switch with 1Gbps CPU uplink to CPU (Basically a 5 port switch chip with one port internally connected)
Port 5-8: Direct CPU

Did you need to know anything else? Looking at other CCR block diagram's and how the TileGX CPU is built and what kind of buses it has can also be helpful!
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
ptr727
newbie
Posts: 36
Joined: Wed May 09, 2012 8:35 am
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue May 13, 2014 2:07 am

What is the US availability date, I see it available for pre-order only?
 
User avatar
Belgarion186
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Thu Jan 23, 2014 3:33 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue May 13, 2014 3:10 am

can come one post
architecture diagram of 1009?
None is available yet but it isn't too hard to puzzle together.

SFP port : Direct CPU
SFP+ port : Direct CPU
Port 1-4: Switch with 1Gbps CPU uplink to CPU (Basically a 5 port switch chip with one port internally connected)
Port 5-8: Direct CPU

Did you need to know anything else? Looking at other CCR block diagram's and how the TileGX CPU is built and what kind of buses it has can also be helpful!
SFP port seems to be part of the switch group according to the wiki :

http://wiki.mikrotik.com/wiki/Switch_Chip_Features
 
User avatar
Belgarion186
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Thu Jan 23, 2014 3:33 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue May 13, 2014 3:10 am

What is the US availability date, I see it available for pre-order only?
According to Baltic Networks, shipment is expected to arrive within these couple of days.
 
drb
just joined
Posts: 9
Joined: Mon Jul 25, 2011 8:20 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue May 13, 2014 5:47 am

What is the US availability date, I see it available for pre-order only?
We already received our unit from one of the US resellers (roc-noc.com). They are now sold out of the CCR1009-8G-1S-1S+model, but do have some of the CCR1009-8G-1S-1S.
 
Shiro
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Sep 25, 2013 6:44 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue May 13, 2014 12:59 pm

can come one post
architecture diagram of 1009?
None is available yet but it isn't too hard to puzzle together.

SFP port : Direct CPU
SFP+ port : Direct CPU
Port 1-4: Switch with 1Gbps CPU uplink to CPU (Basically a 5 port switch chip with one port internally connected)
Port 5-8: Direct CPU

Did you need to know anything else? Looking at other CCR block diagram's and how the TileGX CPU is built and what kind of buses it has can also be helpful!
SFP port seems to be part of the switch group according to the wiki :

http://wiki.mikrotik.com/wiki/Switch_Chip_Features
I hoped both sfp ports are directly connected to the cpu. The Tile should support this.

From Tilera's site:
"Integrated I/O features include up to 12 ports of 1Gb Ethernet and 2 ports of 10Gb Ethernet, along with multiple PCI Express controllers that can be configured as either root complex or endpoints. An assortment of USB, RS-232, I2C and GPIO ports further consolidate the system peripherals into the TILE-Gx9 System-on-Chip (SoC)."

UPS is delivering my CCR1009-8G-1S-1S+ today (Germany), can't wait to put that thing under load testing :)
 
ATG
just joined
Posts: 22
Joined: Fri Feb 21, 2014 9:45 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue May 13, 2014 2:15 pm

I've had this CCR1009-8G-1S-1S+ in use for a week now with 6.12, and so far so good :)

However my WAN uplink(15dB TX 1310\RX 1550) for Internet and IPTV is currently run throug a fiber converter (10/100/1000FD BiDI -> 10/100/1000Base-T) before it is connected to my CCR.

I have tested 2 SFP's, one mikrotik and one fiberworks, none of them are able to pass any traffic when used in the CCR(The Cisco one works in a media converter and switch. )
Mikrotik S-35LC20D is a 1.25G Single Mode, LC, T1310nm/R1550nm
Fiberworks(Cisco coded, dual rate) SFP-DR-BX40D-35 BiDi, 100 / 1000 Mbps, DDM, SM, 40km TX/RX=1310/1550nm, 20dB, LC

If SFP slot in the CCR is set to auto negotiation, then no link is established. If set to manual 100 or 1000Mbit, i get 'link ok', but no trafic is able to pass(no recieved packets). I think my fiber converter links towards my provider with 100Mbit over the fiber, and that causes the problems since I have read that mikrotik dont support 100Mbit over the SFP ports. Any thoughts about this?

The Fiberworks sfp module I have do support dual rate(100 and 1000Mbit) and is compliant to SFP MSA and SFF-8472. Will Mikrotik support 100Mbit on the SFP slot?

Best Regards
Joakim
 
Shiro
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Sep 25, 2013 6:44 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri May 16, 2014 6:54 pm

I got my CCR-1009 4 days ago and testing some stuff, i found something strange. If i plug a 10 gig sfp+ in my CCR-1009, the device Fan slows down/almost stopped for a moment and speed up again, but not at the same speed without that sfp module. It happens on both ports. sfp and sfp+.

From information slide, Fan(s) running with 5400 rpm, with a sfp+ plugged in, it runs with 5000 rpm. I can't see this behaviour Microtiks sfp+ cable.

Anyone else with sfp has this issue? maybe a power issue? the brocade sfp+ itself is detected and shows normal ddm stats.

Atm i only have sfp+ modules around for testing.
 
ATG
just joined
Posts: 22
Joined: Fri Feb 21, 2014 9:45 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri May 16, 2014 9:00 pm

This also happends to me, on both SFP+ and the SFP port, with all the modules I have tested.

However I'm not sure if matters or affects the CCR, can't say that I have encountered any strange behavior other that the sound itself. Maybe just a voltage drop, that gets readjusted after a while?
 
djdrastic
Member
Member
Posts: 305
Joined: Wed Aug 01, 2012 2:14 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue May 27, 2014 12:05 am

Hi Quindor any chance you have RB1100AHx2 to test against ? My 1100's have served me really well so far but I would always welcome some extra performance.
 
User avatar
Kreacher
Member
Member
Posts: 359
Joined: Wed Sep 25, 2013 3:58 pm
Location: Hogwarts

Re: CCR1009-8G-1S-1S+ General info & Questions

Sun Jun 01, 2014 3:30 pm

Hello Quindor,

the same like the thread about the RB2011 well done and very informative for me,
it would be more interesting for my self to know what different kinds of VPN methods
would be natively supported by the hardware especial by the MiCA encryption engine.

And with DPI tasks is this device slowing down hard or not?

Related to the fans inside I found this one here, perhaps you would take a short overview
if this can be interesting for you. Noiseblocker BlackSilent Pro Fan PM2

@Vanta
How do I know if one of the PSUs broken?
- PRTG
- Nagios
- Incinga
- Zabbix
at max it is small office and Home-office (where noise is big problem
A little or small ventilated 19" Rack is in my eyes the best solution for becoming
a smooth work ground or a quiet office.

@KoDak
*RB2011UiAS-2HnD-IN* but on CPU: TLR4-00980CG-10CE
I didn´t consider, if I own a router such as the CCR1009-8G-1S-1S+ then
I want also to be free and setting up WLAN as I need or want it, and then
I will having more "fun" with the CCR1009 and a brand new RB953as an WLAN AP!!!!

@SwissWISP
In my opinion such a device should have LEDs which are indicating the status of each PSU.
I am considering with you but the LED light should be more made for home usage
or SOHO usage, but having some would be great.
In bigger instalments or networks it should be more something like support for PRTG from Paessler
and/or support for the USPs from APC (both protocols from them) then you will be able to set up
a sensor for the dual PSU and if one is failing you will be informed by mail or sms if you are using
PRTG and Kentix equipment, because the PRTG is able to use the SMS unit insite of the Kentix
monitoring system! Quindor, the PRTG is comming for free with 10 Sensors and is supporting also
USPs from APC and if you are placing a banner on your homepage, you will be able to get up to
30 Sensors for free, enough for a small home network as I think.
Kindly regards
Kreacher ♬

--------------------------------------
Karma points must not be paid by you
 
ptr727
newbie
Posts: 36
Joined: Wed May 09, 2012 8:35 am
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu Jun 19, 2014 2:59 am

Hi, just got a CCR1009-8G-1S-1S+ setting it up, would like some help.
I'm used to RB750 and RB2011 where quickset worked fine, but quickset on CCR not so much, e.g. sets SFP port as internet.

Any advice or pointers on proper config to help me set the device for NAT internet use, specifically the firewall rules?

I found several sources of firewall config, reasonably similar, but also slightly different to make me question why and what is current:

ros code

# RB2011 backup config
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add action=drop chain=input comment="default configuration" in-interface=ether1-gateway

# RB2011 quickset config
/ip firewall filter
add chain=input action=accept protocol=icmp comment="default configuration"
add chain=input action=accept connection-state=established comment="default configuration"
add chain=input action=accept connection-state=related comment="default configuration"
add chain=input action=drop in-interface=ether1-gateway comment="default configuration"
add chain=forward action=accept connection-state=established comment="default configuration"
add chain=forward action=accept connection-state=related comment="default configuration"
add chain=forward action=drop connection-state=invalid comment="default configuration"

# http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/Filter
/ip firewall filter
add chain=input connection-state=invalid action=drop comment="Drop Invalid connections"  
add chain=input connection-state=established action=accept comment="Allow Established connections"  
add chain=input protocol=icmp action=accept comment="Allow ICMP" 
add chain=input src-address=192.168.1.0/24 action=accept in-interface=!ether5-wan 
add chain=input action=drop comment="Drop everything else"
add chain=forward protocol=tcp connection-state=invalid action=drop comment="drop invalid connections"  
add chain=forward connection-state=established action=accept comment="allow already established connections"  
add chain=forward connection-state=related action=accept comment="allow related connections"

# http://forum.mikrotik.com/viewtopic.php?f=13&t=74024
/ip firewall filter
add action=drop chain=input comment="Drop invalid connections" connection-state=invalid
add chain=input comment="Accept established connections" connection-state=established
add chain=input comment="Accept related connections" connection-state=related
add chain=input comment="Allow access from local network" in-interface=br-PrivateNetwork src-address=192.168.25.0/24
add chain=input comment="Allow access from guest network for DNS" dst-port=53 in-interface=br-GuestNetwork protocol=udp src-address=192.168.125.0/24
add action=log chain=input comment="Log everything else" disabled=yes log-prefix="IPv4 Drop input RR:"
add action=drop chain=input comment="Drop everything else"
add action=drop chain=forward comment="Drop invalid connections" connection-state=invalid
add chain=forward comment="Accept established connections" connection-state=established
add chain=forward comment="Accept related connections" connection-state=related
add chain=forward comment="Allow traffic from Local network" in-interface=br-PrivateNetwork src-address=192.168.25.0/24
add chain=forward comment="Allow Guest network going outside" in-interface=br-GuestNetwork out-interface=pppoe-***** src-address=192.168.125.0/24
add action=log chain=forward comment="Log everything else" disabled=yes log-prefix="IPv4 Drop forward RR:"
add action=drop chain=forward comment="Drop everything else"

# http://wiki.mikrotik.com/wiki/A_script_ ... ou_started
/ip firewall filter
add action=accept chain=input comment="Local access to RB for Winbox" disabled=no dst-port=8291 protocol=tcp src-address-list=local
add action=jump chain=input comment="Treat all traffic equally" disabled=no jump-target=inbound
add action=jump chain=forward comment="Treat all traffic equally" disabled=no jump-target=inbound
add action=drop chain=inbound comment="Drop invalid" connection-state=invalid disabled=no
add action=accept chain=inbound comment="Allow limited icmp" disabled=no limit=50/5s,2 protocol=icmp
add action=drop chain=inbound comment="Drop excess icmp" disabled=no protocol=icmp
add action=accept chain=inbound comment="Accept established" connection-state=established disabled=no
add action=accept chain=inbound comment="Accept related" connection-state=related disabled=no
add action=accept chain=inbound comment="Internal traffic can do what it wants." disabled=no src-address-list=local
add action=drop chain=inbound comment="And drop everything else" disabled=no
add action=accept chain=output comment="Allow everything out" disabled=no
What would a reasonable set of rules look like?


From what I gather ether1 to ether4 is on a switch, so I can config them for a switch.
Ports 5 to 8 is not on a switch, so no switch config.
I tried disabling all unused ports, including SFP and SFP+, and then noticed that ether5 and ether6 does not want to disable.

ros code

/interface set ether5,ether6 disabled=yes
failure: master-port and bandwidth settings not supported on this port
What ethernet (non-SFP) ports should be used for LAN and for WAN links?
Do you config ports 1 to 4 for LAN and switch, or if they are switch no rules, or just no rules between ports?


Lastly, is there an easier way to reset to factory defaults (after I screwed up network access) than pressing reset while powering on, impossible for one person to do that with the device in the rack?

P.
 
Redman
just joined
Posts: 18
Joined: Mon Jun 16, 2014 3:59 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Jun 24, 2014 11:01 pm

Quick note to Quindor, you are connecting to Ether8, but the IP address is on Ether1. Unlike the RB2011, the CCR series doesn't have all ports switched, so you need to connect to Eth1 and configure the device according to your needs.
I have CCR1009 since 2 weeks but I remember from a mistake I disabled Ether1. and I connected in Ether2 without any problem. So you can configure from any port you want
 
mpreissner
Member
Member
Posts: 356
Joined: Tue Mar 11, 2014 11:16 pm
Location: Columbia, MD

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Jun 30, 2014 2:27 am

I can't wait to get my hands on one of these...I just "finished" setting up my new CRS226-24G-2S+RM (I'll never really finish because I'm always playing with it) and I'm loving it. I'm interested to see just what the maximum wire-speed routing capacity of the CCS1009 is...obviously it only has 5 gigabit ports connected directly to the CPU, but with the 10Gb SFP+, I wonder if it can reach 10+ Gb/s total routing before maxing out the CPU.
Michael Preissner
CISSP, CCSP, CEH, PMP
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Jun 30, 2014 9:38 am

I wonder too. Have you tried it? What routing maximum you were able to achieve? Packets-mbits-cpu utilisation.
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Jun 30, 2014 11:40 am

I have not yet tried with routing, but NAT it seems capable of doing at least 2Gbit sustained without too much trouble. Maybe 35% CPU utilization. I do not have the equipment to test more. But if it can do NAT at those speeds I would expect it to be quite capable in routing only!
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
mmmigoro
newbie
Posts: 39
Joined: Mon Feb 14, 2011 3:48 pm
Location: PRAHOVA, Romania

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Jun 30, 2014 3:36 pm

Does anybody know if SFP+ port supports also SFP modules (1,25gbps).
I would like to replace actual config (RB1100AHx2 + 2 gigabit media converters) with 1 CCR1009-8G-1S-1S+ and 2 SFP modules.
 
mpreissner
Member
Member
Posts: 356
Joined: Tue Mar 11, 2014 11:16 pm
Location: Columbia, MD

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Jun 30, 2014 3:46 pm

I might be wrong, but I don't believe the 10G SFP+ port supports 1.25G modules. Usually, when they do, the port will be labeled 1/10G, but the picture Quindor posted clearly only shows 10G on the SFP+ port. At this point, your best bet to get multiple SFP cages is the CCR1036-12G-4S
Michael Preissner
CISSP, CCSP, CEH, PMP
 
djdrastic
Member
Member
Posts: 305
Joined: Wed Aug 01, 2012 2:14 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Jun 30, 2014 5:25 pm

Does anybody know if SFP+ port supports also SFP modules (1,25gbps).
I would like to replace actual config (RB1100AHx2 + 2 gigabit media converters) with 1 CCR1009-8G-1S-1S+ and 2 SFP modules.
Hi mmigoro , MTK have noted that certain SFP+ routers are backwards compatible with SFP but requires it to be hard set on both sides to 1GB iirc.

http://forum.mikrotik.com/viewtopic.php?f=3&t=81079
 
mmmigoro
newbie
Posts: 39
Joined: Mon Feb 14, 2011 3:48 pm
Location: PRAHOVA, Romania

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Jun 30, 2014 5:53 pm

Thanks for info.

I only have access to my side of the link, the other ends are at provider PoP's. So I guess I'm stuck with 1100AHx2...
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Jun 30, 2014 8:04 pm

Thanks for info.

I only have access to my side of the link, the other ends are at provider PoP's. So I guess I'm stuck with 1100AHx2...
You are paying for the link right? Just ask them to set it to the specified settings and they should?
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
User avatar
Belgarion186
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Thu Jan 23, 2014 3:33 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Jul 01, 2014 3:49 am

I only have access to my side of the link, the other ends are at provider PoP's. So I guess I'm stuck with 1100AHx2...
If you're currently using 1100AHx2 with fiber-to-copper media converter, why not use that with the CCR1009 too ?

It's a waste to use an SFP+ for 1Gbps connection when it's capable of 10Gbps.
 
mmmigoro
newbie
Posts: 39
Joined: Mon Feb 14, 2011 3:48 pm
Location: PRAHOVA, Romania

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Jul 01, 2014 6:38 am

By replacing three devices with only one we figured we will have full power redundancy because two sfp's being powered by device itself (which in turn is dual-powered (even three as i understand)).
 
User avatar
Kreacher
Member
Member
Posts: 359
Joined: Wed Sep 25, 2013 3:58 pm
Location: Hogwarts

Re: CCR1009-8G-1S-1S+ General info & Questions

Wed Jul 02, 2014 12:48 pm

Does anybody know if SFP+ port supports also SFP modules (1,25gbps).
I would like to replace actual config (RB1100AHx2 + 2 gigabit media converters) with 1 CCR1009-8G-1S-1S+ and 2 SFP modules.
Perhaps this answer from @janisk will matching best this question.
Topic: CCR1036-8G-2S+ SFP Problems
Kindly regards
Kreacher ♬

--------------------------------------
Karma points must not be paid by you
 
Shiro
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Sep 25, 2013 6:44 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Jul 21, 2014 3:11 pm

Did anyone ever tried to use the smart card slot? i wonder if that slot really works.
Anyone knows a compatible card for that slot?
 
User avatar
Vanta
just joined
Posts: 7
Joined: Mon Nov 29, 2010 5:24 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Aug 26, 2014 9:21 pm

starting from RouterOS 6.13 PSU monitoring will be possible. Due to some technical difficulties this feature was delayed. Same will be true for CCR1016-12S-1S+
Monitoring of PSU has already been implemented?

RouterOS 6.18
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2298
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Aug 26, 2014 9:36 pm

Try in terminal:
/system healt print
LAN, FTTx, Wireless. ISP operator
 
User avatar
Vanta
just joined
Posts: 7
Joined: Mon Nov 29, 2010 5:24 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Aug 26, 2014 10:11 pm

It works

Thank you.

/system healt print
                    fan-mode: auto
                     use-fan: main
                  active-fan: main
          cpu-overtemp-check: yes
      cpu-overtemp-threshold: 100C
  cpu-overtemp-startup-delay: 1m
                     voltage: 23.7V
                     current: 763mA
                   fan-speed: 5081RPM
                 temperature: 36C
             cpu-temperature: 54C
           power-consumption: 18.1W
                  psu1-state: ok
                  psu2-state: ok
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Sep 08, 2014 4:17 pm

Per stats now published on http://routerboard.com/CCR1009-8G-1S-1Splus you can seemingly push close 12Gbps through it with large packets!

This must have been tested using the 10Gbit ports because even combining the 4 switch ports is 1Gbps to CPU + 4x1Gbps CPU ports = 5Gbps or 10Gbps in full-duplex. The SFP adds another 1Gbit. But the 10Gbit port is also direct CPU connected and thus adds a whopping 10Gbit or 20Gbit full-duplex!

So basically, this is a ~10Gbit* router. More realistic you should scale it in around 5Gbps* with having some filters or queues active and looking at different packet sizes. Very awesome for the price. :D

Combine the CCR1009-8G-1S-1S+ with a $29 10Gbps DAC cable to a CRS226-24G-2S+RM and you create 24 x 1Gbit ports with a 10Gbit uplink! And since the CRS226-24G-2S+RM has 2 x 10Gbit ports you can continue "stacking" them! All routable and everything 'wire-speed'. :shock: :D

*It all depends on your usage pattern
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu Sep 11, 2014 2:54 am

yup, and Tilera own evalution board with such CPU state - it rated for up to 10Gbps traffic(depend specific details of such) http://www.tilera.com/sites/default/fil ... 12_WEB.pdf
p.s.
i was dreamed bout putting CCR1009 even to my home. really Love CCR1009 performance
but after some experience with it - skipped idea. just too loud for HOME use :( and need something 1.5x or 2x smaller, preferably(like RB2011 case or bit bigger), but thats not so big deal as noise or dust concerns.
maybe later Mikrotik - release something with MASSIVE fully-pasive radiators for such CPU, instead of Turbine cooler(like Asus-branded beefy routers with Al-made radiator weighting hugreds of gramms :P)it will really put in home use.
because for 25W power disspipation its not impossible, yet. and future versions(28nm and 22nm transistors -made)would be even colder than now. and even with mild 30% downclock to 800Mhz it still about 10x faster than Rb2011 and just fine for Home use, then, even with 1Gbps subscriptions and complex config.
 
Omiar
just joined
Posts: 3
Joined: Fri Sep 12, 2014 5:01 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri Sep 12, 2014 5:22 pm

I just got my first Mikrotik (CCR1009-8G-1S-1S+). Have some previous experience with a cheaper device.

First issue, the Quicket menu via WebFig doesn't show any settings, all fields are empty. When I login via winbox, the quickset shows me the current configuration.
Second issue, the quickset menu in WebFig is showing Wireless settings although the wireless package is disabled.
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Sep 16, 2014 2:44 pm

I just got my first Mikrotik (CCR1009-8G-1S-1S+). Have some previous experience with a cheaper device.

First issue, the Quicket menu via WebFig doesn't show any settings, all fields are empty. When I login via winbox, the quickset shows me the current configuration.
Second issue, the quickset menu in WebFig is showing Wireless settings although the wireless package is disabled.
Have you tried to upgrade the CCR1009 to the newest version and see what that does?
Are you able to also check it inside of Winbox?
Wireless is disabled because the CCR1009 does not have Wireless?
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
RSRS
just joined
Posts: 3
Joined: Sun Sep 21, 2014 8:28 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Sun Sep 21, 2014 8:55 am

Is this how the architecture looks?
Combining the various datasheets this is what I have come up with.
MT could you please confirm?
You do not have the required permissions to view the files attached to this post.
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Sep 23, 2014 12:53 pm

Is this how the architecture looks?
Combining the various datasheets this is what I have come up with.
MT could you please confirm?
Yes I believe that is correct! Nice drawing too, but, euhm, Mikrotik released their block diagram a while ago : http://i.mt.lv/routerboard/files/CCR100 ... 151432.pdf maybe you missed it. :)
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Sep 23, 2014 2:34 pm

official shematics - of course cooler :) it also had mention of flash, leds, reset, buzzer, serial port and even sd slot. and not also you forgot thats dual-sfp/sfp+ variation exist too.
 
je1to
just joined
Posts: 7
Joined: Fri Dec 19, 2014 4:00 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri Dec 19, 2014 4:08 am

Related to the fans inside I found this one here, perhaps you would take a short overview
if this can be interesting for you. Noiseblocker BlackSilent Pro Fan PM2
Hi all,

I justed registered to let you know, that I've installed these fans today. They seem to work perfectly - I don't see any differences in temperature and I don't hear a thing :D
Thanks for all the information you guys provided in this thread, helped a lot!
 
Shiro
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Sep 25, 2013 6:44 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Sat Dec 27, 2014 5:29 pm

Related to the fans inside I found this one here, perhaps you would take a short overview
if this can be interesting for you. Noiseblocker BlackSilent Pro Fan PM2
Hi all,

I justed registered to let you know, that I've installed these fans today. They seem to work perfectly - I don't see any differences in temperature and I don't hear a thing :D
Thanks for all the information you guys provided in this thread, helped a lot!
Thanks for sharing this! i ordered two of them. Did they fit perfectly or do you have to made some changes to the case?
 
je1to
just joined
Posts: 7
Joined: Fri Dec 19, 2014 4:00 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Dec 29, 2014 11:31 pm

Thanks for sharing this! i ordered two of them. Did they fit perfectly or do you have to made some changes to the case?
They fit perfectly. No changes to the case or fans necessary. The package contains a gasket for vibration-free mounting - I didn't try to install them.
 
Shiro
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Sep 25, 2013 6:44 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri Jan 02, 2015 3:21 pm

I got the new Fan's today and installed them. As je1to mentioned they fit perfectly.

The Original Chiefly Microtik running around 6000-6300 RPM and keeping the CPU at 53-54C.
The NB-BlackSilent Pro running at 4400-4600 RPM and keeping the CPU at 55-56C.

They take a little longer to spin up, after that typical squeeking noise (Fan controller?) on this CCR's, i hear a ticking noise from the new fan, looks like they need a little more power to come up. After another 20 seconds the Fan finaly spins up.

It takes around 5-10 Minutes and they run around 4400-4600 RPM. At that point, the Fan is very quite.

/system health> print
fan-mode: auto
use-fan: main
active-fan: main
cpu-overtemp-check: yes
cpu-overtemp-threshold: 100C
cpu-overtemp-startup-delay: 1m
voltage: 23.8V
current: 907mA
temperature: 31C
cpu-temperature: 55C
power-consumption: 21.6W
psu1-state: ok
psu2-state: fail
fan1-speed: 4481RPM
 
dw5304
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Tue Apr 12, 2011 9:36 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Jan 13, 2015 10:35 pm

I can confirm that with MW-SX-MM-US (1.25gbps) on the spf+ 10gbe port it will link.
i will be doing some testing on thoughput shortly.
 
roborkk
just joined
Posts: 22
Joined: Mon Sep 21, 2009 12:07 am
Location: Slovak republic

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri May 01, 2015 10:05 pm

Hi, can I ask - I have CCR1009 as edge router with NAT.
I used Eth5 as WAN and Eth6 as LAN. But in high data load from customers - above 300Mbps, occurs high cpu usage of CCR up to 100% and traffic decerase to forexample 110Mbps and latency to internet is 100ms and higher. This is during 3-6s, then CPU goues back to 20%. And for a minute -two that repeats. Is my device bad or that config is wrong?
Thanks.
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri May 01, 2015 10:39 pm

Hi, can I ask - I have CCR1009 as edge router with NAT.
I used Eth5 as WAN and Eth6 as LAN. But in high data load from customers - above 300Mbps, occurs high cpu usage of CCR up to 100% and traffic decerase to forexample 110Mbps and latency to internet is 100ms and higher. This is during 3-6s, then CPU goues back to 20%. And for a minute -two that repeats. Is my device bad or that config is wrong?
Thanks.
Do you have Mangle rules? Queues? What are you firewall rules?
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
roborkk
just joined
Posts: 22
Joined: Mon Sep 21, 2009 12:07 am
Location: Slovak republic

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri May 01, 2015 11:34 pm

Hi, can I ask - I have CCR1009 as edge router with NAT.
I used Eth5 as WAN and Eth6 as LAN. But in high data load from customers - above 300Mbps, occurs high cpu usage of CCR up to 100% and traffic decerase to forexample 110Mbps and latency to internet is 100ms and higher. This is during 3-6s, then CPU goues back to 20%. And for a minute -two that repeats. Is my device bad or that config is wrong?
Thanks.
Do you have Mangle rules? Queues? What are you firewall rules?
Simple Q cca 30x, firewall cca 70x, NaT 240x
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri May 01, 2015 11:40 pm

Simple Q cca 30x, firewall cca 70x, NaT 240x
Could be as simple as the order of your rules.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
roborkk
just joined
Posts: 22
Joined: Mon Sep 21, 2009 12:07 am
Location: Slovak republic

Re: CCR1009-8G-1S-1S+ General info & Questions

Sat May 02, 2015 2:30 am

Previous PC router goes permanently on 70% on CPU load (dual-core 2200MHz Pentium. And it has lower latency to internet and no such issue, during 4 years.
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: CCR1009-8G-1S-1S+ General info & Questions

Sat May 02, 2015 7:06 am

Previous PC router goes permanently on 70% on CPU load (dual-core 2200MHz Pentium. And it has lower latency to internet and no such issue, during 4 years.
Post your filter and mangle, when we can see what could be causing it.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
User avatar
zervan
Member
Member
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Sat May 30, 2015 4:46 pm

What is the meaning of green and orange ethernet LED?

I have some new remote CCR1009 to configure. I asked operator to connect eth1 to LAN and eth8 to WAN, then connected by VPN there and made basic configuration. After reboot I lost connection - router is not responding even to WinBox discovery from LAN. Operator said eth1 had just green LED on and eth8 both green and orange LEDs lighting constantly. When he disconnected eth8, router was available again from LAN. I'd like to know what happened. Maybe it was not a good idea to connect special port 8 (with POE and boot) as WAN...
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
User avatar
zervan
Member
Member
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Jun 01, 2015 10:40 am

Today the router was connected to WAN by port 7 - it was working, but after reboot it is not accessible again, neither from LAN / WinBox discovery. What's wrong? Is this some incompatibility with Cisco switch? I am feeling like a fool when I need to ask remote operator to disconnect cable again and again :?

EDIT: After some more testing I found out that orange LED means probably gigabit. Problem I described is obviously not related to ports 7/8 (as I thought), but to switch - if the ports 1-4 are switched, bootloader will hang sometimes. It doesn't matter if there is Cisco or TP-Link device. I have created ticket and will solve this with MT support.
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
User avatar
PeterFalken
just joined
Posts: 19
Joined: Wed May 13, 2015 6:11 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu Jun 04, 2015 1:14 am

Can anybody confirm that there is a memtest option in RouterBOOT for the rack mountable CCR1009-8G-1S-1S+ and other CCRs?
I recently bought a CCR1009-8G-1S-1S+PC ( Awesome device), but I wasn't able to find the option to test RAM in the console while on RouterBOOT.
 
User avatar
dgonzalezh
Trainer
Trainer
Posts: 33
Joined: Wed Jun 05, 2013 9:39 am
Location: Colombia
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri Aug 14, 2015 7:15 pm

at max it is small office and Home-office (where noise is big problem
the CCR1009 has the power to run a medium sized ISP, so, I don't agree to the above.
I agree 100% with Normis, these products are ISP grade products.
--
All the Best
David Gonzalez H
TikAcademy :: Training and consulting Services
Mikrotik: MCT, MTCNA, MTCRE, MTCWE, MTCIPv6E, MTCUME & MTCTCE
www.tikacademy.com
www.dghvoip.com
CO: +57-312-770-4122
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri Aug 14, 2015 9:57 pm

I am not sure they are small business grade in the VPN area, with users frequently referring to slower performance compared to RB1100AH.
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri Aug 14, 2015 10:01 pm

I am not sure they are small business grade in the VPN area, with users frequently referring to slower performance compared to RB1100AH.
My main office is 500/500 fiber, feeding three bunch offices each with 100/100 fiber. Each office has a CCR1009 with 2GB. They have no issue sustaining 95~100mbps throughput, saturating the branch fiber. The main office routinely sustains 300mbps out to the offices.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri Aug 14, 2015 10:07 pm

I am not sure they are small business grade in the VPN area, with users frequently referring to slower performance compared to RB1100AH.
My main office is 500/500 fiber, feeding three bunch offices each with 100/100 fiber. Each office has a CCR1009 with 2GB. They have no issue sustaining 95~100mbps throughput, saturating the branch fiber. The main office routinely sustains 300mbps out to the offices.
With what VPN configuration?
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri Aug 14, 2015 10:09 pm

Ipsec, AES128-CBC, SHA1
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
Dilergore
just joined
Posts: 7
Joined: Wed Aug 05, 2015 12:05 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Aug 17, 2015 8:11 am

I am not sure they are small business grade in the VPN area, with users frequently referring to slower performance compared to RB1100AH.
Well they are saying that it can handle a "lot more than 500Mbps" with the correct VPN config:

http://forum.mikrotik.com/viewtopic.php?f=3&t=87892
 
easyspot
Frequent Visitor
Frequent Visitor
Posts: 66
Joined: Thu Jun 07, 2012 7:09 pm

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu Oct 22, 2015 1:18 pm

I'd like to buy this router but notice 1 thing. According to block diagram, it should be:
SFP = 1gbps line
SFP+ = 10gbps line
Eth1-4 = 1gbps switched line
Eth5 = 1gbps line
Eth6 = 1gbps line
Eth7 = 1gbps line
Eth8 = 1gbps line
Total: 16gbps line
Why performance test result capped to 12gbps? Any invisible shared line?
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1723
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu Oct 22, 2015 2:39 pm

I believe it is testing method limitation, you have only 6Gbps that you can receive or send on other than SFP+ port. There is ports from where get 4 more Gbps so that you can send out 10G via SFP+, to do so you need additional configuration, and that will impact the performance and make it useless for comparison with other products, (with smaller packets and more configuration).
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1053
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Oct 26, 2015 10:44 pm

I am not sure they are small business grade in the VPN area, with users frequently referring to slower performance compared to RB1100AH.
Well they are saying that it can handle a "lot more than 500Mbps" with the correct VPN config:

http://forum.mikrotik.com/viewtopic.php?f=3&t=87892
MikroTik can confirm or deny this, but I believe the CCRs use the same IPSEC hardware chip which means the CCR1009 performance ought to be close to the other CCRs.

We were able to get a max of 7.5 Gbps of encrypted throughput using EoIP over IPSEC in our testing of the CCR1036s.

http://www.stubarea51.net/2015/10/16/10 ... ip-tunnel/
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1747
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Mon Oct 26, 2015 11:03 pm

I am not sure they are small business grade in the VPN area, with users frequently referring to slower performance compared to RB1100AH.
Well they are saying that it can handle a "lot more than 500Mbps" with the correct VPN config:

http://forum.mikrotik.com/viewtopic.php?f=3&t=87892
MikroTik can confirm or deny this, but I believe the CCRs use the same IPSEC hardware chip which means the CCR1009 performance ought to be close to the other CCRs.

We were able to get a max of 7.5 Gbps of encrypted throughput using EoIP over IPSEC in our testing of the CCR1036s.

http://www.stubarea51.net/2015/10/16/10 ... ip-tunnel/
according ezchip website the MiCA™ acceleration engines responsible for crypto acceleration have the following theoretical performance:

tilegx9 (ccr1009) 10Gbps of crypto and 5Gbps of compression
tilegx16 (ccr1016) 20Gbps of crypto and 10Gbps of compression
tilegx36 (ccr1036) 40Gbps of crypto and 20Gbps of compression
tilegx72 (ccr1072) 40Gbps of crypto and 20Gbps of compression

off course we have to take in count cpu and memory performance and the complexity of configuration
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1053
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Oct 27, 2015 2:21 am

according ezchip website the MiCA™ acceleration engines responsible for crypto acceleration have the following theoretical performance:

tilegx9 (ccr1009) 10Gbps of crypto and 5Gbps of compression
tilegx16 (ccr1016) 20Gbps of crypto and 10Gbps of compression
tilegx36 (ccr1036) 40Gbps of crypto and 20Gbps of compression
tilegx72 (ccr1072) 40Gbps of crypto and 20Gbps of compression

off course we have to take in count cpu and memory performance and the complexity of configuration
Very helpful info! I've looked several times but never saw which chip was being used for IPSEC offload on the CCR. Just out of curiosity, where did you find the info on what chip is in the CCRs? :-)
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1747
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Tue Oct 27, 2015 2:28 am

according ezchip website the MiCA™ acceleration engines responsible for crypto acceleration have the following theoretical performance:

tilegx9 (ccr1009) 10Gbps of crypto and 5Gbps of compression
tilegx16 (ccr1016) 20Gbps of crypto and 10Gbps of compression
tilegx36 (ccr1036) 40Gbps of crypto and 20Gbps of compression
tilegx72 (ccr1072) 40Gbps of crypto and 20Gbps of compression

off course we have to take in count cpu and memory performance and the complexity of configuration
Very helpful info! I've looked several times but never saw which chip was being used for IPSEC offload on the CCR. Just out of curiosity, where did you find the info on what chip is in the CCRs? :-)
this are the chip manufacturer links

http://www.tilera.com/products/?ezchip=585&spage=614
http://www.tilera.com/products/?ezchip=585&spage=636
http://www.tilera.com/products/?ezchip=585&spage=635
http://www.tilera.com/products/?ezchip=585&spage=621
http://www.tilera.com/products/?ezchip=585&spage=618
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu Dec 10, 2015 3:11 am

Funny story, since purchasing the CCR1009 I've only used it as a testing router and temporary router where I needed it. Today I ported my configuration from the RB2011 I was using to my CCR1009 and am using it as my home "production" router!

I did set the CPU down to 600Mhz which has made it so that the stock fans just turn off. Performance is still miles and leagues ahead of the RB2011.

The reason for the switching the routers? I've started using a PPTP VPN tunnel to redirect some traffic to another site and anything more then 40Mbit would cause the RB2011 CPU to hit max CPU load and it became noticeable with other stuff I was running through it. With the CCR1009, even using 600Mhz, no problems whatsoever and I've seen it hit 60MBit to 80Mbit without problem!

Awesome device! :D
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1747
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu Dec 10, 2015 4:29 am

Funny story, since purchasing the CCR1009 I've only used it as a testing router and temporary router where I needed it. Today I ported my configuration from the RB2011 I was using to my CCR1009 and am using it as my home "production" router!

I did set the CPU down to 600Mhz which has made it so that the stock fans just turn off. Performance is still miles and leagues ahead of the RB2011.

The reason for the switching the routers? I've started using a PPTP VPN tunnel to redirect some traffic to another site and anything more then 40Mbit would cause the RB2011 CPU to hit max CPU load and it became noticeable with other stuff I was running through it. With the CCR1009, even using 600Mhz, no problems whatsoever and I've seen it hit 60MBit to 80Mbit without problem!

Awesome device! :D

what cpu usage when hitting 80mbit of pptp?? in tool profile you see cores evenly charged??
 
Quindor
Member
Member
Topic Author
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu Dec 10, 2015 9:00 pm

what cpu usage when hitting 80mbit of pptp?? in tool profile you see cores evenly charged??
See for yourself. This was downloading about 16GB of data, I saw peaks up to 110Mbit but average was more around 60MBit. I have included a bandwith graph and 2 CPU graphs. One is of each CPU individually, one of them averaged together.

Not sure where the high peak value of one of cores came from, it also seems to be before I started the downloads. Generally speaking and monitoring the resources I did not see this spike and everything was evenly distributed over the cores with one of two hitting 20% at max.

And again, this is with the CCR1009 running at 600Mhz, so only using half of the power it actually has!

*Use the scrollbars within the picture to see the data in numbers.
ccr_pptp_cpu2.png
ccr_pptp_cpu1.png
ccr_pptp_throughput.png
You do not have the required permissions to view the files attached to this post.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1747
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: CCR1009-8G-1S-1S+ General info & Questions

Thu Dec 10, 2015 10:03 pm

thx for sharing the graphs

i have my ccr1009 PC at underclocked too at 400mhz to save some watts hehe
 
kramer
just joined
Posts: 7
Joined: Mon Jun 18, 2018 1:21 am

Re: CCR1009-8G-1S-1S+ General info & Questions

Fri Jun 29, 2018 5:13 pm

Hello,

is that 1009 model capable maintain 1 Gbit as edge router with NAT ?

Regards,
Darek

Who is online

Users browsing this forum: No registered users and 17 guests