Community discussions

 
opensourcecat
just joined
Topic Author
Posts: 12
Joined: Wed Mar 20, 2013 12:35 pm

CCR-1016 Kernel Panic

Wed Aug 06, 2014 11:41 am

Just after a normal reboot, the device got stuck in "loading kernel from NAND" status. Connected to serial terminal that's what i get:
RouterBOOT booter 3.13                                                                                                                                               

CCR1016-12G                                                                                                                                                          

CPU frequency: 1200 MHz                                                                                                                                              
  Memory size: 2048 MiB                                                                                                                                              
    NAND size: 512 MiB                                                                                                                                               

Press any key within 2 seconds to enter setup..

loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
Could not mount ubifs filesystem: Structure needs cleaning
opendir: No such file or directory
opendir: No such file or directory
ERROR: no system package found!
Kernel panic - not syncing: Attempted to kill init!

Starting stack dump of tid 1, pid 1 (init) on cpu 15 at cycle 15173358619
  frame 0: 0xfffffff7004ef9e8 dump_stack+0x0/0x20 (sp 0xfffffe003d26fc08)
  frame 1: 0xfffffff7004e8c68 panic+0x168/0x388 (sp 0xfffffe003d26fc08)
  frame 2: 0xfffffff700050e68 do_exit+0x1c8/0xd48 (sp 0xfffffe003d26fcb0)
  frame 3: 0xfffffff700051b30 do_group_exit+0xf0/0x1e8 (sp 0xfffffe003d26fd78)
  frame 4: 0xfffffff700051c48 __wake_up_parent+0x0/0x18 (sp 0xfffffe003d26fdb0)
  frame 5: 0xfffffff7004f05c0 handle_syscall+0x210/0x2d0 (sp 0xfffffe003d26fdc0)
  <syscall while in user mode>
  frame 6: 0x735d0 0x735d0 (sp 0x7fa8faa8)
Stack dump complete
Client requested halt.
Solutions?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24055
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CCR-1016 Kernel Panic

Wed Aug 06, 2014 12:30 pm

Please use the Netinstall utility to reinstall RouterOS. This time use RouterOS v6.18 and the device should return to normal
No answer to your question? How to write posts
 
francescooneri
just joined
Posts: 2
Joined: Thu Jul 02, 2009 12:28 pm

Re: CCR-1016 Kernel Panic

Thu Aug 14, 2014 11:44 am

Is happened to me.
The solution is ok, but what is the problem?
Is a particular version of RouterOS?

Thanks in advance.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24055
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CCR-1016 Kernel Panic

Thu Aug 14, 2014 11:48 am

There was a problem in one of the earlier versions, in RouterOS v6.18 it should be fixed.
What's new in 6.17 (2014-Jul-18 15:14):
*) CCR1009 - fixed crash;

What's new in 6.16 (2014-Jul-17 13:12):
*) CCR - fixed rare file system corruption when none
of configuration could be changed or some of it disappeared;
No answer to your question? How to write posts
 
User avatar
nick3dos
Member Candidate
Member Candidate
Posts: 189
Joined: Fri Apr 29, 2011 11:03 pm
Location: Greece

Re: CCR-1016 Kernel Panic

Fri Aug 22, 2014 2:45 pm

There was a problem in one of the earlier versions, in RouterOS v6.18 it should be fixed.
The same problem after a reboot in my CCR-1009-8G-1S-1S+
I tried with netinstall v6.18 but the same errors !!!
Please help...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24055
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CCR-1016 Kernel Panic

Fri Aug 22, 2014 3:37 pm

Please contact support with a supout.rif file and console output attached, our developers will analyse this.
No answer to your question? How to write posts
 
User avatar
nick3dos
Member Candidate
Member Candidate
Posts: 189
Joined: Fri Apr 29, 2011 11:03 pm
Location: Greece

Re: CCR-1016 Kernel Panic

Fri Aug 22, 2014 3:38 pm

Please contact support with a supout.rif file and console output attached, our developers will analyse this.
how to make support.rif if i can't login to the router?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24055
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CCR-1016 Kernel Panic

Fri Aug 22, 2014 3:39 pm

Sorry, in this case, full console output. If you device doesn't operate, always contact support or seller. In the community forum, other users will not be able to help with such issues.
No answer to your question? How to write posts
 
User avatar
nick3dos
Member Candidate
Member Candidate
Posts: 189
Joined: Fri Apr 29, 2011 11:03 pm
Location: Greece

Re: CCR-1016 Kernel Panic

Fri Aug 22, 2014 3:49 pm

I already contact my reseller for RMA.
But what if in my new CCR, happens the same?
As i see it's 6xx version the problem. 6.18 didn't fix this problem.
 
skynoc
Member Candidate
Member Candidate
Posts: 141
Joined: Wed Jul 07, 2004 10:20 pm
Contact:

Re: CCR-1016 Kernel Panic

Thu Sep 18, 2014 11:50 pm

i have the same problem with version 6.19 , i downgraded to 6.18 but still having ccr reboots hazardiously , i have changed the queue interface from only-hardware to ethernet-default but with no luck .
i have sent a suppout.rif file to the support and waiting for reply , hope the problem will be fixed
 
skynoc
Member Candidate
Member Candidate
Posts: 141
Joined: Wed Jul 07, 2004 10:20 pm
Contact:

Re: CCR-1016 Kernel Panic

Fri Sep 19, 2014 11:18 am

this is a screenshot of the CCR 16 core log
You do not have the required permissions to view the files attached to this post.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2278
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: CCR-1016 Kernel Panic

Fri Sep 19, 2014 12:13 pm

upgrade to ROS 6.19 then upgrade routerboot
LAN, FTTx, Wireless. ISP operator
 
skoenman
just joined
Posts: 24
Joined: Fri Nov 07, 2008 11:42 am

Re: CCR-1016 Kernel Panic

Sun Apr 26, 2015 11:49 pm

Did you seem to get the problem fixed? Im having same issue but mine runs for a few hours then has kernal failure and then reboots 4 or 5 times...then runs a few hours again...dont understand.

Who is online

Users browsing this forum: No registered users and 18 guests