Page 1 of 1

How to netinstall RB433 with out IP address

Posted: Fri Oct 17, 2014 1:31 am
by gcs
I have a rb433AH that wont boot up. I can see on the serial port it say nand bad. I can go into setup and tell it to boot from Ethernet. I don't know what the ip address of the board is so it won't talk to netinstall.

Thanks

David

Re: How to netinstall RB433 with out IP address

Posted: Fri Oct 17, 2014 7:07 am
by scampbell
You should be able to reformat your nand from serial and enable boot from Ethernet once then nand.

You can then use netinstall to via RB433's ether1.

Your PC should be directly connected and have a static IP address assigned to it's Ethernet.

In netinstall under netbooting you need to specify an address in the same subnet as the pc is configured to it.

see http://wiki.mikrotik.com/wiki/Manual:Netinstall

Re: How to netinstall RB433 with out IP address

Posted: Fri Oct 17, 2014 5:34 pm
by gcs
but the RB won't have an IP address. how can netinstall talk to the RB? I can set the computer to any IP address since it is directly connected to RB.

Thanks

Re: How to netinstall RB433 with out IP address

Posted: Fri Oct 17, 2014 6:14 pm
by jarda
Netinstall assignes ip to device when performing startup. No need to make any settings on device if it should be netinstalled.

Re: How to netinstall RB433 with out IP address

Posted: Fri Oct 17, 2014 6:48 pm
by gcs
so what ip address to I give my computer so it is on the same subnet as RB?

Re: How to netinstall RB433 with out IP address

Posted: Sat Oct 18, 2014 1:02 am
by scampbell
assign your pc 192.168.88.254 subnet 255.255.255.0 no gateway needed.

In NetInstall under netbooting put 192.168.88.2

Re: How to netinstall RB433 with out IP address

Posted: Mon Oct 20, 2014 7:29 pm
by gcs
I have formated nand.

I have notebook pluged into poe and have notebook ip address 192.168.88.7 with 255.255.255.0 netmask

I have told netinstall to try 192.168.88.1 and .2 but it just keeps rebooting when it can't fine netinstall.

Somehow a ip address needs to be put into the RB. without one how can it connect to netinstall?

Thanks

David

Re: How to netinstall RB433 with out IP address

Posted: Mon Oct 20, 2014 11:29 pm
by ditonet
@gcs
For succesful netinstall connect your RB via Ether1, on other ports netinstall doesn't work.
I've netinstalled RB433AH in my office two weeks ago, without problems.

HTH,

Re: How to netinstall RB433 with out IP address

Posted: Tue Oct 21, 2014 3:18 am
by scampbell
ditonet is 100% correct. ether1 should be labelled POE/BOOT on the RB433. NetInstall will only work with on a port labelled POE/Boot. Refer www.routerboard.com and download the user guide for your router if unsure.

Re: How to netinstall RB433 with out IP address

Posted: Tue Oct 21, 2014 5:26 pm
by gcs
I am using Eth port 1 through the POE. I have boot from eth set and it tries to boot from ethernet but the notebook running netinstall never sees it.

Usually when i do a netinstall the RB is somewhat working and I can get in and set ip address to a known address. I then tell netinstall the ip address of rb and it works.

I don't think this RB has a default address in it. I guess netinstall can't see the rb. Is there anyway to use mac address?

Re: How to netinstall RB433 with out IP address

Posted: Tue Oct 21, 2014 5:59 pm
by moshtari1
<a href="http://www.behcharge.com">خرید شارژ</a>
خرید شارژ

Re: How to netinstall RB433 with out IP address

Posted: Tue Mar 17, 2015 10:59 am
by saligasht
RB433 and RB433AH are rather similar boards, except for the microSD slot (RB433AH only), CPU frequency (300 vs. 680 MHz) and RAM size (64 vs. 128 MB). RB433UAH adds USB connector and 5V DCDC to power USB devices to RB433AH.

RB433

RB433 Datasheet

RB433AH

RB433AH Datasheet

RB433UL

The Routerboard rb433ul ist currently not supportet. This Board has 64MB RAM and the serial console is not supportet by uboot. There are two Resets. Reset 1 (Button) and Reset 2 (Pad). Reset 1 is to reset the RouterOS and for force the netinstall (PXE). Reset 2 is to choice the backup uboot. Some times you must press both.

RB433UAH

RB433UAH Datasheet

UAH is the same board as AH, but with USB-connectors and dc/dc for 5V USB assembled. Adding unpowered USB to other boards could be easy, just solder in connector or simply wires.

MicroSD Slot

The MicroSD Slot needs SPI-Bus sharing support, which is not implemented in Backfire.

SPI-Bus sharing has been implemented in Trunk r22862 the MicroSD Slot is usable now. Read speed ist about 0.92 MB/s (11/13/10: I get I/O and -89 errors on the SPI bus while assessing the microSD card).

Installation overview

Here are the three main steps of the installation:

Boot the board on OpenWrt from the network (netboot): DHCP and TFTP servers required on the host.
Install OpenWrt to the internal flash with wget2nand: HTTP or FTP server required on the host.
Reboot on the new installation, configure, etc.
Netboot

The bootloader of RB433 is able to load an image in elf format via BOOTP into RAM and execute it.

Build the Target

You need to get OpenWrt trunk. In menuconfig choose:

Target System: Atheros AR7xxx/AR9xxx
Subtarget: Devices with NAND flash (mostly Mikrotik)
Target Images: ramdisk (and also tar.gz if you plan to do a permanent install with the same image)
Now build the ram disk version. While it's building create the tftp-root directory if not already done and a symlink to the ram disk image

Re: How to netinstall RB433 with out IP address

Posted: Tue Mar 17, 2015 11:06 pm
by eigenstate
I'm having problems with this too. For years I've been using NetInstall on several different RB types with no issues. Now however, I have a batch of RB433 boards coming in with ROS 5.26, firmware 3.18, and all of the half-dozen boards I've tested so far have refused to NetInstall as expected. I don't get the "NAND bad" message that David is seeing; in fact I see *no* serial output at all... which is preventing me from selecting the appropriate U-boot options to boot from NetInstall.

Since I can't get these boards to PXE boot, they boot to the installed ROS, but come up with a 0.0.0.0 Ethernet address. (This is no doubt why the BOOTP push button also fails to connect to NetInstall.) After playing around with them quite a bit (downgrading ROS, attempting to downgrade the firmware, using the BOOTP push button, etc., etc.) I have eventually been able to get all six boards to NetInstall but only after considerable effort with procedures that have varied from board to board. Once reinstalled with ROS 5.4 (and retaining the 3.18 firmware), they seem to function normally and the serial console once again displays as it should. The problem is the inconsistency of the steps it has taken to remedy these boards... and I have 26 more to do.

I'm pretty certain we're seeing a bug here. Normis, any suggestions? Is anyone aware of any work-arounds or do I need to send these back to the distributor?

Re: How to netinstall RB433 with out IP address

Posted: Wed Mar 14, 2018 3:10 pm
by mammutgp