Community discussions

MUM Europe 2020
 
dmjita
just joined
Topic Author
Posts: 16
Joined: Mon Nov 12, 2012 6:03 pm

Paid VPN service Nord VPN

Mon Nov 03, 2014 7:48 pm

I am using a dlink dsl-2640b as modem and a rb750g as router everything work fine. Now i bought a vpn service to avoid some limitation about my adsl. NordVPN support ppptp (not very secure) l2tp (better security) open vpn (best security?). I tried to configure my router to connect using ppptp, i was able to connect but not to use vpn, l2tp and open vpn i was not able to connect. I saw few guide but i was not able to make it work. Someone had experience with NordVPN or have some guide to link ? Thanks for your help.
 
NordVPN
just joined
Posts: 1
Joined: Tue Nov 04, 2014 9:47 am

Re: Paid VPN service Nord VPN

Tue Nov 04, 2014 12:31 pm

Hello, thank you for using NordVPN service.

OpenVPN will not be possible to set up due to technical reasons - our service does not use user certificate for the authentication.

Nevertheless, it would be a shame if you could not use great features that we offer due to the setup issues. That is why we suggest you to get a router that supports DD-WRT firmware. You would then be able to use our top-notch security tools like: Double VPN, Tor over VPN, 2048bit SSL encryption and the no logs policy.
 
dmjita
just joined
Topic Author
Posts: 16
Joined: Mon Nov 12, 2012 6:03 pm

Re: Paid VPN service Nord VPN

Tue Nov 04, 2014 9:27 pm

Awwww. i really hoped this could work. I can't change my router. Is it possible to have a guide to set up a l2tp connection? My routerboard is quite powerful and flexible router, honestly i don't want to change it with a router with ddwrt. Thanks you replied me but i think a lot of people in this forum will like to know that NordVpn is a good choice too for vpn service. If openvpn is not possible l2tp is possible?
 
dmjita
just joined
Topic Author
Posts: 16
Joined: Mon Nov 12, 2012 6:03 pm

Re: Paid VPN service Nord VPN

Thu Nov 06, 2014 9:15 pm

This is so strange, when i asked their customers service if my router was supported they said yes (using the chat on their website), now they say change it..... this is confusing.
 
evelyn
just joined
Posts: 2
Joined: Mon Jan 26, 2015 10:28 pm

Re: Paid VPN service Nord VPN

Fri Feb 27, 2015 10:36 pm

Check out this one http://www.bestcheapvpnservice.com/setup-vpn-windows-7/ that's my best VPN ever for unlimited bandwidth, privacy, high speed and complete security for your online activities and all data transfer.
 
strelokr
just joined
Posts: 16
Joined: Wed Dec 09, 2015 12:11 pm
Location: Ukraine

Re: Paid VPN service Nord VPN

Mon Feb 06, 2017 9:29 pm

i\m just check. pptp and l2tp w/o ipsec works fine on my RB951. OpenVPN still not works. It's very bad. You can use nice instruction for service hidemyass :) And this service can do Mikrotik+openVPN+CA
https://support.hidemyass.com/hc/en-us/ ... ient-Setup
 
strelokr
just joined
Posts: 16
Joined: Wed Dec 09, 2015 12:11 pm
Location: Ukraine

Re: Paid VPN service Nord VPN

Mon Feb 06, 2017 10:11 pm

hehe. I'm find instruction for ubuntu. https://support.nordvpn.com/hc/en-us/ar ... 4-04-setup there is opvn files https://nordvpn.com/api/files/zip. We can extract crt from this files.
 
spacemind
Member Candidate
Member Candidate
Posts: 111
Joined: Mon Jul 07, 2008 8:33 pm

Re: Paid VPN service Nord VPN

Sat Jun 03, 2017 7:55 pm

hehe. I'm find instruction for ubuntu. https://support.nordvpn.com/hc/en-us/ar ... 4-04-setup there is opvn files https://nordvpn.com/api/files/zip. We can extract crt from this files.
It dont think nordvpn Openvpn is going to work with mikrotik, but if you found a way to get it working please share :)

Mikrotik uses TCP only (that is supported by nordvpn), needs server certificate, client certificate and key (nordvpn does not have client certificate and key that you can import) and comp-lzo is not supported by mikrotik too.
 
KydeX
just joined
Posts: 6
Joined: Sat Aug 05, 2017 7:26 pm

Re: Paid VPN service Nord VPN

Tue Oct 24, 2017 6:52 pm

Has anyone done anything more with NordVPN on this? I'd like to route traffic from specific ports through the NordVPN account that I have.
 
User avatar
HarvSki
Member
Member
Posts: 388
Joined: Fri May 28, 2004 3:37 pm
Location: London, UK

Re: Paid VPN service Nord VPN

Thu Oct 26, 2017 4:13 pm

I'd like to do this as well, I cannot get the solution posted on NordVPN's site for MikroTik to work as the VPN isn't connecting although the traffic marking and routing does work (with other VPNs I've tested)
 
User avatar
harvey
Member Candidate
Member Candidate
Posts: 101
Joined: Thu Apr 05, 2012 8:16 pm

Re: Paid VPN service Nord VPN

Sat Oct 28, 2017 4:05 pm

I'd like to do this as well, I cannot get the solution posted on NordVPN's site for MikroTik to work as the VPN isn't connecting although the traffic marking and routing does work (with other VPNs I've tested)
I can get NordVPN working only with L2TP/IPSec and only with certain servers, I was provided with three servers in the USA that work, trying to get details of European based servers that will work.

My setup works as follows:-
/ip ipsec peer
add address=181.215.110.128/32 comment="Nord VPN USA 494" dh-group=modp1024 enc-algorithm=3des exchange-mode=main-l2tp \
    secret=nordvpn
/interface l2tp-client
add comment="Nord VPN USA 494" connect-to=181.215.110.128 disabled=no name=nord-l2tp-out1 password=myNordPassword user=\
    my@email.com
add action=mark-routing chain=prerouting comment="Nord Push client 10.1.1.100 through VPN" new-routing-mark=\
    nordvpn-l2tp passthrough=no src-address=10.1.1.100
/ip firewall filter
   add action=accept chain=forward comment="Allow outbound to NordVPN, you may not need this but due to my VLAN setup I require it" out-interface=nord-l2tp-out1 src-address=10.1.1.100
/ip route
add distance=1 gateway=nord-l2tp-out1 routing-mark=nordvpn-l2tp
You can check the connection status with:-
/interface l2tp-client monitor nord-l2tp-out1 
              ;;; Nord VPN USA 494
          status: connected
          uptime: 57s
        encoding: 
             mtu: 1450
             mru: 1450
   local-address: 10.9.9.11
  remote-address: 10.9.9.1
They recommended using the IP address of servers instead of DNS name. I also had issues with my email address and password so had to simplify the password to remove some extra special characters.

However the speed is not great, I'm hoping when I get a closer server to work it may help.
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: Paid VPN service Nord VPN

Mon Oct 30, 2017 8:44 pm

Hello, thank you for using NordVPN service.

OpenVPN will not be possible to set up due to technical reasons - our service does not use user certificate for the authentication.

Nevertheless, it would be a shame if you could not use great features that we offer due to the setup issues. That is why we suggest you to get a router that supports DD-WRT firmware. You would then be able to use our top-notch security tools like: Double VPN, Tor over VPN, 2048bit SSL encryption and the no logs policy.
Isn't there a DD image for metarouter?
 
MattyBoy4444
just joined
Posts: 2
Joined: Fri Sep 08, 2017 6:25 am

Re: Paid VPN service Nord VPN

Mon Oct 30, 2017 9:02 pm

What 3 servers did you get to work?

Sent from my Nexus 6P using Tapatalk
 
alexfn
just joined
Posts: 9
Joined: Wed Nov 01, 2017 12:07 pm

Re: Paid VPN service Nord VPN

Wed Nov 01, 2017 12:11 pm

Hi,
<snipped>

My setup works as follows:-

<snipped>
[/quote]

In this setup, your l2tp runs *without* IPSEC, even you have configured the latter.
 
paca
just joined
Posts: 4
Joined: Fri Jan 13, 2017 1:17 pm

Re: Paid VPN service Nord VPN

Wed Nov 01, 2017 2:56 pm

Hi Guys,
I'm trying to connect my router (RB3011) to NordVPN.
After many emails exchanged with NordVPN support, I got this reply:
"Your router natively supports only PPTP protocol. We do support these protocols, but they are unstable, insecure and outdated. For that reason we do not recommend using it if you value your security. Also, we are dropping the support for this protocol day by day, thus in the upcoming months they will not be supported anymore. Our newest servers are already not supporting it.

Instability comes from the fact that both of these services are using pppd daemon which sometimes gets stuck and is unable to allow new users to connect to the server. Unfortunately we cannot do anything about that and the only thing you could try is connecting to multiple different servers. This is also the reason we are recommending everyone to upgrade their equipment so that they would be able to use OpenVPN.

If you do decide to use them anyways - please do that at your own risk.
"

So, I don't see a bright future in matching Mikrotik with NordVPN, since neither Mikrotik shows any willingness to update their OpenVPN implementation ... which has an impressive list of unsupported features.

My question is: does anyone knows a VPN service which works well with Mikrotik routers?

Thanks!
 
tinus
just joined
Posts: 16
Joined: Thu Oct 27, 2005 9:01 pm

Re: Paid VPN service Nord VPN

Fri Jan 12, 2018 1:02 am

I finally get connected to NordVPN L2TP/IPSec, below is the configuration

/interface l2tp-client
add add-default-route=yes connect-to=NordVPNIP disabled=\
no name=l2tp-out2 password=NordvpnPassword profile=\
default user=NordvpnEmailAccount

/ip ipsec peer
add address=NordVPNIP dh-group=modp1024 \
dpd-interval=10s enc-algorithm=3des exchange-mode=main-l2tp \
generate-policy=port-strict secret=nordvpn

/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des pfs-group=none

/ip ipsec policy
add dst-address=NordVPNIP/32 dst-port=1701 protocol=udp src-address=\
yourPublicIp/32 src-port=1701
 
3D9iWC5pFevQ
just joined
Posts: 5
Joined: Fri Feb 02, 2018 7:43 pm

Re: Paid VPN service Nord VPN

Fri Feb 02, 2018 8:07 pm

Can anybody confirm that mikrotik requires BOTH user/pass AND certificate? My VPN supports only uses user/pass without certificate.

Who is online

Users browsing this forum: uldise and 35 guests