Page 1 of 1

CCR1036-12G-4S SFP port Strange behaviour

Posted: Thu Apr 30, 2015 2:51 pm
by devrim
Hello Mikrotik Users,
We bought CCR1036-12G-4S few month ago for replacement purpose. Also we bought S-31DLC20D SFP modules.
We started to test it before take it online. While we test this device we observed some strange behaviour with Alcatell Metro Switch (Alcatel MPLS 7750) . This problem arise while we tried to connect one of CCR SFP port to Alcatell Switch. In this case port never online.
After some investigation we found that from this forum on Alcatell side it is necessary to set auto-negotiation to off to SFP port. So we request from our ISP to switch off auto-negotiation on our port. And after this operation CCR SFP port went to online.
But while we tried to test with ping in this case from 5% to 7% packet lost occured on this port.
So we tried to make more test with CCR(RouterOS v6.27). And following test has been made:
1) We tried to connect CCR SFP port to Cisco Switch with fiber patch cable. Cisco Switch work without problem and while we tested to ping IP address of machine there are NO any ICMP loss available.
2) We have a netgear GSM7212 and we tried to connect CCR SFP to this machine. Line is not online so we tried to set auto-negotiation to off. Line is turned on. ping IP address of machine there are NO any ICMP loss available.

We want to test if fiber cable has any problem so we test it with one of RB260GS Mikrotik machine.
There is no any ICMP loss hapened. So we sure that this is not fiber cable problem and SFP Gibics is OK.
In last experiment;
3) Connecting fiber line which is come from Alcatell Metro Switch to netgear GSM7212 SFP port. Then connect CCR one gigabit port to GSM7212 gigabit ethernet port. So GSM7212 act as bridge. In this case there are NO any ICMP loss happened. And i test several time with no even one packet loss. Connection represented below;
Alcatel MPLS 7750 (SFP) ------> (SFP) Netgear GSM7212 (Gigabit ethernet) ---> (Gigabit ethernet) Mikrotik CCR

While we did this test i used RouterOS v6.27. Then 10 days ago i new RouterOS released so i want to test today if v6.28 fix this issue.

However this strange problem is consistent. Additionaly we test several different kind of SFP and nothing is changed.

Still we have packet loss.
Could tou suggest some advise to me how can we fix it?
Devrim Seral

Re: CCR1036-12G-4S SFP port Strange behaviour

Posted: Sat May 16, 2015 1:16 pm
by bmv

We're also getting 4-7% packet loss using S-31DLC20D and CCR1036-12G-4S.

SFP1: S-85DLC05D (MM multimode)
SFP2: S-31DLC20D (SM single mode)

I posted a new article on this yesterday:

Our problems started after the CCR was powered off incorrectly after a mains power outage.
Once it came back up we have this packet loss.

We're not getting packet loss via the MM SFP.
It's just to the b-end of the SM SFP.

At the B-end of the SM SFP we have a RB1100AHx2 - however we are using a UBNT EdgeSwitch with a S-31DLC20D SFP fitted.

So does this sounds like an SFP failure rather than a CCR failure??
We could swap the SFP over.

This is the second time this has happened to us following a power cut.