Community discussions

 
kevinM
just joined
Topic Author
Posts: 12
Joined: Mon Jul 28, 2014 8:57 pm

how to send AT commands to EC25 LTE modem in LTAP Mini

Fri Jul 12, 2019 11:26 pm

I am trying to get the EC25 LTE modem to run in LTE mode. By default is appears to run as PPP, I read the forum below stating i need to send it an AT command to switch into lte but it doesn't specify how to do that and i'm new to LTE. Can someone please assit me, i'm running 6.44.3 version with EC25-V modem.

https://wiki.mikrotik.com/wiki/Cellular ... _modems_01
 
kevinM
just joined
Topic Author
Posts: 12
Joined: Mon Jul 28, 2014 8:57 pm

Re: how to send AT commands to EC25 LTE modem in LTAP Mini

Mon Jul 15, 2019 6:54 pm

any help here???
 
User avatar
Exiver
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Sat Jan 10, 2015 6:45 pm
Location: Germany

Re: how to send AT commands to EC25 LTE modem in LTAP Mini

Mon Jul 15, 2019 7:25 pm

In RouterOS v6.39 and newer the EC25-MiniPCIe module can be configured as a LTE Interface which can support local IP address from modem. Use this AT command to enable it and after that reset the module: at+qcfg="usbnet",1
Source: https://wiki.mikrotik.com/wiki/Cellular ... 01#Summary
It is possible to send user defined "at-chat" command to LTE interface with /interface lte at-chat command.
Source: https://wiki.mikrotik.com/wiki/Manual:I ... at_command
 
Amm0
just joined
Posts: 10
Joined: Sun May 01, 2016 7:12 pm

Re: how to send AT commands to EC25 LTE modem in LTAP Mini

Mon Jul 15, 2019 7:29 pm

I have gotten it working in PPP and LTE mode, so it's possible. I'll write up what I know in case that helps.

If it doesn't show up as an LTE modem, the "at-chat" option isn't the only way to issue AT commands, which I think is your problem since it's a catch-22 if the module isn't in ECM mode, it won't show up as LTE, and if there isn't an LTE interface "at-chat" don't work.

But you can always use "/system serial-terminal port=XXX channel=X" to enter the commands from the Quectel wiki page; if you use "/ports print" you'd get the need port#, and I think it its channel=0 but you can try multiple ones. From the serial-terminal to the card you should be able to enter the AT commands mentioned to set the CDC mode (e.g. PPP or LTE in Mikrotik terms, or PPP or ECM in USB driver world

But you may not want LTE mode as the card will act as it own router and do it's own NAT'ing on the miniPCIe, outside of the Mikrotik firewall (e.g. after the Mikrotik routing plane). This wasn't helpful in my case, since I had a static IP address I wanted available to the Mikrotik, so I ended up using PPP mode. Now would have rather used LTE mode (to avoid the ~30Mb/s limit of PPP), but Quectel support told a few months ago: "With ECM mode (AT + QCFG = "usbnet", 1) [e.g. LTE mode on Mikrotik], the connection will work via NAT, so the module will provide it's own local ip address to mikrotik (not the network one)".

For completeness, the USB integration modes available on the EC25 are:

AT+QCFG="usbnet",0 - is PPP & QMI (default)
AT+QCFG="usbnet",1 - is ECM.
AT+QCFG="usbnet",2 - is MBIM

While Quectel EC25 supports QMI and MBIM mode, neither are currently supported by Mikrotik. MBIM mode is what ROS v7 is promised to bring, and would make this a lot easier than AT commands. PPP mode is what I'd recommend, but you can get working in LTE mode if you use /system serial-terminal to set the needed AT+QCFG="usbnet",1 command if you want to try, and you can use AT+QCFG="usbnet",0 to get it back to working in PPP mode.

Finally, if you need to get RSRP, SINR, or RSRQ from the module, then use AT+QENG="servingcell".

Hope this helps.
 
kevinM
just joined
Topic Author
Posts: 12
Joined: Mon Jul 28, 2014 8:57 pm

Re: how to send AT commands to EC25 LTE modem in LTAP Mini

Mon Jul 15, 2019 8:37 pm

I have gotten it working in PPP and LTE mode, so it's possible. I'll write up what I know in case that helps.

If it doesn't show up as an LTE modem, the "at-chat" option isn't the only way to issue AT commands, which I think is your problem since it's a catch-22 if the module isn't in ECM mode, it won't show up as LTE, and if there isn't an LTE interface "at-chat" don't work.

But you can always use "/system serial-terminal port=XXX channel=X" to enter the commands from the Quectel wiki page; if you use "/ports print" you'd get the need port#, and I think it its channel=0 but you can try multiple ones. From the serial-terminal to the card you should be able to enter the AT commands mentioned to set the CDC mode (e.g. PPP or LTE in Mikrotik terms, or PPP or ECM in USB driver world

But you may not want LTE mode as the card will act as it own router and do it's own NAT'ing on the miniPCIe, outside of the Mikrotik firewall (e.g. after the Mikrotik routing plane). This wasn't helpful in my case, since I had a static IP address I wanted available to the Mikrotik, so I ended up using PPP mode. Now would have rather used LTE mode (to avoid the ~30Mb/s limit of PPP), but Quectel support told a few months ago: "With ECM mode (AT + QCFG = "usbnet", 1) [e.g. LTE mode on Mikrotik], the connection will work via NAT, so the module will provide it's own local ip address to mikrotik (not the network one)".

For completeness, the USB integration modes available on the EC25 are:

AT+QCFG="usbnet",0 - is PPP & QMI (default)
AT+QCFG="usbnet",1 - is ECM.
AT+QCFG="usbnet",2 - is MBIM

While Quectel EC25 supports QMI and MBIM mode, neither are currently supported by Mikrotik. MBIM mode is what ROS v7 is promised to bring, and would make this a lot easier than AT commands. PPP mode is what I'd recommend, but you can get working in LTE mode if you use /system serial-terminal to set the needed AT+QCFG="usbnet",1 command if you want to try, and you can use AT+QCFG="usbnet",0 to get it back to working in PPP mode.

Finally, if you need to get RSRP, SINR, or RSRQ from the module, then use AT+QENG="servingcell".

Hope this helps.
Thanks Amm0.

I did try using the serial terminal as I read that in another forum post, but when I get in I cant seem to type any commands. Only channel 0 responds. At first all i see is [Ctrl-A is the prefix key]. If I try and type anything is doesn't respond or print it out on the screen. If I hit Ctrl-A then I get these options:
[Q - quit connection]
[A - send Ctrl-A prefix] [R - autoconfigure rate]

At this point I still cant type anything and only Ctrl-A resopnds and just reprints the same options. THis is where i'm stuck...

[admin@MikroTik] > system serial-terminal port=usb2 channel=0
[Ctrl-A is the prefix key]

[Q - quit connection]
[A - send Ctrl-A prefix] [R - autoconfigure rate]
 
Amm0
just joined
Posts: 10
Joined: Sun May 01, 2016 7:12 pm

Re: how to send AT commands to EC25 LTE modem in LTAP Mini

Mon Jul 15, 2019 11:22 pm

For the Quectel EC25-V, you need to use channel 2 or 3 in "/system serial-terminal usbX channel=2" where X is the /port for the EC25. You shouldn't need to use Ctrl-A until you want to get back to the Mikrotik console (e.g. Ctrl-A, then Q).

So if you used channel 0, it would connect but doesn't understand AT commands. I think if you use channel=2 you'd be set. Also you want to make sure any ppp-client is disabled as that would use the port you need to connect on. (/port print will show if being used by something)

The EC25-V USB channels are:
0 = debug ("DM")
1 = NMEA (GPS)
2 = AT commands
3 = PPP (or normal AT)

For PPP mode, you need to set the info channel to "2" and data channel to "3", as per the Quectel wiki link. While LTE mode will take care of the channels for you... it will be NAT'ed similar to plugging in a USB hotspot, while PPP mode will get IP directly from the carrier's network.
 
kevinM
just joined
Topic Author
Posts: 12
Joined: Mon Jul 28, 2014 8:57 pm

Re: how to send AT commands to EC25 LTE modem in LTAP Mini

Tue Jul 16, 2019 1:14 am

Amm0 your a life saver. I got the device into lte mode for testing, thank you.

The device natting in LTE mode is not a concern as we only need it for basic internet access. It wasn't allowing me to terminal into any channels other then 0 until I set "port firmware set ignore-directip-modem=yes" and rebooted. After I did that I was able to terminal into the other channels and issue the command. Then I set "port firmware set ignore-directip-modem=no" and rebooted and the LTE interface showed up and connected to verizon.

thank you again my friend!

Who is online

Users browsing this forum: No registered users and 8 guests