Community discussions

MikroTik App
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

CAPsMAN 5G doesn't work

Mon Apr 05, 2021 6:32 am

Hello all.

Ok, so after a lot of false positives and false negatives, I came to the conclusion that my CAPsMAN isn't broadcasting in the 5G band.
I have two screenshots of Winbox indicating my 5G networks should be broadcasting (as I understand it), but they aren't.
To show that they are certainly not transmitting, I have a screenshot of my Android running "Wi-Fi Analyzer" and - even better, a HackRF running a scanner - both show nothing whatsoever in the range my AP should be broadcasting.

Anyway, if "running up" doesn't mean broadcasting, I should point out that they spend most of their time like this - and I can't ever seem to find my SSID broadcasting in the 5GHz band.

Attached also my /caps-man export hide-sensitive.

Now the question is: how do I get it to work?
You do not have the required permissions to view the files attached to this post.
 
User avatar
rushlife
Member Candidate
Member Candidate
Posts: 168
Joined: Thu Nov 05, 2015 12:30 pm
Location: czech republic

Re: CAPsMAN 5G doesn't work

Mon Apr 05, 2021 9:27 am

you don't have defined any channels
 
User avatar
rushlife
Member Candidate
Member Candidate
Posts: 168
Joined: Thu Nov 05, 2015 12:30 pm
Location: czech republic

Re: CAPsMAN 5G doesn't work

Mon Apr 05, 2021 9:30 am

pls edit with rules for your country
You do not have the required permissions to view the files attached to this post.
 
erlinden
Forum Veteran
Forum Veteran
Posts: 795
Joined: Wed Jun 12, 2013 1:59 pm

Re: CAPsMAN 5G doesn't work

Mon Apr 05, 2021 10:43 am

On the screenshots I see Quickset, forget about quickset (unless you are using it for getting information).
WPA should never ever be used anymore (and MikroTik should get rid of any screenshot using WPA), only use WPA2 and AES only.
Choose your channels (or use lists as mentioned by rushlife), for 80 MHz width you can select:
5180, 5260, 5500, 5580*, 5660, 5745 (* not sure for your country).
Be aware that some channels could take up to 10 minutes (radar detection) before coming available. And...not all clients do support DFS channels.
First the problem, then the solution
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Mon Apr 05, 2021 4:54 pm

Hello again,

Thanks for the comments.

Why is it that I have to set a list of available channels when using CAPsMAN? If I don't use CAPsMAN, it automatically used the channels available for the selected country. After enabling CAPsMAN, why do I have to manually set a list of channels? Also, why the hell does it say it's transmitting while it's not? Aren't these bugs?!

As for quickset, it's too much of a hassle to change between PPPoE and straight DHCP (without authentication) modes, so I just use quickset because of that (I was receiving a technician from my ISP like every week before they found out the problem was in their own network, and I had to keep changing their modem between router mode - for them to check their own stuff, and bridge - for me to get rid of their terrible router).
Thanks for the call on WPA - normally I disable it, but this time I forgot. Probably got reactivated when I used quickset to change the connection mode.

I'll search for a list of supported channels in my country and if it doesn't solve my problems, I'll come back.

Thank you very much again!

(But I still think having to manually define channels for CAPsMAN is a bug!)
 
erlinden
Forum Veteran
Forum Veteran
Posts: 795
Joined: Wed Jun 12, 2013 1:59 pm

Re: CAPsMAN 5G doesn't work

Mon Apr 05, 2021 5:25 pm

(But I still think having to manually define channels for CAPsMAN is a bug!)
You don't have to define channels (CAPsMAN can do auto), but you should want to. Good luck
First the problem, then the solution
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Mon Apr 05, 2021 5:30 pm

You don't have to define channels (CAPsMAN can do auto), but you should want to. Good luck

Well I surely prefer auto, but why isn't it working then?
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Tue Apr 06, 2021 4:24 pm

And even setting manual channels, it still doesn't really transmit - even though it shows up as "running-ap". 🤷‍♂️
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 2.5G works, 5G doesn't

Thu Apr 08, 2021 6:14 pm

I'm still struggling here.
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 2.5G works, 5G doesn't

Fri Apr 09, 2021 12:57 am

I'm still struggling here.
From the screenshots above, your capsman has selected invalid channels. Devices will not generally find these non standard channels. We have had this happen sometimes and the result is that only macbook pros are able to connect up to the wireless on the non standard channel and no phones or other laptops or tablets seem to work.

I complained to MikroTik in a support ticket that CAPsMAN will select invalid channels and they have not responded yet. The workaround I have found, if you wish to use auto channels, is to force the extension channel setting to Ceee instead of the default "XXXX". XXXX works fine when not using CAPsMAN, but when using CAPsMAN sometimes it will choose something like eCee 5660 which won't work because the 80MHz channel is shifted by 20MHz from where the devices will be searching for it.
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 2.5G works, 5G doesn't

Fri Apr 09, 2021 3:57 am

Devices will not generally find these non standard channels.
Thanks for taking the time to answer, but I think you got it wrong.

It's not a matter of transmitting in the wrong channel/wrong standard. The HackRF + PortaPack photo shows it's not even transmitting AT ALL. It's completely blue (pure noise), whereas any signal should be green. And there's no signal at all except for my neighbours' 5G routers in the lower part of the spectrum. :(
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 2.5G works, 5G doesn't

Fri Apr 09, 2021 4:30 am

It's not a matter of transmitting in the wrong channel/wrong standard. The HackRF + PortaPack photo shows it's not even transmitting AT ALL. It's completely blue (pure noise), whereas any signal should be green. And there's no signal at all except for my neighbours' 5G routers in the lower part of the spectrum. :(
I know the CAPsMAN interface doesn't have the R beside it, but it won't show as running with nobody connected. I haven't actually tested with an RF meter, but with no clients connected it might be in a low power mode where all it does is beacon from time to time and listen for client connections. It could also be that the wrong channel selection is causing it to not transmit at all.

I am saying that the channel selection it is making is invalid (I checked both screenshots to be sure), and that is the only problem I can see. I am not guessing it is invalid, I verified that it is invalid. If you refuse to believe that could possibly be the problem, such that you refuse to even try it, then you don't really seem to care about fixing your problem.

If you do actually want to fix your problem, try hard setting the extension channel to Ceee, reprovision your radios, and paste what channel selection they have made.
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 6:06 am

You are right, I did not.

I had tested before with other combinations, but it still didn't work. But at the time I tried other combinations, I did not check out with the spectrum analyzer.

I tried setting to Ceee as you said, and my phone still doesn't detect the network. Neither does my Hackintosh.
The spectrum analyzer though, detects some short blips on the primary frequency (it chose 5550/20 and 5660/80 this time) every few seconds. Very faint, very short, kinda semi-randomly spaced in time.
You do not have the required permissions to view the files attached to this post.
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 6:14 am

The spectrum analyzer though, detects some short blips on the primary frequency (it chose 5550/20 and 5660/80 this time) every few seconds. Very faint, very short, kinda semi-randomly spaced in time.
I suspect those are probably beacons. MikroTik has never added support for choosing the beacon interval and that makes me suspect it could potentially be random.

Please export your entire capsman config and paste here, and also show screenshots or copy and paste text of the "current channel" from the status tab of the 5GHz cap interfaces ex:

"5180/20-Ceee/ac/P(23dBm)"
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 7:13 am

First off, you have no idea how I'm glad you're taking the time to help. These forums, Reddit and all, are more like an exercise on self learning. But if nobody had your problem before, you're screwed.

CAPsMAN status is:
On main router: 5550/20-Ceee/Ac/DP(15dBm)+5660/80/DP(15dBm)
CAP: 5550/20-Ceee/ac/DP(15dBm)+5660/80/DP(15dBm)

Also, if I try to use "CAPs Scanner", it resets all wireless interfaces (including 2.5GHz). Tried it now and it even crashed (closed) my Winbox.

Export is:
# apr/09/2021 01:02:06 by RouterOS 6.48.1
# software id = H4EN-32RB
#
# model = RB4011iGS+5HacQ2HnD
# serial number = 96890A123C45
/caps-man channel
add band=5ghz-n/ac control-channel-width=20mhz extension-channel=Ceee \
    frequency=5170,5190,5230,5270,5310,5510,5550,5590,5630,5660,5755,5795 \
    name=5GHz-n-ac secondary-frequency=\
    5170,5190,5230,5270,5310,5510,5550,5590,5630,5660,5755,5795
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm \
    name=security
/caps-man configuration
add channel.band=2ghz-b/g/n channel.control-channel-width=20mhz \
    channel.extension-channel=XX country=brazil-anatel \
    datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes \
    name=cfg-2ghz security=security ssid=Bifrost
add channel=5GHz-n-ac country=brazil-anatel \
    datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes \
    name=cfg-5ghz-ac security=security ssid=Bifrost
add channel=5GHz-n-ac country=brazil-anatel \
    datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes \
    name=cfg-5ghz-an security=security ssid=Bifrost
/caps-man manager
set enabled=yes
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=bridge
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=\
    cfg-2ghz name-format=prefix-identity name-prefix=2ghz
add action=create-dynamic-enabled hw-supported-modes=ac master-configuration=\
    cfg-5ghz-ac name-format=prefix-identity name-prefix=5ghz-ac
add action=create-dynamic-enabled hw-supported-modes=an master-configuration=\
    cfg-5ghz-an name-format=prefix-identity name-prefix=5ghz-an
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 7:27 am

/caps-man channel
add band=5ghz-n/ac control-channel-width=20mhz extension-channel=Ceee \
    frequency=5170,5190,5230,5270,5310,5510,5550,5590,5630,5660,5755,5795 \
    name=5GHz-n-ac secondary-frequency=\
    5170,5190,5230,5270,5310,5510,5550,5590,5630,5660,5755,5795
Clear the entire secondary-frequency and frequency list, so that when you export, you only get this for caps-man channel:
/caps-man channel
add band=5ghz-n/ac control-channel-width=20mhz extension-channel=Ceee name=5GHz-n-ac
The secondary-frequency can cause problems for some devices and the main frequency table you have is not correct (ex. 5170 and 5190 are not valid, 5180 is).

The only use for secondary-frequency is if you need more than an 80MHz channel but I think that is not a major concern at the moment given that you are simply trying to get this working.
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 7:40 am

That is how it was in the beginning (config.rsc is attached in the first post).

I cleared it again and I'm waiting for it to scan for radars because I want to check with the spectrum analyzer (which I didn't at the time), but I suspect it'll just beacon at best. It wasn't working back then.

By the way, I think it's a bug that the thing is not transmitting and it still shows as "running-ap" in status.

There are quite a few complaints of mine on another thread about - what I think are - bugs. How does one report them? I see no official channel for reporting bugs.

Edit: Yep, not running. No beacons.
Main: 5740/20-Ceee/ac(15dBm)+5570/80/DP(15dBm)
AP: 5740/20-Ceee/ac(15dBm)+5570/80/DP(15dBm)
Last edited by ghamauricio on Fri Apr 09, 2021 7:49 am, edited 1 time in total.
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 7:45 am

That is how it was in the beginning (config.rsc is attached in the first post).
No, it isn't exactly the same as how it was in the beginning:

channel.extension-channel=XXXX

In your first post, you had that set. The issue is that I have found that XXXX extension channel can cause major issues when using CAPsMAN but it works fine when not using CAPsMAN. XXXX means randomized Ceee or eCee or eeCe or eeeC. When not using CAPsMAN, the XXXX option seems to properly choose one of those four options depending on the selected frequency, but when using CAPsMAN it has a tendency to select one of the four options that is not compatible with the chosen frequency.
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 7:51 am

Yes, indeed! I forgot that. Sorry!
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 7:52 am

Main: 5740/20-Ceee/ac(15dBm)+5570/80/DP(15dBm)
AP: 5740/20-Ceee/ac(15dBm)+5570/80/DP(15dBm)
You shouldn't have this +5570/80/DP(15dBm)

That means you have a secondary-frequency enabled, which isn't compatible with all situations.
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 7:56 am

Well previously I even tried with extension channel "disabled". Tried again now. Still no go.

5800/20/ac(15dBm)
5740/20/ac(15dBm)

Wait, maybe I have some beacons, but they are extremely weak and curiously not really centered around the same frequency (maybe 5MHz for this or that side randomly), but this could be just noise.
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 8:10 am

Wait, maybe I have some beacons, but they are extremely weak and curiously not really centered around the same frequency (maybe 5MHz for this or that side randomly), but this could be just noise.
Try upgrading RouterOS and also make sure that your routerboard firmware is upgraded via system->routerboard. Then, check to make sure the Upgrade Firmware is the same as the Current Firmware. If they are not, then click the button to upgrade the firmware and reboot.

After doing that if it still doesn't work, see if you have the same issue if you take the 5ghz interface out of CAPsMAN and set it up manually. You may have a defective device if you have the same issue with the 5GHz interface when not using CAPsMAN.
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 8:15 am

/caps-man manager interface
set [ find default=yes ] forbid=yes
On mine this is forbid=no, I think forbid=yes is incorrect. But I'm not sure that is related to your issue here.
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 9:08 am

First, before I changed any config, I decided to see if your suggestions on the changes of settings would allow me to use CAP Scanner. I managed to use it to scan, both from the main CAPs-MAN and from the AP. INTERESTINGLY ENOUGH, they both showed/detected my SSID. Don't know if they detect their own, but both could see my SSID.

I disabled CAPs-MAN from the AP and enabled the wlan1 interface. I was not able to find the network, even though it showed as transmitting. I decided to factory reset the AP, and here's the second weird part: after factory reset my cell phone managed to see the 5G network, and so did my mac. I managed to connect to it (5GHz for sure), and the Wi-Fi Analyzer app was showing it a few moments ago, but it's not showing anymore. My cellphone and computer also disconnected and cannot find it anymore. In Winbox it still shows as running, although sometimes it hops from channel to channel quite rapidly (even though it's not doing this now, after dropping my cellphone and disappearing).

And the weirdest part: all this time (while my cell phone and Hackintosh) managed to connect to this network, the spectrum analyzer was blank. Maybe some beacons.

And while I write this, the SSID is back online. Both my cell and computer connected to it, and the HackRF shows beacons at best.

Maybe it was still initialising the interface, I don't know. But it seems to be stable now (stable, but not managed by CAPsMAN, mind you).
You do not have the required permissions to view the files attached to this post.
Last edited by ghamauricio on Fri Apr 09, 2021 9:42 am, edited 1 time in total.
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Fri Apr 09, 2021 9:36 am

Forgot to tell you that they're up to date since day one, Rboard fw included!

I also changed the forbid thing. It was in Mikrotik's "example tutorial". I think it doesn't change much is your don't have another CAPsMAN on the network. But it's allowed now.
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Sat Apr 10, 2021 5:33 am

Forgot to tell you that they're up to date since day one, Rboard fw included!

I also changed the forbid thing. It was in Mikrotik's "example tutorial". I think it doesn't change much is your don't have another CAPsMAN on the network. But it's allowed now.
If you reset it and it is working now without CAPsMAN you can try reapplying the most recent capsman config (the one after the edits we were making should work fine) and enabling that and see what happens. Make sure to set extension channel to Ceee or Ce or none (depending on what channel size you want).
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 2:06 am

The problem is that the router (the CAPs Manager) is now working with this new CAPsMAN config we came to, but the CAP itself isn't (again, only the 5Ghz network).

And when I reset it, it created double NAT and all that stuff which I don't want. When setting it back to CAP (by going to System > Reset Config > CAPs Mode), it still doesn't work.

Setting up any other way, I didn't manage to get it to bride ports and have it working as a CAP is supposed to. I'm just not really a networking guy, I'm still learning with this homelab. :(
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 2:27 am

The problem is that the router (the CAPs Manager) is now working with this new CAPsMAN config we came to, but the CAP itself isn't (again, only the 5Ghz network).
What cap device are you using and what frequency has it selected on 5GHz?
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 4:22 am

I'm running two RB4011iGS+5HacQ2HnD-IN, one as CAPsMAN and the other as CAP.

It was way cheaper then buying a switch and a wireless-capable device, and saved me a lot of space and cables/wires.

CAPsMAN is running 5500/20-Ceee/ac/DP(15dBm)+5770/80(15dBm). Seems to be working.
CAP is running 5740/20-Ceee/ac(15dBm)+5610/80/DP(15dBm). No clients connected, and I'm sitting right next to it and can't find it in my Android Wi-Fi Analyser.
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 4:32 am

I'm running two RB4011iGS+5HacQ2HnD-IN, one as CAPsMAN and the other as CAP.

It was way cheaper then buying a switch and a wireless-capable device, and saved me a lot of space and cables/wires.

CAPsMAN is running 5500/20-Ceee/ac/DP(15dBm)+5770/80(15dBm). Seems to be working.
CAP is running 5740/20-Ceee/ac(15dBm)+5610/80/DP(15dBm). No clients connected, and I'm sitting right next to it and can't find it in my Android Wi-Fi Analyser.
Is the routerboot firmware upgraded in the CAP as well? That is sometimes important depending on what frequency it chooses. Ideally disable the secondary frequency - most people don't really need 160MHz and it can cause issues, 80MHz is fine.

You'll know the secondary frequency is disabled when you no longer see the + symbol in the selected channel.
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 4:59 am

Yep, everything is up-to-date since day 1 (which is like two weeks ago - and I also just checked again to see if there were any updates).

Changing to disabled and to Ce, I can't seem to find even the CAPsMAN's SSID.

5740/20-Ce/ac(15dBm)
5780/20-Ce/ac(15dBm)

It's been at least 5 minutes they both finished the radar scanning and are "running ap".
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 5:07 am

It's been at least 5 minutes they both finished the radar scanning and are "running ap".
Both of those are outdoor frequencies, at least in many countries - in the CAPsMAN->Configurations tab, double click on your config, and make sure the country is properly set, and installation is set to "indoor".
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 5:25 am

Ok, setting to indoor, the CAPsMAN came back. Nothing from CAP.

Which is weird. Isn't my cellphone allowed to connect to outdoors Wi-Fi stations?! 🤔

Signal strength was also too weak, so I enabled Ceee again.

Here's the CAP export hide-sensitive, in case you're curious.
# apr/10/2021 23:23:26 by RouterOS 6.48.1
# software id = 0FDY-HJ9L
#
# model = RB4011iGS+5HacQ2HnD
# serial number = 96890A3CEFEB
/interface bridge
add admin-mac=74:4D:28:4A:FE:6A auto-mac=no comment=defconf name=bridgeLocal
/interface wireless
# managed by CAPsMAN
set [ find default-name=wlan1 ] ssid=MikroTik
# managed by CAPsMAN
# channel: 2412/20-Ce/gn/P(17dBm), SSID: Bifrost, local forwarding
set [ find default-name=wlan2 ] disabled=no ssid=MikroTik
/interface ethernet switch port
set 0 default-vlan-id=0
set 1 default-vlan-id=0
set 2 default-vlan-id=0
set 3 default-vlan-id=0
set 4 default-vlan-id=0
set 5 default-vlan-id=0
set 6 default-vlan-id=0
set 7 default-vlan-id=0
set 8 default-vlan-id=0
set 9 default-vlan-id=0
set 10 default-vlan-id=0
set 11 default-vlan-id=0
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridgeLocal comment=defconf interface=ether1
add bridge=bridgeLocal comment=defconf interface=ether2
add bridge=bridgeLocal comment=defconf interface=ether3
add bridge=bridgeLocal comment=defconf interface=ether4
add bridge=bridgeLocal comment=defconf interface=ether5
add bridge=bridgeLocal comment=defconf interface=ether6
add bridge=bridgeLocal comment=defconf interface=ether7
add bridge=bridgeLocal comment=defconf interface=ether8
add bridge=bridgeLocal comment=defconf interface=ether9
add bridge=bridgeLocal comment=defconf interface=ether10
add bridge=bridgeLocal comment=defconf interface=sfp-sfpplus1
/interface wireless cap
# 
set bridge=bridgeLocal discovery-interfaces=bridgeLocal enabled=yes \
    interfaces=wlan1,wlan2
/ip dhcp-client
add comment=defconf disabled=no interface=bridgeLocal
/system clock
set time-zone-name=America/Bahia
/system identity
set name=Himinbjorg
/system leds
add interface=wlan2 leds="wlan2_signal1-led,wlan2_signal2-led,wlan2_signal3-le\
    d,wlan2_signal4-led,wlan2_signal5-led" type=wireless-signal-strength
add interface=wlan2 leds=wlan2_tx-led type=interface-transmit
add interface=wlan2 leds=wlan2_rx-led type=interface-receive
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 5:33 am

For some magical reason, after setting them both to indoors and setting extension back to Ceee, they're both working. 🤔

5500/20-Ceee/ac/DP(15dBm)+5610/80/DP(15dBm)
5580/20-Ceee/ac/DP(15dBm)+5530/80/DP(15dBm)

I'll keep an eye on this, and if they ever stop working again, I'll check out their frequencies and post here again.
But I'd really like to understand what was going on...
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 5:47 am

I'll keep an eye on this, and if they ever stop working again, I'll check out their frequencies and post here again.
But I'd really like to understand what was going on...
You are still using secondary channels and probably don't need to be.

Also, I don't know enough about wifi regulations in Brazil, but it looks like they block a bunch of channels that are available in most other countries (aside from South Africa):

https://en.wikipedia.org/wiki/List_of_W ... j/n/ac/ax)

It is fairly likely that some of these issues are caused by the fact that the AP is selecting a channel that the CPE device (phone, tablet, laptop) believes it is not allowed to use. I don't know enough about the regulations in your country to know what is correct. But I see there are four different brazils: brazil, brazil-922, brazil-anatel, and brazil direct. I'm guessing you may potentially be using the wrong one of those four choices (either that or MikroTik did not properly configure the frequency lists for that country setting).
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 6:01 am

It does make sense, and I had thought about that.
But it also doesn't make much sense that my cellphone wouldn't be able to connect - after all, nothing stops me from buying a cellphone in Brazil and using it in some other country. The client doesn't need to be permanently capped, as long as stations don't transmit in forbidden frequencies in a given territory.

Anyway, I had filled in manually all channels I found available in that Wikipedia article. I don't know which of Mikrotik's preset contains those (or even if a single preset contains all frequencies). But I found this on another thread (viewtopic.php?t=101470), and so I chose the one with the most frequencies.

If the phone is permanently capped (and the router is choosing a frequency that the client can't see), that could explain a lot of my problems here.
[admin@Main_GW] > in wire info country-info brazil-anatel
ranges: 2402-2482/b,g,gn20,gn40(20dBm)/passive
5170-5250/a,an20,an40,ac20,ac40,ac80,ac160(10dBm)/passive
5250-5330/a,an20,an40,ac20,ac40,ac80,ac160(10dBm)/passive
5490-5710/a,an20,an40,ac20,ac40,ac80,ac160(15dBm)/passive
5730-5845/a,an20,an40,ac20,ac40,ac80,ac160(15dBm)

[admin@Main_GW] > in wire info country-info brazil-922
ranges: 912-932/b,g,gn20,gn40(30dBm)

[admin@Main_GW] > in wire info country-info "brazil direct"
ranges: 2402-2472/b,g,gn20,gn40(36dBm)/passive
2417-2457/g-turbo(36dBm)
5730-5845/a,an20,an40,ac20,ac40,ac80,ac160(36dBm)
5740-5820/a-turbo(36dBm)
But the weirdest part is that without CAPsMAN, I never seemed to have problems with the 5GHz band.

If I ever catch them not transmitting again (or, actually, my cell phone not detecting the 5G network), I'll try to change the country regulation.

Thank you so very much for your patience and good will. I wish I could buy you a beer (or wine, if you prefer). lol
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 6:19 am

But the weirdest part is that without CAPsMAN, I never seemed to have problems with the 5GHz band.
It is not too surprising to me unfortunately. It seems that CAPsMAN is not quite as smart as the regular wireless setup when it comes to only selecting channels that will be supported by the devices. For instance, I have never had a single problem with the extension channel XXXX setting when not using CAPsMAN, but when using CAPsMAN on auto if I have extension channel set to XXXX it will sometimes choose frequencies that are offset from the proper ones so that devices will never find them (ex. 80MHz channel offset by 20 or 40MHz from where it is supposed to be). For whatever reason that doesn't seem to happen when I set Ceee with CAPsMAN instead. When I am not using CAPsMAN, I use XXXX instead of Ceee, but I only use Ceee with CAPsMAN due to these issues.
 
mducharme
Trainer
Trainer
Posts: 1286
Joined: Tue Jul 19, 2016 6:45 pm

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 6:28 am

Also, comparing brazil with brazil-anatel:
[admin@Michael-RB4011] > in wireless info country-info brazil
  ranges: 5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/passive,indoor
          5250-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/dfs,passive
          5490-5710/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(30dBm)/dfs,passive
          5190-5230/a-turbo(20dBm)/dfs,indoor
          5740-5820/a-turbo(30dBm)/outdoor
          5180-5220/a-turbo(20dBm)/dfs,indoor
          5745-5825/a-turbo(30dBm)/dfs,outdoor
          2402-2482/b,g,gn20,gn40(30dBm)/passive
          2417-2457/g-turbo(30dBm)
          5730-5845/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(30dBm)/outdoor
          907-932/b,g,g-turbo,gn20,gn40(30dBm)

[admin@Michael-RB4011] > in wireless info country-info brazil-anatel
  ranges: 2402-2482/b,g,gn20,gn40(20dBm)/passive
          5490-5710/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(15dBm)/dfs,passive
          5730-5845/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(15dBm)/outdoor
          900-910/b,g,g-turbo,gn20,gn40(30dBm)
          913-928/b,g,g-turbo,gn20,gn40(30dBm)
          915-928/b,g,g-turbo,gn20,gn40(30dBm)
brazil-anatel doesn't seem to allow use of the regular indoor frequencies. I suspect you should probably be using just plain "brazil" instead.
 
ghamauricio
newbie
Topic Author
Posts: 40
Joined: Sat Jan 09, 2016 2:20 am

Re: CAPsMAN 5G doesn't work

Sun Apr 11, 2021 7:34 am

Ooo, nice find!

I didn't find what plain "Brazil" meant, and "Brazil-Anatel" was the best candidate until now.
Changing to Brazil right now.

I have a feeling this was the source of 90% of my problems.

Thank you so very much again, mate!

Who is online

Users browsing this forum: No registered users and 49 guests