Community discussions

MikroTik App
 
HAL9OOO
just joined
Topic Author
Posts: 4
Joined: Wed Apr 14, 2021 10:55 pm

Guest Dhcp server relay

Tue Apr 20, 2021 9:24 pm

Atempting to set up a manual repeater setup with 2 audience routers. Also need a guest network on separate subnet. Have configured new dhcp servewre on main AP and set up relay on repeater but cannot get addresses from guestDhcp server.
Main Ap config
# apr/20/2021 13:58:31 by RouterOS 6.48.2
# software id = VZAH-VDVR
#
# model = RBD25G-5HPacQD2HPnD
# serial number = BB0C0A755642
/interface bridge
add admin-mac=74:4D:28:F9:1D:C5 auto-mac=no comment=defconf name=bridge
add name=guestBridge
/interface wireless
set [ find default-name=wlan1 ] disabled=no mode=ap-bridge ssid=\
    "Oak and Iron" wireless-protocol=802.11 wps-mode=disabled
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk group-ciphers=\
    tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
    unicast-ciphers=tkip,aes-ccm
add authentication-types=wpa2-psk comment=defconf disable-pmkid=yes \
    group-ciphers=tkip,aes-ccm mode=dynamic-keys name=wpsSync \
    supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm
add authentication-types=wpa2-psk mode=dynamic-keys name=Guest \
    supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm
/interface wireless
set [ find default-name=wlan2 ] mode=ap-bridge security-profile=Guest ssid=\
    "Guest Oak and Iron" wireless-protocol=802.11 wps-mode=disabled
set [ find default-name=wlan3 ] band=5ghz-a/n/ac channel-width=20/40mhz-XX \
    disabled=no mode=ap-bridge security-profile=wpsSync ssid=oaiconnect \
    wireless-protocol=802.11 wps-mode=disabled
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
add name=GuestPool ranges=192.168.1.10-192.168.1.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
add address-pool=GuestPool disabled=no interface=guestBridge name=\
    GuestDHCPServer src-address=192.168.88.2
add address-pool=GuestPool disabled=no interface=guestBridge name=server1 \
    relay=192.168.1.2 src-address=192.168.1.1
/caps-man manager
set enabled=yes
/caps-man manager interface
set [ find default=yes ] forbid=yes
add comment=defconf disabled=no interface=bridge
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge interface=wlan3
add bridge=bridge interface=wlan1
add bridge=guestBridge interface=wlan2
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/interface wireless cap
set bridge=bridge caps-man-addresses=127.0.0.1 interfaces=wlan1,wlan2
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
    192.168.88.0
add address=192.168.1.1/24 interface=guestBridge network=192.168.1.0
/ip dhcp-client
add comment=defconf disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat out-interface=guestBridge src-address=\
    192.168.1.0/24
/system clock
set time-zone-name=America/New_York
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Repeater config
# apr/20/2021 13:59:01 by RouterOS 6.48.2
# software id = RI47-YSMC
#
# model = RBD25G-5HPacQD2HPnD
# serial number = BB0C0A47EB7A
/interface bridge
add admin-mac=74:4D:28:F9:1D:B5 auto-mac=no comment=defconf name=bridgeLocal
/interface wireless
set [ find default-name=wlan1 ] disabled=no mode=ap-bridge ssid=\
    "Oak and Iron"
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" \
    group-ciphers=tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
    unicast-ciphers=tkip,aes-ccm
add authentication-types=wpa2-psk group-ciphers=tkip,aes-ccm mode=\
    dynamic-keys name=wlan3-oaiconnect-repeater supplicant-identity=MikroTik \
    unicast-ciphers=tkip,aes-ccm
add authentication-types=wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm \
    mode=dynamic-keys name=guest supplicant-identity="" unicast-ciphers=\
    tkip,aes-ccm
/interface wireless
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40mhz-Ce \
    disabled=no mode=ap-bridge security-profile=guest ssid=\
    "Guest Oak and Iron"
set [ find default-name=wlan3 ] band=5ghz-a/n/ac channel-width=20/40mhz-Ce \
    disabled=no mode=station-bridge security-profile=\
    wlan3-oaiconnect-repeater ssid=oaiconnect wps-mode=disabled
/interface bridge port
add bridge=bridgeLocal comment=defconf interface=ether1
add bridge=bridgeLocal comment=defconf interface=ether2
add bridge=bridgeLocal interface=wlan2
add bridge=bridgeLocal interface=wlan3
add bridge=bridgeLocal interface=wlan1
add bridge=bridgeLocal interface=*7
/interface list member
add interface=ether2 list=LAN
add interface=wlan1 list=LAN
add interface=ether1 list=LAN
add interface=wlan3 list=WAN
add interface=wlan2 list=LAN
/interface wireless cap
set bridge=bridgeLocal discovery-interfaces=bridgeLocal interfaces=\
    wlan1,wlan2,wlan3
/ip address
add address=192.168.1.1/24 interface=wlan2 network=192.168.1.0
/ip dhcp-client
add comment=defconf disabled=no interface=bridgeLocal
/ip dhcp-relay
add dhcp-server=192.168.88.2 disabled=no interface=bridgeLocal name=relay1
add dhcp-server=192.168.1.1 disabled=no interface=wlan2 local-address=\
    192.168.1.2 name=relay2
/system clock
set time-zone-name=America/New_York
 
jonah1810
newbie
Posts: 42
Joined: Tue Jul 30, 2019 10:19 pm

Re: Guest Dhcp server relay

Thu Apr 22, 2021 1:22 am

There's really no need for a dhcp relay here. put main router all in bridge with your repeater. 1 DHCP server on main router for that. create Vlan with seperate dhcp server for guest network. bridge vlan with guest network interface.

unless you are trying to seperate all 3 wireless networks (main, repeater, and guest) but it sounds like you just want guest seperate.



Sent from my SM-G955W using Tapatalk

Who is online

Users browsing this forum: No registered users and 68 guests