Community discussions

MikroTik App
 
five
just joined
Topic Author
Posts: 5
Joined: Fri Mar 23, 2018 9:59 pm

Tutorial: Using wAP AC with a Tomato Router

Sun Mar 25, 2018 4:34 am

Note:
I am a beginner and faced some challenges during the process. Documenting my notes online, in case they may help someone else in the future. If you notice something that I could do that would improve my setup, please let me know.

Preface before I start:

My intention was to disable my 2.4 and 5.0 from my current router (Asus RT-N66U running tomato) and use the wap ac as an access point. Main reason being that my current router is placed in a terrible location. And moving the ugly black router to the living room was a no-go with the wife. She liked the idea of the wap ac, said it looked similar to an alarm bell box or fire detector, so no issues on that front.

So the goal was to continue using the tomato router to handle all dhcp and routing duties and use the wap ac as it's antenna basically. There are no fancy vlans or guest wireless networks in this setup. It's just making the wap ac work with my current router.

Directions to flash to the latest firmware:
Recover a Broken Mikrotik Device
New RB951G-2HnD bricked? [Solved with Netinstall]
Firmware that I used

Setup Blues (Winbox where is my device?)
Even after resetting to factory defaults I was not seeing the wireless network Mikrotik and unable to use winbox. On reddit, someone suggested that I put it into CAP mode and see if I could connect to it with winbox at that point. And it worked!!!! So I’m finally in.

Directions to put in CAP mode:
  1. Hard wire WAP to your computer
  2. Manually configure IP to 192.168.88.x subnet. Though I am not sure that is actually necessary. I believe it makes the connection using the MAC address.
  3. Hold reset button until 2.4/5 goes solid and release button when CAP starts blinking.
  4. Wait one minute for WAP to start up. Open winbox and check neighbor. You should see your WAP MAC address!
  5. Connect and you’re in!
  6. Once in, you have to get rid of the CAP mode. System – Reset Configuration. I checked No Default and Do Not Backup.

Resources that I used during the setup phase of the process:
Making a simple wireless AP
Configure your MikroTik router as an Access Point wireless router
(The two above resources, left me with wireless access, but no internet on those devices. Pings and such was working through terminal on winbox, but I was confused. Later I realized that ether1 was good, but not the wireless radios. Slept on it and figured it out in the morning.)
InstrusDave ethernet bridge setup - posted on the forums and helped me get over the hump and get wireless internet connectivity working. If I had seen this post initially, the whole setup would've taken 10 minutes. (Once I got into winbox at least!)

Time to setup the device:
  1. Wireless – go to security profile and create your WPA key. In my case, my 2.4 is different than my 5.0, so I created two.
  2. Wireless – go back to interfaces.
    • Double click on name of one of the interfaces (one is 2.4 and other is 5.0)
    • General tab – I changed the name to match the SSID, to make it easier to identify
    • Wireless tab – Mode AP Bridge
    • Wireless tab – SSID make it the same as your last SSID
    • Wireless tab – Security profile, choose the appropriate one from the first step above
    • Wireless tab – I also modified Band, Channel Width and Frequency (everything else was left at defaults)
    • (Repeat as needed for the second interface)
    • Enable both when done
    • At this point, devices will connect – but will not have internet access
  3. Bridge – create new bridge (lanBridge)
  4. Bridge – Ports tab add the two wireless interfaces and ether1 and choose lanBridge
  5. IP – DHCP Client – I chose the lanBridge as my interface and checked peer dns and ntp

    All done, back up the configuration:
    Method 1
    To do it in a nice easy to read script, use terminal and just run: /export file=config
    Then go to Files, right click and download the file to your desktop and open with a text editor
    Method 2
    To make a backup that your device can restore from, go to Files and choose Backup.
    Then right click the new file and download to your desktop.

    Future plans:
    Replace the tomato router with a hex GR3 router.
    Implement the fancy guest wireless network isolated on its own vlan.

    Script generated by my setup.
    Pretty similar to InstrusDave setup listed above.
    # mar/24/2018 06:55:33 by RouterOS 6.36.4
    # software id = FKCU-VBGC
    #
    /interface bridge
    add name=lanBridge
    /interface wireless security-profiles
    add authentication-types=wpa2-psk eap-methods="" management-protection=\
        allowed mode=dynamic-keys name=WirelessAP24 supplicant-identity="" \
        wpa2-pre-shared-key=This_is_my_password_treat_it_well!!!
    add authentication-types=wpa2-psk eap-methods="" management-protection=\
        allowed mode=dynamic-keys name=WirelessAP50 supplicant-identity="" \
        wpa2-pre-shared-key="This is my password treat it well!!!"
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-Ce \
        disabled=no mode=ap-bridge name=WirelessAP24 security-profile=WirelessAP24 ssid=\
        WirelessAP24
    set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=\
        20/40/80mhz-eeCe disabled=no frequency=auto mode=ap-bridge name=WirelessAP50 \
        security-profile=WirelessAP50 ssid=WirelessAP50
    /interface bridge port
    add bridge=lanBridge interface=ether1
    add bridge=lanBridge interface=WirelessAP24
    add bridge=lanBridge interface=WirelessAP50
    /ip dhcp-client
    add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
        interface=lanBridge
    /system clock
    set time-zone-name=America/New_York
    /system routerboard settings
    set cpu-frequency=720MHz protected-routerboot=disabled
    
 
mkx
Forum Guru
Forum Guru
Posts: 6021
Joined: Thu Mar 03, 2016 10:23 pm

Re: Tutorial: Using wAP AC with a Tomato Router

Sun Mar 25, 2018 8:54 pm

A remark regarding DHCP functionality on wAP ac: if your main router has DHCP server running (for wired clients), and you put both wireless interfaces on bridge with wired interface on wAP, then you don't have to run DHCP server on wAP. Wifi clients should be able to receive DHCP leases from main router.

If you're going to implement guest network and deploy VLANs between wAP and main router, you will still be able to run DHCP server only on main router. I have similar setup running without any issues - my setup is 2x RB951G-2HnD, one as router (with DHCP server for all VLANs. Optionally also WAP, it's configured but disabled), the other one as WAP and trunk containing 4 VLANs running between them.
BR,
Metod
 
five
just joined
Topic Author
Posts: 5
Joined: Fri Mar 23, 2018 9:59 pm

Re: Tutorial: Using wAP AC with a Tomato Router

Mon Mar 26, 2018 4:03 am

Thanks for the info. That makes the setup of the GR3 router in the future a little less daunting.
 
swerty
just joined
Posts: 2
Joined: Tue May 18, 2021 7:27 am

Re: Tutorial: Using wAP AC with a Tomato Router

Tue May 18, 2021 7:35 am

Thank you. Very helpful and the link (Recover a Broken Mikrotik Device) mentioned holding the reset button for 30 seconds or until the device shows up in NetInstall which helped a lot. It took me 25 seconds. I only saw 5,10 and 15 seconds posted on the wiki.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 7448
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: Tutorial: Using wAP AC with a Tomato Router

Tue May 18, 2021 5:17 pm

swerty, that information is in the wiki.........

The note in the MT wiki that discusses the point at which you powerup the device with the reset button depressed..............................
......

..................

Says make sure you read the ETHERBOOT manual (its a linked url)
From there its crystal clear LOL.
...........
reset.jpg
You do not have the required permissions to view the files attached to this post.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!

Who is online

Users browsing this forum: No registered users and 44 guests