Community discussions

MikroTik App
 
nikola89381
newbie
Topic Author
Posts: 26
Joined: Wed May 17, 2017 4:46 pm

Mikrotik failover bonding for LHG60 Link

Tue Jun 22, 2021 4:16 pm

Hi Guys,

We have base stations with LHG60 Ghz links.

And becouse of stability we have between some base stations, backup link on 5 Ghz.

And when for examle becouse of snow, wireless on 60Ghz link is down, we manualy change VLAN to interface where are 5Ghz link. And this is works.

We want to automate this proces without scripts, and I try Mikrotik failover bonding.

But there is problem this not works good. I had packet lost. Only works when both ethernet interface on main links are not running.

Config looks on this way

Main Base station
/interface ethernet
set [ find default-name=ether4 ] name=ether4-main-link
set [ find default-name=ether5 ] name=ether5-backup_link
/interface bonding
add arp-ip-targets=192.168.112.2 link-monitoring=arp mode=active-backup name=bonding-main_router primary=\
    ether4-main-link slaves=ether4-main-link,ether5-backup_link transmit-hash-policy=layer-2-and-3
/interface vlan
add interface=bonding-main_router name=vlan223-main_to_second_router vlan-id=223
/ip address
add address=192.168.112.1/24 interface=bonding-main_router network=192.168.112.0
add address=192.168.88.1/24 interface=vlan223-main_to_second_router network=192.168.88.0


Second Base station
/interface ethernet
set [ find default-name=ether4 ] name=ether4-main-link
set [ find default-name=ether5 ] name=ether5-backup_link
/interface bonding
add arp-ip-targets=192.168.112.1 link-monitoring=arp mode=active-backup name=bonding-second_router primary=\
    ether4-main-link slaves=ether4-main-link,ether5-backup_link transmit-hash-policy=layer-2-and-3
/interface vlan
add interface=bonding-second_router name=vlan223-second-to-main-router vlan-id=223
/ip address
add address=192.168.112.2/24 interface=bonding-second_router network=192.168.112.0
add address=192.168.88.2/24 interface=vlan223-second-to-main-router network=192.168.88.0

This is in laboratory config, this devices are not in production, this is just for test.

Image


Do you have experience with this

Thanks a lot,
Best regards
Nikola
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1436
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: Mikrotik failover bonding for LHG60 Link

Tue Jun 22, 2021 4:43 pm

Consider using an OSPF transit fabric instead of bonding so that you can use all the bandwidth when the speeds aren't equal. You can use it with just OSPF or pair it with eBGP for large scale

I presented at the US MUM in 2017 on this design and we've had a number of WISP clients that have successfully implemented it:

https://www.youtube.com/watch?v=dFZz2z6RdQY

https://mum.mikrotik.com/presentations/ ... 062656.pdf

Image
Global - MikroTik Support & Consulting - English | Español | Serbian | Danish +1 855-645-7684
https://iparchitechs.com/ecosystem/mikr ... consulting mikrotiksupport@iparchitechs.com
 
nikola89381
newbie
Topic Author
Posts: 26
Joined: Wed May 17, 2017 4:46 pm

Re: Mikrotik failover bonding for LHG60 Link

Tue Jun 22, 2021 4:48 pm

HI,

Thank you very much for the offered solution . I will check your presentation. I really appreciate this

Nikola

Who is online

Users browsing this forum: bpwl and 20 guests