Community discussions

MikroTik App
 
JancariusSeiryujinn
just joined
Topic Author
Posts: 4
Joined: Tue Sep 07, 2021 10:42 am

Unable to connect to hAC2 Wirelessly

Tue Sep 14, 2021 5:41 am

Hello. I have an RB4011 as my primary intranet router, a CRS326 serving as my main layer2 device, and 2 wireless devices - a hAC lite, and an hAC2.

The issue I'm having trouble with at the moment is I seem completely unable to get on the wireless networks of the hAC2. Even when I disabled WPA2 key requirements, I'm unable to connect. In the hAC2s logs, I don't even see evidence of that connection.

The hAC2 itself can ping the main router, out to the internet, etc. If I make a wired connection into one of the hAC2s ports, that works fine.

Edit: I determined that nstream was on and that's why the wireless connection was entirely failing. I now can see myself connect in the logs. However, my VID is 1, despite the PVID of the WLAN being 101.
# sep/13/2021 16:11:31 by RouterOS 6.48.4
# software id = IEWC-ASHD
#
# model = RBD52G-5HacD2HnD
# serial number = CDFC0EE28D33
/interface bridge
add name=bridge1 vlan-filtering=yes
/interface vlan
add interface=bridge1 name=vlan100 vlan-id=100
add interface=bridge1 name=vlan101 vlan-id=101
add interface=bridge1 name=vlan102 vlan-id=102
add interface=bridge1 name=vlan103 vlan-id=103
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk,wpa2-eap eap-methods="" mode=dynamic-keys name=Public supplicant-identity="" wpa2-pre-shared-key=MYKEY
add authentication-types=wpa2-psk,wpa2-eap mode=dynamic-keys name=Printer supplicant-identity="" wpa2-pre-shared-key=MYKEY
add authentication-types=wpa2-psk,wpa2-eap mode=dynamic-keys name=Networked supplicant-identity="" wpa2-pre-shared-key=MYKEY
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country="united states" disabled=no installation=indoor mode=ap-bridge security-profile=Public ssid=OuterHeaven-2.4 vlan-mode=use-tag \
    wps-mode=disabled
set [ find default-name=wlan2 ] band=5ghz-a/n/ac disabled=no installation=indoor mode=ap-bridge security-profile=Public ssid=OuterHeavenTest vlan-mode=use-tag wps-mode=disabled
add comment="No-Internet VLAN103" disabled=no keepalive-frames=disabled mac-address=2E:C8:1B:A7:AF:FF master-interface=wlan1 multicast-buffering=disabled name=wlan3 security-profile=\
    Printer ssid=OuterPrinter vlan-id=103 vlan-mode=use-tag wds-cost-range=0 wds-default-cost=0 wps-mode=push-button-virtual-only
add comment="Internet-allowed security devices" disabled=no keepalive-frames=disabled mac-address=2E:C8:1B:A7:AF:FE master-interface=wlan1 multicast-buffering=disabled name=wlan4 \
    security-profile=Networked ssid=Foxhound vlan-id=102 vlan-mode=use-tag wds-cost-range=0 wds-default-cost=0 wps-mode=push-button-virtual-only
/interface wireless manual-tx-power-table
set wlan3 comment="No-Internet VLAN103"
set wlan4 comment="Internet-allowed security devices"
set *A comment="No-Internet VLAN103"
set *B comment="Internet-allowed security devices"
/ip pool
add name=dhcp ranges=192.168.0.50-192.168.0.99
/caps-man manager
set enabled=yes
/interface bridge port
add bridge=bridge1 interface=wlan2 pvid=101
add bridge=bridge1 interface=wlan1 pvid=101
add bridge=bridge1 interface=ether1 trusted=yes
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=wlan3 pvid=103
add bridge=bridge1 interface=wlan4 pvid=102
add bridge=bridge1 interface=ether2 trusted=yes
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface bridge vlan
add bridge=bridge1 tagged=ether1,bridge1 untagged=ether2,ether3,ether4,ether5 vlan-ids=100
add bridge=bridge1 tagged=ether1,bridge1 untagged=wlan1,wlan2 vlan-ids=101
add bridge=bridge1 tagged=ether1,bridge1 untagged=wlan4 vlan-ids=102
add bridge=bridge1 tagged=ether1,bridge1 untagged=wlan3 vlan-ids=103
/interface wireless cap
set interfaces=wlan2,wlan1
/ip address
add address=192.168.100.202/24 interface=vlan100 network=192.168.100.0
add address=192.168.101.202/24 interface=vlan101 network=192.168.101.0
add address=192.168.102.202/24 interface=vlan102 network=192.168.102.0
add address=192.168.103.202/24 interface=vlan103 network=192.168.103.0
/ip dhcp-server network
add address=192.168.0.0/24 gateway=192.168.0.0 netmask=24
add address=192.168.100.0/24 dns-server=192.168.0.1,8.8.8.8 gateway=192.168.100.1 netmask=24
add address=192.168.101.0/24 dns-server=192.168.0.1,8.8.8.8 gateway=192.168.101.1 netmask=24
add address=192.168.102.0/24 dns-server=192.168.0.1,8.8.8.8 gateway=192.168.102.1 netmask=24
add address=192.168.103.0/24 dns-server=192.168.0.1,8.8.8.8 gateway=192.168.103.1 netmask=24
/ip dns
set servers=192.168.0.1,8.8.8.8
/ip route
add distance=1 gateway=192.168.100.1
add distance=1 gateway=192.168.101.1
add distance=1 gateway=192.168.102.1
add distance=1 gateway=192.168.103.1
/system clock
set time-zone-name=America/Denver
/system identity
set name=MikrotikWirelessMai
 
gotsprings
Forum Guru
Forum Guru
Posts: 1217
Joined: Mon May 14, 2012 9:30 pm

Re: Unable to connect to hAC2 Wirelessly

Tue Sep 14, 2021 1:29 pm

Something might be stripping the tag.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
mkx
Forum Guru
Forum Guru
Posts: 6558
Joined: Thu Mar 03, 2016 10:23 pm

Re: Unable to connect to hAC2 Wirelessly

Tue Sep 14, 2021 11:28 pm

This problem is being dealt with in another thread, will just reply here for readers who might get here by chance.

Something might be stripping the tag.

No, it's not. OP has set vlan-mode=use-tag on wireless interfaces without explicitly setting vlan-id property. Implicit default setting is vlan-id=1 which means that the wireless driver tags frames with VID=1 ... bridge's pvid setting has no effect because wireless driver hands over tagged frames.
BR,
Metod

Who is online

Users browsing this forum: khalilce, pomah, uxer and 59 guests