Community discussions

MUM Europe 2020
 
User avatar
Caci99
Forum Guru
Forum Guru
Topic Author
Posts: 1065
Joined: Wed Feb 21, 2007 2:26 pm
Location: Tirane
Contact:

Balance connected customers between AP - s

Thu Oct 08, 2015 1:13 pm

In my area there is an increasing demand of using multiple Access Points in one place with same SSID capable of serving 100 or more customers. The area to be covered are usually conference rooms, halls, big entertainment buildings, etc, meaning customers come and go, so no need to use any radius or pppoe connections (things like that).

My question is, anyone has any idea how to balance the load of connections an AP receives? If one places four APs in one room, how would the customers be fairly distributed between these APs? Signal strength is one way to go, but that isn't a fair system because the signal strength would vary largely depending on indoor environment. Once you can get a -70 for example and the other couple of seconds you can get a -75 signal strength from the same AP. The mesh doesn't seem to solve this issue.

So, anyone has done it before, or has any idea?
-Toni-
Don't crash the ambulance, whatever you do
 
lucky79
Member Candidate
Member Candidate
Posts: 127
Joined: Sat Sep 27, 2014 1:24 pm
Location: Czech Republic

Re: Balance connected customers between AP - s

Thu Oct 08, 2015 4:48 pm

You can limit max number of stations which can connect to an AP, together with limiting the minimum signal should be enough to provide reasonable WiFi service. Keep in mind that you want to limit signal from client to AP, as per your post I would understand that you want to limit the signal strength on the client side. Client=>AP signal is usually lower than AP=>client.

Maybe CAPsMAN has some more sophisticated load-balance feature (I would expect it there), but not sure about that. Did not try it yet.
 
User avatar
Caci99
Forum Guru
Forum Guru
Topic Author
Posts: 1065
Joined: Wed Feb 21, 2007 2:26 pm
Location: Tirane
Contact:

Re: Balance connected customers between AP - s

Thu Oct 08, 2015 7:25 pm

You can limit max number of stations which can connect to an AP, together with limiting the minimum signal should be enough to provide reasonable WiFi service. Keep in mind that you want to limit signal from client to AP, as per your post I would understand that you want to limit the signal strength on the client side. Client=>AP signal is usually lower than AP=>client.

Maybe CAPsMAN has some more sophisticated load-balance feature (I would expect it there), but not sure about that. Did not try it yet.
I haven't tried CAPsMAN, never had actually. To test it would require a lot lab time, but could never simulate the real world when hundred of different users would use it, so it needs a to be tested on real world scenarios.
I mostly want to be prepared about the scenario before it happens, because I see that the need for such covering is increasing.
Everything you mention has crossed my mind, but I didn't want to rely on signal strength because that could vary a lot within indoor, not giving enough stability (I think).
-Toni-
Don't crash the ambulance, whatever you do
 
baggar11
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Tue Oct 22, 2013 4:49 am

Re: Balance connected customers between AP - s

Mon Oct 12, 2015 7:39 pm

There's a couple things that you can do to help out.

1. Do a site survey. You'll want to find out where the best placement of the APs is with minimal signal overlap. Adjusting settings like power output will most likely come into play here too.
2. Setup an access list to kick users when they exceed a certain signal threshold. This will help them roam between the APs better.
3. Turn off some or all of the lower data rates. They'll hog airtime if clients end up using any of them.
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1749
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Balance connected customers between AP - s

Tue Oct 13, 2015 5:29 am

from my experience with (rb951g and rb95ui)

be careful with kicking clients when they fall behind some signal level, some mobile devices like smart phones when are inactive lower tx power, when they do that even staying close to the ap they show as -85dbm to -78dbm signal.

if you establish a threshold of 75dbm you will be kicking this inactive devices even when they are close tho the ap forcing it to connect to a far ap (which is we are trying to avoid) :?

its better to filter the clients at the moment of connection allowing only clients with good signal to connect, allow only 73dbm or better signal to connect and kick only devices who fall to 86dbm and lower signal.

another way its to lower tx power, try from 5dbm and increase until you get the needed coverage

start disabling 802.11b data-rates and bpsk data-rates, then try disabling qpsk data-rates if you need.

take advantage of environment to lower the coverage of ap, in auditoriums will be a nice strategy locate ap at low height to use the people as a attenuating barrier to limit the coverage of ap

another good idea its disable forwarding between clients to mitigate broadcast traffic, use firewall to avoid broadcast to propagate from one ap to another

use short time lease on dhcp (2 hours) and a large network (/22)to get enough room

do not use mesh, connect aps with ethernet cable to the switch
 
User avatar
Caci99
Forum Guru
Forum Guru
Topic Author
Posts: 1065
Joined: Wed Feb 21, 2007 2:26 pm
Location: Tirane
Contact:

Re: Balance connected customers between AP - s

Tue Oct 13, 2015 11:13 am

3. Turn off some or all of the lower data rates. They'll hog airtime if clients end up using any of them.
Turn off the lower data rates? That's the first time I hear it. Or do you mean the "802.11b" data rates?
be careful with kicking clients when they fall behind some signal level, some mobile devices like smart phones when are inactive lower tx power, when they do that even staying close to the ap they show as -85dbm to -78dbm signal.
I have noticed that too, at least with androids. When a smartphone synchronizes with the AP at -80 because it is far away, the screen goes off, and then you come close to the AP it will stay at -80 at the registration table, until you turn on the screen again it will synchronize at much better signal.

Thank you all for your advises, I will have them in account if such a job will be required and let you know how things go.
-Toni-
Don't crash the ambulance, whatever you do
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1749
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Balance connected customers between AP - s

Tue Oct 13, 2015 11:35 am

Turn off the lower data rates? That's the first time I hear it. Or do you mean the "802.11b" data rates?
yes you can start disabling 802.11b datarates and 802.11g/n bpsq datarates, another advantage its that beacons change from 1mbps to 6mbps that its more efficient specially when you have multiple ssid
datarates1.jpg
datarates2.jpg
if you want to restrict more the coverage area then disable 802.11g 12mbps and 18mbps (qpsk)
and 802.11n MCS 1 2 9 10 (qpsk)
Thank you all for your advises, I will have them in account if such a job will be required and let you know how things go.
nice i will be waiting for it
You do not have the required permissions to view the files attached to this post.
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: Balance connected customers between AP - s

Wed Oct 14, 2015 11:09 pm

.. [cut] .. its better to filter the clients at the moment of connection allowing only clients with good signal to connect, allow only 73dbm or better signal to connect and kick only devices who fall to 86dbm and lower signal .. [cut] ..
how exactly do you achieve it ?

This doesn't work well:
/interface wireless access-list
add authentication=yes forwarding=no signal-range=-73..120
add authentication=no forwarding=no signal-range=-120..-86
My phone connect if signal above -73 ..and "disconnected, too weak signal" if (e.g.) signal is -78.
I was expecting it stays connected till -86 ..no

Maybe with script ?

Usually I set:
/interface wireless access-list
add authentication=yes forwarding=no signal-range=-85..120
add authentication=no forwarding=no signal-range=-120..-86
..and work quite well, but your idea is better!
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1749
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Balance connected customers between AP - s

Thu Oct 15, 2015 1:48 am

.. [cut] .. its better to filter the clients at the moment of connection allowing only clients with good signal to connect, allow only 73dbm or better signal to connect and kick only devices who fall to 86dbm and lower signal .. [cut] ..
how exactly do you achieve it ?

This doesn't work well:
/interface wireless access-list
add authentication=yes forwarding=no signal-range=-73..120
add authentication=no forwarding=no signal-range=-120..-86
My phone connect if signal above -73 ..and "disconnected, too weak signal" if (e.g.) signal is -78.
I was expecting it stays connected till -86 ..no

Maybe with script ?

Usually I set:
/interface wireless access-list
add authentication=yes forwarding=no signal-range=-85..120
add authentication=no forwarding=no signal-range=-120..-86
..and work quite well, but your idea is better!
i use this
/interface wireless access-list
add authentication=no forwarding=no signal-range=-120..-73
add signal-range=-85..120
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: Balance connected customers between AP - s

Fri Oct 16, 2015 9:53 am

I was told to put allow rule before, but you clearly show me it doesn't matter :D

I'll try it soon, thanks
 
pateutz
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Wed Jan 11, 2012 5:55 pm

Re: Balance connected customers between AP - s

Wed Feb 24, 2016 2:40 am

Hi all,

any clue if the solutions provided in this topic worked ?
I am asking because i have to front the challenge to manage to configure 5 ap's that should covering a single conference room in order to provide internet access to 200 - 300 peoples. The challenge that i see it's to try to balance clients on all 5 ap's equally mode.

Definitely will be managed by an CAPsMAN 2 and will run on a Mikrotik CCR 1016-12G.
If you have any experience with this kind o setup feel free to share .

Best Regards,

Daniel
 
Miracle
Member Candidate
Member Candidate
Posts: 106
Joined: Fri Sep 11, 2015 9:04 am

Re: Balance connected customers between AP - s

Fri Feb 26, 2016 6:12 pm

Hi all,

any clue if the solutions provided in this topic worked ?
I am asking because i have to front the challenge to manage to configure 5 ap's that should covering a single conference room in order to provide internet access to 200 - 300 peoples. The challenge that i see it's to try to balance clients on all 5 ap's equally mode.

Definitely will be managed by an CAPsMAN 2 and will run on a Mikrotik CCR 1016-12G.
If you have any experience with this kind o setup feel free to share .

Best Regards,

Daniel
You need 15~30 APs to feed 300 clients and use directional antenna to limit coverage every AP.
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1749
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Balance connected customers between AP - s

Fri Feb 26, 2016 8:37 pm

Hi all,

any clue if the solutions provided in this topic worked ?
I am asking because i have to front the challenge to manage to configure 5 ap's that should covering a single conference room in order to provide internet access to 200 - 300 peoples. The challenge that i see it's to try to balance clients on all 5 ap's equally mode.

Definitely will be managed by an CAPsMAN 2 and will run on a Mikrotik CCR 1016-12G.
If you have any experience with this kind o setup feel free to share .

Best Regards,

Daniel
how big is your internet connection for that event???

i think you are very thigh if we are talking about 5 ap for 200-300 concurrent connected wireless devices being optimistic thats 40-60 devices per ap.

I think you need at least 10ap for that scenario

Of course i understand that sometimes the conditions, budget and environment do not allow this

i think the first thing we need to know is the blue print (with measures in feet or meters) of the conference room to trow some ideas on it

to start to server 60 devices per Ap you need to optimize at maximum, i have seen 40 devices connected to a rb951Ui with good performance but in a very optimized scheme, beware some optimizations do not work with capsman

the optimizations point toward 3 points:

1. limiting coverage area to control how many devices are connected to the Ap and ensure that connected clients are using high data-rates to increase available capacity, this can be achieved lowering tx power, limiting datarates, using acl to controls signal strength of allowed clients.

2. making qos at the Ap to balance the available bandwidth between clients to give a stable service, i cases of saturated AP i have seen a limit of 10 or 15 mbps is a good limit to mantain the AP and their cell of coverage with out saturation when connecting more than 20 concurrent clients, i think for this scenario yo have to limit each AP to 10mbps download and 5mbps upload

3. making qos at the internet main connection to guarantee a good performance and filter any unwanted behavior to give stability

Who is online

Users browsing this forum: mfr476 and 42 guests