Community discussions

User avatar
just joined
Topic Author
Posts: 11
Joined: Fri Jul 16, 2010 6:00 pm
Location: Czech republic

How to Lock TX/RX data rates on client

Thu Oct 22, 2015 10:14 am

yesterday I met with a problem with Tx/Rx rates
for example: We have AP that is transmitting,
802.11n with data rate 52,58,65Mbit. There is connected to 10 clients.
One of the 10 clients and has a worse signal to AP. The Tx from client has a variable rate 58 then 65 then 58 then 65Mbit ...
So I need to set communicate the client rate of only 58Mbit. No switching rates

We found that no matter what set speed 802.11a, 802.11n. on client RB. Always connects and operates at top speed, according to the transmitter - AP.
My question is:
- How to LOCK communication speed, for ex. 52Mbit TX from client. So for AP will be TX rare 65Mbit, RX rate 58Mbit)
- Why is the speed of adjustmenton klent RB?

Thank You
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ

Re: How to Lock TX/RX data rates on client

Fri Oct 23, 2015 5:10 am

I think you are describing "rate flapping".

To fix this you need to disable the higher speds in "supported rates" of radio. This is under the "data rates" section, select "configured" and unselect the top speeds.

The logic is if the radio spends 80% of its time at 36Mbbps, 10% at 48Mbps and 10% at 54Mbps then unselcting 48 & 54 means it spends 100% on 36 Mbps.

Likewise for HT-MCS settings under wireless N. You still need to got to "data rates" and select configured, then go to "HT MCS" and make your changes.

Changing "supported rates" will affect all clients but will make the radio more stable.

It is also possible to set "default AP TX Rate" and "default client TX Rate" in relation to data speed. Note that default client tx rate only works with Mikrotik Wireless devices as it is a proprietary extension.

These settings can be global or you can use the access list to specify for specific device(s) by mac address.
Mikrotik Distributor - New Zealand

Who is online

Users browsing this forum: No registered users and 27 guests