Community discussions

 
sdrenner
Member Candidate
Member Candidate
Topic Author
Posts: 138
Joined: Wed Mar 02, 2005 10:03 pm
Contact:

Howto? mAP Lite repeater mode?

Wed Feb 03, 2016 7:09 pm

Has anyone gotten a mAP Lite working in repeater mode?
I have upgraded to 6.35rc3 and installed the wireless-rep package.

When i go to /interface wireless setup-repeater
I get this: no such item (4)

If anyone has successfully made this work please share you config
 
darkprocess
Member Candidate
Member Candidate
Posts: 253
Joined: Fri Mar 20, 2015 1:16 pm

Re: Howto? mAP Lite repeater mode?

Wed Feb 03, 2016 7:26 pm

For a WISP mode :

I've wlan1 as a ap-bridge and second as (virtual AP) as pseudobridge

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
country=france disabled=no distance=indoors frequency=2437 \
frequency-mode=superchannel mode=ap-bridge name=wlan1-local \
ssid=LAN wireless-protocol=802.11 \
add disabled=no keepalive-frames=disabled \
master-interface=wlan1-local mode=station-pseudobridge \
multicast-buffering=disabled name=wlan9-gateway \
ssid=Hotel
 
Kevo
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Wed Oct 12, 2011 1:38 am

Re: Howto? mAP Lite repeater mode?

Thu Sep 22, 2016 11:40 pm

I've been trying to get this setup too, but it doesn't seem to work for me. I'm not real sure how it's supposed to work wither. Every time I try the setup repeater I end up getting locked out of the mAP and have to reset it to defaults to get back in. My attempts to set it up have so far been met with utter failure, and the wiki docs don't really offer much other than saying you can type in the settings manually if you don't have a WPS AP.

Anyone have either a working sample config or even an explanation of how the interfaces should be configured and which is the master, do you need a bridge or NAT or both?

Also, what's the best way to have both basic scenarios available (ethernet hotel connection to local wifi devices, wifi hotel connection to local wifi devices) for someone to choose from. I gave one of these to someone set up for ethernet to wifi with a vpn client configured, but I'd like for them to be able to switch over to wifi to wifi when needed without it requiring a ton of config. TIA
 
Kevo
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Wed Oct 12, 2011 1:38 am

Re: Howto? mAP Lite repeater mode?

Fri Sep 23, 2016 6:30 am

I managed to get this working for the most part.

You can start with quickset configured for AP or CPE. Then you add a virtual wireless interface for the other function. So if you start in AP mode you add a virtual wireless interface for station. Vice versa for CPE mode.

Then you can change the DHCP Server over to the AP interface if needed, ditto for DHCP Client. Be sure to add a NAT masquerade rule if needed as well.

Then you have to get the WPA profile set to connect to the internet source AP. You also need the channel set to match. I had to set the channel manually so it matched the source AP, otherwise things didn't seem to work. I was hoping if the main interface was set to auto that it would switch if required to match the virtual or vice versa, but it didn't seem to work out that way for some reason.

Unfortunately this is all a very manual process. I haven't figured out how to get it setup so that someone could just connect to the source AP in quickset and go about their business. It seems that whenever I try that I end up not being able to connect back to the wireless from my laptop.

I'll keep playing with it, but it would be nice if there was a way to make this type of setup easier for someone who wouldn't ordinarily do this sort of configuration. I'd like to be able to give these out to traveling salespeople or similar so they can easily set up in a hotel or remote site.

As it is now, I think a basic TP-Link travel router is probably easier, with the only main downside being the lack of built-in VPN functions.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Howto? mAP Lite repeater mode?

Fri Sep 23, 2016 9:41 am

Are you running RouterOS 6.37rc42? You must upgrade to use this feature.
No answer to your question? How to write posts
 
Kevo
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Wed Oct 12, 2011 1:38 am

Re: Howto? mAP Lite repeater mode?

Fri Sep 23, 2016 5:50 pm

I think I was testing with rc40. I'll update to the release version and test again.
 
ffilmar
just joined
Posts: 5
Joined: Sat Jan 28, 2017 7:30 pm

Re: Howto? mAP Lite repeater mode?

Sun Jan 29, 2017 7:40 am

Who is online

Users browsing this forum: Google [Bot] and 23 guests