Community discussions

MikroTik App
 
heydude
newbie
Topic Author
Posts: 26
Joined: Wed Dec 02, 2015 4:53 pm
Location: CH

CAPsMAN disable cap interface by SSID name

Wed Aug 17, 2016 5:09 pm

Hi guys,

We are running several cap's with CAPsMAN on a CCR1036 Router. The manager does its job pretty well and all cap's and SSID's are working fine.
Now, we have a guest SSID and I want to disable this during night time. At the moment I did this by access list, where I reject clients on that SSID during a specifig time, but this way the SSID is still visible.
I would like to make a disable script looking like this
/caps-man interface disable [/caps-man interface find SSID=mySSID]
But with the find future I can not search interfaces by SSID.
Has anyone any idea how to this?

Thanks in Advance
 
uldis
MikroTik Support
MikroTik Support
Posts: 3439
Joined: Mon May 31, 2004 2:55 pm

Re: CAPsMAN disable cap interface by SSID name

Wed Aug 17, 2016 5:24 pm

Maybe try using such command:
/caps-man interface disable [/caps-man interface find configuration.ssid=mySSID]
 
heydude
newbie
Topic Author
Posts: 26
Joined: Wed Dec 02, 2015 4:53 pm
Location: CH

Re: CAPsMAN disable cap interface by SSID name

Thu Aug 18, 2016 9:28 am

Thanks for your advice, but it doesn't work. The function is not finding any entries in configuration.ssid.

I tested it like this:
[admin@myrouter] > /put message=[/caps-man interface find configuration.ssid=myssid] 

The output line was emtpy

If I just surch for any entries it looks like this:
[admin@myrouter] > /put message=[/caps-man interface find]                           
*10b;*10c;*10d;*10e;*10f;*110;*111;*112;*fc;*fd;*fe;*ff;*105;*106;*107;*100;*101;*102;*108;*109;
*10a;*d2;*d3;*cb;*cc;*c7;*c8
This way it finds all interfaces that have been provisioned

Any other idea?
 
heydude
newbie
Topic Author
Posts: 26
Joined: Wed Dec 02, 2015 4:53 pm
Location: CH

Re: CAPsMAN disable cap interface by SSID name

Thu Aug 18, 2016 12:53 pm

The only way I could make it work, was that I made a comment to each Interface (only virtual AP's) with the actual SSID. So, then I could disable this SSID on all devices with one scheduler task.
/caps-man interface disable [/caps-man interface find comment=myssid]
But this should not be the solution for this, thought when in provisioning "create dynamic enabled" is set, the comment will be gone when the device goes offline. So at the moment I can only work with provisioning "create enabled" that the device and comments stay in the manager even if they are offline.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6043
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: CAPsMAN disable cap interface by SSID name

Thu Aug 18, 2016 3:49 pm

:put [/caps-man interface find configuration.ssid="myssid"]

or

:put [/caps-man interface find configuration.ssid~"myssid"]

if ssid contains not just "myssid" string.
 
heydude
newbie
Topic Author
Posts: 26
Joined: Wed Dec 02, 2015 4:53 pm
Location: CH

Re: CAPsMAN disable cap interface by SSID name

Thu Aug 18, 2016 3:59 pm

<:put [/caps-man interface find configuration.ssid="myssid"]> only finds entries, if in the cap the ssid is set manually, but like normal the cap gets the ssid for each virtual ap by the provisioning rule (in the CAPsMAN interface list, ssid is grey not black, when set automatic). If ssid is set by provisioning rule, then the find function does not find any entries in configuration.ssid.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6043
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: CAPsMAN disable cap interface by SSID name

Thu Aug 18, 2016 4:21 pm

Sorry I do not know your specific configuration. If entries show configuration.ssid, then you can find by that parameter, if there isn't such parameter then you can find by configuration parameter.

:put [/caps-man interface find configuration="myconf"]
 
heydude
newbie
Topic Author
Posts: 26
Joined: Wed Dec 02, 2015 4:53 pm
Location: CH

Re: CAPsMAN disable cap interface by SSID name

Thu Aug 18, 2016 5:04 pm

If all interfaces are provisioned, the ssid is set to them by the provisioning rule automatic. Then it looks like this:
Clipboard01.jpg
The output then looks like this:
> put message=[/caps-man interface find configuration.ssid~"c-net"]
...means, it did not find any entries, even interfaces contain text in ssid column


If I set the ssid in an existing interface manually on CAPsMAN, then it will find this one:
Clipboard02.jpg
Output contains one entry:
 > put message=[/caps-man interface find configuration.ssid~"c-net"]
*110
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 29 guests