Community discussions

MUM Europe 2020
 
ropeba
Member Candidate
Member Candidate
Topic Author
Posts: 220
Joined: Sat Jul 29, 2006 4:13 pm

Block file sharing on WDS network

Thu Oct 19, 2006 1:28 pm

how?

Thanks
 
User avatar
tneumann
Member
Member
Posts: 394
Joined: Sat Apr 16, 2005 6:38 pm
Location: Germany

Sat Oct 21, 2006 4:23 pm

Exactly what do you mean when you talk about "file sharing"? Do you mean P2P apps such as Gnutelle, eDonkey, etc. or are we talking about windows file sharing (SMB, NetBIOS)?

--Tom
 
simonkizi
newbie
Posts: 45
Joined: Mon Jan 30, 2006 10:38 pm

Re: Block file sharing on WDS network

Sun Oct 22, 2006 3:21 am

how?

Thanks
Just block port 445 for smb. Check in the Mikrotik Manual for suggestions of other ports to block.
 
ropeba
Member Candidate
Member Candidate
Topic Author
Posts: 220
Joined: Sat Jul 29, 2006 4:13 pm

Fri Oct 27, 2006 9:06 pm

i have blocked port 135-139 and 445, but I still can access to some shared folders on computers in network...
 
jo2jo
Forum Veteran
Forum Veteran
Posts: 959
Joined: Fri May 26, 2006 1:25 am

Fri Oct 27, 2006 10:05 pm

I may be wrong but is this not because WDS is a bridge and the computers may be using netbios NOT over tcp to communicate?
 
User avatar
tneumann
Member
Member
Posts: 394
Joined: Sat Apr 16, 2005 6:38 pm
Location: Germany

Fri Oct 27, 2006 10:46 pm

Even if they are running NetBIOS over IP (in contrast to some other option, like NetBEUI, which would also be possible over a bridged network), then any filter placed in /ip firewall filter will be ignored for that traffic because these filters only work in the IP forwarding chain, and as long as everyone doing NetBIOS over IP is in the same layer 2 network no IP forwarding will actually take place. Look into bridge filters if your network is designed like that.

--Tom
 
ropeba
Member Candidate
Member Candidate
Topic Author
Posts: 220
Joined: Sat Jul 29, 2006 4:13 pm

Sun Oct 29, 2006 6:06 pm

yes i use wds + bridge, how I can block file sharing?
 
valens
Trainer
Trainer
Posts: 246
Joined: Tue Jun 01, 2004 5:42 pm
Location: INDONESIA
Contact:

Sun Oct 29, 2006 6:32 pm

You can try to disable the default forward in wireless setting.
And do bridge filter also.

Who is online

Users browsing this forum: No registered users and 31 guests