Community discussions

MikroTik App
 
Jorbu
just joined
Topic Author
Posts: 23
Joined: Sun Apr 01, 2012 4:23 am

Issue CAPsMAN controlling 5Ghz radios on 6.38 and 6.39rc

Sat Jan 07, 2017 2:03 am

Upgraded my CAPsMAN controller (RB1100AH) to version 6.39rc7. This is controlling one wAP AC, one hAP AC lite, and one hAP AC. Once the upgrade happens, I see my 5Ghz network start to feel slow, and all my devices are unable to associate at the higher MCS. Doing a bit of troubleshooting, I'm unable to get them to work properly. Had to downgrade to 6.37.3 in order to make it work. Here's the configuration of one of the 5Ghz CAP in 6.39rc7:
 
 1 M BR name="AP02-MasterBR-5Ghz" mac-address=E4:8D:8C:D5:41:6C arp-timeout=auto radio-mac=E4:8D:8C:D5:41:6C master-interface=none 
        configuration.mode=ap configuration.ssid="Jorbu" configuration.max-sta-count=30 configuration.multicast-helper=default 
        configuration.tx-chains=0,1,2 configuration.rx-chains=0,1,2 configuration.guard-interval=any 
        configuration.country=united states configuration.distance=indoors configuration.hw-retries=0 
        configuration.hw-protection-mode=none security.authentication-types=wpa2-psk security.encryption=aes-ccm 
        security.group-encryption=aes-ccm security.passphrase="password" l2mtu=1600 datapath.client-to-client-forwarding=yes 
        datapath.bridge=bridge1 channel.width=20 channel.band=5ghz-a/n/ac channel.extension-channel=Ceee 
        
Here's the effect of that configuration on the interface details, please note the "current rate set" section:
 1 M BR name="AP02-MasterBR-5Ghz" mac-address=E4:8D:8C:D5:41:6C arp-timeout=auto radio-mac=E4:8D:8C:D5:41:6C master-interface=none 
        configuration.mode=ap configuration.ssid="Jorbu" configuration.max-sta-count=30 configuration.multicast-helper=default 
        configuration.tx-chains=0,1,2 configuration.rx-chains=0,1,2 configuration.guard-interval=any 
        configuration.country=united states configuration.distance=indoors configuration.hw-retries=0 
        configuration.hw-protection-mode=none security.authentication-types=wpa2-psk security.encryption=aes-ccm 
        security.group-encryption=aes-ccm security.passphrase="password" datapath=JorbuDatapath l2mtu=1600 
        datapath.client-to-client-forwarding=yes datapath.bridge=bridge1 channel.width=20 channel.band=5ghz-a/n/ac 
        channel.extension-channel=Ceee rates.vht-basic-mcs="" rates.vht-supported-mcs="" current-state="running-ap" 
        current-channel="5260/20-Ceee/ac/DP(23dBm)" current-rate-set="OFDM:6-54 BW:1x-2x HT:0-23" current-basic-rate-set="OFDM:6" 
5GhzBad.PNG
After downgrading to 6.37.3, the interface started up the same exact way. I had to recreate the "Configuration" object in order to make it work properly. Here is the config in 6.37.3
 1 M BR name="AP02-MasterBR-5Ghz" mtu=1500 l2mtu=1600 mac-address=E4:8D:8C:D5:41:6C arp=enabled arp-timeout=auto 
        radio-mac=E4:8D:8C:D5:41:6C master-interface=none configuration.mode=ap configuration.ssid="Jorbu" 
        configuration.tx-chains=0,1,2 configuration.rx-chains=0,1,2 configuration.guard-interval=any 
        configuration.country=united states configuration.distance=indoors security.authentication-types=wpa2-psk 
        security.encryption=aes-ccm security.group-encryption=aes-ccm security.passphrase="password" 
        datapath.client-to-client-forwarding=yes datapath.bridge=bridge1 channel.width=20 channel.band=5ghz-a/n/ac 
        channel.extension-channel=Ceee 
Here's the interface details, note the "current-rate-set" property (6.37 seems to print out a lot less detail than the newer version):
 1 M BR name="AP02-MasterBR-5Ghz" mtu=1500 l2mtu=1600 mac-address=E4:8D:8C:D5:41:6C arp=enabled arp-timeout=auto 
        radio-mac=E4:8D:8C:D5:41:6C master-interface=none configuration=Configuration_Jorbu5Ghz current-state="running-ap" 
        current-channel="5260/20-Ceee/ac/DP(23dBm)" current-rate-set="OFDM:6-54 BW:1x-4x HT:0-23 VHTMCS:SS1=0-9,SS2=0-9,SS3=0-9" 
        current-basic-rate-set="OFDM:6" 

5GhzGood.PNG
Please note, I was also able to reproduce this issue in v6.38; and have not found a way to allow the 5Ghz radios to reach the higher MCS in either 6.38 or 6.39rc7.

Aside from downgrading, has anyone found a workaround for this?
You do not have the required permissions to view the files attached to this post.
 
User avatar
intelfx
just joined
Posts: 19
Joined: Sun Nov 06, 2016 10:30 am
Location: Moscow, Russia
Contact:

Re: Issue CAPsMAN controlling 5Ghz radios on 6.38 and 6.39rc

Sat Jan 14, 2017 4:34 am

Same issue here (RB2011 as controller, wAP ac as AP). Moreover, my QCA6174 card consistently gets a firmware crash when exposed to such AP; it took me over an hour to understand what's going on...

Just set them manually.
/caps-man interface set YOUR-AP rates.vht-supported-mcs=mcs0-9,mcs0-9,mcs0-9
(repeat that "mcs0-9" once for each spatial stream you have on the AP in question)
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1870
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: Issue CAPsMAN controlling 5Ghz radios on 6.38 and 6.39rc

Sat Jan 14, 2017 9:21 am

This is a known issue and should be fixed in 6.39rc12
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
Jorbu
just joined
Topic Author
Posts: 23
Joined: Sun Apr 01, 2012 4:23 am

Re: Issue CAPsMAN controlling 5Ghz radios on 6.38 and 6.39rc

Tue Jan 17, 2017 9:56 pm

Updated to RC13, all appears to be working fine. Radios now advertise SGI too:
AfterRC13-5GhzSGI.PNG
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: Bing [Bot] and 24 guests