Community discussions

MikroTik App
 
bbranch1
just joined
Topic Author
Posts: 5
Joined: Sun Jan 08, 2017 12:52 am

hAP ac with terrible speeds

Sun Jan 08, 2017 12:59 am

Brand new hAP ac just plugged in today.

Both 2.4 and 5 ghz radios are giving terrible performance.
I had only one enabled at a time when performing testing. No changes to factory configuration were made.
Wired speedtests show 30Mbs download and 5Mbs upload which is correct for my service.
Phone and wireless desktop show .08 - .11 Mbs download and 1.3Mbs upload.
Those devices were getting 10Mbs down and 5Mbs up using previous router.

I also ran iperf from a wired desktop to a wireless laptop and get 3Mbs when the wired is the server and 200-300 Kbs when the laptop is the server.

Upgraded to latest 6.38 RouterOS and 3.34 firmware with no changes.

I've tried changing just about every setting under the sun with little effect.
Any ideas before I send it back?
 
mducharme
Trainer
Trainer
Posts: 981
Joined: Tue Jul 19, 2016 6:45 pm

Re: hAP ac with terrible speeds

Sun Jan 08, 2017 1:35 am

Check your CCQ values for signs of interference. Is the hAP AC perhaps right next to another wireless router that is still turned on?
 
bbranch1
just joined
Topic Author
Posts: 5
Joined: Sun Jan 08, 2017 12:52 am

Re: hAP ac with terrible speeds

Sun Jan 08, 2017 2:34 am

Appears this may be less of a wifi specific problem and more of a switch conflict issue. I decided to test with nothing plugged into the lan ports and got the full speed I was expecting. The moment I plugged in my tp link switch the wireless speed dropped again. Wired speed continues to be unaffected. Still looking for a cause but I think I'm a little closer.
 
sup5
Member
Member
Posts: 325
Joined: Sat Jul 10, 2010 12:37 am

Re: hAP ac with terrible speeds

Sun Jan 08, 2017 2:46 am

Don't use ROS 6.38.
It has a severe bug regarding MAC-address learing and thus floods all unicast traffic.
Simply get ROS 6.37.3 from the Firmware archive: http://download2.mikrotik.com/routeros/ ... 6.37.3.zip

Or alternatively install the latest 6.39rc
 
bbranch1
just joined
Topic Author
Posts: 5
Joined: Sun Jan 08, 2017 12:52 am

Re: hAP ac with terrible speeds

Sun Jan 08, 2017 3:31 am

downgraded to 6.37.3 with no change. When I shut off a wired machine that generates a lot of traffic the problem goes away so it does appear to be some kind of flooding but it's only apparent with the wireless connection.
 
mducharme
Trainer
Trainer
Posts: 981
Joined: Tue Jul 19, 2016 6:45 pm

Re: hAP ac with terrible speeds

Sun Jan 08, 2017 4:56 am

Do you have any systems that are connected both wired and via wireless, rather than either/or?

I would probably do some packet captures to try to figure out what is going on.
 
bbranch1
just joined
Topic Author
Posts: 5
Joined: Sun Jan 08, 2017 12:52 am

Re: hAP ac with terrible speeds

Sun Jan 08, 2017 5:40 pm

I do but not sure how that would prove anything. I was able to separate the wireless traffic on a different bridge group and it seems to have worked around the issue at least from the wireless side. I still believe there is an issue with traffic being flooded over the wireless network unnecessarily.
 
bbranch1
just joined
Topic Author
Posts: 5
Joined: Sun Jan 08, 2017 12:52 am

Re: hAP ac with terrible speeds

Mon Jan 09, 2017 4:28 pm

In talking to a friend that is more familiar with the Mikrotik gear it seems I was not aware that mulitcast traffic does not get filtered on the wireless interfaces by default. This would completely explain the issue I was having.
 
olkitu
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Sat Feb 20, 2016 7:04 pm

Re: hAP ac with terrible speeds

Tue Jan 10, 2017 9:45 pm

Please post your wireless configuration. I have same device and get about 250Mbps max speed.

Please try force to WLAN N and remove not needed rates...

Image

Try this setup, it helps 5Ghz WLAN Speed :)
Network Specialist

Need know where is cellular tower? Try CellMapper to get know where is cellular tower:
https://www.cellmapper.net/map

Who is online

Users browsing this forum: No registered users and 37 guests