Page 1 of 1

hAP AC Lite channel width limit at 20Mhz ?

Posted: Thu Mar 09, 2017 3:06 pm
by timonlio
I have bought a hAP AC Lite TC (v6.37.4), and enable the cap mode, managed by a CapsMan runs on hEX Gr2 (v6.37.4), but the wireless connection runs on low bandwidth mode, always limit at 20Mhz.
How to enable 40MHz for 2.4G band and the 80MHz for 5G band ?

Here is my settings
/caps-man channel
add frequency=2412 name=channel1
add frequency=2417 name=channel2
add frequency=2422 name=channel3
add frequency=2427 name=channel4
add frequency=2432 name=channel5
add frequency=2437 name=channel6
add frequency=2442 name=channel7
add frequency=2447 name=channel8
add frequency=2452 name=channel9
add frequency=2457 name=channel10
add frequency=2462 name=channel11
add frequency=2467 name=channel12
add frequency=2472 name=channel13
add frequency=5745 name=channel149
add frequency=5765 name=channel153
add frequency=5785 name=channel157
add frequency=5805 name=channel161
add frequency=5825 name=channel165
/caps-man security
add authentication-types=wpa2-psk encryption=tkip group-encryption=tkip name=security1 passphrase=MYPASSWORD
/caps-man configuration
add channel=channel4 channel.tx-power=10 country=china datapath=datapath1 distance=indoors mode=ap name=cfg1 security=security1 ssid=MYSSID
add channel=channel161 channel.tx-power=10 country=china datapath=datapath1 distance=indoors mode=ap name=cfg2 security=security1 ssid=MYSSID
/caps-man datapath
add bridge=bridge1 client-to-client-forwarding=yes name=datapath1
/caps-man interface
add arp=enabled configuration=cfg1 disabled=no l2mtu=1600 mac-address=AA:BB:CC:DD:EE:FF master-interface=none mtu=1500 name=cap1 radio-mac=AA:BB:CC:DD:EE:FF
add arp=enabled configuration=cfg2 disabled=no l2mtu=1600 mac-address=AA:BB:CC:DD:EE:FF master-interface=none mtu=1500 name=cap2 radio-mac=AA:BB:CC:DD:EE:FF
/caps-man manager
set enabled=yes
The interface runs in 2427/20-Ce/gn(10dBm) and 5805/20-eeCe/ac(10dBm)
CAP1.png
CAP2.png
The connected device always works at 54Mbps
CAP_RegTable.png
I have try remove the 'country' setting and the 'distance', no difference.
I also try increase the 'channel.tx-power', still no luck.

I also try force specify the 'width' in configuration, ROS report errors e.g. 'band not supported' or 'channel not supported', and failed to enable the interface.
I also try specified 'Ce' or 'Ceee' or other combinations for 'Extension Channel', or limit to '2ghz-g/n' '5ghz-onlyac' '5ghz-onlyn', still can't enable wider bandwidth

Am I missing something ? And how can I enable the 20/40MHz for 2G band, and 40/80MHz for 5G band ?

Re: hAP AC Lite channel width limit at 20Mhz ?

Posted: Thu Mar 09, 2017 3:32 pm
by timonlio
And here is the h/w info query from hAP AC Lite console
/interface wireless info> hw-info wlan1
     ranges: 2312-2732/5/b,g,gn20,gn40
             2484-2484/5/b,g,gn20,gn40
  tx-chains: 0,1
  rx-chains: 0,1

/interface wireless info> hw-info wlan2
     ranges: 4920-6100/5/a,an20,an40,ac20,ac40,ac80
  tx-chains: 0
  rx-chains: 0