Page 1 of 1

Mikrotik wi-fi and Iphone = problem

Posted: Thu Mar 30, 2017 12:34 pm
by колбаскин
Have problem with Mikrotik Groove A52 and all Iphone devices
Before installing Mikrotik have worked TP-link, no problems with wi-fi
We install Mikrotik and iPhone stops work normaly Internet after a while. I wrote many times tickets, tech support does not help.
I tried to change the country, the channel, the band
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode antenna-gain=12 band=2ghz-g/n country=russia disabled=no disconnect-timeout=15s frequency=2442 \
    hw-protection-mode=rts-cts keepalive-frames=disabled mode=ap-bridge multicast-buffering=disabled name=neonmobile ssid=neonmobile.com.ua wds-ignore-ssid=yes wireless-protocol=\
    unspecified wmm-support=enabled
/interface wireless nstreme
set neonmobile enable-polling=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-key-update=1h mode=dynamic-keys wpa-pre-shared-key=22220000 wpa2-pre-shared-key=22220000
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=allowed name=free supplicant-identity=""
/interface wireless
add disabled=no keepalive-frames=disabled mac-address=D6:CA:6D:F0:EE:E5 master-interface=neonmobile mode=ap-bridge multicast-buffering=disabled name=Free_neonmobile \
   security-profile=free ssid="Free neonmobile.com.ua" wds-cost-range=0 wds-default-cost=0 wds-ignore-ssid=yes wps-mode=disabled
winbox_2017-03-30_12-22-36.png
winbox_2017-03-30_12-25-10.png

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Mar 30, 2017 1:35 pm
by matiaszon
I also had problems with Apple devices and MikroTiks, but they are now working fine. Let me ask you few questions...

1. What is your iOS version?
2. What is your RouterOS version?
3. What are your DHCP settings?
4. What are your wireless settings (probably most important)?

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Mar 30, 2017 1:46 pm
by wawinfo
Set peramble-mode in wireless interface to short and check all clients connections.

فرستاده شده از FRD-L09ِ من با Tapatalk

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Mar 30, 2017 2:37 pm
by колбаскин
1. IOS different version. Iphone 7 - 10.3
2. 6.38.5
3. DHCP work fine, 192.168.0.0/24
winbox_2017-03-30_14-31-54.png
winbox_2017-03-30_14-32-18.png

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Mar 30, 2017 3:17 pm
by matiaszon
I would set up preamble for "both".
Disable Nstreme
Disable Polling
Enable CSMA

I would suggest to copy & paste export of your settings.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Mar 30, 2017 3:43 pm
by колбаскин
I would set up preamble for "both".
Disable Nstreme
Disable Polling
Enable CSMA
Not help.
I make export of settings in 1st mess
winbox_2017-03-30_15-39-42.png

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Mar 30, 2017 3:46 pm
by chechito
try disabling multicast helper, and enabling multicast buffering

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Mar 30, 2017 3:54 pm
by matiaszon
try disabling multicast helper, and enabling multicast buffering
I have multicast helper turned on but with keep alive frames on too.


Wysłane z iPhone za pomocą Tapatalk

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Mar 30, 2017 4:40 pm
by chechito
try disabling multicast helper, and enabling multicast buffering
I have multicast helper turned on but with keep alive frames on too.


Wysłane z iPhone za pomocą Tapatalk
ok

turn off multicast helper, disable keep alive frames too (to improve battery life), and enable multi-cast buffering and see if problem solves

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Mar 30, 2017 5:18 pm
by колбаскин
try disabling multicast helper, and enabling multicast buffering
turn off multicast helper, keep alive frames (to improve battery life), and enable multi-cast buffering and see if problem solves
Thx man, i try tomorrow/

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Apr 04, 2017 3:54 pm
by колбаскин
Not helped. Iphone with Mikrotik not work normally

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Apr 04, 2017 4:21 pm
by w32pamela
Try changing the Channel Width to 20/40MHz Ce.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Apr 04, 2017 4:28 pm
by Shadeofspirit
Not helped. Iphone with Mikrotik not work normally
a have hap ac lite, there were problems with ipad on 2.4ghz and with iphone 5s both 2.4 and 5ghz
but with this config all works good
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" management-protection=\
    allowed mode=dynamic-keys name=profile supplicant-identity="" \
    wpa2-pre-shared-key=wifipassword
add authentication-types=wpa2-psk eap-methods="" management-protection=\
    allowed mode=dynamic-keys name=profile5 supplicant-identity="" \
    wpa2-pre-shared-key=wifipassword
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    disabled=no distance=indoors frequency=auto mode=ap-bridge \
    multicast-helper=full preamble-mode=long security-profile=profile \
    ssid=wifinet wireless-protocol=802.11 wmm-support=enabled wps-mode=\
    disabled
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=\
    20/40/80mhz-Ceee country="united states" disabled=no distance=indoors \
    frequency=auto frequency-mode=regulatory-domain mode=ap-bridge \
    preamble-mode=long security-profile=profile5 ssid=wifinet5 \
    wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
try it, the problem in my situation was in country, channel width

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Apr 04, 2017 5:06 pm
by колбаскин
The main problem, when blocking the screen iphone ceases to work the Internet.
Messages don't come to messengers when to wi-fi mikrotik
When iPhones connect to wi-fi tp-link. Take the message normally. There are no problems.
Today I tested several hours.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Apr 04, 2017 5:17 pm
by колбаскин

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Apr 04, 2017 11:31 pm
by Shadeofspirit
the only difference between our configs that i had found is that i don't use "superchanel"
on my config i use manual for 2.4 and regulatory domain (usa) for 5ghz

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Apr 04, 2017 11:43 pm
by колбаскин
the only difference between our configs that i had found is that i don't use "superchanel"
on my config i use manual for 2.4 and regulatory domain (usa) for 5ghz
Your ping vanishes to iphone when the screen is switched off?

Re: RE: Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Apr 04, 2017 11:47 pm
by Shadeofspirit
the only difference between our configs that i had found is that i don't use "superchanel"
on my config i use manual for 2.4 and regulatory domain (usa) for 5ghz
Your ping vanishes to iphone when the screen is switched off?
Actually i didn't test it, but when unblock phone it doesn't need to reconnect and the sreen is of all notifications from internet come to the phone

Отправлено с моего Redmi 3S через Tapatalk

Re: RE: Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 12:00 am
by колбаскин
Actually i didn't test it, but when unblock phone it doesn't need to reconnect and the sreen is of all notifications from internet come to the phone
У меня пропадает ping при блокировке экрана.
Не приходят мессаги из Viber пока не включишь экран. От wi-fi Не отключается, но и не работает.
Техсап молчит. Написали мне что это нормальная работа с iphone.
Что делать не представляю.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 12:07 am
by DJSmiley
Which channels are you using and which iphone?

I know there was an issue with DFS channels which has been rsolved in a RC

https://mikrotik.com/download/changelog ... lease-tree

*) wireless - fixed false positive DFS radar detection caused by iPhone 6s devices;

Re: RE: Re: RE: Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 12:08 am
by Shadeofspirit
Actually i didn't test it, but when unblock phone it doesn't need to reconnect and the sreen is of all notifications from internet come to the phone
У меня пропадает ping при блокировке экрана.
Не приходят мессаги из Viber пока не включишь экран. От wi-fi Не отключается, но и не работает.
Техсап молчит. Написали мне что это нормальная работа с iphone.
Что делать не представляю.
Завтра вечером проверю пинг на айфоне, с уведомлениями поздно приходят только в телеграм (но не только через wifi) - после некоторого времени после сворачивания перестают приходить. Думаю еще будет влиять версия ос

Отправлено с моего Redmi 3S через Tapatalk

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 8:20 am
by baragoon
Guys, this is international forum with only English allowed.
If you want to talk russian - go to russian mikrotik unofficial forum.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 9:27 am
by колбаскин
Guys, this is international forum with only English allowed.
If you want to talk russian - go to russian mikrotik unofficial forum.
If you want to help us - help.
If to teach us to rules - go the wood.
There is an official support through tikets, but they don't answer questions.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 9:31 am
by baragoon
Guys, this is international forum with only English allowed.
If you want to talk russian - go to russian mikrotik unofficial forum.
If you want to help us - help.
If to teach us to rules - go the wood.
There is an official support through tikets, but they don't answer questions.
If you breaking forum rules you can achieve help from nobody.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 9:43 am
by normis
Sausage! All tickets are answered within 3 business days. If you did not get answers, post your ticket number.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 9:53 am
by колбаскин
Sausage! All tickets are answered within 3 business days. If you did not get answers, post your ticket number.
[Ticket#2017032122000472]

I wrote 4 times that haven't helped.
I sent backups, Video, Screenshots
Nobody answers
firefox_2017-04-05_09-52-17.png

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 10:04 am
by колбаскин
I can't adjust two weeks to people wireless network.

Problems on all iPhones
Settings in tp-link standard. Just wi-fi with encoding of WPA2+AES
It is disconnected nothing, everything works
Normally messages come from Viber and Skype
With Mikrotik on problem wi-fi. That generally simply doesn't connect, through half of second stops will be connected.
Byvavet writes the incorrect password, and through time is connected.
Was that doesn't receive ip on the local area network.
I put back tp-link, everything works ideally.
tplink.jpg

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 10:19 am
by normis
[Ticket#2017032122000472]
There are emails to you. Maybe you should check your email service?
screen 2.jpg

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 10:25 am
by колбаскин
There are emails to you. Maybe you should check your email service?
Maybe you won't do of people of fools?
I was responded after I at a forum wrote and I received your message.
Probably it is worth placing in blogs correspondence with technical support?
You helped nothing. At forums people complain of operation of wi-fi with iPhones.
All of you deny.

Maybe you will begin to help?
firefox_2017-04-05_10-26-12.png
When there is next MUM in Ukraine, you won't like our questions.
You promised good support when we met in Kiev.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 10:29 am
by normis
it was not, please use a calculator.

What are you trying to say? Your picture also shows Uldis replied yesterday. One email per day is too slow? I suggest hiring a Consultant, maybe he can help you in real time.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 10:33 am
by колбаскин
it was not, please use a calculator.

What are you trying to say? Your picture also shows Uldis replied yesterday. One email per day is too slow? I suggest hiring a Consultant, maybe he can help you in real time.
Please give me contact
firefox_2017-04-05_10-26-12.png
Yes. its to slow

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 10:36 am
by normis

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 10:39 am
by колбаскин
All of them from Russia, and I from Ukraine?
Someone from them has to help me?
Or you just don't want to solve a problem?

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 10:55 am
by normis
All of them from Russia, and I from Ukraine?
Someone from them has to help me?
Or you just don't want to solve a problem?
... oh really? Try to scroll to Ukraine maybe? ...

you use russian email server, I wrongly suggested Russia because of this.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 11:07 am
by bedior
колбаскин
I think this issue located more deeply, not in settings. Support will not help you, bro. They will be ask you many parameters, all data, maybe even access to device, than connect to it for 2 minutes, and say, that it's ok, try to change iPhone, reinstall Viber...

Mikrotik wi-fi and Iphone = problem

Posted: Wed Apr 05, 2017 11:18 am
by matiaszon
I have few devices working with 3 mikrotik APs: iPad 1, iPad Mini, iPhone 5, iPhone 5S, iPhone 4S, iPhone 6S and iPhone 7. None of them is having any problems with working. There was a problem sometime ago, but after upgrading RouterOS and iOS it started to work properly.

So I believe it's just a matter of proper settings.

Wysłane z iPhone za pomocą Tapatalk

Re: Mikrotik wi-fi and Iphone = problem

Posted: Mon Apr 10, 2017 5:29 pm
by marcperea
100% working iPhone 7 and HAP AC Lite config
/interface wireless export
# apr/10/2017 09:24:02 by RouterOS 6.38.5
# software id = 1Z7U-FUNH
#
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce country="united states" disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=networkd wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=networkd wireless-protocol=802.11
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm group-key-update=1h mode=dynamic-keys supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=mypsk123 wpa2-pre-shared-key=\
mypsk123
add authentication-types=wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm group-key-update=1h management-protection=allowed mode=dynamic-keys name=guest supplicant-identity="" unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=1234567890 \
wpa2-pre-shared-key=1234567890
/interface wireless
add disabled=no keepalive-frames=disabled mac-address=6E:3B:6B:00:BC:15 master-interface=wlan1 mode=ap-bridge multicast-buffering=disabled name=guest-aerez-2.4 security-profile=guest ssid="Join me" wds-cost-range=0 wds-default-cost=0 wps-mode=\
disabled
add disabled=no keepalive-frames=disabled mac-address=6E:3B:6B:00:BC:15 master-interface=wlan2 mode=ap-bridge multicast-buffering=disabled name=guest-aerez-5 security-profile=guest ssid="Join me" wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
wireless.png
advanced.png

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Apr 13, 2017 9:58 am
by uldis
we were able to find the problem. It is related to the DHCP lease time.
By default Lease time on the MikroTik DHCP Server is 10 minutes. The iPhone disconnects approx after 5-7 minutes (little more than half of the DHCP lease time).
On TP-link the lease time is 120 minutes and that is why the iPhone is connected a lot longer. If you lower the lease time on the TP-link also to 10 minutes then you will see that it also disconnects in 5-7 minutes.

The solution for this is to increase the DHCP Server lease time to a lot longer time and then iPhone will keep connection to the AP a lot longer.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Sun Apr 16, 2017 6:16 pm
by freemannnn
its been 3 years now that my iphone and ipad at home disconnected after 5 minutes when screen went off. i didnt have this problem with provider router thomson or zte.
i would never thought the problem was dhcp server set to 10min lease time. i set it now at 24h and everything is ok.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Sun Apr 16, 2017 6:26 pm
by jarda
Apparently the problem is not the dhcp server but the iPhone dhcp client behavior.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue May 02, 2017 4:06 pm
by Anibius
https://youtu.be/nH-nN4Y_dvs?t=64
!!tx power 30 is too BIG!!
Too much power!

I have hAP AC wth 6.37.5 (downgrade from 6.38)
iPhone 7 plus,iPad Air,|ZenPad all works fine.

use 5GHz for all devices.

set "All rates fixed" to 23
Band "5ghz-a/n/ac"
Channel witdh "20/40/80 Ceee"

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" group-key-update=1h mode=\
dynamic-keys name=wifi supplicant-identity="" wpa2-pre-shared-key=\
wifi_password_here
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \
band=2ghz-onlyn channel-width=20/40mhz-Ce country=russia \
default-authentication=no disabled=no distance=indoors frequency=2422 \
hw-protection-mode=rts-cts keepalive-frames=disabled mode=ap-bridge \
multicast-helper=full preamble-mode=long security-profile=wifi ssid=MY \
tx-power=18 tx-power-mode=all-rates-fixed wireless-protocol=802.11 \
wmm-support=enabled wps-mode=disabled
set [ find default-name=wlan2 ] band=5ghz-a/n/ac bridge-mode=disabled \
channel-width=20/40/80mhz-Ceee default-authentication=no disabled=no \
disconnect-timeout=9s distance=indoors keepalive-frames=disabled mode=\
ap-bridge multicast-buffering=disabled security-profile=wifi ssid=MY2 \
tx-power=23 tx-power-mode=all-rates-fixed wireless-protocol=802.11 \
wps-mode=disabled


/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge lease-time=8h10m \

/ip firewall address-list
add address=x.x.x.x list=iOS


/ip firewall filter
add action=fasttrack-connection chain=forward comment="iOS Fasttrack" \
connection-state=established,related src-address-list=iOS

Re: Mikrotik wi-fi and Iphone = problem

Posted: Sun Dec 31, 2017 3:23 pm
by andreapugliese
Hello,
I have seen that the problem of the disconnection of Apple devices from wifi happend when there is a hotspot without "*.apple.com" in the walled garden.
The wg must be written before the device connect to wifi. For my need actually the wg must be empty because otherwise cna doesn't start. Do someone have discoverded any solution? (every ideas such as lease time of dhcp, arp time, ect didn't work) Thanks for any answer

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Feb 06, 2018 9:30 pm
by petar258
Well i had problem with reconnecting iphone 6s plus in intervals about 30 seconds when screen is locked or disconnecting from wifi at random intervals. I experimented with different settings and finally i discovered that iphone dont like AMSDU Limit and AMSDU Treshold when set to default 8192. These both when set to 0, 256 or 4096 made stable connection with iphone and no more reconnects. I dont tryed with different values, feel free to experiment if you want. My device is hap ac, and here my config for wireless:

/interface wireless
set [ find default-name=wlan1 ] amsdu-limit=4096 amsdu-threshold=4096 band=\
2ghz-b/g/n country=bulgaria disabled=no frequency=2432 mode=ap-bridge ssid=\
wifi4 tx-power=23 tx-power-mode=all-rates-fixed wireless-protocol=802.11 \
wmm-support=enabled wps-mode=disabled
set [ find default-name=wlan2 ] amsdu-limit=4096 amsdu-threshold=4096 band=\
5ghz-a/n/ac channel-width=20/40/80mhz-Ceee country=bulgaria disabled=no \
mode=ap-bridge ssid=wifi4_ tx-power=23 tx-power-mode=all-rates-fixed \
wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" \
group-key-update=1h mode=dynamic-keys supplicant-identity=MikroTik \
wpa-pre-shared-key="aaaaaaaa" wpa2-pre-shared-key="aaaaaaaa"

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Feb 06, 2018 10:22 pm
by nichky
@uldis i had same problem on rb951ui-2hnd.
I followed your instruction about increasing Lease time.

all good now :)

Thanks

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Feb 08, 2018 7:40 pm
by ZschimmerIT
Hi Mikrotik Community,

I've problems with Mikrotik WIFI and Apple iOS devices.
At some of my customers they use a new Till System which is based on iOS.
So there is one "Master- Till" (iPad) running the Till- app with a Database and the client- devices like iPod touch, iPhone or iPad are connecting via wifi to the Database for accessing tables etc.
The connection is established via TCP port.

So when you start the app on the clients there'll be a steady TCP connection established to the Master-Device.
This connection is sporadically breaking and then the clients can't connect.
You have to wait till the timeout (10sec)'ll kick in or you need to restart the app.
That's really annoying when you running a busy Bar/Restaurant.

Here is my Setup:
Running CAPsMAN on RB3011UIAS
multiple wAP_AC's directly connected to a main-switch and then running to the CAPsMAN.
Newest FW (6.41.1) on all devices!
For testing activated only 5GHz, no other SSIDs, central bridging of all interfaces, no firewalling inbetween, only RSTP on switch an central bridge
----------------
Same with a hAP-ac (basic-config) with CAPsMAN and only the internal antennas assigned.

The client's aren't loosing the wifi link; you can still open websites in Safari etc.
Also run ping's on master and all clients; there are no drops!
So what can be the issue?
Why is the TCP connection breaking all the time?
With some other brands they don't have these issues (Aerohive, Apple Extreme...)
Even scanned the SSID's around because of interferences/overlapping networks but the 5Ghz network is very clean

Is there any TTL setting for TCP connections on bridged or "client to client" forwarded connections?
only know the settings from "Connection Tracking" but this setting only affects traffic passing the Firewall.

Hopefully somebody knows the magic?

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Feb 08, 2018 8:15 pm
by ZschimmerIT
Another test:
Connected the "Master- Device" running the database with an ethernet- adapter to the hAP_ac on eth3 and sniffed the traffic coming and going through.
Maybe somebody here is an expert reading these with wireshark :)
normal sniff while connecting all three devices:
https://drive.google.com/open?id=1mBjlm ... oitWkttSXx

Sniff after one client (192.168.88.103) lost the connection to x.x.x.10 :
https://drive.google.com/open?id=1dUCKK ... RMKMOTPBMI

Sniff after one client (192.168.88.101) lost the connection to x.x.x.10:
https://drive.google.com/open?id=1uyE92 ... YVd7Qi_gc_

Maybe it's more an app issue?

192.168.88.10 is the Master-Device
192.168.88.101 Client 1
192.168.88.102 Client 2
192.168.88.103 Client 3
192.168.88.201 Printer1
192.168.88.202 Printer2


Cheers

Re: Mikrotik wi-fi and Iphone = problem

Posted: Sat Jun 02, 2018 8:00 am
by chechito
try routeros 6.40.8

wifi performance was improved with some client devices (BCM chipsets)

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Jun 07, 2018 8:23 pm
by Elliot
Have problem with Mikrotik Groove A52 and all Iphone devices
Before installing Mikrotik have worked TP-link, no problems with wi-fi
We install Mikrotik and iPhone stops work normaly Internet after a while. I wrote many times tickets, tech support does not help.
I tried to change the country, the channel, the band
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode antenna-gain=12 band=2ghz-g/n country=russia disabled=no disconnect-timeout=15s frequency=2442 \
    hw-protection-mode=rts-cts keepalive-frames=disabled mode=ap-bridge multicast-buffering=disabled name=neonmobile ssid=neonmobile.com.ua wds-ignore-ssid=yes wireless-protocol=\
    unspecified wmm-support=enabled
/interface wireless nstreme
set neonmobile enable-polling=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-key-update=1h mode=dynamic-keys wpa-pre-shared-key=22220000 wpa2-pre-shared-key=22220000
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=allowed name=free supplicant-identity=""
/interface wireless
add disabled=no keepalive-frames=disabled mac-address=D6:CA:6D:F0:EE:E5 master-interface=neonmobile mode=ap-bridge multicast-buffering=disabled name=Free_neonmobile \
   security-profile=free ssid="Free neonmobile.com.ua" wds-cost-range=0 wds-default-cost=0 wds-ignore-ssid=yes wps-mode=disabled
winbox_2017-03-30_12-22-36.png
winbox_2017-03-30_12-25-10.png
I don't know if it was said before but you need to enable tkip on security profile. I have a lot of apple devices at home and they started working fine after enabling tkip in security profiles

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Jun 26, 2018 3:24 am
by vecernik87
I can also regularly see iOS devices disconnecting from my AP when their screen goes off:
2018-06-26_1016.png

I believe this is some power-saving feature of iOS, because mikrotik cannot possibly know if device has screen on or off.
I don't understand, how could this be a fault of Mikrotik, when iOS sends a disassoc/deauth frame. Maybe it did not happen with tp-link because tp-link don't follow standards? (maybe - i cannot be certain but it is one of many possibilities)

Start logging your wireless info and you might figure out what is happening.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Jun 26, 2018 8:56 am
by ingdaka
Set Wireless Protocol to Any or 802.11, don't leave it unspecified!

Re: Mikrotik wi-fi and Iphone = problem

Posted: Fri Jul 13, 2018 7:04 pm
by bass
Set peramble-mode in wireless interface to short and check all clients connections.

فرستاده شده از FRD-L09ِ من با Tapatalk
I was just the opposite,
I set it up with long preamble with long leased time, and they able to connected just fine until now..
thats it and just it..

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Sep 26, 2018 9:02 am
by njumh
u can tray this metode

in interface wlan
at frecuency mode change to regulatory-domain
select country u base

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Sep 26, 2018 11:36 pm
by UpRunTech
u can tray this metode

in interface wlan
at frecuency mode change to regulatory-domain
select country u base
Don't forget that Apple have some advice on the matter.

https://support.apple.com/en-au/HT202068

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Sep 27, 2018 12:43 am
by Lognet
Just for some of you who still have trouble with some Mikrotik wifi and apple devices...

IP Firewall tracking....OFF

That work all the way for me

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Sep 27, 2018 12:42 pm
by martydingo
We've seen this issue on a few hundred hAP ac lites.

It's WPA1 being selected, you need to have WPA2 w/ AES only in your security profiles and apple devices will work again.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Oct 03, 2018 11:40 am
by DmitryT
Frist DHCP lease time -> 8 hours its works without disconnect

Re: Mikrotik wi-fi and Iphone = problem

Posted: Fri Nov 02, 2018 2:00 am
by DJGlooM
you need to have WPA2 w/ AES only in your security profiles and apple devices will work again.
I have couple sites with "iphone problem" and some other sites that have apple products, but there is no problem, with the same hardware (wap or wap ac). The problem occurs randomly and present itself as "there is a phone connection to SSID, but there's no internet". You can see sometimes "disassoc sending station leaving" in log. I use WPA2 only everywhere, DHCP lease is 24 hrs. Tried to disable RSTP, IGMP spoofing etc. Tried basically everything - problem is still there. With cheap soap routers like dlink\asus there is no problem, so it's pretty hard to explain a customer why mikrotik is better there. Asked Uldis at Moscow MUM - he need specific data to reproduce in lab environment to deal with this stuff and I understand him, but the problem occurs randomly during the day and there's nothing in log to report to support. And because of that one customer just asks for HP OfficeConnect AP instead of mikrotik, that's sad.
Also there's unresolved problem with Android TVs which keep losing lease and connectivity every 5 min.
Image

If anyone want to dig my config here it is:
/caps-man channel
add band=2ghz-b/g/n control-channel-width=20mhz extension-channel=XX name=2.4-auto save-selected=yes skip-dfs-channels=yes tx-power=19
add band=5ghz-a/n/ac extension-channel=XXXX name=5-auto save-selected=yes skip-dfs-channels=yes tx-power=22
/caps-man datapath
add arp=enabled bridge=bridge-lan client-to-client-forwarding=yes local-forwarding=no name=datapath-lan
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm group-key-update=1h name=WhiteHouse passphrase=12345678
/caps-man configuration
add channel=2.4-auto country=russia3 datapath=datapath-lan distance=indoors guard-interval=any hw-protection-mode=rts-cts hw-retries=15 keepalive-frames=enabled mode=\
    ap multicast-helper=full name=WhiteHouse rx-chains=0,1,2 security=WhiteHouse ssid=WhiteHouse tx-chains=0,1,2
add channel=5-auto country=russia3 datapath=datapath-lan distance=indoors guard-interval=any hw-protection-mode=rts-cts hw-retries=15 keepalive-frames=enabled mode=ap \
    multicast-helper=full name=WhiteHouse@5 rx-chains=0,1,2 security=WhiteHouse ssid=WhiteHouse@5 tx-chains=0,1,2
/caps-man access-list
add action=reject allow-signal-out-of-range=10s disabled=no interface=any signal-range=-120..-81 ssid-regexp=""
/caps-man manager
set enabled=yes package-path=/usbflash upgrade-policy=suggest-same-version
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=vlan2
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=a,an,ac master-configuration=WhiteHouse@5 name-format=identity
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=WhiteHouse name-format=identity

Re: Mikrotik wi-fi and Iphone = problem

Posted: Fri Nov 02, 2018 4:23 pm
by tippenring
We stopped using Mikrotik for client wifi several years ago due to connection instability and weak signals vs other brands. We fought with it for a long time. Apple devices are especially troublesome.

We still use Mikrotik routers almost exclusively and Mikrotik radios for point to point wifi links though.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Sun Nov 25, 2018 11:53 pm
by DJGlooM
Ok now mikrotik just ignoring emails to support on this issue. Well, looks like we'll leave mikrotik only as router and wi-fi will go with other brand. This is ridiculous situation, shame on you mikrotik.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Mon Nov 26, 2018 8:33 am
by Jotne
The iPhone disconnects approx after 5-7 minutes (little more than half of the DHCP lease time).
I do not understand why Apple does not follow any standard. It seems that it tries to invent all stuff by it self.
If you pass with you iPhone an Wifi network without security, it will automatically try to connect and call home to Apple.
This is for us a resource problem. When you have a large guest network with more than 1500 active user and wfi access point everywhere we get problems with number of DHCP address. If a buss passes by one of our building, and we have a access point close to the buss stopp, all apple devices connects automatically and gets a DHCP. They do not get any longer, since they does not log inn to the web portal. Due to this we have sett the lease time just to few minutes. Then this gives the problem above with apple device timing out faster than other device. I was hinking of blocking all apple and just have it open for other devices. This is a free net so they can not complain ;)

Re: Mikrotik wi-fi and Iphone = problem

Posted: Sat Dec 01, 2018 2:40 pm
by Redmor
Have problem with Mikrotik Groove A52 and all Iphone devices
Before installing Mikrotik have worked TP-link, no problems with wi-fi
We install Mikrotik and iPhone stops work normaly Internet after a while. I wrote many times tickets, tech support does not help.
I tried to change the country, the channel, the band
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode antenna-gain=12 band=2ghz-g/n country=russia disabled=no disconnect-timeout=15s frequency=2442 \
    hw-protection-mode=rts-cts keepalive-frames=disabled mode=ap-bridge multicast-buffering=disabled name=neonmobile ssid=neonmobile.com.ua wds-ignore-ssid=yes wireless-protocol=\
    unspecified wmm-support=enabled
/interface wireless nstreme
set neonmobile enable-polling=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-key-update=1h mode=dynamic-keys wpa-pre-shared-key=22220000 wpa2-pre-shared-key=22220000
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=allowed name=free supplicant-identity=""
/interface wireless
add disabled=no keepalive-frames=disabled mac-address=D6:CA:6D:F0:EE:E5 master-interface=neonmobile mode=ap-bridge multicast-buffering=disabled name=Free_neonmobile \
   security-profile=free ssid="Free neonmobile.com.ua" wds-cost-range=0 wds-default-cost=0 wds-ignore-ssid=yes wps-mode=disabled
winbox_2017-03-30_12-22-36.png
winbox_2017-03-30_12-25-10.png
Disable wpa authentication and password, leave only wpa2 and disable management protection. If someone wants wpa then he should travel back in time.
I've also noticed that some devices can't connect to 2412 channel, so if you can exclude it from scan list.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Sun Dec 16, 2018 11:29 am
by sabel
Has the author solved the problem?

Re: Mikrotik wi-fi and Iphone = problem

Posted: Wed Jan 02, 2019 4:24 pm
by TAD
Helo her I have juste change de radio name in my configuration and all is working well

Re: Mikrotik wi-fi and Iphone = problem

Posted: Sat Jan 05, 2019 2:40 pm
by Kerbia
you need to have WPA2 w/ AES only in your security profiles and apple devices will work again.
I have couple sites with "iphone problem" and some other sites that have apple products, but there is no problem, with the same hardware (wap or wap ac). The problem occurs randomly and present itself as "there is a phone connection to SSID, but there's no internet". You can see sometimes "disassoc sending station leaving" in log. I use WPA2 only everywhere, DHCP lease is 24 hrs. Tried to disable RSTP, IGMP spoofing etc. Tried basically everything - problem is still there. With cheap soap routers like dlink\asus there is no problem, so it's pretty hard to explain a customer why mikrotik is better there. Asked Uldis at Moscow MUM - he need specific data to reproduce in lab environment to deal with this stuff and I understand him, but the problem occurs randomly during the day and there's nothing in log to report to support. And because of that one customer just asks for HP OfficeConnect AP instead of mikrotik, that's sad.
Also there's unresolved problem with Android TVs which keep losing lease and connectivity every 5 min.
Image

If anyone want to dig my config here it is:
/caps-man channel
add band=2ghz-b/g/n control-channel-width=20mhz extension-channel=XX name=2.4-auto save-selected=yes skip-dfs-channels=yes tx-power=19
add band=5ghz-a/n/ac extension-channel=XXXX name=5-auto save-selected=yes skip-dfs-channels=yes tx-power=22
/caps-man datapath
add arp=enabled bridge=bridge-lan client-to-client-forwarding=yes local-forwarding=no name=datapath-lan
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm group-key-update=1h name=WhiteHouse passphrase=12345678
/caps-man configuration
add channel=2.4-auto country=russia3 datapath=datapath-lan distance=indoors guard-interval=any hw-protection-mode=rts-cts hw-retries=15 keepalive-frames=enabled mode=\
    ap multicast-helper=full name=WhiteHouse rx-chains=0,1,2 security=WhiteHouse ssid=WhiteHouse tx-chains=0,1,2
add channel=5-auto country=russia3 datapath=datapath-lan distance=indoors guard-interval=any hw-protection-mode=rts-cts hw-retries=15 keepalive-frames=enabled mode=ap \
    multicast-helper=full name=WhiteHouse@5 rx-chains=0,1,2 security=WhiteHouse ssid=WhiteHouse@5 tx-chains=0,1,2
/caps-man access-list
add action=reject allow-signal-out-of-range=10s disabled=no interface=any signal-range=-120..-81 ssid-regexp=""
/caps-man manager
set enabled=yes package-path=/usbflash upgrade-policy=suggest-same-version
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=vlan2
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=a,an,ac master-configuration=WhiteHouse@5 name-format=identity
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=WhiteHouse name-format=identity
i see the very same crap in my logs. did you find a solution?

Re: Mikrotik wi-fi and Iphone = problem

Posted: Tue Mar 12, 2019 1:23 pm
by Noxyron
I saw a similar problem in FAQ. May be it will help to solve. Why I can't connect to MikroTik 802.11n AP with Apple Mac devices?.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Mon Sep 09, 2019 12:21 pm
by MrDim
The same issue on iPad with iOS 9.3.5 on RouterOS 6.45.5 (RB951G-2HnD): after some sleep time no internet on the device. iPhone 5 iOS 10.3.4, iPhone 8 with iOS 12.1, iPhone 8 12.4.1 work fine.
Have changes Default Authenticate to yes, Group key update to 1 hour - no changes - still no internet. DHCP is set to 3 days.
The same device (iPad), but with iOS 7.1.2 worked fine for several years with Mikrotik.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Mon Sep 23, 2019 5:06 am
by shamet
I found solution by djape posted in another thread solving my problem.
I know it is old topic, but after many hours of struggle with 2 MacBook Pro not being able to get IP, complaining about IP already used by another device (when it's not) I was able to solve the problem by changing protocol-mode from rstp to stp:

/interface bridge> print
Flags: X - disabled, R - running
0 R name="bridge1" mtu=1500 actual-mtu=1500 l2mtu=1526 arp=enabled
arp-timeout=auto mac-address=XX:XX:XX:XX:XX:XX protocol-mode=stp
priority=0x8000 auto-mac=no admin-mac=XX:XX:XX:XX:XX:XX
max-message-age=20s forward-delay=15s transmit-hold-count=6
ageing-time=5m

Once changed, everything works like a charm.
I've spent hours if not days trying to figure out the problem and it looks like it was a bridge stp config.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Mon Sep 23, 2019 12:53 pm
by BartoszP

Re: Mikrotik wi-fi and Iphone = problem

Posted: Fri Sep 27, 2019 3:35 am
by shamet
Using all the recommended, in this and other threads, "tips and tricks", brought me to a point where wifi was finally working on Iphone X but not anymore on Galaxy S6. Thing was STP instead of RSTP in bridge config (for Iphone).
What I finally have done was complete reset of system, update to 6.45.6, import things that I was 100% sure didn't have influence on wlan, setting all the bridges, ports etc from scratch and enabling only necessary things for wifi to work as a starting point. And guess what? It just works. Works on everything. Later I have enabled Access List, encryption etc and still works. Bridge - RSTP.
I thought to share because I think it may be good idea to start from nothing sometimes. And after all, it took me less time than playing around and checking different options.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Fri Sep 27, 2019 5:29 am
by UpRunTech
Using all the recommended, in this and other threads, "tips and tricks", brought me to a point where wifi was finally working on Iphone X but not anymore on Galaxy S6. Thing was STP instead of RSTP in bridge config (for Iphone).
For most if not all small Mikrotik setups no devices need any kind of STP and Wifi Radios certainly don't if they are just access points for clients. xSTP is only needed in systems where there is the risk of a loop because there are multiple L2 paths in the system. I always set STP to None on my access points as a rule because it's a redundant option and there's always a risk of it causing problems.

Before anyone jumps up and down on this STP rule you always have to exercise some judgement. Single ethernet devices like a mAP or wAP are very safe to disable STP on the bridge. Devices like a cAP have some risk if eth1 and eth2 end up being plugged into the same switch, and RBx011 or hAPs always run the risk of a looped back ethernet cable.

Re: Mikrotik wi-fi and Iphone = problem

Posted: Thu Nov 07, 2019 11:23 am
by proxymus
Using all the recommended, in this and other threads, "tips and tricks", brought me to a point where wifi was finally working on Iphone X but not anymore on Galaxy S6. Thing was STP instead of RSTP in bridge config (for Iphone).
For most if not all small Mikrotik setups no devices need any kind of STP and Wifi Radios certainly don't if they are just access points for clients. xSTP is only needed in systems where there is the risk of a loop because there are multiple L2 paths in the system. I always set STP to None on my access points as a rule because it's a redundant option and there's always a risk of it causing problems.

Before anyone jumps up and down on this STP rule you always have to exercise some judgement. Single ethernet devices like a mAP or wAP are very safe to disable STP on the bridge. Devices like a cAP have some risk if eth1 and eth2 end up being plugged into the same switch, and RBx011 or hAPs always run the risk of a looped back ethernet cable.
I've the same problem with the mAP lite (STP is disabled). It is working for some time but then it stops working. The iPhone is connected to the WiFi but unable to reach anything. It is working for while again when I reboot the AP.