Page 1 of 1

SXT LTE - Show Physical Cell ID (PCI)

Posted: Fri Apr 21, 2017 6:52 am
by jessearcher
Does anyone know how to show the Physical Cell ID (PCI) the the device is connected to.

I can do it on other hardware (e.g. Huawei B315 and iPhone 6 - screenshot from my iPhone below).
unnamed.png

Re: SXT LTE - Show Physical Cell ID (PCI)

Posted: Fri Apr 21, 2017 4:27 pm
by Aufan388
Hello,

You can find this info on the quickset menu of sxt LTE or by the " /interface lte>info 0 "command on terminal
:)
LTE_quickset.JPG
LTE_info.JPG

Re: SXT LTE - Show Physical Cell ID (PCI)

Posted: Sat Apr 22, 2017 3:49 am
by jessearcher
Unfortunately that command (or doing the equivalent via the GUI) don't expose the PCI.

The PCI is a number between 0 & 503.

I can expose it via my iPhone and despite being connected to the same cell the PCI (130) isn't showing up anywhere on the SXT LTE.

Re: SXT LTE - Show Physical Cell ID (PCI)

Posted: Tue Apr 25, 2017 2:14 pm
by Aufan388
You should post your config concerning the LTE part of the config then maybe we can move forward in finding a solution.

Please hide all critical parts of your configuration when posting.

use " /export compact " in the terminal to get the full config and copy from it everything concerning your LTE config.

also I confused the values you wanted. You can see the Current Cell ID is "2" on my screenshot below current operator.

Re: SXT LTE - Show Physical Cell ID (PCI)

Posted: Thu May 04, 2017 5:42 am
by jessearcher
This is what I get when I run " /interface lte>info 0 "

Code: Select all

revision: chip:2.0 fw:0.1.2.3
current-operator: 530,01 (ECI 786691/ eNBI 3073)
current-cellid: 3
earfcn: 1800 (band 3, bandwidth 20Mhz, DL freq 1865.0Mhz)
imei: 356159060219486
imsi: 530011109255837
uicc: 1527016971281782133115240
rssi: -85dBm
rsrp: -115dBm
rsrq: -10dB
sinr: 9dB
The Cell ID of "3" is not the PCI.

Export of my config as requested is below.

It's important to note that the PCI which is what I'm after (to identify the cell I'm connecting to) is different to the "Cell ID" the Mikrotik is showing.

Code: Select all

# may/04/2017 14:28:20 by RouterOS 6.36.3
# software id = W0N2-AQ96
#
/interface ethernet
set [ find default-name=ether1 ] mac-address=<<REDACTED>>
/interface lte
set [ find ] add-default-route=yes band=3 default-route-distance=1 ip-type=\
ipv4 ipv6-interface=none mac-address=<<REDACTED>> name=lte1 \
network-mode=lte use-peer-dns=yes
/ip neighbor discovery
set lte1 discover=no
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=ether1 name=defconf
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether1 network=\
192.168.88.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=192.168.88.1 \
gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=<<REDACTED>>
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept established,related" \
connection-state=established,related
add action=accept chain=input comment="<<REDACTED>>" dst-port=\
80,8291 protocol=tcp src-address=<<REDACTED>>
add action=drop chain=input comment="defconf: drop all from WAN" \
in-interface=lte1
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related
add action=accept chain=forward comment=\
"defconf: accept established,related" connection-state=\
established,related
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface=lte1
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
out-interface=lte1
/system clock
set time-zone-name=Pacific/Auckland
/system identity
set name="<<REDACTED>>"
/system logging
add topics=lte
/system routerboard settings
set init-delay=0s protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether1
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether1