Community discussions

 
SiByte
just joined
Topic Author
Posts: 4
Joined: Thu Jul 06, 2017 11:20 pm

Slow WiFi (Mikrotik WAP)

Thu Jul 06, 2017 11:50 pm

I have problem with very slow WiFi speed. I use Mikrotik WAP. I try lot of different settings but no change max speed is about 3MB/s from my NAS to device if I use wired connection I get over 100MB/s.

My reality :( Before WAP I use cheap TP-Link for 10€ and I get much higher speed. Around 20-30MB/s or even more.
slow-wifi.png
You do not have the required permissions to view the files attached to this post.
 
effndc
newbie
Posts: 40
Joined: Wed Jan 11, 2017 1:25 am

Re: Slow WiFi (Mikrotik WAP)

Fri Jul 07, 2017 2:27 am

You likely need to provide more info, start with telling us what model of access point you are using and then how that connects to the rest of your network. You may also want to include the configuration from your access point (run /export compact hide-sensitive). To make it easier when you paste the configuration use the block quote in the editor here.
 
Van9018
Long time Member
Long time Member
Posts: 505
Joined: Mon Jun 16, 2014 6:26 pm
Location: Canada - Abbotsford

Re: Slow WiFi (Mikrotik WAP)

Fri Jul 07, 2017 6:25 am

I stopped using Mikrotik for wifi as I've never gotten anything better than 25mbps (3MB/s) on 2.4Ghz. I switched to another brand for wifi APs and performance is better.
Lots of people have this issue and no solutions found yet.
viewtopic.php?f=7&t=122853
 
SiByte
just joined
Topic Author
Posts: 4
Joined: Thu Jul 06, 2017 11:20 pm

Re: Slow WiFi (Mikrotik WAP)

Fri Jul 07, 2017 7:16 am

I'm using Mikrotik WAP, WAP AP is connected to HP switch and directly to that switch is also connected NAS. So WAP and NAS are directly connected to same switch.

My configuration
# jul/07/2017 06:14:03 by RouterOS 6.39.2
# software id = Z031-2NY3
#
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-Ce \
    disabled=no distance=indoors frequency=2417 mode=ap-bridge ssid=Leutgeb_NET \
    wireless-protocol=802.11 wps-mode=disabled
/ip neighbor discovery
set ether1 discover=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys \
    supplicant-identity=MikroTik
add authentication-types=wpa2-psk mode=dynamic-keys name=guest
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=wlan1 name=defconf
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
/ip address
add address=192.168.1.5/24 comment=defconf interface=wlan1 network=192.168.1.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add comment=defconf gateway=0.0.0.0
/ip dns
set allow-remote-requests=yes servers=192.168.1.1
/ip dns static
add address=192.168.1.5 name=router
/ip firewall filter
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept established,related" \
    connection-state=established,related
# in/out-interface matcher not possible when interface (ether1) is slave - use mas
 er instead (bridge1)
add action=drop chain=input comment="defconf: drop all from WAN" in-interface=\
    ether1
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" connection-state=\
    invalid
# in/out-interface matcher not possible when interface (ether1) is slave - use mas
 er instead (bridge1)
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" disabled=yes \
    out-interface=ether1
/ip route
add distance=1 gateway=192.168.1.1
/system clock
set time-zone-name=Europe/Ljubljana
/system identity
set name=AP1
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=wlan1
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=wlan1
 
freemannnn
Long time Member
Long time Member
Posts: 663
Joined: Sun Oct 13, 2013 7:29 pm

Re: Slow WiFi (Mikrotik WAP)

Fri Jul 07, 2017 8:37 am

can u test transfer from a pc or laptop to NAS with wired connection.
i remember in the old days that some NAS network chip, speed u could achive was only 5mb/sec
 
SiByte
just joined
Topic Author
Posts: 4
Joined: Thu Jul 06, 2017 11:20 pm

Re: Slow WiFi (Mikrotik WAP)

Fri Jul 07, 2017 5:33 pm

I use HP ProLiant Microserver Gen8 for NAS, and over wired connection I get around 110-120MB/s.
 
mistry7
Forum Guru
Forum Guru
Posts: 1284
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: Slow WiFi (Mikrotik WAP)

Fri Jul 07, 2017 11:40 pm

Please try Setting band=g/n
Is this Channel clear?
 
Prof13
just joined
Posts: 7
Joined: Wed Nov 02, 2016 11:37 am
Location: Ukraine

Re: Slow WiFi (Mikrotik WAP)

Sat Jul 08, 2017 1:32 pm

I have the similar issue with my cAP that is working as CAPsMAN's slave from RB2011.
Wi-Fi speed reaches 40 MB/s via RB2011 and 3 MB/s via cAP. Bandwidth test shows ~100 MB/s between the devices.

I will try g/n and only-n modes, and share results in a few days.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2982
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Slow WiFi (Mikrotik WAP)

Sat Jul 08, 2017 1:57 pm

I'm using Mikrotik WAP, WAP AP is connected to HP switch and directly to that switch is also connected NAS. So WAP and NAS are directly connected to same switch.
I assume the wAP is not your Internet router.

There are several things that can be improved on your wAP configuration.

cAP and wAP are basic APs, conceived for serving as bare APs in high-density deployments. The better you optimize the config for their humble CPU, the better.

If this is serving just as an AP, try this config:
/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
/interface bridge
set fast-forward=yes 0
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn  \
    disabled=no frequency=2417 mode=ap-bridge ssid=Leutgeb_NET \
    wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys \
    supplicant-identity=MikroTik
add authentication-types=wpa2-psk mode=dynamic-keys name=guest
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=bridge1
/system clock
set time-zone-name=Europe/Ljubljana
/system identity
set name=AP1
This programs the wAP to be essentially a wired/wireless "switch", which gets it's management IP from dhcp.

Is it advisable to create a static lease on your LAN router so that wAP always gets the same IP, though you could ever manage it without ip via mac-winbox or RoMON (i.e. without any IP addressing on the wAP).

No firewall, nor anything else, just an optimized config so that CPU requirements on the wAP are the minimum, the better, and everything is handled by hardware where possible.

DHCP to the wireless clients will be handled by your main Internet router.

Pay special attention to the devices Firmware (make sure Upgrade Firmware is the same as Upgrade Firmware @ System > Routerboard)
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
User avatar
pukkita
Trainer
Trainer
Posts: 2982
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Slow WiFi (Mikrotik WAP)

Sat Jul 08, 2017 2:04 pm

Prof13: which ROS/Firmware on CAPs and CAPsMAN?
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
Deaqui
just joined
Posts: 17
Joined: Sun Jun 21, 2015 8:18 pm

Re: Slow WiFi (Mikrotik WAP)

Sat Jul 08, 2017 9:00 pm

Hello Pukkita,
When I connect with the mobile the map lite shows a connection of 54 mb in tx and 72 mb in rx and I can not exceed more than 20 mb doing a test of speed.I tested it with a unify ac lite and with the Movistar router and the speed test shows 40mb more or less.
It is as if for the download the smartphone will connect in g and for the rise in n.
Has this ever happened to you with some Mikrotik ap?
I have tested with map lite, wap, hap lite and groove, but I always get the same result.
 
SiByte
just joined
Topic Author
Posts: 4
Joined: Thu Jul 06, 2017 11:20 pm

Re: Slow WiFi (Mikrotik WAP)

Sat Jul 08, 2017 11:41 pm

I'm using Mikrotik WAP, WAP AP is connected to HP switch and directly to that switch is also connected NAS. So WAP and NAS are directly connected to same switch.
I assume the wAP is not your Internet router.

There are several things that can be improved on your wAP configuration.

cAP and wAP are basic APs, conceived for serving as bare APs in high-density deployments. The better you optimize the config for their humble CPU, the better.

If this is serving just as an AP, try this config:
/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
/interface bridge
set fast-forward=yes 0
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn  \
    disabled=no frequency=2417 mode=ap-bridge ssid=Leutgeb_NET \
    wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys \
    supplicant-identity=MikroTik
add authentication-types=wpa2-psk mode=dynamic-keys name=guest
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=bridge1
/system clock
set time-zone-name=Europe/Ljubljana
/system identity
set name=AP1
This programs the wAP to be essentially a wired/wireless "switch", which gets it's management IP from dhcp.

Is it advisable to create a static lease on your LAN router so that wAP always gets the same IP, though you could ever manage it without ip via mac-winbox or RoMON (i.e. without any IP addressing on the wAP).

No firewall, nor anything else, just an optimized config so that CPU requirements on the wAP are the minimum, the better, and everything is handled by hardware where possible.

DHCP to the wireless clients will be handled by your main Internet router.

Pay special attention to the devices Firmware (make sure Upgrade Firmware is the same as Upgrade Firmware @ System > Routerboard)
Yes I use WAP only as WiFi AP. I have upgraded both Firmware and Software,

I try your settings but no change, before WAP I use TP Link model TL-WR741ND (cheapest model) and I never have problems with speed. It has slower CPU speed and half the RAM of WAP so I really doubt that problem is in CPU.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2982
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Slow WiFi (Mikrotik WAP)

Sun Jul 09, 2017 12:34 pm

Post

- an export.
- a screenshot of wireless > Registration, open the phone entry, signal tab

I have noticed, specially on devices which were released with only one chain and were later upgraded to two chains, that the second chain1 sometimes is not enabled, watch out for that.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
User avatar
pukkita
Trainer
Trainer
Posts: 2982
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Slow WiFi (Mikrotik WAP)

Sun Jul 09, 2017 12:52 pm

Hello Pukkita,
When I connect with the mobile the map lite shows a connection of 54 mb in tx and 72 mb in rx and I can not exceed more than 20 mb doing a test of speed.I tested it with a unify ac lite and with the Movistar router and the speed test shows 40mb more or less.
It is as if for the download the smartphone will connect in g and for the rise in n.
Has this ever happened to you with some Mikrotik ap?
I have tested with map lite, wap, hap lite and groove, but I always get the same result.
Map lite is a "personal" N device AP, there are two versions of it, one 1x1, latter models are 2x2. That could explain why half of the bw.

Unify Ac Lite is a different range AP, and it's AC, so is very possible you were using the 5GHz band. As ubnt doesn't publish Sensitivity specs but for speakers in their products, I cannot be 100% sure, but would say a more comparable (in hardware terms) product would be the hap AC lite.

That being said, if station is within range, it should be able to get speeds around 35Mbps TCP for 1x1 devices, and around 50-70Mbps for dual chain ones.

That's in N. Try forcing N mode only.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
Deaqui
just joined
Posts: 17
Joined: Sun Jun 21, 2015 8:18 pm

Re: Slow WiFi (Mikrotik WAP)

Sun Jul 09, 2017 3:12 pm

Hello Pukkita,
When I connect with the mobile the map lite shows a connection of 54 mb in tx and 72 mb in rx and I can not exceed more than 20 mb doing a test of speed.I tested it with a unify ac lite and with the Movistar router and the speed test shows 40mb more or less.
It is as if for the download the smartphone will connect in g and for the rise in n.
Has this ever happened to you with some Mikrotik ap?
I have tested with map lite, wap, hap lite and groove, but I always get the same result.
Map lite is a "personal" N device AP, there are two versions of it, one 1x1, latter models are 2x2. That could explain why half of the bw.

Unify Ac Lite is a different range AP, and it's AC, so is very possible you were using the 5GHz band. As ubnt doesn't publish Sensitivity specs but for speakers in their products, I cannot be 100% sure, but would say a more comparable (in hardware terms) product would be the hap AC lite.

That being said, if station is within range, it should be able to get speeds around 35Mbps TCP for 1x1 devices, and around 50-70Mbps for dual chain ones.

That's in N. Try forcing N mode only.
Hello again Pukkita:
I have tested with a low-end ZTE smartphone and I have not had any problems.
I performed the tests in 20 mhz. The connection shows 72 mbps in both tx and rx.
What I have observed is that this smartphone can also connect in 40 mhz. When I connect at 40 mhz the connection shows 150 mbps tx and 150 mbps rx.
I think the problem is in the smartphones that can only connect in 20 mhz. I have tried disabling g and leaving it alone as n, but the connection still shows me 54 mbps tx and 72 mbps rx. With this data I only get a speed of 20-25 mbps doing with speedtest. My smartphone is a low-end Huawey Yumo. I have also tested with wap and groove.

A greeting.
 
Prof13
just joined
Posts: 7
Joined: Wed Nov 02, 2016 11:37 am
Location: Ukraine

Re: Slow WiFi (Mikrotik WAP)

Sun Jul 09, 2017 4:48 pm

Prof13: which ROS/Firmware on CAPs and CAPsMAN?
All devices have RouterOS v6.39 and firmware v3.33.

There is a weirdness in cAP work: first speed test can show dl - 19.93MB, up - 4.91MB and second one that is made in 3 sec after the first one can show dl - 3.28MB, up - 3.91MB...
 
User avatar
pukkita
Trainer
Trainer
Posts: 2982
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Slow WiFi (Mikrotik WAP)

Sun Jul 09, 2017 5:05 pm

Forget about the Air Rate, and 40MHz in 2.4GHz altogether... what counts is a stable connection, for that 20MHz is a must on 2.4GHz.

AirRate doesn't mean data will be actually flowing at those rates.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
User avatar
pukkita
Trainer
Trainer
Posts: 2982
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Slow WiFi (Mikrotik WAP)

Sun Jul 09, 2017 5:11 pm

Prof13: check your spectrum, and make optimal picks for channels for each cAP. In 2.4GHz there are only three non-overlapping in 20MHz channels: 1, 6 and 11.

To troubleshoot, you have too look at the signal screenshot I mentioned on my previous post while doing the transmission tests.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
Prof13
just joined
Posts: 7
Joined: Wed Nov 02, 2016 11:37 am
Location: Ukraine

Re: Slow WiFi (Mikrotik WAP)

Mon Jul 24, 2017 3:32 pm

Prof13: check your spectrum, and make optimal picks for channels for each cAP. In 2.4GHz there are only three non-overlapping in 20MHz channels: 1, 6 and 11.

To troubleshoot, you have too look at the signal screenshot I mentioned on my previous post while doing the transmission tests.
Sorry for the late reply.

I changed band mode to 2ghz-onlyn and it had no effect.
The freest channel was 3rd one, so I configured cAP with 2422 MHz with Ce extension.

Here is "/export compact" for both devices:
RB2011 - CAPsMAN
# jul/22/2017 12:36:49 by RouterOS 6.39
# software id = 37XX-0ZSC
#
/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz extension-channel=Ce frequency=\
    2437 name=channel6 tx-power=30
add band=2ghz-g/n control-channel-width=20mhz extension-channel=Ce frequency=\
    2422 name=channel3 tx-power=20
/interface bridge
add name=bridge-guest
add name=bridge-internal
/interface ethernet
set [ find default-name=ether1 ] comment="ISP - Ukrtelecom"
set [ find default-name=ether2 ] name=ether2-master
set [ find default-name=ether3 ] master-port=ether2-master name=ether3-slave
set [ find default-name=ether4 ] master-port=ether2-master name=ether4-slave
set [ find default-name=ether5 ] master-port=ether2-master name=ether5-slave
set [ find default-name=ether6 ] comment="ISP - DataGroup"
set [ find default-name=ether7 ] name=ether7-master
set [ find default-name=ether8 ] master-port=ether7-master name=ether8-slave
set [ find default-name=ether9 ] comment="Inner cAP" master-port=\
    ether7-master name=ether9-slave
set [ find default-name=ether10 ] master-port=ether7-master name=\
    ether10-slave
set [ find default-name=sfp1 ] disabled=yes
/interface wireless
# managed by CAPsMAN
# channel: 2437/20-Ce/gn(30dBm), SSID: Braviy Shveik - Guest, CAPsMAN forwarding
set [ find default-name=wlan1 ] ssid=MikroTik
/interface pppoe-client
add add-default-route=yes comment="PPPoE - DataGroup" disabled=no interface=\
    ether6 name=pppoe-out1 use-peer-dns=yes user=xxxxxxx
/caps-man datapath
add bridge=bridge-guest client-to-client-forwarding=yes name=datapath-guest
/caps-man security
add name=security-guest
/caps-man configuration
add country="united states" datapath=datapath-guest mode=ap name=cfg-guest \
    rx-chains=0,1,2 security=security-guest ssid="Braviy Shveik - Guest" \
    tx-chains=0,1,2
/caps-man interface
add channel=channel6 configuration=cfg-guest disabled=no l2mtu=1600 \
    mac-address=6C:3B:6B:F9:BF:D7 master-interface=none name=cap1 radio-mac=\
    6C:3B:6B:F9:BF:D7
add channel=channel3 configuration=cfg-guest disabled=no l2mtu=1600 \
    mac-address=6C:3B:6B:8B:C5:6F master-interface=none name=cap2 radio-mac=\
    6C:3B:6B:8B:C5:6F
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool1 ranges=10.17.16.100-10.17.16.254
add name=dhcp_pool2 ranges=192.168.0.100-192.168.0.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge-internal lease-time=\
    1d name=dhcp1
add address-pool=dhcp_pool2 disabled=no interface=bridge-guest lease-time=1h \
    name=dhcp2
/ppp profile
set *0 dns-server=80.91.161.75,80.91.160.5
/tool user-manager customer
set admin access=\
    own-routers,own-users,own-profiles,own-limits,config-payment-gw
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes \
    require-peer-certificate=yes
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=cfg-guest
/interface bridge port
add bridge=bridge-internal interface=ether2-master
add bridge=bridge-internal interface=ether7-master
add bridge=bridge-guest interface=cap2
/interface l2tp-server server
set caller-id-type=ip-address
/interface wireless cap
# 
set bridge=bridge-internal caps-man-certificate-common-names=\
    CAPsMAN-6C3B6BF9BFCC certificate=CAP-6C3B6BF9BFCC discovery-interfaces=\
    bridge-internal enabled=yes interfaces=wlan1 lock-to-caps-man=yes
/ip address
add address=192.168.0.1/24 interface=bridge-guest network=192.168.0.0
add address=10.17.16.1/24 interface=bridge-internal network=10.17.16.0
/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid interface=ether1
/ip dhcp-server network
add address=10.17.16.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=10.17.16.1
add address=192.168.0.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes
/ip firewall address-list
add address=10.17.16.0/24 disabled=yes list=LocalNet
add address=192.168.0.0/24 disabled=yes list=LocalNet
/ip firewall filter
add action=drop chain=input dst-port=53 in-interface=ether1 log=yes \
    log-prefix=53_drop_ether1 protocol=udp
add action=drop chain=input dst-port=53 in-interface=ether6 log=yes \
    log-prefix=53_drop_ether6 protocol=udp
add action=drop chain=input dst-port=53 in-interface=pppoe-out1 log=yes \
    log-prefix=53_drop_pppoe protocol=udp
/ip firewall mangle
add action=mark-connection chain=input disabled=yes dst-address=10.17.16.5 \
    in-interface=ether1 new-connection-mark="Ukrtelecom -> Input" \
    passthrough=no
add action=mark-routing chain=output connection-mark="Ukrtelecom -> Input" \
    disabled=yes new-routing-mark="ISP - Ukrtelecom" passthrough=no
add action=mark-connection chain=input disabled=yes dst-address=94.232.77.199 \
    in-interface=pppoe-out1 new-connection-mark="DataGroup -> Input" \
    passthrough=no
add action=mark-routing chain=output connection-mark="DataGroup -> Input" \
    disabled=yes new-routing-mark="ISP - DataGroup" passthrough=no
add action=mark-routing chain=prerouting disabled=yes dst-address-list=\
    !LocalNet new-routing-mark="Inner network" passthrough=no src-address=\
    10.17.16.0/24
/ip firewall nat
add action=masquerade chain=srcnat comment="ISP - Ukrtelecom" disabled=yes \
    out-interface=ether1
add action=masquerade chain=srcnat comment="ISP - DataGroup" out-interface=\
    pppoe-out1
/ip route
add disabled=yes distance=1 gateway=10.17.16.1 routing-mark=\
    "ISP - Ukrtelecom"
add disabled=yes distance=1 gateway=195.114.143.0 routing-mark=\
    "ISP - DataGroup"
add check-gateway=arp disabled=yes distance=10 gateway=195.114.143.0 \
    routing-mark="Inner network"
add check-gateway=arp disabled=yes distance=11 gateway=10.17.16.1 \
    routing-mark="Inner network"
/ip route rule
add action=unreachable dst-address=10.17.16.0/24 src-address=192.168.0.0/24
add action=unreachable dst-address=192.168.0.0/24 src-address=10.17.16.0/24
cAP
# jun/29/2017 13:09:54 by RouterOS 6.39
# software id = ULE6-YZHP
#
/interface wireless
# managed by CAPsMAN
# channel: 2422/20-Ce/gn(20dBm), SSID: Office - Guest, CAPsMAN forwarding
set [ find default-name=wlan1 ] band=2ghz-g/n channel-width=20/40mhz-Ce \
    country="united states" frequency=2422 frequency-mode=superchannel \
    guard-interval=long hw-protection-mode=rts-cts hw-retries=15 mode=\
    ap-bridge rx-chains=0,1 ssid="Office - Guest" tx-chains=0,1 \
    wireless-protocol=802.11 wps-mode=disabled
/interface wireless nstreme
# managed by CAPsMAN
# channel: 2422/20-Ce/gn(20dBm), SSID: Office - Guest, CAPsMAN forwarding
set wlan1 enable-polling=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" \
    supplicant-identity=MikroTik wpa2-pre-shared-key=1234567890
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/tool user-manager customer
set admin access=\
    own-routers,own-users,own-profiles,own-limits,config-payment-gw
/interface l2tp-server server
set caller-id-type=ip-address
/interface wireless cap
# 
set caps-man-certificate-common-names=CAPsMAN-6C3B6BF9BFCC certificate=\
    CAP-6C3B6B8BC56E discovery-interfaces=ether1 enabled=yes interfaces=wlan1 \
    lock-to-caps-man=yes
/ip address
add address=10.17.16.99/24 disabled=yes interface=ether1 network=10.17.16.0
add address=192.168.1.1/24 network=192.168.1.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
/system clock
set time-zone-name=Europe/Kiev
/system identity
set name=AP-inside
Configurations look a bit "dirty" because I tried some new configurations for me.
I would be very grateful if you will tell me where is my mistake.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2982
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Slow WiFi (Mikrotik WAP)

Mon Jul 24, 2017 3:49 pm

Do a spectral-history on both, are you sure the spectrum is useable? Please post it here.

Can you connect another RB as wireless client to cAPs, and post: wireless interface status, and wireless registration signal tab.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
Prof13
just joined
Posts: 7
Joined: Wed Nov 02, 2016 11:37 am
Location: Ukraine

Re: Slow WiFi (Mikrotik WAP)

Wed Jul 26, 2017 1:28 pm

Do a spectral-history on both, are you sure the spectrum is useable? Please post it here.

Can you connect another RB as wireless client to cAPs, and post: wireless interface status, and wireless registration signal tab.
Spectral history from RB2011: http://imgur.com/xboVlvT
Spectral history from cAP: http://imgur.com/h9YRrN3

I used wAP to connect as a wireless client to the cAP and got the following results.
Wireless interface status: http://imgur.com/LBzuFOT
Wireless registration tab: http://imgur.com/kuwOq4W

Why does Tx/Rx rate reach only1mb/6mb?...
 
mistry7
Forum Guru
Forum Guru
Posts: 1284
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: Slow WiFi (Mikrotik WAP)

Wed Jul 26, 2017 10:35 pm

Channel is crouded
 
User avatar
pukkita
Trainer
Trainer
Posts: 2982
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Slow WiFi (Mikrotik WAP)

Thu Jul 27, 2017 12:45 pm

Why does Tx/Rx rate reach only1mb/6mb?...
it could be it actually isn't able to lock on higher modulations, please re-take the shots while passing traffic with bandwith test, ping speed or whatever.

From what you posted:

1.- Looks like your spectrum is really crowded
2.- Please double click on the registration tab entry, and shot the signal tab while passing traffic between them (e.g. by using bandwidth test between them).
3.- Looks they are using most basic G modulations, which could be explained by #1 (interference forces fallback to using basic rates)
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
smaritz
just joined
Posts: 5
Joined: Tue Jul 18, 2017 10:17 pm

Re: Slow WiFi (Mikrotik WAP)

Fri Dec 22, 2017 8:01 am

I'm having the exact same issue, and it seems Pukitta is not able to provide any other help than the basic 1 2 3 guide to wifi problems.

* No channel congestion
* Cable from router to AP tested with another device, tested fine
* Another cable used to test, same result.
* B/G/N makes no difference
* Newest firmware/software
* Tested with various clients

Very low latency (30ms+), low speeds (1-2mbps), and I've come to the conclusion that this is just a low quality device that should now have been released to the market, and will be returning it next week and replacing it with a Ubiquiti.
 
Casper87
just joined
Posts: 1
Joined: Thu Feb 15, 2018 10:44 am

Re: Slow WiFi (Mikrotik WAP)

Fri Feb 16, 2018 10:09 pm

I'm having the exact same issue, and it seems Pukitta is not able to provide any other help than the basic 1 2 3 guide to wifi problems.

* No channel congestion
* Cable from router to AP tested with another device, tested fine
* Another cable used to test, same result.
* B/G/N makes no difference
* Newest firmware/software
* Tested with various clients

Very low latency (30ms+), low speeds (1-2mbps), and I've come to the conclusion that this is just a low quality device that should now have been released to the market, and will be returning it next week and replacing it with a Ubiquiti.
Same problem here...but i replaced wAP AC with UAP-AC-PRO and my WiFi it's okay now.
 
Aleksov
just joined
Posts: 1
Joined: Thu Mar 22, 2018 10:09 pm

Re: Slow WiFi (Mikrotik WAP)

Thu Mar 22, 2018 10:48 pm

Hello. Got a same problem. I'm use RB3011 as CAPsMAN controller and CAPac as AP. On 5GHz got maximum 13 Mbit/s download and 89 Mbit/s upload speed. If i use cable connection direct to RB3011, got about 90/90 Mbit/s... Distance between my laptop and CAPac about 150mm (yes, i'm try longer distance)...

https://imgur.com/a/jzHoD

Here my CAPsMAN config:
caps-man export 
# mar/22/2018 23:38:55 by RouterOS 6.41.3
# software id = 6WX1-0034
#
# model = RouterBOARD 3011UiAS
# serial number = 783D08F717B0
/caps-man channel
add band=2ghz-b/g/n frequency=2412 name=CH1
add band=2ghz-b/g/n frequency=2417 name=CH2
add band=2ghz-b/g/n frequency=2422 name=CH3
add band=2ghz-b/g/n frequency=2427 name=CH4
add band=2ghz-b/g/n frequency=2432 name=CH5
add band=2ghz-b/g/n frequency=2437 name=CH6
add band=2ghz-b/g/n frequency=2442 name=CH7
add band=2ghz-b/g/n frequency=2447 name=CH8
add band=2ghz-b/g/n frequency=2452 name=CH9
add band=2ghz-b/g/n frequency=2457 name=CH10
add band=2ghz-b/g/n frequency=2462 name=CH11
add band=2ghz-b/g/n frequency=2467 name=CH12
add band=2ghz-b/g/n frequency=2472 name=CH13
add band=5ghz-a/n/ac frequency=5180 name=CH36
add band=5ghz-a/n/ac frequency=5200 name=CH40
add band=5ghz-a/n/ac frequency=5220 name=CH44
add band=5ghz-a/n/ac frequency=5240 name=CH48
add band=5ghz-a/n/ac frequency=5260 name=CH52
add band=5ghz-a/n/ac frequency=5280 name=CH56
add band=5ghz-a/n/ac frequency=5300 name=CH60
add band=5ghz-a/n/ac frequency=5320 name=CH64
add band=5ghz-a/n/ac frequency=5500 name=CH100
add band=5ghz-a/n/ac frequency=5520 name=CH104
add band=5ghz-a/n/ac frequency=5540 name=CH108
add band=5ghz-a/n/ac frequency=5560 name=CH112
add band=5ghz-a/n/ac frequency=5580 name=CH116
add band=5ghz-a/n/ac frequency=5600 name=CH120
add band=5ghz-a/n/ac frequency=5620 name=CH124
add band=5ghz-a/n/ac frequency=5640 name=CH128
add band=5ghz-a/n/ac frequency=5660 name=CH132
add band=5ghz-a/n/ac frequency=5680 name=CH136
add band=5ghz-a/n/ac frequency=5700 name=CH140
add band=5ghz-a/n/ac frequency=5745 name=CH149
add band=5ghz-a/n/ac frequency=5765 name=CH153
add band=5ghz-a/n/ac frequency=5785 name=CH157
add band=5ghz-a/n/ac frequency=5805 name=CH161
add band=5ghz-a/n/ac frequency=5825 name=CH165
/caps-man datapath
add bridge=BV0101 local-forwarding=yes name=2G-datapath
add bridge=BV0101 local-forwarding=yes name=5G-datapath
add bridge=BV0200 local-forwarding=no name=Public-datapath vlan-id=1
/caps-man configuration
add channel=CH6 country=russia3 datapath=Public-datapath mode=ap name=2G-config-pub rates.vht-basic-mcs="" rates.vht-supported-mcs="" rx-chains=0,1,2 ssid=hotspot.set.local  tx-chains=0,1,2
/caps-man rates
add basic=54Mbps ht-basic-mcs="" ht-supported-mcs="" name=rate-54 supported=54Mbps vht-basic-mcs="" vht-supported-mcs=""
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm,tkip name=public passphrase=password1
add authentication-types=wpa2-psk encryption=aes-ccm,tkip name=local passphrase=password2
/caps-man configuration
add channel=CH6 country=russia3 datapath=2G-datapath mode=ap name=2G-config rx-chains=0,1,2 security=local ssid=hs2.set.local tx-chains=0,1,2
add channel=CH52 channel.tx-power=10 country=russia3 datapath=5G-datapath mode=ap name=5G-config rx-chains=0,1,2 security=local ssid=hs5.set.local tx-chains=0,1,2
/caps-man manager
set enabled=yes package-path=/disk1/packages/routeros upgrade-policy=require-same-version
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=VR0600
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn identity-regexp="spot([0-9]+).hotspot.set.local" master-configuration=2G-config name-format=prefix-identity slave-configurations=2G-config-pub
add action=create-dynamic-enabled hw-supported-modes=gn identity-regexp="spot([0-9]+).hotspot.set.local" master-configuration=2G-config name-format=prefix-identity
add action=create-dynamic-enabled hw-supported-modes=ac identity-regexp="spot([0-9]+).hotspot.set.local" master-configuration=5G-config name-format=prefix-identity
 
Hammer
newbie
Posts: 40
Joined: Sat Sep 20, 2014 6:39 am

Re: Slow WiFi (Mikrotik WAP)

Mon May 07, 2018 12:10 pm

Is there anything new? I have an RB3011 in two places as CAPsMAN with hAP ac and the WLAN speed is about 10% of what I should have.
Newest stabile RoutOS FW and HW FW on all Device.
 
yhfung
Member Candidate
Member Candidate
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: Slow WiFi (Mikrotik WAP)

Mon May 07, 2018 12:58 pm

Hello. Got a same problem. I'm use RB3011 as CAPsMAN controller and CAPac as AP. On 5GHz got maximum 13 Mbit/s download and 89 Mbit/s upload speed. If i use cable connection direct to RB3011, got about 90/90 Mbit/s... Distance between my laptop and CAPac about 150mm (yes, i'm try longer distance)...
Have you upgraded your CAP ac to the most newest one v6.43rc6? It includes significant speed improvement on WiFi of CAP ac and hAP ac^2.
 
Hammer
newbie
Posts: 40
Joined: Sat Sep 20, 2014 6:39 am

Re: Slow WiFi (Mikrotik WAP)

Mon May 07, 2018 8:08 pm

I saw the notice in another post, so it is an improvement there (not much time to test).
CAPsMAN and its products have been on the market for a long time, what's the problem?
 
luigim
just joined
Posts: 6
Joined: Wed Nov 23, 2016 9:38 pm

Re: Slow WiFi (Mikrotik WAP)

Mon Jul 09, 2018 10:05 pm

I am having the same issue here. RB3011 as main router and CAP ac as AP. Very slow wireless speed. When I connect directly to 3011, I do get about 99mbs but wireless will only get 1~2. Anyone found a solution for this?
 
aschulze
just joined
Posts: 4
Joined: Mon Jun 11, 2018 12:17 am

Re: Slow WiFi (Mikrotik WAP)

Tue Jul 10, 2018 11:59 pm

The same problem here: 2011UiAS as CAPSManager and three hAP ac as CAPs.
All connected with 1GBit on a HP1820 Switch. On the ethernet ports I can transfer up to 108MB/s constantly. On WLAN I can transfer max. 1-2MB/s with strong fluctuations. This is terrible poor and unusable.
 
SilverNodashi
Frequent Visitor
Frequent Visitor
Posts: 69
Joined: Mon Sep 04, 2017 4:18 pm
Location: South Africa
Contact:

Re: Slow WiFi (Mikrotik WAP)

Thu Jan 10, 2019 11:54 am

I am having the same issue with a RB951Ui-2HnD, acting as "home AP. The wireless devices connect at 150Mbps yet they only get about 1Mbps internet speed on a 30Mbps fiber link. When plugging my laptop directly into the RB951Ui-2HnD LAN ports I get about 18Mbps download and 30Mbps (http://www.speedtest.net/result/7945325110) upload on speedtest.net. Yet, on wifi I only get about 3Mbps (http://www.speedtest.net/result/7944015867)

Does anyone know what could cause this?

Who is online

Users browsing this forum: Google [Bot] and 10 guests