Community discussions

 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

CAPsMAN Wireless clients do not get IP addresses

Sat Aug 26, 2017 1:51 am

I have recently configured a CAPsMAN setup. I've got it going, my CAP is provisioned correctly with both wireless interfaces managed by the CAPsMAN.
But the thing is... whey I try to register with a wireless client, I'm able to, the wireless registration succeeds, but the client does not get an IP address.
So here's the thing, in the log I see:
aug/26 01:38:13 caps,info 48:27:EA:BE:6D:D7@CAP_5GHz connected
aug/26 01:38:20 dhcp,warning dhcp-local offering lease 192.168.82.48 for 48:27:EA:BE:6D:D7 without success
aug/26 01:38:49 caps,info 48:27:EA:BE:6D:D7@CAP_5GHz disconnected, received disassoc: sending station leaving (8)

So the original request from the client is received and the DHCP server responds but apparently the client does not get the DHCP offer and hence it does not respond.
I'm really struggling to find out what's wrong with my config. Here's how it looks like:
/caps-man channel
add band=2ghz-onlyn extension-channel=Ce name=2G_channels width=20
add band=5ghz-a/n/ac extension-channel=Ce frequency=5260 name=5G_channel width=20
/caps-man rates
add basic=1Mbps,2Mbps,5.5Mbps,11Mbps,6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps name="5GHz Rates" supported=1Mbps,2Mbps,5.5Mbps,11Mbps,6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps \
vht-basic-mcs=mcs0-9 vht-supported-mcs=mcs0-9
add basic=1Mbps,2Mbps,5.5Mbps,11Mbps,6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps ht-basic-mcs=\
mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23 ht-supported-mcs=\
mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23 name="2GHz rates" supported=\
1Mbps,2Mbps,5.5Mbps,11Mbps,6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
/caps-man security
add authentication-types=wpa2-psk comment="2GHz Security" encryption=aes-ccm group-encryption=aes-ccm name=2GHz passphrase=password
add authentication-types=wpa2-psk comment="5GHz Security" encryption=aes-ccm group-encryption=aes-ccm name="5GHz Security" passphrase=password
/caps-man configuration
add channel=2G_channels comment=2GHz datapath=DataPath_2G datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes guard-interval=any mode=ap multicast-helper=full name=2GHz rates="2GHz rates" \
rx-chains=0,1,2 security=2GHz ssid=ssid1 tx-chains=0,1,2
add channel=5G_channel comment=5G datapath=datapath_5G datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes guard-interval=any mode=ap multicast-helper=full name=5Ghz rates="5GHz Rates" \
rx-chains=0,1,2 security="5GHz Security" ssid=ssid2 tx-chains=0,1,2
/caps-man datapath
add bridge=bridge-local client-to-client-forwarding=yes comment="Local Path for 2Ghz Interface" local-forwarding=yes name=DataPath_2G
add bridge=bridge-local client-to-client-forwarding=yes comment="Data Path for 5GHz Interface" local-forwarding=yes name=datapath_5G
/caps-man interface
add configuration=2GHz disabled=no l2mtu=1600 mac-address=E4:8D:8C:49:37:F2 master-interface=none name=CAP_2GHz radio-mac=E4:8D:8C:49:37:F2
add configuration=5Ghz datapath=datapath_5G disabled=no l2mtu=1600 mac-address=E4:8D:8C:49:37:F1 master-interface=none name=CAP_5GHz radio-mac=E4:8D:8C:49:37:F1
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=2GHz radio-mac=E4:8D:8C:49:37:F2
add action=create-dynamic-enabled comment=5G master-configuration=5Ghz radio-mac=E4:8D:8C:49:37:F1


Have you guys stumbled upon this?


Regards,
Boyan
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: CAPsMAN Wireless clients do not get IP addresses

Sun Aug 27, 2017 12:42 pm

So here's how I was able to solve this.
As I saw in several guides and videos, the bridge interface that's associated with the CAPs Manager should have STP disabled. I did the same with the CAP bridge interface.
After doing that I was able to get it working. So I guess it might have been the STP that has been blocking the traffic.


Regards,
Boyan
 
User avatar
PatrickDunn
just joined
Posts: 5
Joined: Wed Aug 16, 2017 2:16 pm

Re: CAPsMAN Wireless clients do not get IP addresses

Wed Aug 30, 2017 6:51 am

Try to read other thread they solve it already.

Who is online

Users browsing this forum: No registered users and 10 guests