Community discussions

 
forliberty
just joined
Topic Author
Posts: 2
Joined: Thu Sep 28, 2017 5:24 pm

Wireless Access List Not Dropping Clients with Weak Signal

Thu Sep 28, 2017 5:50 pm

I am trying to configure a RB 951Ui 2HnD to drop weak WiFi clients so they will switch to another AP as they travel around our building. I'm using RouterOS 6.37.1. I followed the instructions in the manual, as follows:

/interface wireless access-list
add interface=wireless signal-range=-55
add authentication=no forwarding=no interface=wireless signal-range=-120..-56

However, this only prevents clients with a weak signal from connecting - it does NOT drop the client, even if the signal falls far below the threshhold, and even if I give it plenty of time.

I tried switching the order of the rules, but that changed nothing.

Per the suggestion in this post (viewtopic.php?t=49603), I also tried adding the following command:
/interface wireless set 0 default-authentication=no

However, with this command, nothing will connect at all - even if I drop the rule with authentication=no. Any ideas?? Thanks!
 
andriys
Forum Guru
Forum Guru
Posts: 1187
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: Wireless Access List Not Dropping Clients with Weak Signal

Thu Sep 28, 2017 6:08 pm

I am trying to configure a RB 951Ui 2HnD to drop weak WiFi clients so they will switch to another AP as they travel around our building.
This is a rather bad idea.
add interface=wireless signal-range=-55
These should look like add interface=wireless signal-range=-55..0
 
lambert
Long time Member
Long time Member
Posts: 532
Joined: Fri Jul 23, 2010 1:09 am

Re: Wireless Access List Not Dropping Clients with Weak Signal

Fri Sep 29, 2017 7:50 pm

I think the signal level access-list entry is only evaluated at connect time. It works that way with Ubiquiti's "threshold" setting also.

I think if you want to kick weak signal clients, you will have to write a script to parse their current signal levels and kick them if below some threshold, probably after some time delay showing consistently poor signals. The threshold should probably be significantly lower than the connect limit.

When devices move, they can get temporarily obscured but not have anything better to which they can connect. Someone can stand between the device and the AP causing a significant, temporary, reduction in signal.

If you're going to do this you may find the results are poorer than allowing the device, which is likely pretty smart these days, to figure it out itself.
 
forliberty
just joined
Topic Author
Posts: 2
Joined: Thu Sep 28, 2017 5:24 pm

Re: Wireless Access List Not Dropping Clients with Weak Signal

Mon Oct 02, 2017 7:22 pm

Andriys, thank you very much - your simple comment that I needed "..0" at the end of my command fixed my issue. As you noted, the command should be:

add interface=wireless signal-range=-55..0

As to the merits of this change, time will tell. Maybe I just have very dumb devices, but my laptop and cell phone consistently "stick" with a bad signal, even when there other, much better signals close by.

Lambert, it is incorrect that signal level is assessed only at connect time, as both the manual indicates and as many users have stated in their posts. See, e.g., the thread cited in my original post.
 
lambert
Long time Member
Long time Member
Posts: 532
Joined: Fri Jul 23, 2010 1:09 am

Re: Wireless Access List Not Dropping Clients with Weak Signal

Tue Oct 03, 2017 6:52 am

Good to know.

Who is online

Users browsing this forum: No registered users and 37 guests