Page 1 of 1

WiFi AP speed Issue, multiple devices affected

Posted: Fri Jan 05, 2018 1:58 am
by nordex
Hello,

I'm seeing speed issues in wireless, 2.4ghz, download direction.
Upload works better then download .

Download gets 20 mbit, upload goes full.
Issue is with mobile phones(most of them, only high end are ok, but its only 25% of them). Laptops seems to work fine.

Yes, I've read forum about this.
Yes, configuration is ok, spectrum is clean, no obstacles, power limit fine, firmware fine...trust me.

No, I'm not sending this to support first as I want other users to see more about this problem. If I red it before, I would not buy it.

We have installed 200 (two hunred) of hap ac lite in large hotel.
If this can not be solved we are literally fucked. yes, you red it.

Is there a way to resolve this ?

Re: WiFi AP speed Issue, multiple devices affected

Posted: Fri Jan 05, 2018 8:11 am
by R1CH
If you've really installed 200 there is interference simply from the beacons. 20mbps from a phone over 2.4 GHz sounds pretty decent given how bad 2.4 GHz is these days. Try forcing G/N only to remove some of the beacon overhead.

Re: WiFi AP speed Issue, multiple devices affected

Posted: Fri Jan 05, 2018 10:50 am
by nordex
Ok, let me put it this way.

Take one RB, connect it to 2.4ghz, clean surrounding.
Try speedtest with 5-6 different mobile phones. Do you get more then 22mbit on all of them ?

I bet some of them will have tx rate 54 mbit max on wireless registration tab. THAT is the issue.

Mikrotik does not work well with most of mobile phones on 2.4 ghz (not just cheap mobiles). Slow download

Did anyone found solution to this ?

Re: WiFi AP speed Issue, multiple devices affected

Posted: Sat Jan 06, 2018 6:17 pm
by haik01
Start doing a a good WiFi survey. See how much overlap you have, how much interference. THAT is mostly the "problem" of speed issues.

After that you should tune the network for power and beacons.


It is not "just install 200 units", connect, and voila... a miracle happened. It is more than that.

Re: WiFi AP speed Issue, multiple devices affected

Posted: Sun Jan 07, 2018 12:00 am
by nordex
Sorry, I must have overreacted because of frustration.
Here are some facts:

I follow and use Mikrotik since version 2.9.27. That is long.
It's not about 200 devices and interference.
Take only one mikrotik wifi AP 2.4ghz in absolutely clean wireless area.
Take 10 different mobile phones.
Do a speed test.
How many will go beyond 22-23 mbit on 40hmz 802.11n ?
One, maybe two. (high end samsung and apple).
Take cheap tplink 802.11n, it will work full speed in same conditions.
It is known mikrotik bug. (now I know it).
viewtopic.php?t=102908#p618248



How will I change 200 devices, and who will pay for that ?
The investor does not accept project as complete, since it does not work as advertised.
Do you understand the issue now ?

Re: WiFi AP speed Issue, multiple devices affected

Posted: Sun Jan 07, 2018 12:27 am
by rognick
It seems to be a problem with the latest software version
I have a WAP ac never seen a speed higher than 30 Mbps on 2.4 GHz on 5 GHz I have stable 90 Mbps.

You may try an older version without HW, , it can help

You can look here is someone who has done 100 Mbps on 2.4GHz with hap lite

viewtopic.php?f=7&t=113830&p=635494&hil ... te#p635031

Re: WiFi AP speed Issue, multiple devices affected

Posted: Sun Jan 07, 2018 12:36 am
by honzam
Sorry, I must have overreacted because of frustration.
Here are some facts:

I follow and use Mikrotik since version 2.9.27. That is long.
Take cheap tplink 802.11n, it will work full speed in same conditions.
It is known mikrotik bug. (now I know it).
[url]viewtopic.php?t=102908#p618248[/url
As you say. It is problem with driver in ROS. For Mikrotik it is low priority problem :-(
Do you use CAP in hotel? If no, there is solution viewtopic.php?f=7&t=127793

Re: WiFi AP speed Issue, multiple devices affected

Posted: Sun Jan 07, 2018 5:40 pm
by jarda
My wife's old notebook with centrino n220 gets 150 - 250 Mbits when receiving backups from other computers in the network. Over 2g wifi from RB 2011 or rb493g. The speed depends on where the notebook actually is relatively to the access points and other sources of interference which are many of them close around. What else to say about the "bad" wifi mikrotik performance? Just that if anyone has problems, he should be able find them around him and not in the technology implementation itself.

Re: WiFi AP speed Issue, multiple devices affected

Posted: Sun Jan 07, 2018 8:25 pm
by soooc
Same trouble, hap ac, angry clients ...
wifi problem.png

Re: WiFi AP speed Issue, multiple devices affected

Posted: Sun Jan 07, 2018 11:44 pm
by Fangcz
I occasionaly do wifi coverage for some smallish (up to 150 ppl) events with 2x RB433 (+R52Hn-M) and 4x RBcAP2nD and I confirm this issue with 2.4G clients. Some clients gets up to normal N rates but some of them gets stuck on TX rate of 54 Mbps even when it's set to only N mode.
I also tested it at home, where I have some cheap old single chain N TP-Link access point. Normally I get up to 70 Mbps on 2.4G band (40 Mhz, Ce), if I replaced AP with one cAP2nD it resulted with behavior same as everybody previously described, for eg. my Huawei P10 lite phone was getting around 20 Mbps downlink which is waaay lower than the TP-Link metioned.

Re: WiFi AP speed Issue, multiple devices affected

Posted: Mon Jan 08, 2018 12:15 am
by nordex
@honzam - tnx, but then I loose wireless controller, and openwisp controller looks bit complicated

@jarda - I really did not think of you, old forum veteran, to give this kind of answer. It's not about notebook issue, read my post again. Only connection from mobile phones are affected.
Please don't answer: Use other, more quality phones, it would be kindergarden style conversation.

The fact is that Mikrotik has major performance issue with AP wifi and mobile phones, which are not stated anywhere in selling brochures and catalogs.
That mislead users and makes direct financial harm to buyers.

Is there a way to resolve this?

Re: WiFi AP speed Issue, multiple devices affected

Posted: Mon Jan 08, 2018 5:44 pm
by jarda
Sorry I misunderstood your concern. Mobiles are problematic also, I admit. Especially when an ap transmits with inadequately high power they do not want to roam or disconnect and trying to keep modulation with the ap. Not good for anything.

Re: WiFi AP speed Issue, multiple devices affected

Posted: Sun Apr 29, 2018 4:45 pm
by chechito
solved on 6.40.8 (bugfix old bridges) and 6.42.1 (current new bridges)