Community discussions

 
MikroTikFan
Member Candidate
Member Candidate
Topic Author
Posts: 196
Joined: Sat Aug 02, 2014 1:13 am

wAP DHCP problem with virtual wireless interface

Fri Jan 19, 2018 12:32 am

My problem is to get from DHCP address in virtual wireless interface.
I have Mikrotik wAP AC access point in mode: WISP AP
Main DHCP server is router Mikrotik RB3011

From main wireless interfaces i-wifi1 and i-wifi2 I'm getting addresses and DHCP is working fine.
From v-wifi (virtual interface) I can't get address and probably something wrong is with DHCP.
Please help me to find how to fix this problem.

name="i-wifi1" mtu=1500 l2mtu=1600 mac-address=64:XX:XX:XX:XX:85 
      arp=enabled interface-type=Atheros AR9300 mode=station ssid="wifi1" 
      frequency=2462 band=2ghz-b/g/n channel-width=20mhz secondary-channel="" 
      scan-list=default wireless-protocol=802.11 vlan-mode=no-tag vlan-id=1 
      wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no 
      bridge-mode=enabled default-authentication=yes default-forwarding=yes 
      default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no 
      security-profile=secure compression=no 

 1  R name="i-wifi2" mtu=1500 l2mtu=1600 mac-address=64:XX:XX:XX:XX:84 
      arp=enabled interface-type=Atheros AR9888 mode=ap-bridge ssid="wifi2" 
      frequency=auto band=5ghz-a/n/ac channel-width=20/40/80mhz-eeeC 
      secondary-channel="" scan-list=default wireless-protocol=802.11 
      vlan-mode=no-tag vlan-id=1 wds-mode=disabled wds-default-bridge=none 
      wds-ignore-ssid=no bridge-mode=enabled default-authentication=yes 
      default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 
      hide-ssid=no security-profile=default compression=no 

 2    name="v-wifi1" mtu=1500 l2mtu=1600 mac-address=66:XX:XX:XX:XX:85 
      arp=enabled interface-type=virtual master-interface=i-wifi1 
      mode=ap-bridge ssid="virt1" vlan-mode=no-tag vlan-id=1 wds-mode=disabled 
      wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled 

 
gotsprings
Forum Veteran
Forum Veteran
Posts: 774
Joined: Mon May 14, 2012 9:30 pm

Re: wAP DHCP problem with virtual wireless interface

Tue Jan 23, 2018 7:01 pm

You need to export more.

Interfaces must be tied to interfaces with DHCP for a DHCP server to be reached.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain

Who is online

Users browsing this forum: No registered users and 8 guests