Community discussions

MikroTik App
 
scheme
just joined
Topic Author
Posts: 3
Joined: Wed Feb 21, 2018 3:39 pm

iPhone disconnects from hotspot

Wed Feb 21, 2018 4:01 pm

Hello!

I have problem with mikrotik and iPhone.

I use hotspot. My network is open (without password). WiFi on iPhone turns off when the user turns off the screen and it sleeps ~20 seconds. After turning on the phone WiFi does not connect immediately.

On my iPad 2017 the delay is 4-5 sec. It is not bad. Unfortunately, some people have delay up to 30 seconds. It is not comfortable. It is problem. And I have no idea how to fix it.

I experimented with the settings of the WiFi. Nothing changed. I increased all related parameters keep alive, idle timers, DHCP leases time. Nothing changed.

I tried to deactivate hotspot. In this case there are no disconnects.

So, iPhone "remember" that this network is hotspot and test it before connection. Can I minimize or escape time of reconnect?

Android phones works fine.


Logs:

So intresting, I turn on iPhone at 16:20:34, logs starts with delay.

Code: Select all

Feb/21/2018 16:20:37 wireless,debug w_: wlan1: 68:AB:1E:E8:4D:9F attempts to associate
Feb/21/2018 16:20:37 wireless,debug w_: wlan1: 68:AB:1E:E8:4D:9F not in local ACL, by default accept
Feb/21/2018 16:20:37 wireless,info 68:AB:1E:E8:4D:9F@wlan1: connected, signal strength -49
Feb/21/2018 16:20:37 wireless,info w_: 68:AB:1E:E8:4D:9F@wlan1: connected, signal strength -49
Feb/21/2018 16:20:38 route,debug,event w_: Interface change
Feb/21/2018 16:20:38 route,debug,event w_: interface=wlan1
Feb/21/2018 16:20:38 route,debug,event w_: status=UP,RUNNING
Feb/21/2018 16:20:38 route,debug,event w_: mtu=1500
Feb/21/2018 16:20:38 route,debug,calc w_: Begin calculation
Feb/21/2018 16:20:38 route,debug,event w_: Link up
Feb/21/2018 16:20:38 route,debug,event w_: interface=wlan1
Feb/21/2018 16:20:38 route,debug,event w_: Update
Feb/21/2018 16:20:38 route,debug,event w_: interface=wlan1
Feb/21/2018 16:20:38 route,debug,calc w_: End calculation
Feb/21/2018 16:20:38 dhcp,debug,packet w_: dhcp1 received request with id 4114251213 from 0.0.0.0
Feb/21/2018 16:20:38 dhcp,debug,packet w_: ciaddr = 0.0.0.0
Feb/21/2018 16:20:38 dhcp,debug,packet w_: chaddr = 68:AB:1E:E8:4D:9F
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Msg-Type = request
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Parameter-List = Subnet-Mask,Classless-Route,Router,Domain-Server,Domain-Name,Domain-Search,Auto-Proxy-Config
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Max-DHCP-Message-Size = 1500
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Client-Id = 01-68-AB-1E-E8-4D-9F
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Address-Request = 172.17.9.253
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Address-Time = 7776000
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Host-Name = "iPad"
Feb/21/2018 16:20:38 dhcp,debug,packet w_: dhcp1 sending ack with id 4114251213 to 172.17.9.253
Feb/21/2018 16:20:38 dhcp,debug,packet w_: ciaddr = 0.0.0.0
Feb/21/2018 16:20:38 dhcp,debug,packet w_: yiaddr = 172.17.9.253
Feb/21/2018 16:20:38 dhcp,debug,packet w_: siaddr = 172.17.9.1
Feb/21/2018 16:20:38 dhcp,debug,packet w_: chaddr = 68:AB:1E:E8:4D:9F
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Msg-Type = ack
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Server-Id = 172.17.9.1
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Address-Time = 14400
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Subnet-Mask = 255.255.255.0
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Router = 172.17.9.1
Feb/21/2018 16:20:38 dhcp,debug,packet w_: Domain-Server = 172.17.9.1
Feb/21/2018 16:20:38 dns,packet w_: --- got query from 172.17.9.253:60546:
Feb/21/2018 16:20:38 dns,packet w_: id:bbe8 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error'
Feb/21/2018 16:20:38 dns,packet w_: question: captive.apple.com:A:IN
Feb/21/2018 16:20:38 dns w_: query from 172.17.9.253: #1443 captive.apple.com. A
Feb/21/2018 16:20:38 dns w_: done query: #1443 dns name exists, but no appropriate record
Feb/21/2018 16:20:38 dns,packet w_: --- sending reply to 172.17.9.253:60546:
Feb/21/2018 16:20:38 dns,packet w_: id:bbe8 rd:1 tc:0 aa:0 qr:1 ra:1 QUERY 'no error'
Feb/21/2018 16:20:38 dns,packet w_: question: captive.apple.com:A:IN
Feb/21/2018 16:20:38 dns,packet w_: answer:
Feb/21/2018 16:20:38 dns,packet w_: <captive.apple.com:A:86400=10.0.41.3>
Feb/21/2018 16:20:38 dns,packet w_: authority:
Feb/21/2018 16:20:38 dns,packet w_: <apple.com:NS:77152=f.ns.apple.com>
Feb/21/2018 16:20:38 dns,packet w_: <apple.com:NS:77152=e.ns.apple.com>
Feb/21/2018 16:20:38 dns,packet w_: <apple.com:NS:77152=nserver5.apple.com>
Feb/21/2018 16:20:38 dns,packet w_: <apple.com:NS:77152=d.ns.apple.com>
Feb/21/2018 16:20:38 dns,packet w_: <apple.com:NS:77152=a.ns.apple.com>
Feb/21/2018 16:20:38 dns,packet w_: <apple.com:NS:77152=b.ns.apple.com>
Feb/21/2018 16:20:38 dns,packet w_: <apple.com:NS:77152=nserver6.apple.com>
Feb/21/2018 16:20:38 dns,packet w_: <apple.com:NS:77152=c.ns.apple.com>
Feb/21/2018 16:20:38 dns,packet w_: additional:
Feb/21/2018 16:20:38 dns,packet w_: <f.ns.apple.com:A:71125=204.13.250.129>
Feb/21/2018 16:20:38 dns,packet w_: <e.ns.apple.com:A:71125=208.78.70.129>
Feb/21/2018 16:20:38 dns,packet w_: <nserver5.apple.com:A:77152=17.171.63.30>
Feb/21/2018 16:20:38 dns,packet w_: <d.ns.apple.com:A:71125=204.26.57.1>
Feb/21/2018 16:20:38 dns,packet w_: <a.ns.apple.com:A:71125=17.253.200.1>
Feb/21/2018 16:20:38 dns,packet w_: <b.ns.apple.com:A:71125=17.253.207.1>
Feb/21/2018 16:20:38 dns,packet w_: <nserver6.apple.com:A:77152=17.171.63.40>
Feb/21/2018 16:20:38 dns,packet w_: <c.ns.apple.com:A:71125=204.19.119.1>
Feb/21/2018 16:20:39 dns,packet w_: --- got query from 172.17.9.253:59879:
Feb/21/2018 16:20:39 dns,packet w_: id:91f8 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error'
Feb/21/2018 16:20:39 dns,packet w_: question: www.apple.com:A:IN
Feb/21/2018 16:20:39 dns w_: query from 172.17.9.253: #1444 www.apple.com. A
Feb/21/2018 16:20:39 dns,packet w_: --- sending udp query to 10.0.0.4:53:
Feb/21/2018 16:20:39 dns,packet w_: id:a4b rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error'
Feb/21/2018 16:20:39 dns,packet w_: question: www.apple.com:A:IN
Feb/21/2018 16:20:39 dns,packet w_: --- got query from 172.17.9.253:52526:
Feb/21/2018 16:20:39 dns,packet w_: id:ea0d rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error'
Feb/21/2018 16:20:39 dns,packet w_: question: www.icloud.com:A:IN
Feb/21/2018 16:20:39 dns w_: query from 172.17.9.253: #1445 www.icloud.com. A
Feb/21/2018 16:20:39 dns,packet w_: --- sending udp query to 10.0.0.4:53:
Feb/21/2018 16:20:39 dns,packet w_: id:c623 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error'
Feb/21/2018 16:20:39 dns,packet w_: question: www.icloud.com:A:IN
Feb/21/2018 16:20:39 dns,packet w_: --- got answer from 10.0.0.4:53:
Feb/21/2018 16:20:39 dns,packet w_: id:c623 rd:1 tc:0 aa:0 qr:1 ra:1 QUERY 'no error'
Feb/21/2018 16:20:39 dns,packet w_: question: www.icloud.com:A:IN
Feb/21/2018 16:20:39 dns,packet w_: answer:
Feb/21/2018 16:20:39 dns,packet w_: <www.icloud.com:CNAME:533=www-cdn.icloud.com.akadns.net>
Feb/21/2018 16:20:39 dns,packet w_: <www-cdn.icloud.com.akadns.net:CNAME:45=www.icloud.com.edgekey.net>
Feb/21/2018 16:20:39 dns,packet w_: <www.icloud.com.edgekey.net:CNAME:21253=e4478.a.akamaiedge.net>
Feb/21/2018 16:20:39 dns,packet w_: <e4478.a.akamaiedge.net:A:12=104.126.164.240>
Feb/21/2018 16:20:39 dns w_: done query: #1445 www.icloud.com 104.126.164.240
Feb/21/2018 16:20:39 dns,packet w_: --- sending reply to 172.17.9.253:52526:
Feb/21/2018 16:20:39 dns,packet w_: id:ea0d rd:1 tc:0 aa:0 qr:1 ra:1 QUERY 'no error'
Feb/21/2018 16:20:39 dns,packet w_: question: www.icloud.com:A:IN
Feb/21/2018 16:20:39 dns,packet w_: answer:
Feb/21/2018 16:20:39 dns,packet w_: <www.icloud.com:CNAME:534=www-cdn.icloud.com.akadns.net>
Feb/21/2018 16:20:39 dns,packet w_: <www-cdn.icloud.com.akadns.net:CNAME:45=www.icloud.com.edgekey.net>
Feb/21/2018 16:20:39 dns,packet w_: <www.icloud.com.edgekey.net:CNAME:21253=e4478.a.akamaiedge.net>
Feb/21/2018 16:20:39 dns,packet w_: <e4478.a.akamaiedge.net:A:12=104.126.164.240>
Feb/21/2018 16:20:39 dns,packet w_: --- got answer from 10.0.0.4:53:
Feb/21/2018 16:20:39 dns,packet w_: id:a4b rd:1 tc:0 aa:0 qr:1 ra:1 QUERY 'no error'
Feb/21/2018 16:20:39 dns,packet w_: question: www.apple.com:A:IN
Feb/21/2018 16:20:39 dns,packet w_: answer:
Feb/21/2018 16:20:39 dns,packet w_: <www.apple.com:CNAME:1071=www.apple.com.edgekey.net>
Feb/21/2018 16:20:39 dns,packet w_: <www.apple.com.edgekey.net:CNAME:17683=www.apple.com.edgekey.net.globalredir.akadns.net>
Feb/21/2018 16:20:39 dns,packet w_: <www.apple.com.edgekey.net.globalredir.akadns.net:CNAME:18=e6858.dsce9.akamaiedge.net>
Feb/21/2018 16:20:39 dns,packet w_: <e6858.dsce9.akamaiedge.net:A:19=104.126.160.134>
Feb/21/2018 16:20:39 dns w_: done query: #1444 www.apple.com 104.126.160.134
Feb/21/2018 16:20:39 dns,packet w_: --- sending reply to 172.17.9.253:59879:
Feb/21/2018 16:20:39 dns,packet w_: id:91f8 rd:1 tc:0 aa:0 qr:1 ra:1 QUERY 'no error'
Feb/21/2018 16:20:39 dns,packet w_: question: www.apple.com:A:IN
Feb/21/2018 16:20:39 dns,packet w_: answer:
Feb/21/2018 16:20:39 dns,packet w_: <www.apple.com:CNAME:1071=www.apple.com.edgekey.net>
Feb/21/2018 16:20:39 dns,packet w_: <www.apple.com.edgekey.net:CNAME:17684=www.apple.com.edgekey.net.globalredir.akadns.net>
Feb/21/2018 16:20:39 dns,packet w_: <www.apple.com.edgekey.net.globalredir.akadns.net:CNAME:19=e6858.dsce9.akamaiedge.net>
Feb/21/2018 16:20:39 dns,packet w_: <e6858.dsce9.akamaiedge.net:A:19=104.126.160.134>
Feb/21/2018 16:20:39 dns,packet w_: authority:
Feb/21/2018 16:20:39 dns,packet w_: <apple.com:NS:77151=e.ns.apple.com>
Feb/21/2018 16:20:39 dns,packet w_: <apple.com:NS:77151=nserver5.apple.com>
Feb/21/2018 16:20:39 dns,packet w_: <apple.com:NS:77151=d.ns.apple.com>
Feb/21/2018 16:20:39 dns,packet w_: <apple.com:NS:77151=a.ns.apple.com>
Feb/21/2018 16:20:39 dns,packet w_: <apple.com:NS:77151=b.ns.apple.com>
Feb/21/2018 16:20:39 dns,packet w_: <apple.com:NS:77151=nserver6.apple.com>
Feb/21/2018 16:20:39 dns,packet w_: <apple.com:NS:77151=c.ns.apple.com>
Feb/21/2018 16:20:39 dns,packet w_: <apple.com:NS:77151=f.ns.apple.com>
Feb/21/2018 16:20:39 dns,packet w_: additional:
Feb/21/2018 16:20:39 dns,packet w_: <e.ns.apple.com:A:71124=208.78.70.129>
Feb/21/2018 16:20:39 dns,packet w_: <nserver5.apple.com:A:77151=17.171.63.30>
Feb/21/2018 16:20:39 dns,packet w_: <d.ns.apple.com:A:71124=204.26.57.1>
Feb/21/2018 16:20:39 dns,packet w_: <a.ns.apple.com:A:71124=17.253.200.1>
Feb/21/2018 16:20:39 dns,packet w_: <b.ns.apple.com:A:71124=17.253.207.1>
Feb/21/2018 16:20:39 dns,packet w_: <nserver6.apple.com:A:77151=17.171.63.40>
Feb/21/2018 16:20:39 dns,packet w_: <c.ns.apple.com:A:71124=204.19.119.1>
Feb/21/2018 16:20:39 dns,packet w_: <f.ns.apple.com:A:71124=204.13.250.129>
Feb/21/2018 16:20:40 dns,packet w_: --- got query from 172.17.9.253:54547:
Feb/21/2018 16:20:40 dns,packet w_: id:6882 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error'
Feb/21/2018 16:20:40 dns,packet w_: question: apple.com:A:IN
Feb/21/2018 16:20:40 dns w_: query from 172.17.9.253: #1446 apple.com. A
Feb/21/2018 16:20:40 dns w_: done query: #1446 dns name exists, but no appropriate record
Feb/21/2018 16:20:40 dns,packet w_: --- sending reply to 172.17.9.253:54547:
Feb/21/2018 16:20:40 dns,packet w_: id:6882 rd:1 tc:0 aa:0 qr:1 ra:1 QUERY 'no error'
Feb/21/2018 16:20:40 dns,packet w_: question: apple.com:A:IN
Feb/21/2018 16:20:40 dns,packet w_: answer:
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:A:16=17.172.224.47>
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:A:16=17.142.160.59>
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:A:16=17.178.96.59>
Feb/21/2018 16:20:40 dns,packet w_: authority:
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:NS:77151=nserver5.apple.com>
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:NS:77151=d.ns.apple.com>
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:NS:77151=a.ns.apple.com>
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:NS:77151=b.ns.apple.com>
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:NS:77151=nserver6.apple.com>
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:NS:77151=c.ns.apple.com>
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:NS:77151=f.ns.apple.com>
Feb/21/2018 16:20:40 dns,packet w_: <apple.com:NS:77151=e.ns.apple.com>
Feb/21/2018 16:20:40 dns,packet w_: additional:
Feb/21/2018 16:20:40 dns,packet w_: <nserver5.apple.com:A:77151=17.171.63.30>
Feb/21/2018 16:20:40 dns,packet w_: <d.ns.apple.com:A:71124=204.26.57.1>
Feb/21/2018 16:20:40 dns,packet w_: <a.ns.apple.com:A:71124=17.253.200.1>
Feb/21/2018 16:20:40 dns,packet w_: <b.ns.apple.com:A:71124=17.253.207.1>
Feb/21/2018 16:20:40 dns,packet w_: <nserver6.apple.com:A:77151=17.171.63.40>
Feb/21/2018 16:20:40 dns,packet w_: <c.ns.apple.com:A:71124=204.19.119.1>
Feb/21/2018 16:20:40 dns,packet w_: <f.ns.apple.com:A:71124=204.13.250.129>
Feb/21/2018 16:20:40 dns,packet w_: <e.ns.apple.com:A:71124=208.78.70.129>
Feb/21/2018 16:20:42 dns,packet w_: --- got query from 172.17.9.253:52262:
Feb/21/2018 16:20:42 dns,packet w_: id:7cf6 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error'
Feb/21/2018 16:20:42 dns,packet w_: question: gateway.icloud.com:A:IN
Feb/21/2018 16:20:42 dns w_: query from 172.17.9.253: #1447 gateway.icloud.com. A
Feb/21/2018 16:20:42 dns,packet w_: --- sending udp query to 10.0.0.4:53:
Feb/21/2018 16:20:42 dns,packet w_: id:9b7 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error'
Feb/21/2018 16:20:42 dns,packet w_: question: gateway.icloud.com:A:IN
Feb/21/2018 16:20:42 dns,packet w_: --- got answer from 10.0.0.4:53:
Feb/21/2018 16:20:42 dns,packet w_: id:9b7 rd:1 tc:0 aa:0 qr:1 ra:1 QUERY 'no error'
Feb/21/2018 16:20:42 dns,packet w_: question: gateway.icloud.com:A:IN
Feb/21/2018 16:20:42 dns,packet w_: answer:
Feb/21/2018 16:20:42 dns,packet w_: <gateway.icloud.com:CNAME:7=gateway.fe.apple-dns.net>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.19>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.115>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.118>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.18>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.55>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.51>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.46>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.106>
Feb/21/2018 16:20:42 dns w_: done query: #1447 gateway.icloud.com 17.248.150.19
Feb/21/2018 16:20:42 dns,packet w_: --- sending reply to 172.17.9.253:52262:
Feb/21/2018 16:20:42 dns,packet w_: id:7cf6 rd:1 tc:0 aa:0 qr:1 ra:1 QUERY 'no error'
Feb/21/2018 16:20:42 dns,packet w_: question: gateway.icloud.com:A:IN
Feb/21/2018 16:20:42 dns,packet w_: answer:
Feb/21/2018 16:20:42 dns,packet w_: <gateway.icloud.com:CNAME:7=gateway.fe.apple-dns.net>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.19>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.115>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.118>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.18>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.55>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.51>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.46>
Feb/21/2018 16:20:42 dns,packet w_: <gateway.fe.apple-dns.net:A:35=17.248.150.106>
Feb/21/2018 16:20:45 pptp,ppp,debug,packet w_: pptp-out1: rcvd LCP EchoReq id=0xca
Feb/21/2018 16:20:45 pptp,ppp,debug,packet w_: <magic 0xe6b0a16>
Feb/21/2018 16:20:45 pptp,ppp,debug,packet w_: pptp-out1: sent LCP EchoRep id=0xca
Feb/21/2018 16:20:45 pptp,ppp,debug,packet w_: <magic 0x5f6d8e20>
Feb/21/2018 16:20:50 wireless,info 68:AB:1E:E8:4D:9F@wlan1: disconnected, received disassoc: sending station leaving (8)
Feb/21/2018 16:20:50 wireless,info w_: 68:AB:1E:E8:4D:9F@wlan1: disconnected, received disassoc: sending station leaving (8)
Feb/21/2018 16:20:53 route,debug,event w_: Interface change
Feb/21/2018 16:20:53 route,debug,event w_: interface=wlan1
Feb/21/2018 16:20:53 route,debug,event w_: status=UP
Feb/21/2018 16:20:53 route,debug,event w_: mtu=1500
Feb/21/2018 16:20:53 route,debug,calc w_: Begin calculation
Feb/21/2018 16:20:53 route,debug,event w_: Link down
Feb/21/2018 16:20:53 route,debug,event w_: interface=wlan1
Feb/21/2018 16:20:53 route,debug,event w_: Update
Feb/21/2018 16:20:53 route,debug,event w_: interface=wlan1
Feb/21/2018 16:20:53 route,debug,calc w_: End calculation
Thanks for any ideas!
 
2frogs
Long time Member
Long time Member
Posts: 542
Joined: Fri Dec 03, 2010 1:38 am

Re: iPhone disconnects from hotspot

Wed Feb 21, 2018 4:25 pm

https://wiki.mikrotik.com/wiki/Manual:H ... MAC_Cookie
You should activate MAC Cookies, this will help in your situation.
 
scheme
just joined
Topic Author
Posts: 3
Joined: Wed Feb 21, 2018 3:39 pm

Re: iPhone disconnects from hotspot

Wed Feb 21, 2018 4:56 pm

Unfortunately, there is no effect.

I see the device in IP -> Hotspot -> Active, IP -> Hotspot -> Hosts (with "A" flag). I see cookie in IP -> Hotspot -> Cookies (with empty domain), but connection to WiFi still slowly.
 
2frogs
Long time Member
Long time Member
Posts: 542
Joined: Fri Dec 03, 2010 1:38 am

Re: iPhone disconnects from hotspot

Wed Feb 21, 2018 5:22 pm

Can you post:
/ip hotspot export
 
2frogs
Long time Member
Long time Member
Posts: 542
Joined: Fri Dec 03, 2010 1:38 am

Re: iPhone disconnects from hotspot

Wed Feb 21, 2018 5:27 pm

Also, what do you have for your DHCP Lease Time? Having a short lease will also give an issue.
 
scheme
just joined
Topic Author
Posts: 3
Joined: Wed Feb 21, 2018 3:39 pm

Re: iPhone disconnects from hotspot

Wed Feb 21, 2018 9:47 pm

Can you post:
/ip hotspot export
Sorry, problem with markup.

/ip hotspot profile
add dns-name=auth.wifi.mysite.me hotspot-address=172.17.9.1 login-by=mac,mac-cookie mac-auth-mode=mac-as-username-and-password name=hsprof1 radius-accounting=no use-radius=yes
/ip hotspot
add address-pool=default-dhcp disabled=no idle-timeout=2h5m interface=bridge keepalive-timeout=1h login-timeout=1h name=hotspot1 profile=hsprof1
/ip hotspot user profile
set [ find default=yes ] keepalive-timeout=2h2m session-timeout=1h status-autorefresh=1h1m
/ip hotspot user
add name=admin password=sddf
/ip hotspot walled-garden
add comment="place hotspot rules here" disabled=yes
/ip hotspot walled-garden ip
add action=accept disabled=no !dst-address dst-host=oauth.vk.com dst-port=0-65535 !protocol !src-address
add action=accept disabled=no !dst-address dst-host=m.vk.com dst-port=0-65535 !protocol !src-address
add action=accept disabled=no !dst-address dst-host=vk.com dst-port=0-65535 !protocol !src-address
add action=accept disabled=no !dst-address dst-host=login.vk.com dst-port=0-65535 !protocol !src-address
add action=accept disabled=no !dst-address dst-host=api.vk.com dst-port=0-65535 !protocol !src-address
add action=accept disabled=no !dst-address dst-host=wifi.mysite.me dst-port=0-65535 !protocol !src-address


Also, what do you have for your DHCP Lease Time? Having a short lease will also give an issue.
I increased the DHCP Lease Time from 10 minutes to 4 hours
 
2frogs
Long time Member
Long time Member
Posts: 542
Joined: Fri Dec 03, 2010 1:38 am

Re: iPhone disconnects from hotspot

Wed Feb 21, 2018 11:37 pm

You should also set the Hotspot address pool to none. This is a NAT helper, intended to help device that have static IPs set in their network settings. It can cause more issues than it solves. If you see multiple attempts in the hotspot from the same MAC but different IPs, this is the cause.
 
dejanb
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Wed Apr 21, 2010 12:05 am
Location: Serbia, Belgrade

Re: iPhone disconnects from hotspot

Mon Mar 12, 2018 10:20 am

Can you post:
/ip hotspot export
Sorry, problem with markup.

/ip hotspot profile
add dns-name=auth.wifi.mysite.me hotspot-address=172.17.9.1 login-by=mac,mac-cookie mac-auth-mode=mac-as-username-and-password name=hsprof1 radius-accounting=no use-radius=yes
/ip hotspot
add address-pool=default-dhcp disabled=no idle-timeout=2h5m interface=bridge keepalive-timeout=1h login-timeout=1h name=hotspot1 profile=hsprof1
/ip hotspot user profile
set [ find default=yes ] keepalive-timeout=2h2m session-timeout=1h status-autorefresh=1h1m
/ip hotspot user
add name=admin password=sddf
/ip hotspot walled-garden
add comment="place hotspot rules here" disabled=yes
/ip hotspot walled-garden ip
add action=accept disabled=no !dst-address dst-host=oauth.vk.com dst-port=0-65535 !protocol !src-address
add action=accept disabled=no !dst-address dst-host=m.vk.com dst-port=0-65535 !protocol !src-address
add action=accept disabled=no !dst-address dst-host=vk.com dst-port=0-65535 !protocol !src-address
add action=accept disabled=no !dst-address dst-host=login.vk.com dst-port=0-65535 !protocol !src-address
add action=accept disabled=no !dst-address dst-host=api.vk.com dst-port=0-65535 !protocol !src-address
add action=accept disabled=no !dst-address dst-host=wifi.mysite.me dst-port=0-65535 !protocol !src-address


Also, what do you have for your DHCP Lease Time? Having a short lease will also give an issue.
I increased the DHCP Lease Time from 10 minutes to 4 hours
Hello!

Did You solve this problem with Iphone''s? i have identical problem like You with Mikrotik Hotspot and Apple devices, Androids works well, as You said.

Regards!
 
saint739
just joined
Posts: 3
Joined: Wed Jul 31, 2019 8:16 am

Re: iPhone disconnects from hotspot

Wed Jul 31, 2019 8:20 am

We have this problem too on our 1000+ routers, have any solution?
 
eminkaplan
just joined
Posts: 4
Joined: Sat May 20, 2017 6:28 am

Re: iPhone disconnects from hotspot

Fri Sep 27, 2019 2:20 pm

Yes, this is a big problem.. any idaea any one ?
 
TheLordOfTheShells
newbie
Posts: 29
Joined: Tue Oct 03, 2017 2:48 am

Re: iPhone disconnects from hotspot

Tue Jan 07, 2020 5:37 am

Hi guys.
I'm facing the same problem, does the problem solved ?
 
mozzec
just joined
Posts: 4
Joined: Wed Dec 18, 2019 5:40 am
Contact:

Re: iPhone disconnects from hotspot

Tue Jan 07, 2020 7:07 pm

Does this has a solution
https://www.neeapps.com/

Who is online

Users browsing this forum: Baidu [Spider], keno and 71 guests