Page 1 of 1

Hotspot users can't reach https sites since update

Posted: Fri Mar 30, 2018 6:15 pm
by azurtem
Hi

I recently upgraded ROS on a couple of sites (hotels) running RB433 hotspots
The upgrade went from 6.27 to 6.41.3

On one of the sites, running an RB433AH hotspot with a few RB912 access
points, a strange situation has presented itself.

The RB912 access points are present on the upper floors, and the RB433AH is
positioned on the ground floor (lobby)

Internet access from the ground floor doesn't work anymore i.e. direct connections
to the RB433AH can't authenticate or browse the web.

When connecting directly through the RB433AH the user's browsers receive
the following error messages :
"Secure Connection Failed" (Firefox)
"Cannot connect securely to this page" (Chrome)

Furthermore the hotspot login page is not displayed correctly : ascii characters, missing
logo, ...When a user enters the login and password his credentials are refused with the
following error : "web browser did not send challenge response (try again, enable Javascript)"

I can assure you that I have Javascript enabled for browsers on my laptop and I
obtained the same errors

The other site (RB433GL) which is fine has practically the same config, and the same login.html

Next I moved up a floor in the hotel and attempted the same tests; here the logon page
displayed properly and authenticated me properly. The Internet browsing worked fine too.
Tried again on the fourth floor : same positive results.

I can therefore conclude that the issue is with the RB433AH itself. But how can that be ?
Since the RB in the upper floors are all connected to the hotspot router - shouldn't they
also be impacted by the same phenomena ? Weird huh ?

Any ideas ?

regards
yann

Re: Hotspot users can't reach https sites since update

Posted: Wed Apr 11, 2018 8:06 am
by manuzoli
Where you using the same device? Browsers have become quite picky when it comes to SSL and captive portals. Maybe it isn‘t connected to your Mikrotik setup?

Re: Hotspot users can't reach https sites since update

Posted: Wed Apr 11, 2018 12:26 pm
by azurtem
Thanks Manuzoli
Same device, same connections, same everything : the only change was the ROS update to 6.41.3
I will try, as suggested by MKT support, to fiddle around with the login.html which was slightly customized during the initial installation two years ago (background photo, and removal of Latvian options)

Re: Hotspot users can't reach https sites since update

Posted: Sun May 13, 2018 11:42 pm
by korg
HI,

I have almost the same problem... my hotspot login pages are not opening at all... and this happened since update from 6.33 to 6.42...

did you get some workaround from MIKROTIK?

tx

korg