Community discussions

 
dougunder
newbie
Topic Author
Posts: 40
Joined: Tue May 01, 2018 10:53 pm

Wireless woes and how to fix em :)

Tue May 08, 2018 11:09 pm

Updated
This is far and away the best version!

{
:global WLANMAC [/interface wireless get wlan1 mac-address];
:global SSID "YOURSSID";
:global SETWIFI do={:global SSID; /interface wireless set $1 ssid=($SSID.$2) comment=3.4 mode=ap-bridge wireless-protocol=802.11 station-roaming=disabled wmm-support=enabled distance=indoors multicast-buffering=disabled multicast-helper=disabled frequency=auto security-profile=ap-security-0 wps-mode=disabled disabled=no arp=enabled hw-retries=$9 disconnect-timeout=$10 keepalive-frames=disabled bridge-mode=disabled country="united states3" frequency-mode=regulatory-domain band=$3 channel-width=$4 scan-list=$5 antenna-gain=$6 tx-power-mode=default amsdu-limit=$7 rx-chains=$8 tx-chains=$8};
:global SETWIFISEC do={/interface wireless security-profiles set group-key-update=1h management-protection=disabled [find name~""]};
:global 2GCHAN do={/interface wireless channels add name=$1 frequency=$2 extension-channel=$3 band=2ghz-b/g/n width=20 list=WiFi24};
:global 5GCHAN do={/interface wireless channels add name=$1 frequency=$2 extension-channel=$3 band=5ghz-a/n/ac width=20 list=WiFi5};
:global CHANCLN do={/interface wireless channels remove [find name~""]};
:global 2GWIFICHAN do={:global 2GCHAN; $2GCHAN chan1 2412 Ce; $2GCHAN chan11 2462 eC};
:global 5GWIFICHAN do={:global 5GCHAN; $5GCHAN chan36 5180 Ceee; $5GCHAN chan44 5220 eeCe; $5GCHAN chan149 5745 Ceee; $5GCHAN chan157 5785 eeCe};
:global WIFION do={:execute {:delay 10; /interface wireless set [find name~""] disabled=no}};
:global CLNUP do={/system script environment remove [find name!=MODE name!=model name!=config]};
$CHANCLN;
$2GWIFICHAN;
$5GWIFICHAN;
$SETWIFI wlan1 2G 2ghz-b/g/n 20/40mhz-XX "WiFi24" 0 256 0,1 15 15;
$SETWIFI wlan2 5G 5ghz-a/n/ac 20/40/80mhz-XXXX "WiFi5" 3 2048 0,1 7 3;
$WIFION;
$CLNUP
}


Hi,
I'm a network engineer at a municipal broadband provider in Western Massachusetts
We have 500 customers and growing by 50 each month

Our network design is fiber to the pole, wireless to the home.
CPE is all mikrotic.

After much struggle I think Ive finally got a good in home wireless configuration!
Here is the script I've been pushing via tr069
Have a group of 25 testers (customers with the worst wifi probs) that are all quite happy now!

I'll gladly explain the tweaks if asked, but generally its: Anything Mikrotik does dynamically it does badly, so find and set a good static value :)

If you have any suggestions I'd love to hear them before i roll this out widely.

:global model [/system resource get board-name ];
:if (model~"hAP") do={
:local resetwifi do={
:local reset do={
:local wlanMac [/interface wireless get wlan1 mac-address];
:local ssid "REDACTED";
/interface wireless set $1 ssid=($ssid.$2) comment=3.1 mode=ap-bridge wireless-protocol=802.11 station-roaming=disabled wmm-support=enabled distance=indoors multicast-buffering=disabled multicast-helper=disabled frequency=auto security-profile=ap-security-0 wps-mode=disabled disabled=no arp=enabled hw-retries=$9 disconnect-timeout=$10 keepalive-frames=disabled bridge-mode=disabled country="united states3" frequency-mode=regulatory-domain band=$3 channel-width=$4 scan-list=$5 antenna-gain=$6 tx-power-mode=default amsdu-limit=$7 rx-chains=$8 tx-chains=$8;
};
$reset wlan1 2G 2ghz-b/g/n 20/40mhz-Ce 2414,2437,2462 0 256 0,1 15 15;
$reset wlan2 5G 5ghz-a/n/ac 20/40mhz-Ce 5180,5220,5745,5785 0 2048 0,1 7 3;
/interface wireless {set [find name~"wlan"] disabled=yes; :delay 5; set [find name~"wlan"] disabled=no}
};
$resetwifi;
/interface wireless security-profiles set group-key-update=1h management-protection=disabled [find name~""]
}

P.S.
I've seen a lot of folks blaming DHCP for wireless issues. Our hAP's are all in bridge mode, with dhcp upstream.
We faced and (hopefully) solved many of the same issues posted about w/o touching DHCP.....


I should add I also have a tr-069 task to reboot the devices. Apparently downing and upping the interface is not sufficient.

This is primarily tested against 6.42.1, but also confirmed working on 6.40.rc6 and 6.42.rc6
Last edited by dougunder on Wed Mar 27, 2019 9:15 pm, edited 13 times in total.
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: Wireless woes and how to fix em :)

Wed May 09, 2018 1:43 am

For 2.4GHz only use 20MHz and channels 2412, 2437 or 2462.

Also add in two access list rules, one to accept connections between -80..120 and another to reject signals -120..120. This aids handoff from one AP to the other and feel free to alter the -80 threshhold.

Also you may want to reduce the tx-power of your 2.4GHz AP's to make the 5G more attractive to the wireless clients.

Another concern is that if you make your AP's too powerful some portable devices may get 5 bars of signal but lack the power to transmit back to the AP....
MTCNA, MTCWE, MTCRE, MTCTCE, MTCSE, MTCINE, Trainer
___________________
Mikrotik Distributor - New Zealand
http://www.campbell.co.nz
 
dougunder
newbie
Topic Author
Posts: 40
Joined: Tue May 01, 2018 10:53 pm

Re: Wireless woes and how to fix em :)

Wed May 09, 2018 4:24 pm

Thanks you

This is in home wireless, single AP. No roaming

We are using 20MHz for 2.4g.

Why only 3 2.4ghz bands? The spectrum in this area is very crowded, surely all 11 channels is better?
We have some multi unit homes with 4-6 of of our customers alone, never mind our competitors.
We're also planning to server 100+ unit affordable housing when we have a solid foundation.

I know of one 2.4G device that just won't connect, even right on top of the AP. Was leaning toward the frequency being at fault.

I do think the AP may be a bit to powerful..
What is a good figure? I went with the regulatory max. 27dbi or even lower?
Doing some live debugging shortly with a user have chrome cast issues where the didn't previously. It seems the signal is better but the throughput is worse.
I'll adjust my post with my findings.

Sigh of course the problem isn't there when I connect :(
CCQ looks a bit better with 27dbi.

Wish I could set it dynamic but (and this is easily repeatable) one poor device cripples the network for all.

Just grab an Iphone5, go to a 3 bar spot, do a speed test(iperf3) with a decent device (Samsung S5 Active in our testing) and see good numbers. Run it on the Iphone and see terrible results, run again on the S5 and see terrible results. That will hold until the interface is downed and upped, then when the iphone reconnects it is crap again.

Statically set it and the problem disappears. But you've adversely affected all the customers that don't have a crappy device dragging down the network.

Then there is Mikrotik's totally screwed up channel bonding. Simply get enough customers and you'll start hearing about disappearing networks and networks that exist but can't be connected to.
investigate and you'll see it chose an odd ball frequency, or it put the control channel outside the usable spectrum. Give it a correct connection list and that problem goes away.

2G didn't have this problem, as it's not channel bonding but it has a bad habit of choosing the first channel even when unusably congested.
Give it a list and it behaves correctly, but now I've got 2G connection issues.

This whackamole is driving me nuts. We are very close to abandoning Mikrotik inside the home. SXT's are great, but we control both sides of the connection, it's not 1000 random devices
 
User avatar
Petri
Frequent Visitor
Frequent Visitor
Posts: 95
Joined: Mon Dec 05, 2016 1:55 pm
Location: Helsinki, Finland
Contact:

Re: Wireless woes and how to fix em :)

Fri May 11, 2018 10:24 am

The 11 channels on 2.4GHz are 5MHz wide. Wi-Fi uses 20 or 22MHz wide channels. If you use channels next to each other they will overlap. By using 1, 6 and 11 you have three genuinely distinct channels. Here in Europe you can occasionally use 1, 5, 9 and 13 and get a fourth channel.

Apparently you mean you are transmitting at 27dBm (not dBi). Decibel values are interpreted "as compared to". The last character tells what is the base of comparison. "i" means an isotropic antenna, "m" means one milliwatt.

Setting the transmit power to 27dBm you are driving the amps to the limit and probably causing clipping and distortion. Yes, the client devices may receive the signal further away, but they can't reply because their transmit levels are typically much lower. Wi-Fi is always bidirectional. I don't know where you are located but here in Europe the regulations limit 2.4GHz transmission to 20dBm. I try to get aways with a value below ten and only increase it if absolutely necessary. (PtP links are a different matter.)

No, an iPhone connecting to the network can't change any setting in the AP. There is no such mechanism. There is something else going on. You can start looking into it by using Wifi Analyzer on the Samsung to see what else is on the spectrum. A spectrum analyzer requires extra hardware. Wireshark on a PC is the ultimate tool, but requires more skill and knowledge.

RF is complicated and it looks like you have a lot homework to do. I would highly recommend attending a MikroTik's MTCWE or CWNP's CWNA class.
 
User avatar
Petri
Frequent Visitor
Frequent Visitor
Posts: 95
Joined: Mon Dec 05, 2016 1:55 pm
Location: Helsinki, Finland
Contact:

Re: Wireless woes and how to fix em :)

Fri May 11, 2018 10:32 am

Once I had one device that only supported 2.4GHz but occasionally wouldn't connect. It turned out that the device only supported the U.S. channel set 1–11 and the channel plan was European 1, 5, 9, 13. Whenever the device was in areas covered by an AP on channel 13 it was disconnected. That is one more reason to use the American plan 1, 6, 11 also over here. The major reason is that all neighbors tend to use it so you'll actually get more throughput by aligning your channel plan to them.
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Wireless woes and how to fix em :)

Fri May 11, 2018 3:58 pm

I think best practice is to leave power-mode alone and instead increase the gain if you want to reduce power.
 
yottabit
Member Candidate
Member Candidate
Posts: 160
Joined: Thu Feb 21, 2013 5:56 am

Re: Wireless woes and how to fix em :)

Fri May 11, 2018 4:05 pm

Yes, by increasing the antenna gain value, the radio will automatically adapt to proper power levels for the different modulation types, as well as maintain regulatory conformance.

Essentially you're "faking" a higher gain antenna, so the radio backs off appropriately to maintain the maximum EIRP that would be allowed.

Keep in mind RouterOS defaults to a value of 0 dBi antenna gain, but I'm pretty sure it uses the actual antenna gain value for each model, typically 2-2.5 dBi. So to see a real difference, you'd have to increase the value by the real antenna gain + the difference you want, e.g., set to 5 dBi to reduce the power by half, then to 8 dBi to reduce by half again. (dB are logarithmic, so you double or halve at every 3 dB.)

Sent from my Pixel XL using Tapatalk


 
dougunder
newbie
Topic Author
Posts: 40
Joined: Tue May 01, 2018 10:53 pm

Re: Wireless woes and how to fix em :)

Fri May 11, 2018 11:41 pm

Ok I have upgraded the script.

2G is working much better with an honest gain.

Previously the iphone saw 3-4 bars but the throughput was only less then a Mb.
I believe the amount of data getting lost and resent is why it was killing other device.

Now when the SIGNAL-STRENGTH is <-70 it sees 1-2 bars and ups its power in response
When the SIGNAL-STRENGTH is approx -85..-90 the device disconnects it's self willingly. Removing the problem.

Previously (both with a static tx power or default) if saw 4 bars with <-70, so it didn't try.

A gain of 2 and 3 is absolute fantasy land.

I'll double check WLAN channels setting.
We only supply one AP which is why i didn't give space, i want the device to determine the best channel and it seems to be doing a good job.
I'll be look further into that next week.

BTW 5G hasn't been looked at yet as it didn't have the same major issues
I'll be looking in to applying what we've learned..

also lowered the amsdu-limit to 256 which made a huge difference for the iphone's and dint seem to harm other devices
 
yhfung
Member Candidate
Member Candidate
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: Wireless woes and how to fix em :)

Mon May 14, 2018 9:14 am

dougunder,

Thank you for sharing your script of setting up WiFi automatically. I am sorry that I am a newbie for RouterOS scripting, then I am not understand your script in full.

Based on my limited scripting knowledge that you have pre-set a set of pre-defined values for channel-width, antenna-gain, tx-power-mode, amsdu-limit, rx- and tx-chains. How about the frequency, it seems that the script will use the frequency in the scan-list and test one by one until an acceptable frequency is found, right? What is the criteria to determine the good and bad frequency to be used?

YH
 
dougunder
newbie
Topic Author
Posts: 40
Joined: Tue May 01, 2018 10:53 pm

Re: Wireless woes and how to fix em :)

Mon May 14, 2018 7:26 pm

Hi,

Updated script again today.

First to answer your question YH, yes the scan-list is checked one by one until it finds a clear(ish) channel.
Warning: my list is valid for only the USA allowed frequencies.
Based on info here: https://en.wikipedia.org/wiki/List_of_WLAN_channels
We limited the 5G to 4, as otherwise RouterOS chooses non working channels, their bonding is kinda of a mess.
2G functions ok with out a list but tends to just pick the first channel. IDN why but it behaves properly with a basically identical to default list.

Digging deeper trying to determine why the gain had to be down rated so far to be stable, we opened the case.
20180514_085655.jpg
As you can see there are 4 integrated antenna's (near 0 Dbi) and 2 discrete antennas (guessing 7-9 Dbi) so the 2/3 figure given must have been an average, which is crap as you'll have packet loss out the wazoo on the weak spacial stream; which is likely behind much of the odd intermittent problems we've been facing.

After testing we disabled chain 2 and set the gain on 0,1 to zero. Throughput is affected a bit in short range but more then made up for in the consistent performance over the whole range.
Shame on Mikrotik for these shenanigans.
We also went back to 20mhz as it is stable in the new configuration.

Also did some work on the 5G, setting amsdu-limit to 2048 and gain to 0 here as well.
So far this looks great. Doing some wider testing and will update this post

First user report is in.
Absolutely glowing! Said he had 4-5 bars of 5G throughout his 1800 sqft home, and 70mb+ on a speedtest on his phone. Full power device (PCs, laptops) could pull full 150mb/150mb which is what he is rate limited at. 2G had coverage to the extents of the property with a minimum 20mb/20mb speed. Said it blew away his Comcast (previous ISP) Wifi.

Please test this out and post your results!
You do not have the required permissions to view the files attached to this post.
 
yhfung
Member Candidate
Member Candidate
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: Wireless woes and how to fix em :)

Tue May 15, 2018 6:52 am

dougunder,

I have modified the code a little bit such as "security-profile=default" and model="hAP ac^2".

I put the following script to the terminal of RouterOS and pressed enter key. After a while, the scanning was completed. I carried out the iperf3 test and found the 2G performance was only 40Mbps, which was lower than what I got previous, 60Mbps. 5G performance, I only got 200Mbps, instead of 380Mbps. I believe that main cause of these differences is the bandwidth. For 380Mbps, I chose 80Mbps and your script is 40Mbps.

In your post, you did not mentioned the maximum transfer rate that you can achieve. Do you have figures in terms of data rate after applying your script?
:global model [/system resource get board-name ];
:if (model="hAP ac" or model="hAP ac lite" or model="hAP ac^2") do={
	:local resetwifi do={
		:local reset do={
			:local ssid "REDACTED";
			/interface wireless set $1 ssid=($ssid.$2) mode=ap-bridge wireless-protocol=802.11 wmm-support=enabled distance=indoors multicast-buffering=disabled multicast-helper=disabled frequency=auto security-profile=default wps-mode=disabled disabled=no arp=enabled keepalive-frames=disabled bridge-mode=disabled country="united states3" frequency-mode=regulatory-domain band=$3 channel-width=$4 scan-list=$5 antenna-gain=$6 tx-power-mode=default amsdu-limit=$7 rx-chains=$8 tx-chains=$8;
		};
		$reset wlan1 2G 2ghz-b/g/n 20mhz 2412,2417,2422,2427,2432,2437,2442,2447,2452,2457,2462 0 256 0,1;
		$reset wlan2 5G 5ghz-a/n/ac 20/40mhz-Ce 5180,5220,5745,5785 0 2048 0,1;
		/interface wireless {set [find name~"wlan"] disabled=yes; :delay 30; set [find name~"wlan"] disabled=no}
	};
	$resetwifi;
	/interface wireless security-profiles set group-key-update=1h management-protection=disabled [find name~""]
}
 
dougunder
newbie
Topic Author
Posts: 40
Joined: Tue May 01, 2018 10:53 pm

Re: Wireless woes and how to fix em :)

Tue May 15, 2018 4:03 pm

Hi,

Yea you will defiantly do much better with 80Mbps. We supply a maximum of 150mb/150mb, with the majority using 30/30 so with our use case the 80Mbps is an unnecessary waste of spectrum.
If throughput is your primary objective I would use channel-width=20/40/80mhz-Ceee on wlan1 and wlan2. The scan list will need corrected to account for it, it's set for 40Mhz and 20Mhz width respectively.

On a full power device with 2+ spacial streams we see 250+ Mbs on the 5G and 60+ Mbps on the 2.4ghz with iper3 to a local server.
With a single stream device we see figures more akin to yours. 2G is defiantly very dependent on how clear the channel is and the potential of the client device.

We're not using any ac2's yet, waiting on the "Pro" version as we requite poe out, and prefer to have an spf cage.

You could also do a fuzzy find, I updated my script to use that as it is neater, and changed the security policy to default as thats more common.
We use a different policy name.

# if($model~"hAP") do{}
 
dougunder
newbie
Topic Author
Posts: 40
Joined: Tue May 01, 2018 10:53 pm

Re: Wireless woes and how to fix em :)

Tue May 15, 2018 4:20 pm

Thanks you

This is in home wireless, single AP. No roaming

We are using 20MHz for 2.4g.

Why only 3 2.4ghz bands? The spectrum in this area is very crowded, surely all 11 channels is better?
We have some multi unit homes with 4-6 of of our customers alone, never mind our competitors.
We're also planning to server 100+ unit affordable housing when we have a solid foundation.

I know of one 2.4G device that just won't connect, even right on top of the AP. Was leaning toward the frequency being at fault.

I do think the AP may be a bit to powerful..
What is a good figure? I went with the regulatory max. 27dbi or even lower?
Doing some live debugging shortly with a user have chrome cast issues where the didn't previously. It seems the signal is better but the throughput is worse.
I'll adjust my post with my findings.

Sigh of course the problem isn't there when I connect :(
CCQ looks a bit better with 27dbi.

Wish I could set it dynamic but (and this is easily repeatable) one poor device cripples the network for all.

Just grab an Iphone5, go to a 3 bar spot, do a speed test(iperf3) with a decent device (Samsung S5 Active in our testing) and see good numbers. Run it on the Iphone and see terrible results, run again on the S5 and see terrible results. That will hold until the interface is downed and upped, then when the iphone reconnects it is crap again.

Statically set it and the problem disappears. But you've adversely affected all the customers that don't have a crappy device dragging down the network.

Then there is Mikrotik's totally screwed up channel bonding. Simply get enough customers and you'll start hearing about disappearing networks and networks that exist but can't be connected to.
investigate and you'll see it chose an odd ball frequency, or it put the control channel outside the usable spectrum. Give it a correct connection list and that problem goes away.

2G didn't have this problem, as it's not channel bonding but it has a bad habit of choosing the first channel even when unusably congested.
Give it a list and it behaves correctly, but now I've got 2G connection issues.

This whackamole is driving me nuts. We are very close to abandoning Mikrotik inside the home. SXT's are great, but we control both sides of the connection, it's not 1000 random devices
Turns out that the device in question(a smart bathroom scale) was a wireless B device. Figured we had left the 90s but apparently they are still making them.
Script has been updated to enable it.
 
Bivvy
newbie
Posts: 32
Joined: Sat Feb 04, 2017 1:36 am

Re: Wireless woes and how to fix em :)

Thu May 17, 2018 9:45 am

Great thread @dougunder

Before we start trying out your script on some of our "friendly" customers can you, @Petri and@yottabit give some pointers on the "best" settings for the UK
Considering the two $reset lines in the script

$reset wlan1 2G 2ghz-b/g/n 20mhz 2412,2417,2422,2427,2432,2437,2442,2447,2452,2457,2462 0 256 0,1;
$reset wlan2 5G 5ghz-a/n/ac 20/40mhz-Ce 5180,5220,5745,5785 0 2048 0,1;

For UK 2Ghz channels 1,6,11 should we limit the 2GHz frequencies to 2412, 2437,2462?
and for the 5GHz channels 3 and 11 (for a 40MHz channel width) 2422,2462
https://en.wikipedia.org/wiki/List_of_W ... _countries

Antenna gain is set to zero ($6). Should we increase this to try to reduce the transmit power? This is discussed in the thread but does not appear to be implemented

amsdu-limit=$7 - Why is this 256 on wlan1 and 2048 on wlan2? (Sorry - bit of a newb...) Although I can see in dougunder's notes that he's set amsdu to 256, disabled chain 2 and set gain to 0. Is it simply that the work has been focused on the 2Ghz wireless?

What about @scampbell's suggestion
Also add in two access list rules, one to accept connections between -80..120 and another to reject signals -120..120. This aids handoff from one AP to the other and feel free to alter the -80 threshhold.
Has anyone tried this? What changes would we need in the script to implement this?

Thanks
 
dougunder
newbie
Topic Author
Posts: 40
Joined: Tue May 01, 2018 10:53 pm

Re: Wireless woes and how to fix em :)

Thu May 17, 2018 7:24 pm

Updated again today

Back to 20/40 on 2G, heavy users had connection issues on 20
Updated scan list to accommodate.

Unsure of regulatory limits in the UK.
My loose understanding is you get more frequencies, we get more power.

I think 0 gain in fine once the crappy antenna's (2) are disabled. We had used a higher gain in an earlier version, prior to discovering the two quite different antenna configs.
No stability issues thus far. You can adjust $6 upward if you want to downgrade it.

The amdpu-limit difference is due to testing. 5g handles a larger packet then 2G does. Mikrotik default is 8192 btw, which is totally unsuitable for AP usage, sensible for p2p.

Also started updating to 6.42.2 seems an improvement on the ever present 2G disconnects.

No do not use access rules on a single AP!!!!
It works but the user sees "bad password"
Customer service nightmare, upping gain until the cutoff is what you desire is better.
Also when phones sleep the reported signal strength skyrockets. Hard and fast limits don't make much sense.


5/18 Minor revision, went back to full 11 2.4G channels.
Also regarding gain setting, In the US the FCC limits us to 1w , or 30Dbm (recently raised for 5G) which is the effective max output with 0 Gain.
In the EU 2 or 3 would likely keep you legal, though I've not done the calculations myself for that.


This is out of testing for us.

All new hAp's provisioned use these settings and 6.42.2
It's being applied on a case by case basis to deployed equipment if wireless issues are reported.
I'll update this forum if any issues or improvements arise.
 
dougunder
newbie
Topic Author
Posts: 40
Joined: Tue May 01, 2018 10:53 pm

Re: Wireless woes and how to fix em :)

Wed Aug 08, 2018 7:03 pm

Updated after significant usage.

Set to US Bands and lowered 5g gain.
Also upped the HW timeout to 15s on 2G; cannie mind if it was this go round or earlier.

Currently using with 6.42.3
 
dougunder
newbie
Topic Author
Posts: 40
Joined: Tue May 01, 2018 10:53 pm

Re: Wireless woes and how to fix em :)

Wed Mar 27, 2019 9:17 pm

Updated again

It's now using channel lists and appropriate extension channels.

Customers are very happy with this,
With a 40/80hrz devices throughput is exponentially more at the edge of coverage.
 
User avatar
mrmut
Member Candidate
Member Candidate
Posts: 142
Joined: Mon May 18, 2009 2:10 pm

Re: Wireless woes and how to fix em :)

Fri Nov 08, 2019 8:21 am

Did you do any updates to these scripts recently?

Any changes in a year or so, due to ROS changes?

Thanks

Who is online

Users browsing this forum: No registered users and 23 guests